17:00:05 <mhroncok> #startmeeting FESCO (2021-05-04)
17:00:05 <zodbot> Meeting started Tue May  4 17:00:05 2021 UTC.
17:00:05 <zodbot> This meeting is logged and archived in a public location.
17:00:05 <zodbot> The chair is mhroncok. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:05 <zodbot> The meeting name has been set to 'fesco_(2021-05-04)'
17:00:08 <mhroncok> #meetingname fesco
17:00:08 <zodbot> The meeting name has been set to 'fesco'
17:00:12 <mhroncok> #chair nirik, ignatenkobrain, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, cverna, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
17:00:12 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku cverna dcantrell decathorpe ignatenkobrain mhroncok nirik sgallagh zbyszek
17:00:14 <mhroncok> #topic init process
17:00:21 <nirik> morning
17:00:41 <Eighth_Doctor> .hello ngompa
17:00:42 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:00:45 <bcotton> .hello2
17:00:48 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
17:00:56 <decathorpe> good evening
17:01:03 <zbyszek> .hello2
17:01:04 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
17:01:10 <mhroncok> we have quorum
17:01:20 <mhroncok> hello everybody
17:01:26 <mhroncok> .hello churchyard
17:01:27 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:02:00 <mhroncok> #topic #2597 F35 Change: Debuginfod By Default
17:02:08 <mhroncok> .fesco 2597
17:02:09 <zodbot> mhroncok: Issue #2597: F35 Change: Debuginfod By Default - fesco - Pagure.io - https://pagure.io/fesco/issue/2597
17:02:26 * mhroncok looks up action items form last week
17:03:06 <Eighth_Doctor> I'm pretty sure this is approved now
17:03:19 <nirik> There's now a disclamer I think.
17:03:22 <mhroncok> I think it might be,
17:03:41 * mhroncok sgallagh to talk to Security team about a threat analysis
17:03:42 <decathorpe> yeah if this needs another vote it can have my +1, I think I hadn't cast my vote yet.
17:03:46 <mhroncok> sgallagh is not here
17:03:54 * mhroncok dcantrell to speak to Council about privacy concerns
17:03:58 <mhroncok> dcantrell is not here
17:04:07 * mhroncok fche to explore consent dialogs/warnings
17:04:15 <mhroncok> this has been done and is in the ticket
17:04:28 <bcotton> i can speak for the Council if dcantrell didn't update the ticket
17:04:36 <mhroncok> #info there is now a warning with sleep on the first time you run this
17:04:42 <Eighth_Doctor> mhroncok: dcantrell already did last week
17:04:50 <mhroncok> bcotton: speak up
17:05:11 <bcotton> essentially, the Council agreed that this is a technical matter for FESCo
17:05:16 <bcotton> let me find the reference
17:05:27 <mhroncok> #info the Council agreed that this is a technical matter for FESCo
17:05:32 <mhroncok> bcotton: I trust you :)
17:05:46 <mhroncok> (this time, that is)
17:05:53 <bcotton> #link https://meetbot.fedoraproject.org/teams/council/council.2021-04-29-17.00.log.html#l-230
17:06:00 <bcotton> mhroncok: that's your first mistake :-)
17:06:30 <mhroncok> I don't think we *need* the security analysis to approve this
17:06:41 <dcantrell> .hello2
17:06:42 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
17:06:43 <mhroncok> if Security team has serious concerns, we can always revisit
17:06:51 <mhroncok> dcantrell: hi
17:06:58 <dcantrell> sorry I'm late
17:07:01 * nirik is still +1
17:07:05 <mhroncok> so, with the warning and sleep, I am totally fine with the change proposal
17:07:20 <mhroncok> let's vote...
17:07:23 <mhroncok> +1
17:07:26 <zbyszek> +1
17:07:34 <dcantrell> what are we voting on?
17:07:41 <Eighth_Doctor> +1
17:07:44 <mhroncok> dcantrell: https://pagure.io/fesco/issue/2597
17:08:03 <dcantrell> ah, +1
17:08:03 <mhroncok> dcantrell: with https://pagure.io/fesco/issue/2597#comment-730463
17:08:35 <dcantrell> noted.  some of you were in the last council meeting.  they didn't have any concerns from a council perspective, but I imagine someone already mentioned that
17:08:44 <mhroncok> decathorpe: ?
17:09:57 <mhroncok> there are no extra votes in the ticket
17:10:04 <mhroncok> #agree The change is approved with the warning in https://pagure.io/fesco/issue/2597#comment-730463 (+5,0,-0)
17:10:29 <mhroncok> #topic Next week's chair
17:10:39 <mhroncok> I can do this again, this was a short meeting
17:10:51 <mhroncok> if nobody wants it more... ?
17:11:14 <mhroncok> #action mhroncok will chair next meeting
17:11:23 <mhroncok> #topic Open Floor
17:11:27 <dcantrell> thanks, mhroncok
17:12:21 <zbyszek> thanks mhroncok
17:12:22 <mhroncok> anythign for open floor?
17:12:31 <dcantrell> I have a question
17:12:38 <mhroncok> dcantrell: ask
17:13:04 <dcantrell> I haven't noticed any significant fallout from the orphaning of all the java packages, but part of me feels like that is going to become a big issue.  Am I alone in this concern?
17:13:11 <dcantrell> Is there anything we should be doing in the interim?
17:13:27 <mhroncok> I think mizdebsk said he will take care of it
17:13:46 <mhroncok> many packages are affected via systemtap java subpackage only and we can remove that one if needed
17:13:54 <nirik> well, orphaning is just letting them coast... the retirement will be the earth shattering kaboom.
17:14:05 <mhroncok> #link https://churchyard.fedorapeople.org/orphans.txt
17:14:08 <dcantrell> I guess that's what I meant, the retirement if that ever happens
17:14:09 <decathorpe> sorry :D
17:14:17 <mhroncok> decathorpe: don't be
17:14:22 <mhroncok> decathorpe: in fact..
17:14:24 <nirik> yeah.
17:14:24 <mhroncok> decathorpe++
17:14:24 <zodbot> mhroncok: Karma for decathorpe changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:14:41 <mhroncok> #link https://packager-dashboard.fedoraproject.org/orphan
17:15:10 <mhroncok> dcantrell: is there anything really important that seems affected?
17:15:10 <decathorpe> I'm contemplating whether it would actually be possible to drop those Java packages, if nobody seems to actually need or want them?
17:15:28 <dcantrell> from my standpoint, nothing really.  but I'm not really in the java circles
17:15:51 <dcantrell> I suppose the best thing to do here is keep watching these orphaned package reports
17:15:53 <Eighth_Doctor> the main problem is LibreOffice and a few other bigger and older desktop apps
17:15:54 <mhroncok> well, I think the java circles might as well burn
17:15:54 <zbyszek> decathorpe: In my experience, they are useful as a basis to do other things.
17:15:59 <decathorpe> it should be possible to build libreoffice without Java scripting support I think
17:16:05 <mhroncok> it is the non-java stuff that depends on the java circles that might be a problem
17:16:13 <Eighth_Doctor> the LibreOffice database functionality is JDBC based
17:16:13 <decathorpe> the only problem I see is FreeIPA
17:16:23 <dcantrell> yeah, ok, so that's the thing.  lots of stuff use some/all of these java packages as deps to build or whatever
17:16:33 <dcantrell> I don't particularly care about the java packages themselves, but I care about libreoffice
17:16:34 <zbyszek> I.e. it is possible to make do e.g. with locally compiled copies, but it is very convenient to have stuff packaged in the distro.
17:16:42 <zbyszek> For example for scientific work...
17:17:07 <Eighth_Doctor> and there are folks trying to get Bazel packaged in Fedora so that Tensorflow can be built in Fedora
17:17:10 <decathorpe> true. but if nobody wants to commit to maintaining this stuff it will just rot.
17:17:14 <Eighth_Doctor> which is basically becoming mandatory for data science :/
17:17:33 <zbyszek> And and in particular, for stuff like jblas, which sits on the intersection of java and non-java stuff, having it in the distro is superb.
17:17:40 <Eighth_Doctor> (Tensorflow is Python, but it uses Bazel to build instead anything "normal", per Google "specialness")
17:17:51 <dcantrell> if no one wants to maintain these things, but we have users that want other things that need java stuff indirectly, then I can see us modifying build policy in the future
17:18:17 <mhroncok> I think it's too early to say how much is this going to hurt Fedora. the maintainership will change in the next 6 weeks and the deps might get cut after
17:18:19 <Eighth_Doctor> 🤷‍♂️
17:18:25 <dcantrell> fair
17:18:48 <Eighth_Doctor> at least from my perspective, I just felt that Java packaging was too baroque relative to the other ecosystems we have
17:18:56 <Eighth_Doctor> they've never had the "make better" hammer taken to them
17:18:57 <mhroncok> the nodejs stuff seemed bad and at the end, we now have only a handful of nodejs packages and it works
17:19:32 <mhroncok> I think we'll do nicely
17:19:45 <Eighth_Doctor> nodejs is a special case where it's rare to do system integration
17:19:48 <decathorpe> mhroncok: the stuff I kept until last week was already the naked robotic core to keep libreoffice and FreeIPA working, so I'm not sure if there is much space for pruning left.
17:19:49 <Eighth_Doctor> java is almost the opposite
17:20:13 <mhroncok> decathorpe: yeah, but hiks are affected becasue "libreoffice-1:7.1.2.2-3.fc35.src requires ant = 1.10.9-2.fc34" etc.
17:20:27 <mhroncok> and I think the plan is to have ant and maven working
17:20:41 <nirik> oh no, ants in our libreoffice. :)
17:20:50 <mhroncok> let's give mizdebsk some time to do that before panicking :D
17:20:59 <mhroncok> nirik++
17:20:59 <zodbot> mhroncok: Karma for kevin changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:21:04 <decathorpe> yeah, and to keep ant and maven working with all the plugins you need you need basically all the packages I orphaned.
17:21:04 <Eighth_Doctor> I think I'm just more disappointed in how so many rely on us to do the work, but nobody came to help when freenode_decathorpe[m] and I asked
17:21:35 * Eighth_Doctor sent emails to pretty much all the major downstream consumers of Fedora Java and nobody responded
17:21:40 <mhroncok> if only we had people paid to maintain the packages... oh, never mind
17:21:54 <decathorpe> mhroncok: shhhh
17:22:00 <Eighth_Doctor> 😒
17:22:23 <mhroncok> ok, nothing to do here, at least for now, ack?
17:22:39 <decathorpe> yeah
17:23:06 <mhroncok> ok, next thing
17:23:13 <mhroncok> .fesco 2600
17:23:13 <zodbot> mhroncok: Issue #2600: Election Interview Questions — FESCo (F34) - fesco - Pagure.io - https://pagure.io/fesco/issue/2600
17:23:32 <mhroncok> I think nobody is eager to change anything here, but if you are, you better be quick
17:23:49 <mhroncok> it would need to be approved on the next meeting or before
17:23:54 <dcantrell> it looks fine to me, but should CentOS Stream be mentioned along with RHEL in that question?
17:24:19 <mhroncok> dcantrell: I don't think it is necessary
17:24:28 <dcantrell> fine by me
17:24:57 <mhroncok> dcantrell: we are at a point where CentOS Stream needs pretty mach are RHEL needs and whoever wants to talk about stream in the answer can do that
17:25:39 <dcantrell> not a problem, I guess I was more asking do we feel more comfortable saying CentOS or RHEL as FESCo  :)
17:26:40 <mhroncok> dcantrell: in this question, I think RHEL is more appropriate, but I don't have a strong preference. IMHO nto worth changing and voting about that
17:26:46 <dcantrell> +1
17:26:48 <zbyszek> Same.
17:26:49 <mhroncok> s/nto/not/
17:27:03 <mhroncok> ok, let me close with a reminder...
17:27:19 <mhroncok> #info FESCo nominations are open until 2021-05-12
17:27:25 <mhroncok> #link https://fedoraproject.org/wiki/Development/SteeringCommittee/Nominations
17:27:49 * mhroncok will now end the meeting if nobody has anything else
17:28:48 <mhroncok> Thank you all, see you.
17:28:55 <mhroncok> #endmeeting