19:10:41 <mhroncok> #startmeeting FESCO (2021-07-12)
19:10:41 <zodbot> Meeting started Mon Jul 12 19:10:41 2021 UTC.
19:10:41 <zodbot> This meeting is logged and archived in a public location.
19:10:41 <zodbot> The chair is mhroncok. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:10:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:10:42 <zodbot> The meeting name has been set to 'fesco_(2021-07-12)'
19:10:45 <mhroncok> #meetingname fesco
19:10:46 <zodbot> The meeting name has been set to 'fesco'
19:10:51 <dcantrell> hello, sgallagh lbrack m rbrack
19:10:56 <mhroncok> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, defolos, mboddu, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
19:10:56 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe defolos mboddu mhroncok nirik sgallagh zbyszek
19:10:59 <mboddu> .hello mohanboddu
19:11:03 <sgallagh[m]> .hello sgallagh
19:11:03 <dcantrell> .hello2
19:11:03 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
19:11:04 <mhroncok> #topic init process
19:11:04 <bittin> .hello2
19:11:06 <zodbot> sgallagh[m]: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
19:11:07 <nirik> morning
19:11:09 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
19:11:10 <mhroncok> .hello churchyard
19:11:11 <nirik> .hello kevin
19:11:12 <zodbot> bittin: bittin 'Luna Jernberg' <droidbittin@gmail.com>
19:11:15 <zodbot> mhroncok: churchyard 'Miro HronĨok' <mhroncok@redhat.com>
19:11:15 <bittin> good evening (here as a first time guest)
19:11:17 <Eighth_Doctor> .hello ngompa
19:11:17 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
19:11:21 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
19:11:45 <mhroncok> sounds like a quorum to me
19:11:54 <mhroncok> sorry for the dealy everybody
19:11:57 <mhroncok> *delay
19:12:15 <mhroncok> the agenda is quite short today
19:12:19 <mhroncok> let me dig it up
19:12:42 <bittin> its in the email zbyszek sent
19:12:48 <mhroncok> #topic #2624 Proposal: Ban bots from submitting non-scratch koji builds
19:12:55 <mhroncok> bittin: thanks :)
19:13:25 <sgallagh[m]> .fesco 2624
19:13:26 <zodbot> sgallagh[m]: Issue #2624: Proposal: Ban bots from submitting non-scratch koji builds - fesco - Pagure.io - https://pagure.io/fesco/issue/2624
19:13:36 <mhroncok> sgallagh[m]: thank you
19:13:44 <mhroncok> I think the consensus is *not* to ban bots, but rather demand an obvious contact infofrmation
19:13:54 <sgallagh[m]> I contribute occasionally :)
19:13:58 <nirik> so, I think the last proposal was to require them to have a wiki page?
19:13:58 <mhroncok> and treat misbehaving bots as... misbehaving humans
19:14:17 <dcantrell> yeah, there has to be a responsible party for every bot
19:14:40 <sgallagh[m]> Yeah, I think bots are both necessary and good... so long as we know how to respond if they go rogue and start killing people.
19:14:52 * nirik nods
19:15:10 <mhroncok> do we want to put together a proposal and vote here, or vote async? I don't think this is time sensitive
19:15:24 <mboddu> Wiki page with contact info and also if no response from the owner if the bots go rogue in 15 days, we will disable the bot
19:15:36 <sgallagh[m]> I think a reasonable policy would be "Wiki page with contact information and if they don't respond within two weeks to an issue with the bots, the bot loses its access"
19:15:43 <mhroncok> mboddu: in case of emergency, we need to be able to disbale the bot immediatelly
19:15:43 <nirik> how about: if the bot is causing problems, escalate to fesco?
19:15:45 <sgallagh[m]> mboddu: I see we're on the same page :)
19:16:01 <mboddu> sgallagh[m]: Yeah :)
19:16:02 <nirik> right, I don't think we should say a timeline here.
19:16:12 <mhroncok> I agree
19:16:13 <mboddu> mhroncok: Sure, emergency clause can be added as well
19:16:14 <nirik> just that it can be escalated to fesco... or releng perhaps?
19:17:03 <sgallagh[m]> releng probably has the actual access to address it.
19:17:09 <mhroncok> in case of an emergency (bot actively does something wrong, contact person sleeps, releng/infra? can temporarily disable the account)
19:17:21 <sgallagh[m]> I'd say direct it to releng and have releng raise it to us if there's uncertainty
19:17:35 <nirik> mhroncok: +1
19:17:56 * mboddu agrees with sgallagh[m]
19:17:58 <mhroncok> in case of noresponsive humans, use the nonresponsive procedure
19:18:23 <mhroncok> in case of responsive but unfriendly humans, well, do what you would normally do. drink a lot and cry :D
19:18:30 <mhroncok> or approach fesco
19:18:40 <sgallagh[m]> "or"? :)
19:18:52 <mhroncok> and
19:18:54 <mboddu> mhroncok: So, we will drink a lot and cry? :D
19:19:02 <mhroncok> on their behavlf, yes
19:19:05 <mhroncok> *behalf
19:19:31 <mhroncok> anyway, I think there is a general consensus of the spirit of the "bot policy"
19:19:47 <sgallagh[m]> Yeah, probably no need to make this too specific.
19:19:52 <mhroncok> but I am to tired to write an actual proposal to vote on
19:19:55 <sgallagh[m]> If it's an emergency, ask releng to cut it off while it gets sorted.
19:20:05 <nirik> proposal: Bot accounts are allowed, but MUST create a wiki page with contact information for the human(s) running the bot and what it does. If the bot causes immediate problems, ask releng to disable it. If longer term problems, bring to fesco like for any maintainer.
19:20:07 <sgallagh[m]> Escalate to FESCo if there are any questions.
19:20:23 <mhroncok> nirik: +1
19:20:27 <nirik> Did I miss anything there?
19:20:32 <sgallagh[m]> nirik: +1
19:20:37 <mhroncok> nirik: I don't think so
19:20:44 <mboddu> nirik: +1
19:20:55 * nirik is +1 to his own proposal too
19:21:04 <dcantrell> does it need to mention anything about nonresponsive action?
19:21:07 <dcantrell> timing, etc?
19:21:18 <mhroncok> dcantrell: I don't think so
19:21:30 <nirik> I would think fesco could deal with that... escalate, wait more, etc as needed
19:21:37 <dcantrell> sounds good
19:21:39 <dcantrell> +1 from me
19:22:00 <mhroncok> we can write a bot that deals with the misbehaving bots if there are too many requests
19:22:23 * bittin wrote up nirik s proposal in the ticket
19:23:13 <mhroncok> bittin: no need for that. after the meeting, the chair usually updates all tickets we discussed (unless there was nothing noteworthy said)
19:23:27 <mhroncok> anyone else who's here but haven't voted?
19:23:29 <bittin> mhroncok: ah alright then i know that
19:23:30 <mhroncok> fesco members
19:23:48 <nirik> Eighth_Doctor: ^
19:24:10 <Eighth_Doctor> nirik: I want something in FAS
19:24:15 <Eighth_Doctor> wiki page is not sufficient
19:24:22 <Eighth_Doctor> so as-is, -1
19:24:25 <mhroncok> Eighth_Doctor: that is crrently not wuite possible AFAIK
19:24:29 <mhroncok> *quite
19:24:52 <Eighth_Doctor> we own our data model, we should be able to prioritize extending it accordingly
19:25:16 <Eighth_Doctor> I would be okay with approving a wiki page for now if there's a plan to encode it in FAS later
19:25:23 <mhroncok> Eighth_Doctor: we are not able to task infra folsk to implement stuff
19:25:26 <Eighth_Doctor> wiki pages don't get maintained
19:25:34 <mboddu> Eighth_Doctor: We can start with wiki, and once we have the support in FAS, then we could move the wiki info to FAS and update the policy
19:25:34 <mhroncok> the ticket where we did that the last time si open for a logn time
19:25:35 <dcantrell> I think it would be nice in FAS, but the main objective is to have a policy around what to do with bots and ownership.  The "how" can evolve over time.
19:25:46 <Eighth_Doctor> mhroncok: yes, but most of the bots are _from_ them
19:25:55 <Eighth_Doctor> aren't they?
19:26:00 <nirik> huh?
19:26:01 <mhroncok> Eighth_Doctor: I don't think so
19:26:26 <mhroncok> I know rhcontainerbot, zuul, packit
19:26:51 <mhroncok> most of the "infra" bots don't push to git
19:26:59 <nirik> I'm not sure the account system could easily contain the information we want here...
19:27:11 <sgallagh[m]> We've got distrobaker and OSCI's jenkins also
19:27:16 <mhroncok> nirik: a short Bio would do I guess
19:27:20 <nirik> I mean it could note whats a bot and what isn't... but how does it encode 'humans to contact' or 'what this bot does' ?
19:27:27 <mhroncok> sgallagh[m]: but do they commit stuff and do changes?
19:27:32 <nirik> I suppose...
19:27:39 <mhroncok> anyway
19:28:07 <mhroncok> we could either say this has been approved with (+5, 0, -1)
19:28:20 <mhroncok> or keep the proposal up for discussion async for another week
19:28:38 <sgallagh[m]> mhroncok: Builds, yes. Not git (in Fedora) so much
19:28:41 <nirik> I think it's passed ,unless someone wants to change their vote? but yeah, it's not urgent...
19:28:57 <mboddu> FAS will take time, its better to start with something and then move it as needed
19:29:11 <dcantrell> mboddu: +1
19:29:42 <mhroncok> my idea was that I would rather have a policy we all agree on in couple weeks than have one that "barely" passed immediately
19:30:20 <sgallagh[m]> mhroncok: I honestly don't see that we need to make it perfect out of the gate.
19:30:28 <nirik> I don't think anything can be implemented in the account system in a few weeks.
19:30:31 <sgallagh[m]> The proposal is better than the current state
19:30:35 <mboddu> True, but FAS approach cant be implemented in 2 weeks
19:30:35 <mhroncok> ack
19:30:58 <mhroncok> #agree Bot accounts are allowed, but MUST create a wiki page with contact information for the human(s) running the bot and what it does. If the bot causes immediate problems, ask releng to disable it. If longer term problems, bring to fesco like for any maintainer.  (+5, 0, -1)
19:31:30 <Eighth_Doctor> mboddu: I'm fine with this as long as we eventually make this something that's a property of bot users
19:31:33 <Eighth_Doctor> in FAS
19:31:51 <nirik> we should add this to our policy on docs.
19:31:58 * mhroncok wait for this discussion to end before opening the next topic
19:32:00 <mhroncok> *waits
19:32:13 <Eighth_Doctor> nobody really does things in wikis, so I don't want to trust that long term
19:32:14 <mboddu> Eighth_Doctor: Agreed
19:33:34 <mhroncok> #topic Next week's chair
19:33:57 <mhroncok> not a chance for me, sorry
19:34:08 <bittin> (not me will rig up GUADEC then and not really in fesco)
19:35:36 <sgallagh[m]> Mondays are tough for me to chair; I'm double-booked. I can usually manage to juggle the meeting, but it's not often I will be able to chair.
19:35:57 <nirik> Eighth_Doctor: say, would this move your vote: instead of the wiki we made it use fesco docs... ie, to add a bot you have to submit a fesco PR ?
19:36:12 <Eighth_Doctor> can we enforce that somehow?
19:36:12 <mboddu> I am not sure if I will be around for next Monday
19:36:14 <nirik> I'll be out next week. :)
19:36:27 <Eighth_Doctor> nirik: basically, I want it to be possible to ask zodbot who owns the bot user
19:36:30 <Eighth_Doctor> that's my ask
19:36:34 <nirik> Eighth_Doctor: nope, but we can't enforce the wiki page either. ;)
19:36:35 <dcantrell> today is my last day in the office until beginning of august.  PTO.  I'
19:36:47 <dcantrell> m going to try to join meetings, but I'm not sure I'll be able to
19:36:52 <Eighth_Doctor> nirik: I know :)
19:37:30 <mhroncok> foooo
19:37:39 <Eighth_Doctor> anyway, it doesn't matter, I was overruled and when this becomes a problem again, we'll have more urgency to deal with it
19:38:11 <mhroncok> Eighth_Doctor: always a good think to try to improve things
19:38:14 <mhroncok> Eighth_Doctor++
19:38:19 <mhroncok> *thing
19:40:10 <sgallagh[m]> Is anyone going to be here next week or should we skip?
19:40:43 * mhroncok will be here, just not up for chairing
19:41:04 * mboddu might be here or will be on PTO
19:41:52 <mhroncok> #info There is no chair available, mhroncok will ask asynchronously for one and cancel next week's meeting if nobody volunteers
19:42:01 <mhroncok> #topic Open Floor
19:42:03 <sgallagh[m]> ack
19:42:17 <bittin> don't have anything
19:42:18 <mhroncok> I have one topic
19:42:33 <mhroncok> .fesco 2636
19:42:37 <zodbot> mhroncok: Issue #2636: Nonresponsive maintainer: Conrad Meyer (@konradm) - fesco - Pagure.io - https://pagure.io/fesco/issue/2636
19:42:44 <mhroncok> This was opened 6 days ago
19:42:53 <mhroncok> there wa sno response and it was not on the agenda today
19:43:18 <mhroncok> we talk about escalating bot issues to fesco, but we don't deal with human issues very well
19:44:19 <mhroncok> this uses the Nonresponsive maintainer template, but in fact does not follow the policy: the maintain is responsibe, but in a way that does not help the reporter
19:44:35 <mhroncok> otoho the reporter is not interested in comaintaining the package
19:45:00 <mhroncok> so I don't think I know if there is a way out other than trying to talk to them
19:45:11 <michel> mhroncok: is it for EPEL?
19:45:44 <bittin> michel: https://src.fedoraproject.org/rpms/fftw
19:45:51 <mhroncok> michel: no, why?
19:45:58 <sgallagh[m]> mhroncok: We actually have an exception policy for this case
19:46:01 * sgallagh[m] looks it up
19:46:16 <sgallagh[m]> https://docs.fedoraproject.org/en-US/fesco/Policy_for_nonresponsive_package_maintainers/#exception-procedure
19:46:24 <michel> ah. no, just wondering - if it's for EPEL there is a packaging group that can take it if the maintainer doesn't. but this is just a normal patch
19:46:50 <sgallagh[m]> "Examples include [...] maintainer response prevents the non-responsive process from proceeding without actually resuming maintenance."
19:47:12 <mhroncok> sgallagh[m]: so we would "reassign" the package to orphan?
19:47:51 <sgallagh[m]> That would be my recommendation, yes
19:48:01 <dcantrell> has co-maintenance been suggested by the reporter here?
19:48:03 <mboddu> Yeah, assigning to orphan makes sense to me
19:48:03 <sgallagh[m]> Then it'll end up on the regular orphan announcements
19:48:06 <dcantrell> I don't actually that it has
19:48:15 <sgallagh[m]> If anyone cares about it, it'll get picked up.
19:48:24 <dcantrell> fair enough, orphan in this case works for me
19:48:25 <mhroncok> "otoh the reporter is not interested in comaintaining the package"
19:48:28 <sgallagh[m]> If not, it'll be retired.
19:49:00 <dcantrell> mhroncok: right
19:49:11 <dcantrell> ok, well I like the idea of reassigning it to orphan and letting it get picked up
19:49:11 <mhroncok> in case of "maintainer response prevents the non-responsive process from proceeding without actually resuming maintenance", they can just take it back :/
19:49:13 <sgallagh[m]> Proposal: Orphan fftw
19:49:19 <dcantrell> *but*, what if the same owner claims it again
19:49:42 <nirik> yeah...
19:49:44 <sgallagh[m]> That would be cause for us to intervene with the maintainer.
19:50:20 <mhroncok> updated proposal: (typing...)
19:50:25 <sgallagh[m]> But we don't necessarily need to plan for that case. If it happens, we address it then.
19:50:33 <nirik> perhaps a one time provenpackager intervention to apply the patch (if it's ok)?
19:50:34 <dcantrell> the reason I ask is that this approach could potentially be poorly received by the maintainer now
19:50:48 <dcantrell> and I don't want it to appear as though fesco is ganging up on the current maintainer
19:51:04 <sgallagh[m]> dcantrell: Then they probably ought to have responded at some point in the last two months.
19:51:13 <mhroncok> we ask @konradm to respond and take action. if they don't take action within a week, we orphan the package. in case it is reclaimed by the original maintainer, we'll deal with that later
19:51:15 <sgallagh[m]> Remember: maintainers aren't "owners", they're caretakers.
19:51:22 <dcantrell> sgallagh[m]: I'm not going to disagree with that
19:51:34 <dcantrell> right, caretakers is a good term
19:51:51 <dcantrell> but I also think the approach of the reporter here is not really the kind of behavior we want encouraged in fedora either
19:51:55 <nirik> that seems kinda pushy...
19:52:13 <mhroncok> nirik: it kinda is
19:52:20 <dcantrell> _usually_ people offer to help at least do a one-off patch and build -or- become comaintainer
19:52:47 <sgallagh[m]> dcantrell: The reporter did in fact offer a patch
19:52:52 <sgallagh[m]> Which the maintainer has ignored.
19:53:11 <sgallagh[m]> But they don't want to assume comaintainership long-term.
19:53:16 <dcantrell> ok, then I have missed some of the details
19:53:17 <nirik> well, they said it was large and they haven't had time to review it
19:53:18 <mhroncok> dcantrell: a patch was offered here,
19:53:20 <sgallagh[m]> Which is a perfectly reasonable situation.
19:53:25 <dcantrell> apologies
19:53:51 <mhroncok> " Can you estimate when this will be fixed? This has already been ignored for  18 months, then, explaining the issue didn't produce any progress, and now even providing a fix isn't helping. It's very frustrating."
19:54:00 <mhroncok> this was posted in May
19:54:08 <nirik> how about we contact the maintainer and ask them if they need help? a provenpackager to review/apply that patch? or soliciting a co-maintainer(s) on the devel list?
19:54:23 <mhroncok> tha they followed the nonresponsive policy somehow, and the miantainer said "yes, I am responsive, closed"
19:55:21 <dcantrell> ahhh, ok.  caught up through the BZs
19:55:40 <dcantrell> I like nirik's proposal and then failing that move the package to orphan
19:56:24 <decathorpe> hey, im very sorry for not attending the meeting for my own topic, but I'm 100% out of order today :(
19:56:24 <mhroncok> right, I agree offering help is better than "threatening to orphan"
19:56:45 <sgallagh[m]> So, I just took a look at the patch and I'm pretty sure I wouldn't be comfortable applying it
19:56:46 * mboddu agrees with nirik proposal
19:57:13 <mhroncok> nirik: would you be able to contact them? or should we ask in the ticket?
19:57:31 <nirik> either way. I am happy to contact them...
19:57:38 <nirik> sgallagh[m]: oh?
19:58:10 <sgallagh[m]> It's a lot of integer precision esoterica
19:58:23 <sgallagh[m]> I wouldn't be comfortable approving that in lieu of a subject matter expert
19:59:31 <nirik> huh, so perhaps we should ask why they didn't submit that upstream?
19:59:58 <mhroncok> this looks like a spec patch to me
20:00:08 <dcantrell> yeah, this is a patch to how we build it
20:00:34 <dcantrell> which may also explain why it's been so long.  looks like a fairly significant restructuring of the packaging
20:00:59 <sgallagh[m]> mhroncok: Yes, it's a spec patch that essentially rewrites the build system
20:01:07 <mhroncok> I definitively understand that this patch is hard to take, especially by a volunteer maintainer
20:02:01 <mhroncok> anyway, this looks like a more complex topic than I originally thought :/
20:02:14 <mhroncok> I jumped to conclusions too quickly
20:02:19 <sgallagh[m]> agreed
20:03:01 <mhroncok> I don't think we can solve this situation here and I need to go feed the dogs, so let's end it here and think about ti more as a homework :D
20:03:05 <sgallagh[m]> New proposal: FESCo responds on the BZ, asking Larry to take the issue upstream.
20:03:23 <dcantrell> +1, I'm reading this now and was planning to comment in the BZ
20:03:55 <mhroncok> I think anybody can can ask them without a formal fesco vote
20:04:16 <sgallagh[m]> Right, but I meant that as our official response to #2626
20:04:22 <sgallagh[m]> * Right, but I meant that as our official response to #2636
20:04:22 <mhroncok> (I can either end the meeting, or pass it to somebody else)
20:04:35 <sgallagh[m]> I'll take over
20:04:38 <mhroncok> thanks
20:04:50 <sgallagh[m]> (For what I hope will only be a few minutes :) )
20:04:55 <mhroncok> sgallagh[m]: let me know who sends the minutes, I'll re-read the messages later
20:05:02 <mhroncok> bye
20:05:07 <sgallagh[m]> ack
20:05:10 <sgallagh[m]> I'll send them
20:05:54 <bittin> (well the meeting is scheduled for 5 minutes longer)
20:06:34 <sgallagh[m]> dcantrell: If you were going to comment anyway, want to represent us there?
20:06:52 <dcantrell> sgallagh[m]: sure, I can do that
20:07:05 <sgallagh[m]> Ask Larry to file an issue upstream with fftw, explaining the research they did to locate the issue.
20:07:06 <sgallagh[m]> Thank you
20:07:26 <sgallagh[m]> #action dcantrell to respond on the Bugzilla ticket asking the reporter to take the issue to upstream
20:08:54 <sgallagh[m]> OK, anyone have anything else today?
20:09:54 <sgallagh[m]> I'll read that as "no"
20:10:00 <sgallagh[m]> Thanks, everyone.
20:10:05 <dcantrell> thanks
20:10:08 <sgallagh[m]> #endmeeting
20:10:08 <bittin> thx
20:10:29 <sgallagh[m]> Hmm, zodbot isn't recognizing me as a chair...
20:10:54 <sgallagh[m]> #chair
20:10:57 <nirik> it's due to the [m] probibly
20:11:01 <nirik> #endmeeting