19:03:26 <Eighth_Doctor> #startmeeting FESCO (2021-10-04)
19:03:26 <zodbot> Meeting started Mon Oct  4 19:03:26 2021 UTC.
19:03:26 <zodbot> This meeting is logged and archived in a public location.
19:03:26 <zodbot> The chair is Eighth_Doctor. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:03:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:03:26 <zodbot> The meeting name has been set to 'fesco_(2021-10-04)'
19:03:46 <Eighth_Doctor> hmm
19:03:57 <Eighth_Doctor> that's not a good sign
19:04:10 <zodbot> defolos: Error: Can't start another meeting, one is in progress.
19:04:17 <StephenGallagher> What isn't?
19:04:34 <Eighth_Doctor> it just synced
19:04:36 <StephenGallagher> I see Zodbot responding, if that's your concern?
19:04:51 <bcotton> the bridge is struggling today
19:04:51 <Eighth_Doctor> #meetingname fesco
19:04:51 <zodbot> The meeting name has been set to 'fesco'
19:05:24 <nirik> yeah, the bridge is slowish. ;(
19:05:27 <Eighth_Doctor> #chair nirik, decathorpe, zbyszek, sgallagh, StephenGallagher mhroncok, dcantrell, defolos, mboddu, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
19:05:27 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku StephenGallagher dcantrell decathorpe defolos mboddu mhroncok nirik sgallagh zbyszek
19:05:36 <defolos> .hello2
19:05:37 <zodbot> defolos: defolos 'Dan Čermák' <dan.cermak@cgc-instruments.com>
19:05:38 <dcantrell> .hello2
19:05:40 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
19:05:42 <StephenGallagher> .hello sgallagh
19:05:42 <zbyszek_> .hello2
19:05:43 <zodbot> StephenGallagher: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
19:05:46 <zodbot> zbyszek_: Sorry, but user 'zbyszek_' does not exist
19:05:47 <mhroncok> .helloc churchyard
19:05:50 <Eighth_Doctor> .hello ngompa
19:05:52 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
19:05:54 <zbyszek> .hello2
19:05:55 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
19:05:55 <nirik> morning
19:05:56 <mhroncok> .hello churchyard
19:05:58 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
19:06:06 <bcotton> .hello2
19:06:07 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
19:06:28 <zbyszek> Eighth_Doctor: please note that we added https://pagure.io/fesco/issue/2671 to the agenda
19:06:49 <zbyszek> s/we/bcotton/
19:06:56 <decathorpe> .hello2
19:06:57 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
19:07:16 <zbyszek> But indeed, there isn't much time.
19:07:41 <King_In7> #topic init process
19:08:21 <StephenGallagher> We did that already
19:08:54 <mhroncok> #chair King_InuYasha
19:08:54 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku StephenGallagher dcantrell decathorpe defolos mboddu mhroncok nirik sgallagh zbyszek
19:09:07 <dcantrell> I feel there's a glitch in the matrix
19:09:10 <King_InuYasha> #topic init process
19:09:41 <King_InuYasha> #topic #2670 Consider triggering contingency plan for F35 WirePlumber change
19:09:45 <King_InuYasha> .fesco 2670
19:09:46 <zbyszek> dcantrell: did you just have a déjà vu?
19:09:46 <zodbot> King_InuYasha: Issue #2670: Consider triggering contingency plan for F35 WirePlumber change - fesco - Pagure.io - https://pagure.io/fesco/issue/2670
19:10:07 <dcantrell> zbyszek: indeed
19:10:10 <zbyszek> wtay: welcome to the matrix^W meeting
19:10:23 <King_InuYasha> wtay: hey :)
19:10:25 <wtay> hi everyone
19:10:28 * nirik is interested to hear wtay's thoughts on this.
19:10:42 <King_InuYasha> wtay: is George also going to be here?
19:10:51 <wtay> Not that I know..
19:11:10 <defolos> 30s internet delay sounds pretty bad
19:11:27 <StephenGallagher> defolos: Different topic
19:11:58 <decathorpe> (hm. looks like the IRC -> matrix bridge is having trouble, messages are delayed, discussion might end up jumbled at either end ...)
19:12:03 <defolos> Stephen Gallagher: bridge is super slow…
19:12:19 <StephenGallagher> This should be fun
19:12:45 <mhroncok> may I suggest everybody who is on matrix to use a proper IRC client for now (even the web based one should do)?
19:12:53 <zbyszek> I think the messages end up in the correct order, but with a significant delay.
19:13:09 <mhroncok> https://web.libera.chat/?channels=#fedora-meeting
19:13:12 <nirik> oddly I am not seeing a delay... wonder where it is. ;(
19:13:17 <wtay> ..regarding Wireplumber, I talked to George and he's confident we can get WirePlumber in shape this week.
19:13:32 <King_InuYasha> nirik: it's only with matrix.org accounts, it seems
19:13:34 <nirik> oh wow. good news.
19:13:44 <King_InuYasha> wtay: that's excellent news!
19:13:45 <nirik> King_InuYasha: ah...
19:13:46 <StephenGallagher> Ahhh, I'm on fedora.im
19:14:00 * nirik is on his own homeserver.
19:14:04 <mhroncok> do we have adamw?
19:14:15 <adamw> i'm around
19:14:17 <dcantrell> at least we're not having this meeting on facebook
19:14:19 <wtay> it seems the issues we've seen so far are rather easy to fix.. nothing fundamental..
19:14:34 <adamw> (though i'm on matrix)
19:14:35 <mhroncok> adamw: is "one week" to get the wireplumber thing in order acceptable?
19:14:41 <StephenGallagher> wtay: Confident enough that we could set a hard deadline of "Working before Final Freeze or it gets reverted"?
19:14:50 <bcotton> dcantrell++
19:14:51 <zodbot> bcotton: Karma for dcantrell changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:14:54 <decathorpe> one thing I was concerned about is that after upgrading three machines to F35, none of them ended up with working sound without me manually fiddling with systemd units
19:14:54 <nirik> StephenGallagher: final freeze is tomorrow
19:14:55 <mhroncok> StephenGallagher: final freeze is tmrw
19:14:55 <adamw> final freeze is tomorrow, isn't it?
19:15:03 <King_InuYasha> freeze is tomorrow
19:15:06 <wtay> tomorrow? no..
19:15:10 <bcotton> indeed it is
19:15:12 <King_InuYasha> but EOW is workable
19:15:20 <adamw> let me look where a week puts us
19:15:21 <nirik> so that would need at least a FE
19:15:27 <wtay> end of week we certainly know more..
19:15:34 <StephenGallagher> Oh, so it is. Yikes.
19:15:54 <mhroncok> if we decide to give it more week, I'd certianly like to add a blocker to fix or revert things, not just hoping for a FE to fix this
19:16:15 <King_InuYasha> George Kiagiadakis sounded extremely confident to me in his email to me and Wim that WirePlumber would work by the end of the week
19:16:27 * mboddu is here
19:16:30 <King_InuYasha> (he's the main developer of WirePlumber)
19:16:41 <adamw> early target is the 19th, so go/no-go is 14th. so, uh, we have ten days to go/no-go. if we wait till end of week to decide what to do we would be pushing things a bit.
19:16:57 <mhroncok> King_InuYasha: the problems sound quite complex, the confidence strikes me somewhat optimistic
19:17:01 <adamw> if we get to end of week and wireplumber works great, that would probably be fine.
19:17:15 <bcotton_> especially given how important sound is to the desktop experience
19:17:24 <King_InuYasha> I can prepare the work to revert to pipewire-media-session and have it to merge if we can't get it in place this week
19:17:27 <nirik> can we line up what a revert would look like and pull the trigger on that thursday/friday if things aren't done?
19:17:31 <adamw> if we get to end of week and it doesn't, that gives us a pretty tight timeframe to switch out to the old manager and check  we got it all right.
19:17:31 <StephenGallagher> Assuming we made the decision to revert, how fast could that be done?
19:17:33 <King_InuYasha> since I'm the one that flipped it in the first place
19:17:38 <adamw> nirik: yeah, that would not be a bad idea
19:17:39 <King_InuYasha> I can do the revert in less than 12 hours
19:17:43 <mhroncok> Proposal: By the end of the week, QA will determine whetehr this is working. if not, we trigger the contingency plan ASAP
19:17:59 <dustymabe> .hi dustymabe
19:18:00 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:18:04 <nirik> King_InuYasha: yeah. Thanks. ;)
19:18:12 <StephenGallagher> King_InuYasha: And that's a revert to a known-good state, not just a different set of bugs?
19:18:25 <King_InuYasha> we'd go back to pipewire-media-session as the default session manager
19:18:39 <mhroncok> and I suggest we have the switch prepared, ready to be merged and pushed first thing on Monday
19:18:44 <adamw> i don't think the state is precisely the same as before, is it?
19:18:54 <King_InuYasha> it's not exactly since pipewire has been upgraded a few times
19:19:00 <wtay> it's the state in f34
19:19:01 <nirik> I think we kept presets for both
19:19:04 <King_InuYasha> yeah, we did
19:19:07 <nirik> so that can stay the same
19:19:09 <adamw> we're going back to the same session manager, but of course pipewire itself has changed a bit since we last used it. and i don't think it was set up exactly the same in f34.
19:19:14 <adamw> oh, it was? okay then.
19:19:29 <defolos> can we have a "side tag compose" with the old session manager in?
19:19:36 <King_InuYasha> that's complicated
19:19:39 <wtay> in f35 it'll be started with systemd, that's about the only change
19:19:47 <adamw> right, that's what i meant
19:19:48 <King_InuYasha> since we have to make changes to pipewire package + comps
19:20:12 <King_InuYasha> "started with systemd" is the upstream way to do it
19:20:21 <King_InuYasha> we actually deviated for f34 for expedience
19:20:31 <wtay> yes, I would keep that..
19:20:39 <King_InuYasha> but those issues were resolved in order to support swapping session managers
19:20:41 <StephenGallagher> So, rolling it back might bring in additional headaches, but we don't and can't know without doing so.
19:20:54 <StephenGallagher> Do I have that right?
19:21:10 <King_InuYasha> yes
19:21:29 * StephenGallagher is not loving this set of choices
19:21:35 <zbyszek> StephenGallagher: that's possible, but doesn't seem very likely. But we could ask people to test this locally… It's one command to switch.
19:21:37 <King_InuYasha> but note that people have already verified reverting to pipewire-media-session and doing nothing else fixes the reported issues right now
19:21:49 <mboddu> King_InuYasha: Is there any way that we can roll it back to last known working solution?
19:22:03 <King_InuYasha> mboddu: not easily, because we need to in-place change system configs
19:22:08 <StephenGallagher> How do we identify which solution we're using at the moment?
19:22:23 <King_InuYasha> unfortunately, layered configuration model is not fully supported in pipewire
19:22:29 <King_InuYasha> otherwise this would be less challenging
19:22:42 <StephenGallagher> e.g. my upgrade happened shortly after the branch, and I'm not sure where the upgrade would have happened.
19:22:44 <adamw> Stephen Gallagher: check whether wireplumber.service or the other one is running in your user session.
19:22:45 <King_InuYasha> and I don't particularly want to do config patching in an rpm scriptlet
19:22:49 <adamw> i forget the exact name of the other one's service.
19:22:59 <King_InuYasha> pipewire-media-session is the name of the other one
19:23:06 <nirik> StephenGallagher: rpm -q wireplumber pipewire-media-session and see which is installed
19:23:16 <adamw> or that, yeah.
19:23:30 <StephenGallagher> wireplumber, thanks
19:24:08 <mhroncok> my proposal?
19:24:12 <adamw> i think i'm reluctantly okay with the 'prepare a revert for immediate application and decide on friday' plan, with the caveat that it does present a small but non-zero chance of something unexpected going wrong.
19:24:36 <adamw> i can run a special meeting or something on friday to decide.
19:24:48 <zbyszek> mhroncok: +1 to your proposal
19:25:04 <nirik> yeah, +1 if we are voting
19:25:18 <King_InuYasha> mhroncok: +1
19:25:29 <wtay> +1 let's try that
19:25:30 <StephenGallagher> mhroncok: Could you restate? I'm not finding it in my backlog
19:25:32 <dcantrell> mhroncok: +1
19:25:54 <mhroncok> Proposal: By the end of the week, QA will determine whetehr this is working. if not, we trigger the contingency plan ASAP
19:25:56 <mhroncok> and I suggest we have the switch prepared, ready to be merged and pushed first thing on Monday
19:26:02 <mhroncok> StephenGallagher: ^
19:26:06 <defolos> +1 to that, since adamw is okay-ish with that
19:26:09 <StephenGallagher> Thanks.
19:26:12 <adamw> i would prefer we do the revert friday
19:26:15 <StephenGallagher> I would like to amend that to...
19:26:21 <StephenGallagher> yeah, exactly as adamw says
19:26:25 <adamw> no point waiting three days after deciding
19:26:28 <mboddu> Not so happy about it, but its the best we got, so +1
19:26:34 <mhroncok> if wtay is ok with friday, so am I
19:26:45 <wtay> I'm ok with it
19:27:03 <adamw> if nobody has a better idea i'll schedule a special meeting for friday AM west coast time
19:27:04 <zbyszek> Yeah, having the fresh compose with the revert on Saturday sounds good.
19:27:06 <StephenGallagher> Revised: QA will meet on Friday to decide if this is fixed. If not, we have a revert ready to go at the end of that meeting.
19:27:06 <mhroncok> ok, porposal doesn'T say monday, just th suggestion
19:27:07 <wtay> if we can't make it friday we should delay to f36
19:27:11 <adamw> (so, about 2-3 hours before right now)
19:27:25 <StephenGallagher> * Revised Proposal: QA
19:27:27 <mhroncok> StephenGallagher: +1
19:27:41 <wtay> but I still want to option for people to switch to wireplumber by swapping session managers
19:27:51 <mboddu> StephenGallagher: +1
19:28:03 <King_InuYasha> if we revert, we can leave it in the f36 comps so it's still set up there
19:28:07 <StephenGallagher> wtay: Good fodder for a Fedora Magazine article.
19:28:18 <King_InuYasha> and I can adjust the packaging so that pipewire prefers wireplumber on f36
19:28:29 <King_InuYasha> that way we can keep going with it
19:28:30 <nirik> f35 you mean. ;)
19:28:35 <King_InuYasha> no
19:28:35 <wtay> yeah
19:28:39 <King_InuYasha> I mean what I said :D
19:28:46 <adamw> well, you wouldn't have to change anything on f36
19:28:51 <nirik> right, ok...
19:28:57 <adamw> only 35 would need changing, heh
19:29:00 <nirik> I misread that as backwards.
19:29:39 <King_InuYasha> adamw: the f35 and rawhide branches are merged right now, so I'd make the conditional there accordingly
19:29:53 <King_InuYasha> but yes technically I could deviate in the f35 branch only
19:30:07 <zbyszek> King_InuYasha: can we action you to prepare the revert?
19:30:10 <King_InuYasha> yes
19:30:13 <StephenGallagher> We don't need to discuss the specific implementation.
19:30:21 <StephenGallagher> Right, I was about to ask the same.
19:30:36 <King_InuYasha> anyway, if we're good for the plan, then can we have a final vote for...
19:31:01 <King_InuYasha> Proposal: QA will meet on Friday to decide if this is fixed. If not, King_InuYasha will revert after the end of that meeting.
19:31:08 <mboddu> +1
19:31:11 <zbyszek> +1
19:31:18 <StephenGallagher> King_InuYasha: +1
19:31:31 <decathorpe> +1
19:31:32 <mhroncok> +1
19:31:33 <dcantrell> +1
19:31:38 <defolos> +1
19:31:58 <zbyszek> I assume that "this is fixed" means wireplumber is deemed good enough. (There's more than one issue open.)
19:32:02 <King_InuYasha> yes
19:32:23 <adamw> +1
19:32:44 <StephenGallagher> adamw: Appreciated, but your vote doesn't (officially) count here.
19:32:54 <King_InuYasha> #agreed QA will meet on Friday to decide if WirePlumber is in good enough shape. If not, King_InuYasha will revert after the end of that meeting (+8, 0, -0)
19:33:15 <mhroncok> i see 7
19:33:19 <King_InuYasha> I am 8 :)
19:33:22 <zbyszek> StephenGallagher: we do what adamw says anyway ;)
19:33:28 <StephenGallagher> plus Neal, yeah
19:33:34 <StephenGallagher> Well, obviously
19:33:36 <mhroncok> I see 7 with neal
19:33:42 <mhroncok> sorry
19:33:44 <mhroncok> I am tired
19:33:46 <mhroncok> I see 8
19:33:48 <King_InuYasha> :)
19:33:50 * nirik was +1 too
19:33:52 <StephenGallagher> all good
19:33:56 <King_InuYasha> anyway... next item
19:34:17 * wtay goes to work
19:34:25 <King_InuYasha> bye wtay
19:34:27 <zbyszek> wtay: thanks!
19:34:40 <nirik> thanks wtay
19:34:45 <wtay> 'till friday :)
19:34:50 <King_InuYasha> #topic #2671 [DNS over TLS] following connection to a wifi AP, internet is not available for ~30s
19:34:54 <King_InuYasha> .fesco 2671
19:34:55 <zodbot> King_InuYasha: Issue #2671: [DNS over TLS] following connection to a wifi AP, internet is not available for ~30s - fesco - Pagure.io - https://pagure.io/fesco/issue/2671
19:35:00 <StephenGallagher> tl;dr: Everyone in the blocker review agreed that this was serious enough to block, but writing an appropriate criterion was too hard. I suggested we ask FESCo to vote it a blocker instead.
19:35:11 <King_InuYasha> I'm fine with that
19:35:11 <StephenGallagher> QA will look into the criterion improvement for F36
19:35:17 <zbyszek> +1 to making this a blocker
19:35:19 <nirik> sure, +1
19:35:19 <King_InuYasha> StephenGallagher: want to wordsmith a proposal?
19:35:28 <mhroncok> +1 to making this a blocker
19:35:29 <StephenGallagher> +1
19:35:35 <dcantrell> agreed, blocker material +1
19:35:42 <mboddu> +1 Blocker
19:35:43 <King_InuYasha> blocker material to me too +1
19:35:59 <King_InuYasha> I guess we can just agree to that :)
19:36:36 <defolos> +1 for making this a blocker
19:36:36 <adamw> i offer "this bug sucks, we want to block on it"
19:37:08 <StephenGallagher> Sorry, schoolbus just arrived, had to collect my kid.
19:37:10 <King_InuYasha> #agreed FESCo agrees that this is a Final Blocker. QA will add criterion for this for F36. (+7, 0, -0)
19:37:13 <decathorpe> +1 to blocker
19:37:18 <mboddu> +1
19:37:30 <King_InuYasha> gah
19:37:32 <King_InuYasha> #undo
19:37:32 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f2570392240>
19:37:40 <King_InuYasha> #agreed FESCo agrees that this is a Final Blocker. QA will add criterion for this for F36. (+9, 0, -0)
19:38:00 <King_InuYasha> #undo
19:38:00 <zodbot> Removing item from minutes: AGREED by King_InuYasha at 19:32:54 : QA will meet on Friday to decide if WirePlumber is in good enough shape. If not, King_InuYasha will revert after the end of that meeting (+8, 0, -0)
19:38:05 <King_InuYasha> holy crap
19:38:07 <King_InuYasha> what?
19:38:19 <King_InuYasha> meh fixing now
19:38:26 <mhroncok> redo?
19:38:30 <King_InuYasha> #agreed QA will meet on Friday to decide if WirePlumber is in good enough shape. If not, King_InuYasha will revert after the end of that meeting (+9, 0, -0)
19:38:37 <zbyszek> King_InuYasha: I think you put a space before '#'
19:38:40 <adamw> you maybe undid so fast the bot hadn't done yet
19:38:45 <King_InuYasha> #topic #2671 [DNS over TLS] following connection to a wifi AP, internet is not available for ~30s
19:38:50 <King_InuYasha> .fesco 2671
19:38:53 <zodbot> King_InuYasha: Issue #2671: [DNS over TLS] following connection to a wifi AP, internet is not available for ~30s - fesco - Pagure.io - https://pagure.io/fesco/issue/2671
19:39:01 <King_InuYasha> #agreed FESCo agrees that this is a Final Blocker. QA will add criterion for this for F36. (+9, 0, -0)
19:39:09 <adamw> oh yeah or that.
19:39:09 <King_InuYasha> there we go
19:39:12 <StephenGallagher> Computers were a mistake
19:39:25 <zbyszek> King_InuYasha: but it's only +8, mboddu voted twice.
19:39:33 <King_InuYasha> ugh
19:39:38 <King_InuYasha> #undo
19:39:38 <zodbot> Removing item from minutes: AGREED by King_InuYasha at 19:39:01 : FESCo agrees that this is a Final Blocker. QA will add criterion for this for F36. (+9, 0, -0)
19:39:43 <King_InuYasha> #agreed FESCo agrees that this is a Final Blocker. QA will add criterion for this for F36. (+8, 0, -0)
19:39:47 <dcantrell> I think we should have a recount.  I'm concerned about election integrity
19:39:52 <King_InuYasha> nope
19:39:55 <King_InuYasha> not doing this anymore
19:39:57 <mboddu> King_InuYasha: Sorry, I thought it was the proposal and I +1'd it again :(
19:39:59 <dcantrell> haha
19:40:07 <King_InuYasha> #topic Next week's chair
19:40:15 <defolos> Stephen Gallagher: dang computers, stealing our jobs 😛
19:40:16 <King_InuYasha> so who's going to do it next?
19:40:25 <zbyszek> I can.
19:40:30 <King_InuYasha> excellent
19:40:38 <adamw> i for one look forward with interest to reading the minutes
19:40:44 <StephenGallagher> Next week is a holiday in parts of the US
19:40:48 <King_InuYasha> #action zbyszek will chair next meeting
19:40:53 <zbyszek> (I'm not ready to give up my job on the computer to the computer just yet.)
19:41:02 <King_InuYasha> #topic Open Floor
19:41:11 <King_InuYasha> anything anyone wants to bring up?
19:41:44 <defolos> I will most likely not be available
19:41:59 <mboddu> FYI, I wont be available next week
19:42:39 <King_InuYasha> hmm, next week is Columbus Day/Natives' Day?
19:42:58 <StephenGallagher> Indiginous People's Day here, but yes
19:43:42 <defolos> I have a biweekly clash with the current fesco meeting time
19:43:47 <King_InuYasha> well, do we want to cancel next week's meeting?
19:43:59 <defolos> does the current time & day still work for everyone?
19:44:12 <King_InuYasha> I don't think I could take another meeting move :(
19:44:14 <StephenGallagher> It doesn't sound like it affects too many people. Let's try for it and see if we have quorum
19:44:22 <King_InuYasha> sounds good
19:44:26 <zbyszek> StephenGallagher: yeah
19:44:41 <King_InuYasha> is there anything else want to talk about? or should I end the meeting now?
19:45:07 <mboddu> This time works for me, its just that I will be on PTO next Monday, that is all
19:45:37 <mhroncok> this time is horrible, but we don't have anything better
19:46:37 <King_InuYasha> hmm
19:46:47 <King_InuYasha> well, going once...?
19:46:50 <mhroncok> release us
19:46:51 <King_InuYasha> going twice...?
19:47:02 <King_InuYasha> DONE
19:47:04 <King_InuYasha> #endmeeting