19:00:15 <zbyszek> #startmeeting FESCO (2021-10-11)
19:00:15 <zodbot> Meeting started Mon Oct 11 19:00:15 2021 UTC.
19:00:15 <zodbot> This meeting is logged and archived in a public location.
19:00:15 <zodbot> The chair is zbyszek. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:15 <zodbot> The meeting name has been set to 'fesco_(2021-10-11)'
19:00:15 <zbyszek> #meetingname fesco
19:00:15 <zodbot> The meeting name has been set to 'fesco'
19:00:15 <zbyszek> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, defolos, mboddu, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
19:00:15 <zbyszek> #topic init process
19:00:15 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe defolos mboddu mhroncok nirik sgallagh zbyszek
19:00:31 <Eighth_Doctor> .hello ngompa
19:00:32 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
19:00:33 <dcantrell> .hello2
19:00:35 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
19:00:40 <decathorpe> .hello2
19:00:41 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
19:00:43 <zbyszek> .hello2
19:00:44 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
19:00:55 <StephenGallagher> .hello sgallagh
19:00:56 <zodbot> StephenGallagher: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
19:01:04 <zbyszek> We have quorum.
19:01:21 <zbyszek> But I'll wait a few seconds for more folks to show up.
19:02:01 <defolos> .hello2
19:02:02 <zodbot> defolos: defolos 'Dan Čermák' <dan.cermak@cgc-instruments.com>
19:02:07 <zbyszek> Perfect timing.
19:02:09 <zbyszek> #topic #2667 F36 Change: Enable exclude_from_weak_autodetect by default in LIBDNF
19:02:09 <zbyszek> .fesco 2667
19:02:09 <zbyszek> I included this in the agenda before I knew that the title has been changed to
19:02:09 <zbyszek> "Install only newly recommended packages on upgrades with dnf/PackageKit/microdnf"
19:02:09 <zbyszek> I'm not sure if there anything else we need to discuss here. If not, we can just jump to the next topic.
19:02:11 <zodbot> zbyszek: Issue #2667: F36 Change: Enable exclude_from_weak_autodetect by default in LIBDNF - fesco - Pagure.io - https://pagure.io/fesco/issue/2667
19:02:16 <nirik> morning
19:02:54 <zbyszek> In particular, should we rename the page?
19:03:14 <Eighth_Doctor> I don't think there's anything to discuss
19:03:16 <Eighth_Doctor> they fixed the title
19:03:51 <zbyszek> OK, so let's move on.
19:03:57 <StephenGallagher> I think zbyszek wants to know if the Wiki page should move to match the new title
19:04:10 <StephenGallagher> Never mind, it appears that ALSO already happened.
19:04:11 <mhroncok> .hello churchyard
19:04:14 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
19:04:34 <zbyszek> Yeah, it's a detail, I probably shouldn't have brought this up.
19:04:37 <zbyszek> #topic #2672 Nonresponsive group: @java-maint-sig
19:04:37 <zbyszek> .fesco 2672
19:04:38 <zodbot> zbyszek: Issue #2672: Nonresponsive group: @java-maint-sig - fesco - Pagure.io - https://pagure.io/fesco/issue/2672
19:04:41 <StephenGallagher> Anyway, +1 from  me. I hadn't had a chance before today to review it
19:04:59 <zbyszek> From the original list made by Miro + an addition based on Peter's comment:
19:04:59 <zbyszek> 1. We remove all BZ assignee overrides to @java-maint-sig. This is a must.
19:04:59 <zbyszek> 2. We remove access of @java-maint-sig from all packages.
19:04:59 <zbyszek> 3. We ask the members of the group if they want to admin the list/BZ account.
19:04:59 <zbyszek> - We give it to the volunteer.
19:05:00 <zbyszek> - We empty the group and cancel the BZ account/list if nobody shows up.
19:05:03 <StephenGallagher> That +1 was for the previous topic
19:05:04 <zbyszek> 4. We don't orphan the packages, they have some "de jure" maintainers.
19:05:06 <zbyszek> 5. Replace the description of pagure.io/java-maint-sig
19:05:17 <Eighth_Doctor> +1
19:05:21 <zbyszek> StephenGallagher: I'll add your vote to the tally.
19:05:28 <dcantrell> +1
19:05:46 <defolos> +1 to the previous
19:05:47 <nirik> I don't think the group is primary maintainer on any package, but yes, +1 to this
19:06:06 <zbyszek> Please don't vote on the previous topic… It was already approved in the ticket.
19:06:14 <zbyszek> It's been up for two weeks.
19:06:21 <Eighth_Doctor> for the previous topic, the option "exclude_from_weak_autodetect" probably should be renamed to "auto_exculde_unsatisfied_weakdeps_on_upgrade" or something more meaningful
19:06:36 <Eighth_Doctor> because "exclude_from_weak_autodetect" tells me nothing
19:06:38 <StephenGallagher> Conan Kudo: Please take that to the list
19:06:51 <Eighth_Doctor> sure
19:06:55 <zbyszek> Or maybe even file a bug against libdnf?
19:07:13 <zbyszek> ... Returning to 2672 ...
19:07:31 <mhroncok> nirik: the group is a bugzilla ovveride for many packages
19:07:55 <StephenGallagher> mhroncok: So what do we do about those BZ links?
19:07:59 <nirik> yes, but it's not actual point of contact on any I don't think. So, if you remove the override the actual poc will get assigned
19:08:00 <StephenGallagher> Do they just become unassigned?
19:08:05 <mhroncok> StephenGallagher: what links?
19:08:06 <StephenGallagher> switched back to the main PoC?
19:08:17 <StephenGallagher> Sorry, links was the wrong word
19:08:24 <StephenGallagher> Who becomes the default assignee in BZ?
19:08:35 <nirik> the POC/main admin will
19:08:38 <mhroncok> the overrides will be removed, the "man admin" will be the poc
19:08:50 <mhroncok> *main
19:08:51 <decathorpe> main admin would become default assignee again. and BZ sync script would then reassign all bugs.
19:08:57 <mhroncok> indeed
19:09:04 <StephenGallagher> Ack, that's what I would have expected.
19:09:11 <zbyszek> painful, but necessary.
19:09:20 <StephenGallagher> (I always check, because expectations don't always match reality)
19:09:28 <defolos> zbyszek: Yes
19:10:31 <zbyszek> OK, so should we approve the orphaning and plan I copied above? (There was only one +1 vote in the ticket.)
19:10:40 <nirik> yes, +1
19:10:48 <decathorpe> well, no packages would actually become orphaned, would they?
19:10:52 <mhroncok> +1, it's my proposal
19:11:01 <defolos> +1 from me
19:11:05 <Eighth_Doctor> +1 from me
19:11:09 <zbyszek> decathorpe: true, "orphan" is the wrong verb.
19:11:11 <zbyszek> I'm +1 too FTR
19:11:23 <mhroncok> zbyszek: there were +2 explciit in the ticket, + me
19:11:26 <StephenGallagher> +1 from me
19:11:33 <dcantrell> +1
19:11:54 <decathorpe> +1 to the plan outlined in the ticket
19:12:11 <mhroncok> following the nonrespnsibe maintainer procedure, I'd liek to repeat the "do you wan tthis group" question in 2 days
19:12:26 <mhroncok> but I don't expect anyone would take it
19:12:59 <zbyszek> #agreed @java-maint-sig is declared "nonresponsive", and the plan (pasted below) will be implemented. (+7, 0, 0)
19:13:10 <zbyszek> (I'll paste the thing again in the ticket for clarity.)
19:13:21 <zbyszek> #topic Next week's chair
19:13:30 <zbyszek> I can do it again since this one was short…
19:13:50 <zbyszek> Unless somebody wants to
19:13:52 <zbyszek> 1
19:13:53 <zbyszek> 2
19:13:53 <zbyszek> 3
19:13:56 <zbyszek> #action zbyszek will chair next meeting
19:14:01 <zbyszek> #topic Open Floor
19:14:25 <zbyszek> So... the release is approaching quickly. Is there anything we should discuss?
19:14:27 <defolos> Thanks zbyszek
19:15:22 <StephenGallagher> zbyszek: How are things looking with resolved?
19:16:21 <zbyszek> That's a good question... I need some more time, I've been a bit overloaded with other things over the last few days. (Not work related.)
19:17:05 <zbyszek> Sorry, I don't have anything concrete atm.
19:17:22 <nirik> lots of blockers, but it sounds like most are getting addressed.
19:17:46 <zbyszek> #info https://qa.fedoraproject.org/blockerbugs/milestone/35/final/buglist
19:18:46 <zbyszek> It seems things are moving in the right direction…
19:18:56 <zbyszek> If nothing else, I'll close in a minute.
19:20:02 <zbyszek> #endmeeting