17:00:17 <mhroncok> #startmeeting FESCO (2022-04-05)
17:00:17 <zodbot> Meeting started Tue Apr  5 17:00:17 2022 UTC.
17:00:17 <zodbot> This meeting is logged and archived in a public location.
17:00:17 <zodbot> The chair is mhroncok. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:17 <zodbot> The meeting name has been set to 'fesco_(2022-04-05)'
17:00:17 <mhroncok> #meetingname fesco
17:00:17 <zodbot> The meeting name has been set to 'fesco'
17:00:22 <mhroncok> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, mboddu, tstellar, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
17:00:22 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe mboddu mhroncok nirik sgallagh tstellar zbyszek
17:00:26 <mhroncok> #topic init process
17:00:33 <sgallagh> .hi
17:00:34 <nirik> morning everyone.
17:00:34 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:00:38 <trodgers> .hi
17:00:39 <zodbot> trodgers: trodgers 'Thomas Rodgers' <trodgers@redhat.com>
17:00:40 <Eighth_Doctor> .hello ngompa
17:00:42 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:00:43 <tstellar> .hello tstellar
17:00:46 <mhroncok> .hello churchyard
17:00:47 <zodbot> tstellar: tstellar 'Tom Stellard' <tstellar@redhat.com>
17:00:50 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:00:57 <dcantrell> .hello2
17:00:58 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
17:01:01 <dcantrell> (wrong one first)
17:01:04 <zbyszek> .hello2
17:01:04 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
17:01:18 <mhroncok> dcantrell: who's on first
17:01:27 <dcantrell> hehe
17:02:05 <bcotton> .hello2
17:02:06 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
17:02:40 <mhroncok> do we have siosm or jrybar?
17:03:08 <mhroncok> if not, let's start with trodgers so they don't need to wait
17:03:27 <trodgers> I'm not going anywhere any time soon ;->
17:03:28 <mhroncok> #topic #2774 provenpackager for trodgers
17:03:35 <mhroncok> .fesco 2774
17:03:36 <zodbot> mhroncok: Issue #2774: provenpackager for trodgers - fesco - Pagure.io - https://pagure.io/fesco/issue/2774
17:03:42 <mboddu> .hello mohanboddu
17:03:43 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:04:24 <mhroncok> #info mhroncok plans to help trodgers pushing the boost bumps this time, it hasn't happened yet, but mhroncok is ready
17:05:00 <trodgers> I expect to be ready by late this week
17:05:31 <mhroncok> trodgers: would you still prefer to become provenpackager now, in the light of that?
17:05:56 <trodgers> that solves the near term problem, and codonnell has offered himself and Florian to help with future releases, I only plan to rebase Boost once per year, so on the one hand it is not imperative that I gain PP status
17:05:59 <decathorpe> .hello2
17:06:00 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
17:06:21 <trodgers> I would however note that jwakely has PP, with four packages, one of which is dead, and two others have or are transitioning to me
17:06:53 <trodgers> so I do kinda disagree with the idea that this a "numbers game" on package count which was what one of the package sponsors seemed to imply
17:07:04 <trodgers> in their response
17:07:19 <mhroncok> note that for me, not only packages count, but any track of previous work
17:07:34 * nirik is still +1, but I've known trodgers forever and knows he knows what he's doing and is trustworthy, etc.
17:07:35 <mhroncok> packaging work, that is
17:07:39 <trodgers> almost all of my work is upstream of Fedora
17:08:10 <mhroncok> technically, PPs are approved by sponsors, but this request has not gained enough support (only +1 - nirik, who knows them)
17:08:10 <trodgers> I only maintain two Fedora packages, that count is only every likely to grow by one-ish in the forseeable future
17:08:15 <nirik> most of the boost cleanup is also likely upstream... fixing things that broke this time due to boosts api changes...
17:08:17 <mhroncok> so now fesco votes
17:08:25 <Eighth_Doctor> my only issue is that I don't know trodgers much
17:08:40 <mhroncok> the cotes in the ticket are +1,0,-3
17:08:46 <mhroncok> *votes
17:08:48 <mboddu> I dont know trodgers much, but I trust nirik
17:08:54 <Eighth_Doctor> I haven't seen posts from them on list
17:09:25 <Eighth_Doctor> and I have revdeps of boost and haven't interacted with them
17:09:37 <Eighth_Doctor> only jwakely so far
17:09:47 <mhroncok> I trust nirik as well but I am a bit worried to set a precedence of "1 FESCo member trusts somebody => they become PP"
17:09:58 <zbyszek> FWIW, the fact that I know somebody personally is not really relevant. Packaging work != upstream work != being a trustworthy person in general.
17:09:59 <trodgers> jwakely has tended to handle them in the past, he is about to relenquish maintainer of boost
17:10:19 <Eighth_Doctor> so just don't know what way to vote on this, and in absence of info or anything, I can't comfortably vote +1
17:10:49 <zbyszek> My vote from the ticket still stands.
17:10:59 <Eighth_Doctor> like even if trodgers had PRs to prove packaging stuff, or did package reviews, or anything, that would help
17:11:07 <nirik> well, perhaps we could revisit after this boost work? would that give folks enough information?
17:11:26 <trodgers> mhroncok: FWIW I agree with precedent
17:11:48 <Eighth_Doctor> I don't particularly care that trodgers only maintains a few packages
17:11:49 <mhroncok> as I said before, I would very much prefer to create that track record now and reopen this request later
17:11:51 <Eighth_Doctor> that's not a huge deal to me
17:11:55 <trodgers> nirik: I think that is more or less what mhroncok agreed in our initial offline discussion anyway
17:12:05 <Eighth_Doctor> what's more important is that there's some record of expertise I can see
17:12:11 <zbyszek> +1 to what mhroncok said.
17:12:32 <sgallagh> Same, +1 to mhroncok / nirik
17:12:33 <nirik> well, if everyone is ok with that... I'm +1 for revisiting after boost work too..
17:12:45 <mboddu> Yeah, +1 for what mhroncok said
17:12:52 <Eighth_Doctor> so to be clear, I'm not saying trodgers is bad or anything. I just don't have anything to work with to feel comfortable voting +1
17:13:00 <Eighth_Doctor> I'm cool with revisiting after a boost cycle
17:13:03 <mhroncok> trodgers: would you consider withdrawing your request for now and reopening it later?
17:13:11 <mhroncok> same for me
17:13:15 <trodgers> I have done the majority of the packaging work for the past two Fedora releases, I have done all of the work for this release, modulo the package bumps
17:13:16 <tstellar> The question for me is are we allowed to consider our interactions without someone outside of Fedora?  Because if so this would be an easy +1 for me.
17:13:16 <trodgers> 
17:13:24 <trodgers> mhroncok: +1
17:13:40 <Eighth_Doctor> tstellar: what do you mean by that?
17:13:52 <Eighth_Doctor> I'm not sure I understand the question
17:13:55 <mhroncok> tstellar: you are allowed you use your own best judgement, hence yes
17:14:22 <tstellar> Eighth_Doctor: Like if we know someone in some other context, like work, upstream, etc. do we factor that in, or are we only supposed to consider work done in the Fedora community?
17:14:37 <Eighth_Doctor> tstellar: I see. Yeah if you want to, yes.
17:14:43 <mhroncok> I read trodgers's +1 as an agreement to withdraw the request for now
17:14:47 <mhroncok> so no need to vote
17:15:02 <Eighth_Doctor> I do factor that in myself, but I also have examples of "good upstream work & bad downstream packaging expertise"
17:15:11 <trodgers> just to avoid any discontent, I think that is the best thing at this point
17:15:26 <trodgers> we can get this release done, and I'll come back early next year :)
17:15:34 <Eighth_Doctor> sounds good to me
17:15:34 <mhroncok> awesome
17:15:47 <mhroncok> #info trodgers withdrw
17:15:49 <Eighth_Doctor> trodgers: if you would also consider doing some package reviews too, that would seriously help :)
17:15:53 <mhroncok> #undo
17:15:53 <zodbot> Removing item from minutes: INFO by mhroncok at 17:15:47 : trodgers withdrw
17:15:54 <mhroncok> cat
17:16:02 <trodgers> Eighth_Doctor: noted
17:16:28 <mhroncok> #info trodgers withdraws their provenpackager request for now, and will retry later
17:16:46 <Eighth_Doctor> trodgers: what I look for is an indication that you have good knowledge of RPM packaging and Fedora conventions around packaging, as well as awareness of the distribution impact of packaging choices/changes/etc.
17:16:49 <mhroncok> thank you trodgers
17:16:57 <Eighth_Doctor> so package reviews to me are a good substitute for actually having packages
17:17:01 <mhroncok> trodgers++
17:17:01 <zodbot> mhroncok: Karma for trodgers changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:17:13 <Eighth_Doctor> trodgers++
17:17:13 <zodbot> Eighth_Doctor: Karma for trodgers changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:17:22 <mhroncok> next topic?
17:17:26 <Eighth_Doctor> oh yay, the bot works for me again :D
17:17:46 <mhroncok> #topic #2766 Change proposal: Make pkexec and pkla-compat optional
17:17:48 <zbyszek> Eighth_Doctor: are you on irc or bridged?
17:17:53 <mhroncok> .fesco 2766
17:17:54 <zodbot> mhroncok: Issue #2766: Change proposal: Make pkexec and pkla-compat optional - fesco - Pagure.io - https://pagure.io/fesco/issue/2766
17:18:16 <mhroncok> say what you need to say
17:18:28 <mhroncok> if there is nothing more to be said, we can vote
17:18:34 <mhroncok> I plan to abstain
17:19:01 <mhroncok> (which works more or less as voting against, I know)
17:19:28 * mhroncok saves his -1s for worst things
17:19:58 <zbyszek> FWIW, I think the idea has some merit, but probably not enough to overcome all the destractors.
17:20:05 <zbyszek> *detractors
17:20:12 <nirik> This seems not worth it... -1 from me.
17:20:25 <mhroncok> 0
17:20:37 <tstellar> 0
17:20:50 <sgallagh> -1
17:20:52 <zbyszek> -1
17:20:56 <dcantrell> 0
17:20:58 <Eighth_Doctor> -1
17:21:05 <mboddu> -1, I feel like the change is not worth it
17:21:13 <mhroncok> I forgot who is here and who isn't
17:21:25 <mhroncok> Fabio Valentini: ?
17:22:10 <dcantrell> (https://www.youtube.com/watch?v=BQT08NFsf4w)
17:22:25 <mhroncok> #agree REJECTED (+0, 3, -5)
17:22:44 <mhroncok> #topic #2759 Proposal: periodic check on packagers reachability
17:22:50 <mhroncok> .fesco 2759
17:22:51 <zodbot> mhroncok: Issue #2759: Proposal: periodic check on packagers reachability - fesco - Pagure.io - https://pagure.io/fesco/issue/2759
17:23:04 <mhroncok> so, this is on the agenda for one reason
17:23:13 <mhroncok> please go read it and vote there
17:23:22 <mhroncok> it is sitting there for too long
17:23:30 * mhroncok is guilty as well
17:23:52 <mhroncok> we don't need to discuss it here, but we can, in case there is something to discuss
17:24:13 <sgallagh> I don't think I can internalize this quickly enough to have a discussion here today.
17:24:16 <nirik> Who is going to write and maintain the scripting?
17:24:39 <mhroncok> that is a very good question
17:24:48 <mhroncok> and in fact, it popped in y head as well
17:24:53 <mhroncok> *my
17:25:29 <mhroncok> we can at least allow it to be written and approve the policy, if in reality nobody does it, we can revert
17:25:40 <zbyszek> I'd propose the following: let's approve the policy provisionally, and only merge the PR when we have an implementatino.
17:25:44 <mhroncok> (I imagine nobody is highly motivated to write the script before they know it will be approved)
17:25:45 <nirik> or make the policy contingent
17:25:50 <zbyszek> (Or what mhroncok said.)
17:25:52 <mhroncok> right
17:25:55 <zbyszek> (Or nirik.)
17:25:58 <mhroncok> both works for me
17:26:01 <bcotton> who will run the script, too?
17:26:17 <nirik> I'm happy to help deploy it and fix simple things, but I don't want to write it
17:26:32 <nirik> IMHO it would be best to be deployed in infra...
17:26:34 <mhroncok> who runs the provenpackager script?
17:26:43 <bcotton> i do
17:27:06 <mhroncok> nirik: BTW I have many things that would be best to be deployed in infra... :D
17:27:21 <mhroncok> Ben Cotton (he/him): so you run this one as well :)
17:27:23 <nirik> yeah...
17:27:39 <mhroncok> it's called decentralized infra
17:27:47 <bcotton> that should be explicitly reflected in the policy, then
17:28:00 <zbyszek> Hmm, why?
17:28:05 <bcotton> and also, that would make me pay more attention to what it says :-)
17:28:19 <bcotton> (i've mostly ignored this proposal until now)
17:29:00 <mhroncok> BTW when we revisited FTBFS/FTI policies, I made sure that everybody can do the steps manually or write a script or run the script -- that way, thepolociy was not blocked on implementation
17:29:11 <mhroncok> *the policy
17:29:21 <nirik> thats another nice want to do it... however...
17:29:41 <nirik> this policy calls for specific times. It's harder for a human to do that than a cronjob.
17:29:41 <bcotton> zbyszek: why what?
17:29:49 <mhroncok> right
17:29:57 <zbyszek> bcotton: "that should be explicitly reflected in the policy, then"
17:30:01 <mhroncok> more flexible times would help
17:30:24 <mboddu> Maybe releng can take over it? Write the script and put it as a cron job some where in the fedora infra?
17:30:42 <bcotton> zbyszek: because that makes it clear who is responsible as opposed to "oh, someone will do that"
17:30:47 <mhroncok> mboddu: is releng available to do that?
17:30:52 <nirik> mboddu: in their copious spare time?
17:30:52 <zbyszek> Wasn't there some early version of the script posted?
17:31:27 <zbyszek> bcotton: I don't think that needs to be part of the written policy. Who does the work is often not mentioned at all in our rules.
17:31:28 <mboddu> mhroncok: I can check with jednorozec
17:31:40 <Eighth_Doctor> what defines reachable? is it just activity in src.fedoraproject.org?
17:31:56 <bcotton> zbyszek: i'm not opposed to it being added to the FPgM's responsibilities, but having it explicit helps with continuity
17:32:01 * mboddu wont be available as a full time release engineer in couple of weeks time
17:32:10 <zbyszek> Eighth_Doctor: please read the proposal
17:32:10 <bcotton> zbyszek: arguably, that's a bug in the current policies :-)
17:32:26 <Eighth_Doctor> I did, but it's very long and a little confusing
17:32:44 <Eighth_Doctor> that's why I am asking
17:33:14 <mhroncok> since not everybody is 100% up to date with the proposal, we can continue this asynchronously. I just added it on the agenda, to remind us that the proposal exists
17:34:14 <zbyszek> "any activity in the last 12 months period in the following places:", and there's a list of 5 places.
17:34:44 <zbyszek> Isn't this clear enough?
17:36:08 <mhroncok> seems clear enouh to me
17:36:15 <mhroncok> anyway...
17:36:45 <mhroncok> #info FESCo, please post your votes to the ticket and nitpicks to the PR
17:37:06 <mhroncok> #topic Next week's chair
17:37:46 <mhroncok> I might need to leave 30 minutes after the meeting starts next week
17:37:54 <mhroncok> so I prefer not to chair
17:40:14 <nirik> I guess i've not done it in a while...
17:40:31 <mhroncok> #action nirik will chair next meeting
17:40:41 <mhroncok> nirik++
17:40:48 <mhroncok> #topic Open Floor
17:41:13 <zbyszek> How is F36 coming along?
17:41:22 <mboddu> Freeze just started :)
17:41:25 <zbyszek> Anything particularly on fire?
17:41:40 <nirik> Just out of curiosity... how many fesco members are on from matrix currently? or still on from irc I guess would be better to ask...
17:41:53 <dcantrell> irc here
17:41:53 <mboddu> I am still on irc
17:41:55 <mhroncok> matrix here
17:42:01 <zbyszek> I'm on both, but typing in irc.
17:42:12 <mhroncok> zbyszek: https://qa.fedoraproject.org/blockerbugs/milestone/36/final/buglist
17:42:13 <dcantrell> mhroncok: if you're on from matrix, how do you not have the silly '[m]' suffix?
17:42:16 <Eighth_Doctor> matrix
17:42:29 <nirik> ok. Just wondering if we could use the matrix polling feature for votes... ;) But seems not yet.
17:42:33 <mhroncok> dcantrell: I've chnaged it somewhere, but I don't recall
17:42:34 <zbyszek> I have the problem with the graphical clients that they display previews of all links, and the previous are 99% useless.
17:42:41 <Eighth_Doctor> you can set the nick in the appservice
17:42:50 <mhroncok> yes, appservice
17:42:52 <nirik> zbyszek: you can turn that off.
17:42:55 <mhroncok> !nick whatever
17:42:55 <tstellar> PRs for the redhat-rpm-config repo are starting to pile up again (some are from me).
17:43:02 <Eighth_Doctor> I did the same thing, so that's why Conan Kudo is Eighth_Doctor
17:43:46 <mhroncok> tstellar: I was hoping somebody will beta me to it, but if not, ping me directly during my working hours and I can have a look
17:43:47 <nirik> for f36: lots of blockers known need fixing. ;( Scientific KDE is failing due to Julia... which appears to be a gcc thing
17:43:49 <Eighth_Doctor> tstellar: I'm planning on reviewing them later this week, I also need to sit down and fix some brokenness about how redhat-rpm-config is actually versioned and maintained
17:43:51 <mhroncok> *beat
17:44:15 <mboddu> If someone can suggest me a great client for matrix, then I would love to jump
17:44:17 <Eighth_Doctor> the main reason I hadn't gotten to them yet is that both Workstation and KDE have been on fire with blocker bugs for the past three weeks
17:44:26 <Eighth_Doctor> that's finally doused so I can get to looking at them
17:44:35 <dcantrell> mboddu: I've been slowly trying to figure out matrix via weechat
17:44:38 <tstellar> mhroncok, Eighth_Doctor: Ok thanks.
17:44:44 <mhroncok> "fix some brokenness about how redhat-rpm-config is ... maintained" -- well, it is not maintained
17:44:46 <nirik> mboddu: all of them have their faults... element is probibly the best bet right now. ;(
17:44:56 <dcantrell> mboddu: it's less objectionable than the libpurple plugin
17:44:56 <mboddu> dcantrell: Ohhh, let me know how it goes
17:45:00 <dcantrell> sure
17:45:27 <mboddu> nirik: Yeah, but it feels like bloted and always lags (at least for me)
17:45:28 <dcantrell> I sidetracked and migrated all of my existing chat from irssi over to weechat and now am trying to add in matrix
17:45:30 <dcantrell> but....ugh
17:45:38 <Eighth_Doctor> I use Element right now, though I continually try NeoChat
17:45:46 <zbyszek> nirik: thanks, I see the option in element now. No idea how i missed it before.
17:45:54 <zbyszek> Element is pretty nice.
17:45:57 <mboddu> It seems the new thunderbird has support for matrix, waiting to try it out
17:46:18 <Eighth_Doctor> it also seems like we might get Element in the distro with having a potential nodejs-electron implementation
17:46:40 <Eighth_Doctor> asn is asking for co-maintainers to help with it before submitting it for review
17:47:23 <mhroncok> ok folks
17:47:51 <mhroncok> let's move matrix discussion to another channel if you wish
17:48:13 <mhroncok> I plan to end this meeting if no other topic pops out
17:48:20 <mhroncok> pops up?
17:49:12 <mhroncok> What I like about Matrix is that I can see who's up to date wit my recent messages here
17:49:30 <mhroncok> (currently that is nobody)
17:50:03 <Eighth_Doctor> 👍️
17:50:16 <mhroncok> #endmeeting