17:00:00 <mhayden> #startmeeting FESCO (2022-08-23)
17:00:00 <zodbot> Meeting started Tue Aug 23 17:00:00 2022 UTC.
17:00:00 <zodbot> This meeting is logged and archived in a public location.
17:00:00 <zodbot> The chair is mhayden. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:00 <zodbot> The meeting name has been set to 'fesco_(2022-08-23)'
17:00:05 <mhayden> #meetingname fesco
17:00:05 <zodbot> The meeting name has been set to 'fesco'
17:00:12 <mhayden> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, music, mhayden, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
17:00:12 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe mhayden mhroncok music nirik sgallagh zbyszek
17:00:21 <mhayden> #topic init process
17:00:27 <nirik> morning
17:00:33 <mhayden> 👋🏻
17:00:45 <mhayden> .hello mhayden
17:00:46 <zodbot> mhayden: mhayden 'Major Hayden' <mhayden@redhat.com>
17:01:26 <mhayden> nirik: howdy!
17:01:34 <zbyszek> .hello2
17:01:35 <mhroncok> .hello churchyard
17:01:35 <music[m]> .hello music
17:01:36 <bcotton> .hello2
17:01:37 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
17:01:40 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:01:43 <zodbot> music[m]: music 'Benjamin Beasley' <code@musicinmybrain.net>
17:01:46 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
17:01:48 <mhayden> hello zbyszek mhroncok bcotton music[m]!
17:02:21 <mhayden> i think we're one short of quorum if i am counting correctly (first time chair here)
17:02:47 <mhayden> apologies for missing the monday assignments of chair duties 🤦🏻‍♂️
17:03:23 <zbyszek> I think we have 5 folks, no?
17:03:42 <nirik> yeah, just barely quorum...
17:03:58 <mhayden> oh yes, i forgot nirik's early message there since the last four arrived simultaneously (how did you plan that?)
17:04:00 <zbyszek> None of us can fall asleep in the next hour!
17:04:18 <salimma> .hi
17:04:19 <zodbot> salimma: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:04:28 <mhayden> howdy salimma
17:04:30 * bcotton plays the vuvuzela to keep everyone awake
17:04:48 <mhayden> okay, since we have quorum, i'll move along -- i only found four issues with potential decisions required
17:04:53 <salimma> hi all (I don't count towards the quorum, in case anyone wonders)
17:05:09 <mhayden> but you do count towards my enjoyment of this meeting, salimma
17:05:29 <mhayden> #topic #2853 Reduce default service timeout to 15s
17:05:32 <mhayden> .fesco 2853
17:05:33 <zodbot> mhayden: Issue #2853: Reduce default service timeout to 15s - fesco - Pagure.io - https://pagure.io/fesco/issue/2853
17:06:07 <mhayden> request here is to shrink the default service timeout to make shutdowns/reboots faster, but this can hide some underlying bugs
17:06:12 <mhayden> most notably in packagekit
17:06:25 <nirik> Ideally this would get changed upstream... but I guess that didn't work out
17:06:42 <mhayden> the packagekit one has gotten me a few times on silverblue
17:07:13 <mhayden> nirik: ideally, it would be awesome to find these problems causing delays but it seems they're not the easiest to find/solve
17:07:38 <nirik> indeed... I have seen this with httpd on servers...
17:07:42 <mhroncok> we are at 100% code complete now
17:07:45 <mhroncok> this is too late for f37
17:07:48 <nirik> yep
17:07:53 <mhayden> that is for sure
17:08:04 <mhroncok> and for f38, it can (and IMHO should) go trough the change process
17:08:13 <nirik> +1
17:08:20 <mhroncok> to collect feedback from others, not just us
17:08:23 <mhayden> +1
17:08:27 * bcotton nods in program manager
17:08:30 <zbyszek> Yeah, this is harder than it looks. I think F38 is more reasonable…
17:09:01 <mhayden> okay, is this something we need to vote on, or should i update that ticket and ask for a change request to be submitted?
17:09:32 <nirik> I don't think we need a vote... close ticket ask them to file a f38 change
17:09:51 <mhayden> #action mhayden to update 2853 with a request to submit a change for F38 instead
17:09:56 <mhroncok> ack
17:10:07 <mhayden> moving along...
17:10:22 <mhayden> #topic #2855 Improve package orphaning process
17:10:26 <mhayden> .fesco 2855
17:10:27 <zodbot> mhayden: Issue #2855: Improve package orphaning process - fesco - Pagure.io - https://pagure.io/fesco/issue/2855
17:11:16 <mhayden> if i read this correctly, it talks about adding co-maintainers onto a non-responsive maintainer ticket as well as notifying the package-owners list?
17:11:41 <mhayden> errr, $PACKAGENAME-maintainers@ list
17:11:48 <nirik> (alias actually)
17:11:55 <mhayden> thanks, nirik
17:12:05 <kalev> yeah, exactly that
17:12:17 <Eighth_Doctor> .hello ngompa
17:12:18 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:12:20 <kalev> I filed that ticket in response to some um, heated discussion on irc after a co-maintainer noticed that someone else had been promoted as the main admin
17:12:23 <mhayden> howdy Eighth_Doctor!
17:12:34 <mhroncok> this is more work
17:12:35 <Eighth_Doctor> hey folks :)
17:12:42 <zbyszek> Can we automate it?
17:12:44 <nirik> I think thats reasonable... although in most cases I suspect co-maintainers that aren't paying attention don't really care about those packages... but there are cases where they very much do
17:12:47 <nirik> hey Eighth_Doctor
17:12:47 <kalev> and it came out of blue for the co-maintainer who had no idea that someone else had taken over the package
17:12:51 <mhroncok> nobody does that work but me
17:13:01 <mhroncok> happy to rty to be more friendly, but at the same time would be great if others also did the work
17:13:16 <mhayden> it would be nice to replace mhroncok-as-a-service with a script or some other automation 😉
17:13:17 <mhroncok> s/rty/try/
17:13:28 <nirik> mhayden: +1
17:13:40 <mhroncok> it is possible to automate it, but the devil is in the details
17:14:09 <mhayden> could we update some docs/wiki as a stopgap until we figure out an automation solution?
17:14:22 <zbyszek> I think if we implement 1), i.e. @mention for comaintainers in the ticket, we can skip 2).
17:14:32 <bcotton> we don't need to solve all of the edge cases if we can improve the notifications for most cases
17:14:35 <mhroncok> (note that there are much more tedious mhroncok-as-a-service task that should be done by automation than this)
17:14:54 <mhroncok> that would be much easier to implement
17:15:00 <kalev> zbyszek: yeah, agreed, and that should be easy enough to script I think
17:15:03 <bcotton> zbyszek++
17:15:03 <zodbot> bcotton: Karma for zbyszek changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:15:09 <mhayden> zbyszek: agreed
17:15:14 <mhroncok> See https://pagure.io/fesco/issue/2852#comment-811351 and https://pagure.io/fesco/issue/2856#comment-812124
17:15:30 <mhayden> #link https://pagure.io/fesco/issue/2852#comment-811351
17:15:31 <mhroncok> this is a result fo the actual script that would do the orphaning
17:15:37 <mhayden> #link https://pagure.io/fesco/issue/2856#comment-812124
17:15:44 <bcotton> churchyard++ for his mhroncok-as-a-service-ing, too
17:15:44 <zodbot> bcotton: Karma for churchyard changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:15:44 <mhroncok> except I queried comaintainers manually becasue both of them only were main admins of a few packages
17:16:15 <mhroncok> once we get a nonresponsive maintainer with plenty (should be Igor soon), I will look into automating that part
17:16:24 <kalev> mhroncok: that's excellent, exactly what I meant -- thank you!
17:16:34 <mhayden> oh yeah, i see the @ mentions there
17:16:43 <mhayden> that is good
17:16:52 <bcotton> i suspect the fallout from the inactive packager process will make us glad to have this, too
17:17:00 <kalev> and thanks for being the orphaning service, I really appreciate that we get rid of broken packages nowadays
17:17:15 <mhroncok> note that from experiance, the comaintainers tned to be dead as well
17:17:19 <mhroncok> *tend
17:17:22 * nirik nods
17:17:29 <mhayden> that's good insight
17:17:31 <mhroncok> the situation that triggered thsi ticket is not common
17:17:37 <mhayden> i was hoping the comaintainers would be more active
17:17:57 <mhroncok> and the person who took over the package is agressively taking over anything orpahned (which makes a bit worried)
17:18:05 <nirik> if they were, typically no one would bother to start the process...
17:18:10 <mhayden> okay, long term action is automation -- do we have anything in the short term? looks like the fesco ticket template calls out the comaintainer mentions there
17:18:37 <music[m]> (was pulled away, jumped back in and caught up, have nothing to add)
17:18:50 <mhroncok> the comaintainer mentions have 2 major flaws
17:19:03 <mhroncok> 1) people only fill in comaintainers of the one package they care about
17:19:13 <mhroncok> 2. people don't actually bother to fill it at all
17:19:55 <mhayden> couldn't we ask them to complete the entire form for this process? (if it's not fully completed)
17:19:59 <mhroncok> as said. I am OK to post a dry-run output of the script I use to actually get the thing done at the end
17:20:10 <zbyszek> That'd be useful.
17:20:12 <mhayden> mhroncok: that would be nice
17:20:19 <mhroncok> and once there are too many packages that would get orphaned, it should be easy to load the list of comaintainers
17:20:54 <mhayden> #action mhroncok to share script output or the script that does the unresponsive maintainer work at the end
17:21:13 <mhayden> mhroncok++
17:21:13 <zodbot> mhayden: Karma for churchyard changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:21:20 <mhroncok> if @music opens the ticket for Igor, I get a nice playground for this
17:21:20 <kalev> mhroncok++
17:21:20 <zodbot> kalev: Karma for churchyard changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:21:27 <zbyszek> mhroncok++
17:21:27 <zodbot> zbyszek: Karma for churchyard changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:21:29 <mhayden> is there anything else we need to do with this one right now?
17:21:36 <music[m]> so, as the person who needs to file a fesco ticket for ignatenkobrain soon, i don’t know of a documented trivial way to answer the question: for which packages is this FAS account main admin?
17:21:44 <mhroncok> it's raining cookies
17:21:49 <mhayden> kalev: thanks for bringing this up 🫂
17:21:54 <mhroncok> music: and neither should you
17:22:09 <music[m]> much less: what are all of the co-maintainers for all of those packages?
17:22:21 <mhayden> music[m]: oof, i might be one of the co-maintainers on a few
17:22:42 <mhroncok> so do I
17:23:21 <music[m]> well, a lot are co-maintained with sigs, so a huge number of people are co-maintainers with at least one ignatenkobrain package
17:23:33 <mhroncok> oh
17:23:36 <bcotton> what if we don't care if someone is a main admin? ideally, we'd only notify on those packages, but notifying all co-maintainers on all packages seems better than notifying no one
17:23:44 <mhroncok> we cannot @mention sigs
17:23:57 <mhayden> do we have high-level requirements for a script for this? seems it needs to find 1) packages owned by someone and 2) identify anyone else with packaging rights on the package
17:24:07 <mhroncok> but I don't think we ned to @mention all sig members instead
17:24:47 <nirik> thinking about it, it would be nice if we just didn't have the concept of 'main admin'... but I guess that would take a bunch of pagure work. ;(
17:24:49 <mhroncok> mhayden: we already have 1
17:24:54 <mhayden> oh!
17:25:29 <mhroncok> https://pagure.io/releng/blob/main/f/scripts/distgit/retire_packagers.py
17:25:46 <mhroncok> this supports --dry-run
17:26:00 <mhayden> #link https://pagure.io/releng/blob/main/f/scripts/distgit/retire_packagers.py
17:26:17 <mhroncok> or rather does require --retire to actually do any changes
17:26:40 <mhroncok> so I need to extend the output it spits -- and it probbaly laready has the data in some dicts
17:27:00 <mhroncok> anyway, we are on this for a long time
17:27:30 <mhayden> indeed. i think we have a good stopgap with mentions there but some automation would be welcomed in the medium/long term
17:27:42 <mhayden> is there anything else we need to add on this right now?
17:27:58 <nirik> when all the inactive packagers are removed this will need a good process to handle all them.
17:28:32 <Eighth_Doctor> there's always going to be a concept of a "main admin"
17:28:38 <Eighth_Doctor> other systems call them "owner"
17:28:40 <mhroncok> nirik: good point
17:28:48 <mhroncok> we can post the ouput to the tickets there as well
17:29:17 <nirik> Eighth_Doctor: why? the only reason it was really set that way was for bugzilla, but we can assign bugzilla bugs to anyone as long as there is an asignee. ;)
17:29:38 <Eighth_Doctor> nirik: it's an ACL thing, not a BZ thing
17:30:14 <Eighth_Doctor> Pagure, GitHub, and GitLab all have similar concepts, the difference is that Pagure only allows one "main admin"
17:30:16 <nirik> I don't see why there cannot be N co-equal admins maintaining something.
17:30:39 <nirik> anyhow, thats probibly driving things off topic, sorry...
17:30:44 <mhayden> alrighty -- good discussion but i think we're wandering a little 😉
17:30:54 <mhroncok> when there is no primary maintainer, e.g. when the main bz contact is a sig, it makes it harder to deal with ignored bugillas and PRs
17:31:19 <mhayden> are we good to move on to the next topic?
17:31:26 <mhroncok> yes
17:31:31 <zbyszek> mhayden: you're the boss
17:31:31 <mhayden> woot
17:31:40 <mhayden> zbyszek: uh oh
17:31:44 <decathorpe> hi, sorry, was pulled away for family dinner.
17:31:50 <mhayden> #topic #2849 enable systemd preset for waagent.service (WALinuxAgent)
17:31:53 <mhayden> .fesco 2849
17:31:53 <zodbot> mhayden: Issue #2849: enable systemd preset for waagent.service (WALinuxAgent) - fesco - Pagure.io - https://pagure.io/fesco/issue/2849
17:32:34 <mhayden> azure allows customers to make changes to running instances using an agent -- that agent is not enabled by default
17:32:49 <mhayden> azure's infrastructure talks to the agent, tells it to do things, and it does them
17:33:04 <mhayden> (this is supplemental to cloud-init's changes on the first boot)
17:33:25 <mhayden> we're being asked about enabling that daemon by default on azure images
17:33:51 <mhayden> currently stalled on whether the daemon listens on TCP/UDP ports by default
17:34:28 <mhayden> and bcotton requested a devel thread on it (searching for that)
17:34:39 <zbyszek> I didn't see no thread.
17:34:44 * mhayden cannot find a thread
17:35:01 <decathorpe> Yeah, I don't think the questions we had have been answered yet.
17:35:18 <mhayden> my concern here is that without the agent, some of the azure functionality is missing (but the instance still does everything it's supposed to)
17:35:27 <mhayden> but it's also a thing running as root taking instructions from outside the instance
17:35:32 <mhayden> so there's a bit of a balance here
17:36:15 <mhayden> my suggestion: 1) Ask requester to start a devel thread 2) verify that the daemon isn't listening on network ports by default and 3) revisit after that
17:36:32 <mhroncok> ack
17:36:49 <decathorpe> I wonder, how does it get communications from the "outside" if not via network ports
17:36:59 <zbyszek> mhayden: ack
17:37:02 <mhayden> azure does offer a metadata service
17:37:37 <mhayden> which exists on a locally-accessible address: 169.254.169.254
17:37:44 <mhayden> that could be it, but it requires more investigation
17:38:09 <mhayden> #action mhayden to update #2849 and ask for a devel thread and how walinuxagent communicates w/azure's cloud
17:38:11 <decathorpe> yeah. :(
17:38:12 <mhayden> anything else here?
17:38:55 <mhayden> since zbyszek says i'm the boss... moving along 😜
17:38:58 <mhayden> #topic Next week's chair
17:39:15 <mhayden> I am happy to do it next week so I can actually do the prep work this time, but i am happy to yield to someone else
17:39:53 * mhayden feels like he is bossing himself around now
17:39:57 * zbyszek has a conflicting meeting and is not sure he'll be able to make it next week
17:40:16 <mhayden> zbyszek: we will miss you 😢
17:40:30 <zbyszek> or not ;)
17:40:33 <decathorpe> I'm pretty busy until end of September, but I can run meetings again starting October
17:40:47 <mhayden> okay, i'll take for next week and actually do the prep work this time around 😂
17:40:50 * mhroncok will be after a all-weekend Czech Python community gathering, so probably dead tired
17:41:04 <mhayden> #action mhayden to chair the next meeting and he will actually follow the instructions
17:41:13 <mhayden> #topic Open Floor
17:41:35 <mhayden> 🪑
17:41:51 <mhayden> anything that anyone would like to bring up?
17:41:55 <zbyszek> Do we need to discuss the sig-package ownership tickets?
17:42:17 <mhayden> zbyszek: r-maint-sig and go-sig?
17:42:24 <zbyszek> yep
17:42:29 <mhayden> #link https://pagure.io/fesco/fesco-docs/pull-request/69
17:42:34 <mhayden> #link https://pagure.io/fesco/fesco-docs/pull-request/68
17:43:17 <zbyszek> I'm fine with the answer being "no, people just need to vote in the ticket".
17:43:18 <nirik> I'm happy to merge and run that later today... I don't have any problems with the tickets/script
17:43:26 <mhayden> it looks like #69 is just about done
17:43:33 <decathorpe> for r-maint-sig, I think it would make sense to include anything that BuildRequires: R-devel, as well, but I'm happy with it as-is, too
17:43:34 <mhroncok> no, people just need to vote in the ticket
17:44:05 <zbyszek> mhroncok: I like your answer
17:44:28 <zbyszek> Please do vote.
17:44:47 <mhroncok> i might, evenetually, if not approved without me :)
17:44:58 <music[m]> Jumping back to waagent, a glance at the source suggests that it meddles with firewall rules: https://github.com/Azure/WALinuxAgent/blob/master/azurelinuxagent/common/persist_firewall_rules.py
17:45:02 <mhayden> #action everyone go vote on both FESCo PRs (#68 and #69) please
17:45:06 <music[m]> Something to look into more closely…
17:45:17 <mhayden> music[m]: it does many things
17:45:44 <mhayden> okay, anything else for open floor?
17:46:21 <mhroncok> release us :)
17:46:31 <mhayden> haha, consider yourself RELEASED
17:46:34 <mhayden> thanks everyone
17:46:40 <mhayden> have a great rest of your day
17:46:41 * mhroncok needs to water the tomatoes beore it's completely dark out there :D
17:46:50 <zbyszek> Thanks mhayden
17:46:52 <mhayden> #endmeeting