17:00:12 <nirik> #startmeeting FESCO (2022-09-06)
17:00:12 <zodbot> Meeting started Tue Sep  6 17:00:12 2022 UTC.
17:00:12 <zodbot> This meeting is logged and archived in a public location.
17:00:12 <zodbot> The chair is nirik. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:12 <zodbot> The meeting name has been set to 'fesco_(2022-09-06)'
17:00:12 <nirik> #meetingname fesco
17:00:12 <zodbot> The meeting name has been set to 'fesco'
17:00:12 <nirik> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, music, mhayden, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
17:00:12 <nirik> #topic init process
17:00:12 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe mhayden mhroncok music nirik sgallagh zbyszek
17:00:24 <mhayden> .hello mhayden
17:00:25 <zodbot> mhayden: mhayden 'Major Hayden' <mhayden@redhat.com>
17:00:35 <decathorpe> .hi
17:00:36 <nirik> morning everyone
17:00:36 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
17:00:46 <Eighth_Doctor> .hello ngompa
17:00:47 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:01:04 <dcantrell> .hello2
17:01:05 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
17:01:08 <mhroncok> .hello churchyard
17:01:09 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:01:21 <gotmax[m]> .hello gotmax23
17:01:24 <zodbot> gotmax[m]: gotmax23 'Maxwell G' <gotmax@e.email>
17:01:53 <nirik> lets wait just a minute or so more for any other folks.
17:02:48 <salimma> .hi
17:02:49 <zodbot> salimma: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:02:53 <bcotton> .hello2
17:02:54 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
17:03:15 <nirik> ok, lets go ahead and get started. ;)
17:03:23 <mhayden> 👋
17:03:25 <nirik> #topic #2859 F37 incomplete Changes: 100% complete deadline
17:03:25 <nirik> https://pagure.io/fesco/issue/2859
17:03:42 <sgallagh> .hi
17:03:43 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:03:59 <nirik> so lets see....
17:04:46 <nirik> do we want to go thru these one by one? just give more time?
17:05:34 <nirik> or punt all incomplete ones to f38 and do contingency?
17:05:42 <mhroncok> nromally, we go one by one for the system ones
17:05:57 <decathorpe> doesn't look too bad this time
17:06:19 <nirik> ok, lets do that then...
17:06:23 <mhroncok> however, I propose that the system wide changes with beta freeze contingency deadline should be defered
17:06:31 <nirik> ah, ok.
17:06:31 <mhroncok> but we should check if they ar enot in fact done
17:06:36 <mhroncok> s/ar/are/, s/enot/not/
17:06:59 <mhroncok> LegacyXorgDriverRemoval
17:07:49 <mhroncok> https://src.fedoraproject.org/rpms/xorg-x11-server/commits/rawhide does not indicate any change
17:07:57 <nirik> I don't see anything that looks like this in those commits.
17:07:58 <nirik> yeah.
17:08:00 <mhroncok> drop_NIS_support_from_PAM
17:08:18 <mhroncok> "Adapt the pam spec file to build without support for NIS(+)."
17:08:34 <bcotton> i'm beginning to wonder if we should start the nonresponsive maintainer process for besser82 :/
17:08:41 <mhroncok> I see no relevant commits in https://src.fedoraproject.org/rpms/pam/commits/rawhide
17:08:41 <Eighth_Doctor> yeah....
17:08:47 <Eighth_Doctor> I haven't seen Bjorn around in a while
17:09:09 <nirik> hopefully he's just busy.
17:09:14 <mhroncok> retire_NIS_user_space_utils
17:09:29 <mhroncok> listed packages were not retired
17:09:35 <Eighth_Doctor> I think if the pam change hasn't happened, the userspace ones didn't either
17:09:35 <mhroncok> JdkInTreeLibsAndStdclibStatic
17:09:58 <mhroncok> https://src.fedoraproject.org/rpms/java-latest-openjdk/pull-request/98#request_diff was merged
17:10:27 <decathorpe> side note: I think the Xorg Legacy Driver removal happened ... I don't see vesa_drv.so or fbdev_drv.so files here: https://koji.fedoraproject.org/koji/rpminfo?rpmID=31373185
17:11:04 <nirik> they are in their own packages I thought?
17:11:28 <mhroncok> Fabio Valentini: but do you see them in f36?
17:11:38 <mhroncok> I am nto sure how to check the Java thing properly
17:11:51 <nirik> xorg-x11-drv-vesa ? xorg-x11-drv-fbdev
17:12:05 <Eighth_Doctor> that's what I thought too
17:12:16 <mhroncok> common denominator of all the change proposals is that the How To Test section gves no cle about how to test if this happeened :(
17:12:18 <decathorpe> oh, nirik is right.
17:12:21 <nirik> yeah, not sure on java.
17:12:29 <decathorpe> the description in the Change page is wrong then.
17:12:37 <nirik> The last one is Cloud Editon...
17:12:59 <nirik> decathorpe: well, I think the change is removing the support code in the server to even open those?
17:13:30 <decathorpe> or I can'T read.
17:13:31 <mhroncok> * common denominator of all the change proposals is that the How To Test section gives no clue about how to test if this happened :(
17:13:47 <mhroncok> https://src.fedoraproject.org/rpms/java-17-openjdk/c/b6fe10006550dde2aee2763c06dd2f0143850dfa?branch=rawhide 5 days ago
17:13:48 <Eighth_Doctor> davdunc: ping
17:13:48 <zodbot> Eighth_Doctor: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
17:13:57 <davdunc[m> .hello2
17:13:57 <zodbot> davdunc[m: Error: Missing "]".  You may want to quote your arguments with double quotes in order to prevent extra brackets from being evaluated as nested commands.
17:14:19 <mhroncok> Java seem to have only happened in rawhide
17:14:25 <nirik> mhroncok: good find.
17:14:42 <salimma> zodbot has a syntax error, it seems
17:15:12 <davdunc> .hello2
17:15:12 <mhroncok> Hence, I propose that the system wide changes with beta freeze contingency deadline should be deferred to F38
17:15:12 <zodbot> davdunc: davdunc 'David Duncan' <davdunc@amazon.com>
17:15:16 <davdunc> there.
17:15:18 <nirik> it's because [ ] is a 'expand this' call to supybot, and davdunc[m's nick doesn't match closing ]
17:15:26 <mhroncok> that is all listed System-Wide Changes except Return Cloud Base to Edition Status
17:15:51 <gotmax[m]> You just need `.hello davdunc`
17:15:57 <gotmax[m]> If you're using Matrix
17:16:00 <decathorpe> mhroncok: +1
17:16:15 <salimma> ah. I just make sure my Matrix is always mapped to a valid IRC nick :)
17:16:19 <nirik> mhroncok: +1
17:16:32 <davdunc> :) thanks gotmax[m] I just need to fix my nick, but yes. That's a good workaround.
17:16:48 <Eighth_Doctor> that's why I use `.hello ngompa`
17:16:49 <nirik> davdunc: what can you tell us about the Cloud Edition status change? are websites/docs updated? not sure what else there was to do there.
17:16:59 <Eighth_Doctor> also for a while, it couldn't read my nick map :)
17:17:20 <gotmax[m]> I still have [m] in my Matrix nick, because I occasionally use IRC
17:17:48 <davdunc> nirik: we have updated some docs for the project and we have more to do. We have a guidelines document from mhayden that's in review now.
17:17:53 <salimma> gotmax (He/Him): you can have multiple Libera nicks grouped together - and FAS let you register three nicks
17:17:55 <mhroncok> LLVM-15 has condingency at FinalFreeze - punt
17:18:13 <Eighth_Doctor> Michel Alexandre Salim 🎩: you can have way more than 3 :)
17:18:19 <mhayden> davdunc: yeah, we probably need a mini-hackfest to run through the remaining items
17:18:25 * davdunc I have been working with the websites group to determine what I need to do for the updates and I have not been given any additional tasks to complete.
17:18:31 <mhroncok> IoTArtifactsWithOSBuild has contingency deadline: Beta -- I propose if this land in beta, it lands in F37, else it is defered to F38
17:18:32 <bcotton> discussion of nicks in FAS are probably off-topic for this meeting
17:18:57 <davdunc> mhayden: I'd like that
17:19:23 <nirik> mhroncok: seems reasonable. I know there's been activity on this, but I am not sure what the current status is.
17:19:31 <mhroncok> and Preset_All_Systemd_Units_on_First_Boot says "This can be done at any time up to the release." but I'd rather do it in beta and not later
17:19:47 <mhroncok> but, let's vote on the system wide proposal?
17:19:57 <nirik> mhroncok: so, then, proposal is:
17:20:16 <mhroncok> I count +3 nirik Fabio Valentini and me
17:20:49 <nirik> All incomplete changes except Cloud Edition and IoTArtifactsWithOSBuild are deferred to f38 and should execute any contingency plans they have (if needed).
17:21:13 <Eighth_Doctor> mhroncok: +1
17:21:28 <mhayden> +1 here, too
17:21:52 <nirik> ok, thats enough to pass... other votes?
17:22:40 <nirik> #agreed All incomplete changes except Cloud as Edition and IoTArtifactsWithOSBuild are deferred to f38 and should execute any contingency plans they have (if needed).  (+5,0,0)
17:22:46 <mhroncok> nono
17:22:46 <Eighth_Doctor> +1
17:22:50 <nirik> no?
17:22:52 <mhroncok> LLVM
17:22:53 <nirik> #undo
17:22:53 <zodbot> Removing item from minutes: AGREED by nirik at 17:22:40 : All incomplete changes except Cloud as Edition and IoTArtifactsWithOSBuild are deferred to f38 and should execute any contingency plans they have (if needed).  (+5,0,0)
17:23:16 <mhroncok> The proposal was: "the system wide changes with beta freeze contingency deadline should be deferred to F38"
17:23:17 <nirik> #agreed All incomplete changes except Cloud as Edition, IoTArtifactsWithOSBuild and LLVM15 are deferred to f38 and should execute any contingency plans they have (if needed).  (+5,0,0)
17:23:27 <nirik> #undo
17:23:27 <zodbot> Removing item from minutes: AGREED by nirik at 17:23:17 : All incomplete changes except Cloud as Edition, IoTArtifactsWithOSBuild and LLVM15 are deferred to f38 and should execute any contingency plans they have (if needed).  (+5,0,0)
17:23:32 <Eighth_Doctor> that would include the IoTArtifacts one too, right?
17:23:32 <mhroncok> for the self contained ones I have yet to spell it
17:23:45 * nirik sighs
17:24:14 <nirik> so, if thats the proposal, I am not sure I am +1 to it.
17:24:24 <mhroncok> If you want one unified statement, gimme a sec
17:24:33 <nirik> did we not want to give Return Cloud to Edition status more time?
17:25:12 <Eighth_Doctor> the Edition status one is largely paperwork and marketing
17:25:17 <Eighth_Doctor> rather than any code work
17:25:19 <nirik> right.
17:25:45 <nirik> also I suppose if davdunc has no action items left it could just be marked on qa?
17:26:05 <mhroncok> LegacyXorgDriverRemoval, Drop NIS(+) support from PAM, Retire the NIS(+) user-space utility programs and Build all JDKs in Fedora against in-tree libraries and with static stdc++lib system-wide changes are defered to F38. Return Cloud Base to Edition Status and LLVM 15 still have time to land in F37. Build Fedora IoT artifacts with osbuild and Preset all systemd units on first boot can land in Fedora 37 only if they make it to the beta
17:26:05 <mhroncok> release, otherwise they are deferred to Fedora 38.
17:26:32 <davdunc[m> I think I am good for now, but will keep up the momentum.
17:26:47 <mhroncok> we can veote individually, if anything in there is controversial
17:27:09 <nirik> one kind of side point.. iot actually releases on it's own schedule. It's not built with the rest of beta... so their beta is when they say it is and qa tests it...
17:27:11 <mhroncok> s/veote/vote/
17:27:34 <nirik> I'm +1 to that proposal
17:27:43 <decathorpe> Sounds good to me
17:28:03 * Eighth_Doctor sighs
17:28:29 <Eighth_Doctor> how did that get allowed?
17:28:36 <Eighth_Doctor> we pushed back on CoreOS specifically because of the problems doing that causes
17:30:10 <bcotton> my understanding is that IoT releases on its own compose, but not its own schedule
17:30:20 <Eighth_Doctor> okay, that makes more sense
17:30:21 <Eighth_Doctor> that's basically what CoreOS does too
17:30:53 <Eighth_Doctor> lack of visibility aside, as long as they're aligned on our schedule, then it's mostly fine
17:30:57 <nirik> I'm not sure I have time or energy to find references right now.
17:31:37 <nirik> anyhow, votes?
17:31:49 <nirik> we have spent 30min on this and have a number of other items. ;(
17:33:54 <mhroncok> is this still on?
17:34:07 <nirik> I am not sure
17:34:38 <nirik> so, I see +3... mhroncok, decathorpe and me...
17:34:50 <dcantrell> +1
17:35:10 <Eighth_Doctor> I think so?
17:35:56 <nirik> #agreed LegacyXorgDriverRemoval, Drop NIS(+) support from PAM, Retire the NIS(+) user-space utility programs and Build all JDKs in Fedora against in-tree libraries and with static stdc++lib system-wide changes are defered to F38. Return Cloud Base to Edition Status and LLVM 15 still have time to land in F37. Build Fedora IoT artifacts with osbuild and Preset all systemd units on first boot can land in Fedora 37 only if they make it to the beta
17:35:56 <nirik> release, otherwise they are deferred to Fedora 38. (+5,0,0)
17:36:04 <gotmax[m]> Weren't you going to vote for delaying each Change individually?
17:36:36 <nirik> only if something was controversial?
17:37:08 <mhroncok> I have no idea. i posted a proposal. Only @nirik voted
17:37:24 <mhroncok> if you folks really want to vote individually, be explicit about it
17:37:47 <nirik[m]> Looks like matrix <->irc is lagging or something
17:37:47 <davdunc[m> mhroncok has good list comprehension. :)
17:38:13 <mhroncok> :)
17:38:21 * gotmax[m] sighs
17:38:27 <nirik[m]> anyhow, accepted... lets move on
17:38:31 <nirik> #topic #2857 Change proposal: Minizip Renaming
17:38:31 <nirik> https://pagure.io/fesco/issue/2857
17:39:05 <nirik[m]> it's just dropping irc stuff randomly. ;(
17:39:10 <nirik[m]> #2857 Change proposal: Minizip Renaming
17:39:10 <nirik[m]> https://pagure.io/fesco/issue/2857
17:39:35 <gotmax[m]> Wait I don't think there was an `#agreed` for mhroncok revised proposal
17:39:37 <nirik> Change owners updated this. Does anyone want to discuss it? or just vote in ticket?
17:39:40 <mhroncok> I am not sure what exactly was accepted, sorry
17:39:40 <gotmax[m]> * for mhroncok's revised
17:40:06 <nirik[m]> Yes, there was. on irc. It's not showing up on matrix.
17:40:06 <decathorpe> sorry, I might drop off, there's an insane thunderstorm going on right now
17:40:21 <gotmax[m]> 12:35:56 <nirik> #agreed LegacyXorgDriverRemoval, Drop NIS(+) support from PAM, Retire the NIS(+) user-space utility programs and Build all JDKs in Fedora against in-tree libraries and with static stdc++lib system-wide changes are defered to F38. Return Cloud Base to Edition Status and LLVM 15 still have time to land in F37. Build Fedora IoT artifacts with osbuild and Preset all systemd units on first boot can land in Fedora 37 only if
17:40:21 <gotmax[m]> they make it to the beta
17:40:21 <gotmax[m]> 12:35:56 <nirik> release, otherwise they are deferred to Fedora 38. (+5,0,0)
17:40:45 <Eighth_Doctor> +1
17:40:45 <mhroncok> thanks and sorry for the confusion
17:41:13 <nirik> https://meetbot-raw.fedoraproject.org/fedora-meeting/2022-09-06/fesco.2022-09-06-17.00.log.txt is what zodbot 'sees'
17:41:49 <nirik[m]> https://meetbot-raw.fedoraproject.org/fedora-meeting/2022-09-06/fesco.2022-09-06-17.00.log.txt is what zodbot sees
17:42:06 <nirik> ok, perhaps it's back in sync now?
17:42:07 <gotmax[m]> I don't think they amended the proposal
17:42:28 <gotmax[m]> They just replied to zbyszek and my comments on the ML and asked what we thought
17:42:48 <gotmax[m]> https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/TQKOJ2453HU2HKB74S4V44YYBFOCVWZA/
17:43:07 <nirik> ok. Shall we just continue in ticket for this one? Or is there any discussion anyone would like to have?
17:43:51 <gotmax[m]> Simply renaming minizip to minizip-compat is pretty benign
17:44:08 <gotmax[m]> s/compat/ng/
17:44:11 <mhroncok> continue in ticket
17:44:29 <nirik> #info continue discussion in ticket.
17:45:05 <gotmax[m]> Probably a good idea to wait for a revised proposal
17:45:09 <nirik> So, there's 2 changes that have 0 activity after 5 days, so I thought I would bring them up here in case anyone had thoughts.
17:45:26 <nirik> #2862 Change: pcre deprecation
17:45:26 <nirik> https://pagure.io/fesco/issue/2862
17:45:35 <nirik> #topic #2862 Change: pcre deprecation
17:45:37 <Eighth_Doctor> yeah
17:46:29 * nirik[m] waits for the bridge
17:46:41 * mhroncok was busy with other stuff, haven't yet read the proposal/feedback
17:47:29 <gotmax[m]> I don't like the next retirement change, but meh on deprecating
17:47:45 <Eighth_Doctor> deprecation is easy enough to implement
17:47:47 <Eighth_Doctor> but I'm meh about the whole thing
17:47:48 <nirik> yeah, this one seems ok, retirement... not so much
17:48:03 <nirik> ok, so we can continue in ticket here too.
17:48:09 <gotmax[m]> How likely is it for new packages to still use this?
17:48:21 <Eighth_Doctor> somewhat likely
17:48:28 <nirik> no telling.
17:48:40 <gotmax[m]> I don't think we should block new packages just because the current maintainers don't want to maintain it
17:48:41 <gotmax[m]> Plenty of other people expressed interest
17:49:02 <Eighth_Doctor> I'm fine with that as well
17:49:05 <nirik> right, if they don't have capacity, someone else could take it over...
17:49:54 <nirik> #topic #2863 Change: libsoup 3: part two
17:49:54 <nirik> https://pagure.io/fesco/issue/2863
17:50:08 <nirik> this is the other change with no comments for a bit.. ;)
17:50:17 <Eighth_Doctor> and if it's actually not easy to port to pcre2, then it becomes a bigger problem
17:50:41 <gotmax[m]> If they don't have capacity to maintain pcre, how are they going to port 134 packages?
17:51:13 <gotmax[m]> There's a lot of important stuff in that list
17:51:15 <nirik> gotmax[m]: they aren't. They are going to file bugs asking maintainers/upstreams to do so
17:51:25 <nirik> (at least my understanding is that)
17:51:39 <gotmax[m]> I did my own query, because their's was inaccurate
17:51:56 <Eighth_Doctor> the RHEL team has to maintain pcre for the next decade at least for security fixes
17:52:00 <Eighth_Doctor> so there's that at least as a source for maintenance
17:52:21 <kalev> if I could go back in time, I'd just ask upstream to not do libsoup3, all the fallout from these was so not worth it
17:53:08 <gotmax[m]> > <nirik> gotmax[m]: they aren't. They are going to file bugs asking maintainers/upstreams to do so
17:53:08 <gotmax[m]> That's worse
17:54:22 <nirik> worse than what? I'd guess a lot of those projects would be fine to move to pcre2... but also likely not on a timetable.
17:54:40 <mhroncok> "We will remove libsoup 2 and all packages that still depend on it." that's rather harsh, isn't it?
17:54:43 <nirik> this bridge lag is making it very difficult.
17:56:09 * mhroncok runs a --recursive repoquery for libsoup
17:56:33 <gotmax[m]> nirik: Honestly, I don't know what I meant by that...
17:56:53 <nirik> how about we keep discussing this one on list/ticket also... and go to the last issue...
17:57:08 <mhroncok> dnf repoquery --whatrequires libsoup --latest-limit 1 --arch 'noarch,x86_64' --disablerepo='*' --enablerepo=rawhide --recursive | wc -l
17:57:14 <mhroncok> 1407
17:57:22 * gotmax[m] urges nirik to come over to the dark side
17:58:00 <nirik> #topic #2864 Firejail needs a new maintainer
17:58:00 <nirik> https://pagure.io/fesco/issue/2864
17:58:05 <mhroncok> I'll just leave this here. the bridge thing makes this meeting quite exhausting and I need to leave in 3 minutes anyway
17:58:08 <nirik[m]> gotmax (He/Him): I am here, but unless everyone is on this side... 😉
17:58:23 <Eighth_Doctor> the whole libsoup thing was a terrible idea
18:00:11 <nirik[m]> So, on this the maintainer answered on aug 24th... so they are sometimes active. I guess we ping them in the ticket there ?
18:00:12 <mhroncok> Not sure what we can do about Firejail except ask the maintainer nicely to orphan it
18:00:12 <gotmax[m]> I'm not sure what there really is to do here. Tell them to initiate the nonresponsive maintainer process?
18:00:35 <nirik> I think they did... the bug filed has an answer from them tho
18:00:49 <nirik> so, I guess lets ping them again and see what happens.
18:01:14 <nirik> #topic Next Weeks Chair
18:01:28 <nirik> who on earth wants to deal with this bridge laggy mess next week?
18:01:43 <mhroncok> ok folks, sorry, but I need to go. see you later
18:02:22 <Eighth_Doctor> I have to go as well
18:02:22 <music[m]> .hello music
18:02:22 <gotmax[m]> Looks like someone started it in https://bugzilla.redhat.com/show_bug.cgi?id=2120977 but never continued
18:02:22 <zodbot> music[m]: music 'Benjamin Beasley' <code@musicinmybrain.net>
18:02:34 <music[m]> Popping in late, and briefly
18:03:19 <music[m]> Since the firejail maintainer agreed in principle to give someone the package, it seems like the firejail request is really “Please find someone to do the work.”
18:03:38 <nirik> yeah, so we could ask the devel list if anyone wants it...
18:04:42 <nirik> anyone for chair next time? pretty please?
18:04:51 <gotmax[m]> https://bugzilla.redhat.com/show_bug.cgi?id=2120977#c6
18:05:28 <music[m]> I agree, advising a devel list plea for a maintainer is the best response.
18:05:58 <gotmax[m]> No needs for that. This is why we have the orphaning process.
18:06:43 <nirik> sure, but the user wants the update/fixes... asking explicitly for a new maintainer would get that faster than just waiting a week or two for anyone to notice it in the oprhan report
18:08:47 <gotmax[m]> I guess. A PP can also merge a PR.
18:09:08 <nirik> sure.
18:09:54 <nirik> ok, I guess I am stuck with it next week too then...
18:10:00 <nirik> #info nirik to chair again
18:10:05 <nirik> #topic Open Floor
18:11:40 <gotmax[m]> It's pretty open as most of the people had to go...
18:11:45 <nirik> yeah.
18:11:58 <nirik> so, lets end this doomed thing. ;)
18:12:01 <nirik> #endmeeting