17:01:18 <zbyszek> #startmeeting FESCO (2023-05-09)
17:01:18 <zodbot> Meeting started Tue May  9 17:01:18 2023 UTC.
17:01:18 <zodbot> This meeting is logged and archived in a public location.
17:01:18 <zodbot> The chair is zbyszek. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:01:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:18 <zodbot> The meeting name has been set to 'fesco_(2023-05-09)'
17:01:18 <zbyszek> #meetingname fesco
17:01:18 <zodbot> The meeting name has been set to 'fesco'
17:01:18 <zbyszek> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, music, mhayden, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
17:01:18 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe mhayden mhroncok music nirik sgallagh zbyszek
17:01:21 <zbyszek> #topic init process
17:01:28 <sgallagh> .hi
17:01:29 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:01:30 <dcantrell> .hello2
17:01:31 <zbyszek> .hello2
17:01:32 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
17:01:35 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
17:01:40 <mhayden> .hello2
17:01:41 <zodbot> mhayden: mhayden 'Major Hayden' <mhayden@redhat.com>
17:01:55 <mattdm> .hello2
17:01:56 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
17:02:08 <sgallagh> Uh oh, the boss is here. Look busy!
17:02:24 <zbyszek> It'd be said if we didn't make quorum :]
17:02:28 <zbyszek> *sad
17:02:36 <mhayden> I should have dressed nicer
17:03:10 <nirik> morning
17:03:21 <zbyszek> #topic #2989 Proposal to adjust Changes Policy to use Fedora Discussion instead of the devel list
17:03:24 <zbyszek> .fesco 2989
17:03:25 <zodbot> zbyszek: Issue #2989: Proposal to adjust Changes Policy to use Fedora Discussion instead of the devel list - fesco - Pagure.io - https://pagure.io/fesco/issue/2989
17:03:26 <mattdm> lol
17:03:44 <mattdm> lol to the boss jokes, not to my topic
17:03:45 <mhayden> And the discourse discord begins 🤭
17:03:53 <mhayden> Sorry had to kick off with a dad joke
17:04:26 <Eighth_Doctor> .hello ngompa
17:04:27 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:04:43 <zbyszek> So… I'm pretty ready to give this a try.
17:04:43 <sgallagh> Never apologize for a Dad Joke. They're unforgivable anyway.
17:04:44 * Eighth_Doctor is triple booked, so he may not notice things
17:04:56 <zbyszek> In particular:
17:04:58 * nirik too.
17:05:27 <zbyszek> 1. I see much more "connectedness" with topics that I wouldn't be aware of otherwise if things are discussed on discussion.fp.o
17:05:41 <sgallagh> I remain skeptical about Discourse-all-the-Things, but I think the Change process might indeed be well suited to it.
17:05:44 <zbyszek> 2. it's easy to pull in random people
17:05:53 <zbyszek> 3. it's easy to find things
17:06:28 <zbyszek> 4. the mail interface is "good enough" for reading things. And it's very easy to subscribe to select topics, or just to get notifications about new topics.
17:06:34 <dcantrell> I agree with zbyszek on these points too.  I'd love it if we could have something like usenet for this stuff again, but I'm just an unfrozen caveman and this world is strange and unusual to me.  Discourse is pretty close to that, but with more grafix
17:06:42 <nirik> I think we can learn from trying the change process how well it would work for other things...
17:06:52 <zbyszek> 5. it's much easier to link to a discussion in a mail. No need to hunt through the mailman interface for a link.
17:07:15 * nirik notes mailman3 puts a 'archived-at' link in every post. ;)
17:07:15 <zbyszek> (I'm saying that all a *very* heavy email user.)
17:07:35 <zbyszek> Does it? I want 3 months of my life back.
17:07:40 <sgallagh> nirik: That's the first I've heard of that.
17:07:42 <nirik> I use it all the time
17:08:03 <mattdm> it's in a header.
17:08:12 <sgallagh> Hooray for discoverability
17:08:17 <nirik> Anyhow, should we vote? or is there more discussion?
17:08:29 <zbyszek> Jesus. It is there.
17:08:32 <sgallagh> I think we should offer anyone opposed to make their voice heard
17:08:45 <zbyszek> So please scratch #5.
17:09:04 <sgallagh> No, because it's still not realistic for most people to discover that.
17:09:08 <sgallagh> So I think 5) remains
17:10:54 <zbyszek> Dunno, more comments?
17:11:12 <sgallagh> Conan Kudo: I know you're generally in the "no on Discourse" camp. Do you want to have your say before we vote?
17:12:12 <zbyszek> Eighth_Doctor^
17:12:22 <Eighth_Doctor> I find that Discourse make it easier for Fedora to become an island
17:13:05 <Eighth_Doctor> Generally, the idea of creating a Fedora account for upstreams or external folks to share or comment on our stuff is a barrier that most are unwilling to go through
17:13:41 <Eighth_Doctor> Additionally, Discourse encourages patterns where unilateral communication shunting becomes more common
17:14:16 <Eighth_Doctor> with server side topic splitting, it essentially enforces audience splitting, rather than encouraging that concerns to be addressed within a topic/conversation
17:14:43 <zbyszek> Hmm, now to participate in a mail discussion, you effectively need to subscribe to the mailing list. (Or count on everybody propagating CC correctly, which is very unlikely to happen in any bigger thread.)
17:15:03 <zbyszek> So I think discourse may actually be *lowering* the barrier for fly-by commenters.
17:15:18 <nirik> the people who care about that part of the thread would follow the posts to the new thread no? if not... perhaps they don't care about it? I don't see this as a big problem as long as it's not overused.
17:15:35 <Eighth_Doctor> ML subscriptions don't require a Fedora account, and can be done entirely through email flow
17:15:39 <Eighth_Doctor> which people do
17:16:36 <Eighth_Doctor> even ignoring all that, I also am concerned about the quality of discussion lowering as the orientation of discussions on discussion is very different from devel@
17:16:59 <sgallagh> Conan Kudo: How do you feel *specifically* about using Discourse for the Change process? Do you see that as being problematic?
17:17:01 <Eighth_Doctor> previous experiences with other projects making similar moves have led to developer communication dropping drastically rather than increasing or improving
17:17:32 <Eighth_Doctor> The biggest problem I have for the Change process is that archiving those discussions is not easy
17:17:57 <Eighth_Doctor> and if someone does topic splitting, then if we "port out" or data mangling occurs from upgrades/conversions, we will have a broken archive of the data
17:18:17 <Eighth_Doctor> topic splitting, editing, moderation, etc.
17:18:29 <mattdm> Do you mean an external archive separate from the site itself?
17:18:38 <mhayden> Don't we have discussions about changes in pagure too? That's not an email based system
17:18:51 <Eighth_Doctor> all the data in pagure is stored secondarily as Git repo data
17:18:58 <Eighth_Doctor> that can be pulled and processed at any time
17:19:01 <dcantrell> mhayden: we try not to to use the ticketing system for that
17:19:26 <Eighth_Doctor> We have no real disaster recovery, preservation, etc. strategy for discussion.fp.o
17:19:27 <dcantrell> what if we just got rid of all of these systems and moved to Salesforce Community Edition
17:19:28 <mattdm> I'll try not to repeat myself from the thread to much, but: scattered discussions instead of tickets is one of the problems I'm trying to address with this.
17:19:40 * Eighth_Doctor dies
17:19:47 <Eighth_Doctor> please tell me Salesforce CE doesn't actually exist
17:19:47 <nirik> I think an external archive could be valuable. Not sure how that can be implemented, but hopefully we can come up with something. I don't feel it's a blocker tho.
17:20:02 <dcantrell> mattdm: that is a problem I see now too and I think Discourse is a way out of that
17:20:03 <nirik> ha
17:20:12 <Eighth_Doctor> I consider it important enough given how often our Changes and discussion are referenced by others
17:20:26 <dcantrell> Eighth_Doctor: I don't think it is, I was just making a joke.  if it does exists, that will destroy my joke
17:20:31 <Eighth_Doctor> I can come up with enough examples that what we do lead the Linux world's decision-making because of that
17:20:34 <mattdm> For what it's worth, we have a daily sync of the database to a Fedora-owned AWS S3 bucket as part of our hosting contract.
17:20:40 <nirik> you can still refer to them just fine by url.
17:20:56 <Eighth_Doctor> mattdm: backups are not backups unless they can be restored... are we doing that?
17:21:17 <Eighth_Doctor> so far, I've seen nothing about us being able to self-host and hydrate a discourse instance
17:21:33 <mattdm> I agree with the adage. We should go through that exercise but have not yet.
17:21:43 <dcantrell> ok, hold up, I think we need to bring this back down to the actual topic:  let's try discourse for the change proposal process
17:21:54 <dcantrell> we're in to yak shaving here and picking apart everything
17:22:00 <Eighth_Doctor> if we can't do that, then we don't have what I consider the bare minimum for project-critical decision making
17:22:46 <Eighth_Doctor> at this point, we're at a binary choice, and I'm giving my reasons why I don't want to do it
17:22:53 <mattdm> What is "that"?
17:23:25 <Eighth_Doctor> stand up a discourse, and hydrate/restore it from backups, and verify that it fully works
17:23:43 <Eighth_Doctor> if we can't do that, we shouldn't rely on it, because eventually discussion.fp.o will go away and we'll get screwed
17:24:09 <Eighth_Doctor> this has happened enough times with services Fedora has relied on that I consider it a mandatory de-risking measure
17:24:55 <Eighth_Doctor> if you want to ignore everything else I say about Discourse, don't ignore this
17:25:10 <mattdm> Although I agree that we really should do the work, I am confident that we can. We're not doing anything strange. GNOME infra team runs a self-hosted discourse. I know someone (misc?) in RH OSPO had some test instances in OpenShift.
17:25:12 <nirik> all computers are ephemeral. Nothing is forever. We can mitigate risk in a number of ways... in this case with a contract + backups.
17:25:20 <Eighth_Doctor> mattdm: honestly, I'm not confident that we can
17:26:00 <mattdm> Well, my preference is hosting so we can focus project efforts on the things that are unique to distro-making.
17:26:05 * nirik types a few things out, erases them
17:26:06 <Eighth_Doctor> our discourse instance is not a cookie-cutter deployment
17:26:17 <Eighth_Doctor> there are enough different things going on in it that I would be concerned
17:26:21 <zbyszek> I think the backup strategy is something to put on the todo list. But I wouldn't treat this as prerequisite for "getting our toes wet" with the current proposal.
17:26:37 <Eighth_Doctor> I helped with the exercise of migrating the openSUSE forums to Discourse, so I have some idea how interesting that can be
17:26:58 <Eighth_Doctor> and it can be messy if we're not regularly proving it
17:27:02 <nirik> we wouldn't be migrating anything, just installing and restoring no?
17:27:22 <mattdm> Our Discourse deployment is completely standard. Ironically the one non-cookie-cutter thing is the automated backup sync.
17:27:25 <Eighth_Doctor> nirik: hopefully, assuming self-hosted and managed discourse match on versions and codebases
17:27:55 <Eighth_Doctor> but lets say there's a commitment to ensure we do that
17:28:12 <mattdm> Discourse runs "main" in production.
17:28:12 <Eighth_Doctor> then we need certain things removed from discourse: such as the shutdown of threads after 30 days
17:28:31 <Eighth_Doctor> that's completely unacceptable for conversations
17:28:42 <mattdm> "Shutdown of threads after 30 days" is a config option. I do not believe we have anything set up with that.
17:28:42 <Eighth_Doctor> (not the main in prod thing, the thread shutdown thing)
17:29:12 <mattdm> We have a 3-month timer on the Community Blog comment threads.
17:29:19 <sgallagh> FTR, is that "30 days from thread creation" or "30 days from the last message to it"?
17:29:27 <Eighth_Doctor> creation, as I understand it
17:29:46 <Eighth_Doctor> it got activated when ask got merged into discussion
17:29:46 <mattdm> It can be either.
17:30:11 <nirik> it can be per thread/topic and category too
17:30:25 <sgallagh> If it can be either, I feel like making it "30 days from the last message" would be a sensible policy.
17:30:37 <mattdm> Oh! I did this manually on the strategy focus area review threads.
17:30:48 <mattdm> Because that's a specific process we're working through.
17:30:55 <zbyszek> I looked up some random thread, and it's from 2021 and it is still open: https://discussion.fedoraproject.org/t/which-project-do-we-start-with-please-cast-your-votes-by-29th-june-21/31049
17:31:10 <nirik> right, it's off by default as far as I can tell
17:31:50 <zbyszek> I'm sure mattdm / others will tweak the config if appropriate, but it doesn't seem to be any kind of general problem.
17:31:53 <mattdm> I think it makes sense to close change discussions as well, actually. Once the change is accepted or rejected, further followup should be separated. That can be done either via a timer or manually.
17:32:15 * Eighth_Doctor sighs
17:32:19 <mattdm> There is a feature where anyone can continue a closed topic with "reply as linked topic".
17:32:30 <mattdm> https://discussion.fedoraproject.org/t/site-tip-create-linked-topics-for-deep-dives-or-tangents/34526
17:32:55 <Eighth_Doctor> I don't particularly think this is a good idea, but if we're going to kick off an effort to add durability and recoverability to Discourse and we're going to avoid god-like antipatterns on Change threads, then we can try it
17:33:00 <nirik> we get that on the list from time to time too... someone replying to a change that was already approved/landed. Usually someone replies to them and asks them to file a bug.
17:33:01 <sgallagh> We're 30 minutes in and I don't think there are any new arguments forthcoming, so maybe it's time to take it to the vote?
17:33:30 <dcantrell> yes, let's vote
17:33:31 <Eighth_Doctor> mattdm: for what it's worth, I was extremely upset when you split my message in the strategy discussion
17:33:43 <Eighth_Doctor> you effectively hid what I said from people by splitting it
17:33:55 <Eighth_Doctor> and I almost quit all the strategy discussions because of it
17:34:18 <Eighth_Doctor> if I wanted to make it a separate topic, I would have
17:34:29 <sgallagh> Proposal: Fedora Change announcements and discussion will move to discussions.fedoraproject.org for F39 onwards.
17:34:30 <Eighth_Doctor> and that's the whole point of the god-like antipatterns
17:34:48 <dcantrell> sgallagh: +1
17:34:54 <nirik> Stephen Gallagher: we already have done some f39 ones, perhaps just 'from now'? or ?
17:34:56 <zbyszek> Hmm, one sec.
17:34:58 <Eighth_Doctor> s/point/problem/
17:35:02 <zbyszek> What nirik said.
17:35:07 <Eighth_Doctor> Stephen Gallagher: 0, leaning -1
17:35:19 <dcantrell> sgallagh: still +1 with whatever rephrasing
17:35:37 <sgallagh> nirik: I assume importing the existing discussion threads would be painful, so I guess "from here onwards"
17:35:47 <zbyszek> sgallagh: can you rephrase for clarity?
17:35:52 <sgallagh> Will do
17:35:55 <zbyszek> (the proposal, I mean)
17:36:35 <sgallagh> Proposal: Fedora Change announcements and discussion will move to discussions.fedoraproject.org as of 2023-05-10
17:36:42 <mattdm> Stephen Gallagher: importing existing conversations is work, but I can do it if need be.
17:36:51 <zbyszek> sgallagh: +1
17:37:30 <nirik> +1, I think we should try... and learn how well it works and what we can improve or if there's any blockers
17:37:44 <zbyszek> Hmm, thinking about this. Do we want to move discussions that are already in progress?
17:38:25 <nirik> I think that would be confusing
17:38:25 <sgallagh> mattdm: I should have used a less specific word than "importing". I meant mostly what zbyszek just said
17:38:51 <nirik> I think changes moving forward should try it, but existing threads should stay for now...
17:38:56 <zbyszek> Should be maybe phrase this as "Fedora Change announcements and discussion for *new* proposals will be held on discussions.fedoraproject.org" ?
17:40:05 <sgallagh> Proposal: Fedora Changes announced on or after 2023-05-10 will be discussed on discussions.fedoraproject.org
17:40:16 <zbyszek> sgallagh: +1, thanks
17:40:26 <mattdm> I am in favor of starting at some specific point, on the grounds that it's less work for me :)
17:40:26 <nirik> +1 (as before)
17:41:06 <sgallagh> I'll make my +1 explicit
17:41:35 <dcantrell> and my axe....I mean +1
17:41:43 <sgallagh> mattdm: Can you put together a CommBlog post explaining what's happening and how to subscribe to watch for Change announcements?
17:42:02 <zbyszek> mhayden?
17:42:07 <mhayden> +1 from me
17:42:07 <nirik> I think a devel-announce post (possibly pointing to that) would be good to.
17:42:09 <nirik> too
17:42:11 <mattdm> yes, I can
17:42:14 <mattdm> yeah.
17:42:19 <sgallagh> I think that would be ideal
17:42:22 <mattdm> Also: Fabio Valentini had a suggestion which I hope will mitigate some of Neal's last concern: we can create a subcategory for Change Proposals, and have FESCo members be moderators in that category. That way, y'all decide how to manage the conversations.
17:42:30 <zbyszek> Eighth_Doctor, your vote?
17:42:31 <mattdm> Let me know if you don't want that :)
17:42:46 <Eighth_Doctor> +0
17:42:56 <Eighth_Doctor> leaning -1 still
17:43:02 <Eighth_Doctor> but I'm willing to give it a shot
17:43:07 <zbyszek> #agreed APPROVED (+5, 1, 0)
17:43:10 <nirik> I think thats good, but I'd love some kind of training / knowlege transfer on what can be done and when you might do those things...
17:43:23 <nirik> there's a lot of knobs.
17:43:50 * sgallagh just hits buttons randomly until something interesting happens
17:43:57 <zbyszek> Yeah, I think splitting out management will be required if we don't want to burn out the maintainers.
17:44:36 <zbyszek> #action mattdm to put together a CommBlog post explaining what's happening and how to subscribe to Change announcements
17:45:03 <zbyszek> #action mattdm/others a devel-announce post (possibly pointing to the CommBlog story)
17:45:10 <mattdm> Conan Kudo: Thank you for your willingness to try despite misgivings.
17:45:15 <bcotton> Just poking my head in here, but starting the new process tomorrow seems remarkably unfriendly to a lot of people
17:45:37 <Eighth_Doctor> mattdm: I've been burned half a dozen times by this, I hope this time goes slightly better
17:45:42 <sgallagh> Well, we can also just hold off the announcements for a few days
17:45:48 <bcotton> If for no other reason that I know how long it can take to drag a blog post out of Matthew
17:45:54 * mattdm did not look at the actual date proposed. This is why we have Program Managers. :)
17:46:01 <nirik> yeah, true... perhaps we should shoot for f40? or is that too late?
17:46:07 <Eighth_Doctor> F40 is probably more realistic
17:46:16 <Eighth_Doctor> it also gives us time to actually figure this stuff out
17:46:41 <Eighth_Doctor> because we're changing something that we've had since damn near the beginning of the project
17:46:47 <mattdm> I'd suggest somewhere in between there? Like, 2 weeks?
17:47:20 <zbyszek> Let's not wait for F40. That's effectively 6 months of delay.
17:47:46 <bcotton> Not really. F39 deadlines are 1-2 months away
17:47:55 <Eighth_Doctor> is it? F40 changes will probably start coming in July
17:48:06 <Eighth_Doctor> I know that I'm starting to formulate my F39 and F40 changes
17:48:14 <Eighth_Doctor> and I expect Miro will for Python
17:48:15 <bcotton> There are 3 or 4 f40 changes already approved
17:48:38 <zbyszek> OK. mattdm, would F40 work for you then?
17:48:50 <Eighth_Doctor> I would say F39 should be left alone and we do this for F40, so that allows a mostly full Changes cycle
17:48:58 <bcotton> But anyway, Matt Hicks says this isn't my problem, so I'll stay out of it
17:49:07 <Eighth_Doctor> 😭
17:49:44 <zbyszek> bcotton: we'll be all very lost
17:50:17 <zbyszek> mattdm, are you there?
17:50:40 <mattdm> sorry my wife is telling me to bring in fish from outside :)
17:51:00 <dcantrell> that just raises more questions
17:51:10 <mattdm> I think F40 is okay.
17:51:19 <sgallagh> And tips the scales!
17:51:36 <zbyszek> #proposal Subsequent Fedora Changes for F40 and later will be discussed on discussions.fedoraproject.org
17:51:39 <mattdm> And maybe I'll see about importing the 3 or 4 approved change conversations for completeness
17:51:54 * nirik has fish out of water concerns.
17:52:06 <mattdm> fish out of refrigerator is the concern. it's from a delivery service.
17:52:07 <sgallagh> nirik: I don't believe that. You're completely hooked.
17:52:30 <mattdm> so I'm gonna go do that. BRB :)
17:52:36 <nirik> zbyszek: +1
17:52:46 <zbyszek> +1 FTR
17:52:51 <sgallagh> zbyszek: Sure, +1
17:53:01 <dcantrell> zbyszek: +1
17:53:11 <zbyszek> mhayden, Eighth_Doctor?
17:53:25 <mhayden> +1 from me!
17:53:55 <Eighth_Doctor> +1
17:53:57 <Eighth_Doctor> reluctantly
17:54:01 <zbyszek> Oh, nice!
17:54:07 <zbyszek> #undo
17:54:07 <zodbot> Removing item from minutes: ACTION by zbyszek at 17:45:03 : mattdm/others a devel-announce post (possibly pointing to the CommBlog story)
17:54:17 <zbyszek> #action mattdm/others a devel-announce post (possibly pointing to the CommBlog story)
17:54:24 <zbyszek> Too much to undo.
17:54:35 <zbyszek> #agreed APPROVED (+6, 0, 0)
17:54:38 <zbyszek> #topic Next week's chair
17:54:47 <zbyszek> Vlntrs?
17:54:48 <sgallagh> Just add "REVISED" tot he beginning of the new #info?
17:55:01 <sgallagh> s/tot/to/, s/he/the/
17:55:19 <zbyszek> sgallagh: I'll just fix it up in the summary manually.
17:55:29 <sgallagh> I will probably not be around next week due to internal meetings.
17:55:41 <zbyszek> OK, to make things faster, I'll do next week too.
17:55:47 <zbyszek> #action zbyszek will chair next meeting
17:55:51 <zbyszek> #topic Open Floor
17:56:08 <zbyszek> mattdm: thanks for joining
17:56:23 <sgallagh> Thanks, zbyszek
17:57:09 <zbyszek> OK, I guess there's nothing.
17:57:11 * Eighth_Doctor sighs
17:57:17 <zbyszek> Eighth_Doctor?
17:57:43 <Eighth_Doctor> onword to the next meeting for me
17:57:43 <Eighth_Doctor> 2 hour long meeting 🙃
17:57:46 <Eighth_Doctor> and that's with juggling this and another meeting for the past hour
17:57:55 <zbyszek> Oh, OK. Let's wrap this one up.
17:57:58 <zbyszek> #endmeeting