23:07:02 <heidie> #startmeeting
23:07:02 <zodbot> Meeting started Mon Nov  4 23:07:02 2013 UTC.  The chair is heidie. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:07:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:07:26 <heidie> There is an agenda here:
23:07:28 <heidie> #link
23:07:53 <heidie> #link http://foss2serve.org/index.php/IRC_Meetings_POSSE
23:08:02 <heidie> Helps if one actually includes the link :-)
23:08:33 <heidie> #topic Updates
23:09:13 <heidie> Who is doing what?
23:09:17 <heidie> Anyone doing anything interesting?
23:09:33 <becka> I am indeed
23:09:44 <heidie> Tell us!
23:10:16 <becka> I am about half way done developing the curriculum for my HFOSS course winter term
23:10:36 <becka> and I have a meeting with Heidi on Friday to go over what I have
23:10:59 <becka> Heidi gave me some valuable feedback earlier and I am currently incorporating that
23:11:22 <becka> I have installed, built and configured the OpnMRS project
23:11:33 <heidie> Yes!
23:11:37 <becka> now I am going to focus on patches
23:11:54 <heidie> #info Becka is about half way done developing the curriculum for my HFOSS course winter term
23:12:05 <becka> Yes, The heavens opened, the sun shone through and the angel sang that day
23:12:09 <heidie> # info Becka has installed, built and configured the OpenMRS projecct.
23:12:12 <joanne_t> :D
23:12:22 <heidie> #info Becka has installed, built and configured the OpenMRS projecct.
23:12:27 <heidie> Yippee!!!
23:12:31 <heidie> I'm very glad!
23:12:38 <becka> Me too :-D
23:12:43 <heidie> becka: what time is our meeting Friday?
23:13:00 <becka> I do not remember let me check
23:14:09 <becka> Friday 1 your time 10 my time, does that work for you?
23:14:45 <heidie> Ah, no, I can't do that :-(  I have to leave the house at 1, could we do noon?
23:14:52 <heidie> Sorry, noon my time, 9:00 your time?
23:15:09 <becka> yes!! I will put it in my calendar now :-)
23:15:39 <heidie> Me too! :-)
23:16:01 <becka> Meet here?
23:16:08 <heidie> email me your phone number and I'll call you.
23:16:31 <heidie> I'm really excited about Becka's course. I think it's going to be great and can't wait to see how it goes.
23:17:16 <becka> emailing now. I am super excited also
23:17:51 <heidie> Ah, thanks.
23:17:53 <heidie> :-)
23:18:02 <heidie> joanne_t: How are you coming along?
23:18:21 <heidie> Am I remembering correctly that you have an independent study student?
23:18:27 <joanne_t> Yes, coming along well. Monday mornings I meet with my ind. study students for OpenMRS.
23:18:39 <heidie> Ah, and what are you all doing?
23:18:40 <joanne_t> #Students are both committing code!!!
23:18:54 <joanne_t> #info Student are committing code.
23:19:04 <joanne_t> Oops, forgot the protocol...
23:19:35 <joanne_t> The OpenMRS community is excellent.  So helpful, prompt, and nice to newcomers.
23:19:53 <heidie> Cool! This is really good news!
23:20:15 <heidie> #info NCC students committing code to OpenMRS.
23:20:25 <heidie> What part are they working on?
23:20:41 <joanne_t> Yes.  We had a bumpy start, which was expected.  But both students are very comfortable with the installation process (which was repeated several times :) )
23:20:56 <heidie> Ah, good. Yes, that seems to be the case.
23:21:16 <joanne_t> Ok.  The more times they do it, the easier it becomes.
23:21:46 <heidie> Right. It does seem to become more familiar.
23:22:01 <joanne_t> That's about it.  Sounds like a little, but the students have come a long way.
23:22:05 <heidie> What code have they committed?
23:22:25 <heidie> Yes, they (and you) have made great progress!
23:22:36 <joanne_t> Two introductory trouble tickets that they fixed.
23:22:41 <heidie> Ah, good!
23:22:45 <heidie> This is great!
23:23:10 <joanne_t> The OpenMRS wiki has a great set of easy to fix tickets (easy, but it took us days…) so we had a good place to start.
23:23:17 <heidie> Ah, good.
23:23:24 <heidie> #info The OpenMRS wiki has a great set of easy to fix tickets (easy, but it took us days…) so we had a good place to start.
23:23:31 <heidie> Karl, what are you working on?
23:24:02 <kwurst> I spent the beginning of the semester working on the proposal for my Fall 2014 sabbatical.
23:24:22 <kwurst> I will be spending the full semester working inside an HFOSS project
23:24:24 <heidie> Right! You're going to come join us, yes?
23:24:26 <heidie> :-)
23:25:08 <kwurst> I am also thinking about my Spring 2014 course, and something for our Health Informatics course for nursing students - all HFOSS related.
23:25:21 <kwurst> And I blogged twice last week!
23:25:37 <heidie> Ah, good!
23:25:42 <heidie> Wow! You're doing really well!!
23:25:44 <heidie> :-)
23:25:55 <kwurst> I am seriously thinking of jumping ship from Ushahidi to OpenMRS
23:26:03 <heidie> #info Karl is planning on immersing himself in a FOSS project for his sabbatical.
23:26:11 <heidie> Any particular reason why?
23:26:18 <kwurst> This has nothing to do with my POSSE group, but more about synergy for me.
23:26:24 <heidie> And why not MouseTrap?
23:26:44 <kwurst> There are a few reasons... (And I did think about MouseTrap...)
23:27:10 <kwurst> 1. I just installed OpenMRS for our Health Informatics course for our Nursing students.
23:27:27 <kwurst> They have not had a real EHR system to work on during their course.
23:27:58 <heidie> Oh, that makes sense.
23:28:09 <heidie> I like the possibilities for synergy.
23:28:11 <kwurst> So, I thought that installing OpenMRS would be a good practice system, especially with the demo data set of 5,000 patients and 500,000 observations.
23:29:01 <kwurst> 2. We teach primarily Java at the beginning of our program, and OpenMRS is more Java-centric.
23:29:28 <heidie> Yes, right.
23:29:50 <kwurst> I know that our Ushahidi group is investigating ways to use Java with Ushahidi, but it would be more peripheral work, rather than core work.
23:31:08 <heidie> Yes, this makes sense.
23:31:08 <kwurst> 3. (This may just be my uniformed sense - I need to do more research, but...) I feel like OpenMRS uses a more "formal" development model than Ushahidi, which seems more "ad hoc"
23:31:21 <heidie> Yes, I think that is likely the case.
23:31:51 <lorip> kwurst: we are trying to get our OpenMRS meetings back up and running - we plan to meet Tues at 8pm - shall I add you to our email list for meeting announcements?
23:32:38 <kwurst> With my sabbatical plan to work for the semester in a project, I want the more formal model so that I can get a more complete process - planning, design, coding, testing.
23:33:01 <kwurst> lorip: Yes, please. Although Tuesday nights are a challenge for me...
23:33:26 <darci> lorip: Do we have a meeting scheduled this week?
23:33:47 <kwurst> So, I'm still looking, but leaning toward OpenMRS now.
23:34:06 <lorip> I was thinking that an IRC for the POSSE group followed by an OpenMRS meeting might be a bit much... how about next week?
23:34:20 <darci> That sounds good.
23:34:20 <joanne_t> I agree lorip.
23:34:31 <kwurst> In other news, I've had two senior students install a GitLab server for us to use in our programming classes.
23:34:46 <heidie> Cool!
23:34:59 <darci> A GitLab server?
23:35:07 <heidie> #info Karl had two senior students install a GitLab server for us to use in our programming classes.
23:35:20 <kwurst> I started using git and Bitbucket for students to collaborate during lab, to submit their work, and for me to return their graded work.
23:35:40 <kwurst> It worked fine this summer, but I had only 6 students in the class.
23:36:04 <kwurst> Then, I started doing the same this semester and ran up against one of Bitbucket's limitations.
23:36:11 <becka> lorip: works for me
23:36:53 <lorip> great - so Tues 11/12 will be an OpenMRS meeting at 8pm on IRC - if you can join us kwurst that'd be great!
23:36:53 <kwurst> You can have as many private repos as you want, but only 6 collaborators - TOTAL! Not per repo - TOTAL!'
23:36:59 <heidie> Weird!
23:37:15 <kwurst> heidie: Not really, they want you to pay after that...
23:37:29 <heidie> Ah, OK
23:37:51 <darci> kwurst: Do you know if GitHub has similar limitations?
23:37:55 <kwurst> So, one of my summer students tried to add her partner from the fall course, and couldn't because she had had 6 summer collaborators.
23:38:20 <kwurst> darci: GitHub has a restriction on how many free private repos you can have.
23:38:52 <kwurst> So, we installed GitLab, which is a FOSS clone of GitHub.
23:39:08 <darci> Does the same limit apply if you go through their education program?
23:39:16 <darci> Cool!
23:39:24 <lorip> kwurst:  I am setting up a github account and as an educator they claim they will give as many private repos as I need - guess I'll see!
23:39:49 <kwurst> darci: I don't know. Could be true. I just decided that we'd install our own since we could...
23:40:10 <kwurst> #link http://gitlab.org/
23:40:11 <heidie> :-)
23:40:53 <darci> kwurst: Did your students have much trouble setting it up?
23:40:57 <kwurst> So, we've got it up and running, but have had some issues with it sending emails to users when we create accounts.
23:41:10 <darci> :-)
23:41:49 <kwurst> Probably related to the fact that we installed on an internal IP address, then got an external domain name from our IT and changed the address after the install.
23:42:06 <kwurst> So the students are going to do a reinstall and see if that fixes it.
23:42:33 <heidie> Ah, that makes sense.
23:42:56 <heidie> So does anyone need help on anything?
23:42:58 <kwurst> So my current plans are to decide on my project for the Spring course, and Fall sabbatical.
23:43:20 <kwurst> All done with my report. More blog post fodder from all of this. More coming...
23:44:02 <heidie> This is all cool!
23:44:24 <heidie> #topic  Evaluation
23:44:37 <heidie> Who will need evaluation instruments for winter/spring courses?
23:44:43 <kwurst> I will.
23:44:57 <becka> I will
23:45:58 <heidie> We've got a template with interchangeable Likkert-scale items that can be included.
23:46:15 <heidie> If I send those to you, could you let me know if you would like additional questions?  I can run those by my IRB.
23:46:26 <becka> Yes.
23:46:34 <heidie> #info Becka and Karl will need evaluation instruments.
23:46:54 <kwurst> Yes, and I have to run them by my IRB too. (What a pain...)
23:46:55 <heidie> #info We have a template with interchangeable Likkert-sacle items that can be included.
23:47:12 <heidie> #action Heidie will send this to kwurst and becka
23:49:05 <heidie> So far the questions are mostly software engineering and CS2 level questions. We're looking for more.
23:49:16 <becka> OK
23:49:39 <heidie> Does anyone have anything else to report?
23:49:49 <heidie> I should tell you about MouseTrap.
23:49:54 <kwurst> Are there any attitudinal questions?
23:50:08 <heidie> Yes. I've just sent it to you.
23:50:16 <kwurst> Ok, thanks.
23:50:29 <heidie> MouseTrap uses the web cam to track a feature (e.g., forehead) and move the cursor accordingly.
23:51:01 <heidie> The code is now up and running, although not perfectly. It only tracks within about  a100 pixel space.
23:51:35 <heidie> But at least we finally got it running!  And we have a set of requirements posted on the MouseTrap web site and are heading towards a design document.
23:52:19 <heidie> I'm hoping to get at least some of the kinks worked out by the end of the semester. Would be nice to have a working product on GNOME 3, even if it isn't Python 3 compliant.
23:53:03 <becka> That is awesome heidie
23:53:35 <heidie> I sent my class (6 students) to the GNOME Summit in Montreal.
23:54:02 <heidie> They spent three days hacking with Joanie and a Red Hat person and seemed to have solved some of the major problems.
23:54:18 <heidie> I couldn't go because I was at SIGITE.
23:54:41 <heidie> But I did hear that Saturday night was interesting. Something about "Drag Night" at a bar.... I haven't asked for details. :-)
23:55:51 <heidie> Does anyone have anything else?
23:56:03 <becka> What happens in Montreal...
23:56:29 <kwurst> Stoney and I are trying to plan a Hackathon for CCSCNE 2014 in April.
23:56:52 <kwurst> Still trying to determine what project we should approach, and what hours to set.
23:57:04 <heidie> Oh, right.
23:57:19 <kwurst> I may try to go for even more synergy and ask OpenMRS :-)
23:57:26 <heidie> We talked a bit with Peter DePasquale at CCSC-E.
23:57:42 <heidie> Peter said that he easily found supporters for the hackathon.
23:58:01 <heidie> I was tired and didn't ask him further, but he has hosted a successful hackathon.
23:58:16 <kwurst> Was Stoney in on the conversation?
23:58:30 <kwurst> If so, I'll pump him for the info when we meet next.
23:58:37 <lorip> #link http://hacktcnj.com/
23:58:58 <lorip> here's the link to what he did last year - Stoney wasn't with us, sorry :(
23:59:02 <kwurst> lorip: Wow!
23:59:40 <lorip> he is planning another one for Feb and hopes to have registration info before thanksgiving
23:59:56 <lorip> he also mentioned one that he just went to at Rutgers that had over 300 students!
00:00:02 * kwurst checks more on the site...
00:00:18 <kwurst> Ah, this is an issue that we came across already.
00:00:33 <kwurst> The term Hackathon now has a second meaning.
00:01:21 <heidie> What second meaning are you referring to?
00:01:40 <kwurst> This event is the second kind. The kind where you join a team and try to create something new, then they have judges to determine the best "product"
00:01:56 <kwurst> Some have very large cash prizes.
00:02:14 <lorip> yes, that is what they are doing and also at Rutgers - don't know if this will be helpful or not
00:02:23 <lorip> #link https://www.hackerleague.org/hackathons
00:02:41 <kwurst> This is not the meaning we are going for, which is different from what I think Heidie students participated in.
00:03:16 <heidie> What my students participated in was a "Summit".
00:03:16 <lorip> sorry, gotta run...  bye all!
00:03:23 <heidie> bye lorip!
00:03:34 <becka> bye lorip
00:03:40 <heidie> And we can organize a hackathon to work on specific projects.
00:03:44 <heidie> That's what we did at Hopper.
00:04:20 <kwurst> heidie: That's what I'm thinking of - move a project forward, not be an incubator.
00:04:32 <heidie> Yes, right.
00:04:34 <heidie> I agree.
00:04:52 <heidie> We could do a couple of projects if we have space and support.
00:05:08 <kwurst> I'm just concerned because this new definition seems to be gaining ground. I don't want the students to be misled and think they are competing for prizes...
00:05:09 <heidie> I would love to do MouseTrap if we can make it work.
00:05:22 <heidie> Right, we can make that clear in the description.
00:05:29 <heidie> Or call it a "hack event" or something similar.
00:06:04 <kwurst> Well, that depends on how far along  you guys are. I'm willing to work with MouseTrap if you are in a position to have it be the focus of the event...
00:06:57 <kwurst> "Or call it a "hack event" or something similar." or stubbornly try to keep the "correct" definition alive...
00:07:04 <heidie> We've got a community, partly running code, and a bunch of bugs logged.
00:07:08 <heidie> Right.
00:07:10 <heidie> :-)
00:07:25 <heidie> OK, I should go here. Does anyone have anything else?
00:07:32 <darci> What happens if students attend who are unfamiliar with the language? In the case of MouseTrap that would be Python.
00:07:55 <kwurst> darci: I think we have to make it clear what language in the description.
00:08:03 <heidie> That would be an advantage of doing both OpenMRS and MouseTrap. We'd have something for both Java and Python.
00:08:08 <camm_> I can add that Monisha is working with Ushahidi in her course, mostly creating deployments
00:08:16 <heidie> Ah, that might work as well.
00:08:18 <camm_> I haven't heard from Sam recently
00:08:31 <heidie> It really helps to have someone who has actually installed and worked with the project on hand.
00:08:32 <camm_> but I'll try and catch up with him before tomorrow
00:08:40 <heidie> :-) I wouldn't have suggested MouseTrap a year ago.
00:08:44 <kwurst> That's one reason I was thinking OpenMRS - pretty much every student is doing some Java.
00:09:09 <heidie> Ummm, well, our students don't get it until the second year.
00:09:30 <kwurst> heidie: Do your first year student go to CCSCNE?
00:09:59 <kwurst> I'm guessing we will get mostly upper-level students at the conference.
00:10:18 <heidie> So far we haven't had any students at CCSCNE :-)  But a hackathon might attract some.
00:11:03 <kwurst> So, can I sound some of you out about scheduling for a hackathon?
00:11:26 <kwurst> Background: CCSCNE is a Friday/Saturday conference.
00:11:37 <heidie> Yes, that sounds good.
00:11:39 <lorip> not sure I'll be much help, but I'm willing to try!
00:11:59 <heidie> we just submitted a workshop so we'd need to work around that if it gets accepted.
00:12:07 <kwurst> Friday morning is the programming competition - this is where we get the most student participation.
00:12:16 <heidie> But could be really good synergy as the workshop is a tour of how to get started in a real project.
00:12:18 <kwurst> The competition ends at noon.
00:12:19 <darci> I'm not sure what you'll need, but sure.
00:12:47 <heidie> Sure, count me in.
00:13:07 <heidie> I need to go. Shall I end the meeting or pass control to kwurst?
00:13:26 <kwurst> I'm thinking of the hackathon running from about 2:00pm to 10:00pm or midnight, with a break at 7:00pm for eating at the banquet.
00:13:40 <becka> I need to go. Bye all
00:13:51 <kwurst> heidie: you should probably end the meeting, unless you want his to be part of the HFOSS record...
00:14:00 <heidie> Will do
00:14:03 <heidie> #endmeeting