14:05:36 <suzanne> #startmeeting
14:05:36 <zodbot> Meeting started Wed Jun 18 14:05:36 2014 UTC.  The chair is suzanne. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:06:33 <suzanne> #topic regular meeting schedule for the summer.  How often? And on what communication medium?
14:06:52 <hjackson> so far so good :)
14:06:56 <suzanne> lol
14:07:01 * joanie nods
14:07:23 <hjackson> now the hard part... deciding when to meet :)
14:08:03 <suzanne> yes, I am pretty open in the summer.  Who has time constraints?
14:08:25 <joanie> I have time constraints, but the schedule should not be hindered by that. I plan to be a resource for y'all.
14:08:34 <hjackson> I have time demands, but not constraints...
14:08:49 <alex_rmezei> I am pretty open most of the summer, except for some short Workshops/Conferences in July and August
14:08:52 <joanie> So even if I'm not free at your meeting time, I can be reached pretty easily when/if you need me.
14:08:53 <hjackson> so... lot's to do, but when I do it is somewhat flexible
14:09:13 <suzanne> yes, me too.  Not many meetings, just lots of work
14:09:23 <hjackson> yeah Mohsen
14:09:27 <Mohsen_> Hi
14:09:37 <Mohsen_> I still have the wrong address :)
14:09:39 <suzanne> Hi Mohsen, we are discussing when we should meet and how often tihs summer
14:09:49 <Mohsen_> foss2server instead of foss2serve :)
14:09:58 <Mohsen_> ok
14:10:00 <hjackson> that was my typo... sorry
14:10:05 <Mohsen_> no worry
14:10:15 <hjackson> typing server too often :)
14:10:32 <suzanne> So how often should we meet?  Every two weeks? Once a month?
14:10:55 <hjackson> I would pick what works for suzanne, Mohsen_, and alex_rmezei
14:11:03 <joanie> +1 hjackson
14:11:34 <joanie> Silly question: Do you have concrete tasks and goals, etc.? As I think that would dictate how often to meet.
14:11:39 <Mohsen_> I am wideopen especially middle of the weeks
14:11:44 <hjackson> i'm sure heidi, joanie (as she already said), and I will be around
14:13:35 <suzanne> Alex and Mohsen,  are you flexible this summer as well?
14:13:44 <Mohsen_> As I said, I am
14:13:45 <suzanne> We are getting there Joanie!
14:14:02 <alex_rmezei> yes, for most of the time
14:14:03 <Mohsen_> during the day middle of the week is preferred
14:14:22 <alex_rmezei> almost any time works for me
14:15:37 <suzanne> Great!  Let’s say our next meeting is Wednesday, July 9th at 10am?
14:16:17 <Mohsen_> Sounds good to me
14:16:27 <alex_rmezei> works for me too
14:16:36 <suzanne> Cool!  Let me record it.
14:17:13 <suzanne> #info next meeting is July 9th at 10am
14:17:27 <hjackson> 10am EDT?
14:17:38 <hjackson> do we have different timezones in this group?
14:17:53 <suzanne> #info next meeting is July 9th at 10am EDT
14:17:55 <Mohsen_> I am still in CST
14:17:59 <Mohsen_> for the summer
14:18:23 <suzanne> #topic next steps, goals and milestones for the group
14:18:40 <hjackson> before you move on...
14:18:57 <hjackson> are you planning to schedule each meeting as you go?...
14:19:05 <hjackson> or are you thinking something more regular?
14:19:54 <suzanne> We can schedule every two weeks for now if that works for everyone? If we find we need to meet less we can change it?
14:20:44 <hjackson> sounds good to me... others?
14:20:57 <alex_rmezei> sounds good to me as well
14:21:53 <suzanne> #info meetings will be held every two weeks Wednesdays at 10am EDT starting July 9th
14:22:00 <hjackson> excellent! :)
14:22:08 <suzanne> thanks Stoney!
14:22:14 * joanie updates her calendar
14:22:40 <suzanne> Now on to the even harder part.  What are our goals, etc?
14:22:47 * hjackson marks his too
14:24:24 <Mohsen_> sounds good to me
14:24:53 <suzanne> One of my goals is to integrate POSSE labs into my software engineering class in the fall. I have over 40 students.
14:25:43 <suzanne> I would like to get my students working the the VM as we did together as a possible first lab
14:25:47 <Mohsen_> same with me
14:26:14 <hjackson> common goals... love it :)
14:26:18 <Mohsen_> I'll be teaching master's level software engineering course and would like to have different open source activities for them
14:27:08 <suzanne> Ok, so one of our tasks should be to write up what we did together and test it to make sure we can repeat it - we can turn that into a lab
14:27:42 <Mohsen_> great
14:27:58 <Mohsen_> just like the one we already started which was about the set up
14:28:05 <suzanne> yes
14:28:28 <Mohsen_> we need to define some sort of hierarchy of activities first, shouldn't we?
14:28:41 <Mohsen_> after set up
14:28:45 <suzanne> yes
14:29:01 <Mohsen_> So, Joanie , what do you suggest?
14:29:06 <suzanne> set up is the first lab that we can write up and test now
14:29:19 <suzanne> then we need to come up with the next labs
14:29:35 <hjackson> what do you want your students to learn next after setup
14:29:35 <hjackson> ?
14:29:39 <joanie> does cloning and building a module count as part of the setup?
14:30:23 <joanie> if students are new to Linux, just getting the VM working and familiar with how to use it as an end user might be a full lab.
14:30:37 <joanie> but hjackson asks an important question :)
14:30:41 <suzanne> Absolutely joanie
14:30:56 <suzanne> I think just setting up the VM and exploring is a lab.
14:31:12 <suzanne> the cloning and building a module is lab 2
14:32:03 <Mohsen_> well, we need to make sure our students have the right environment and capable of doing common activities
14:32:22 <Mohsen_> so, set up and cloning and building modules are considered labs
14:32:22 <suzanne> yes
14:32:55 <suzanne> so let me try and document what we are saying. Let me be sure first.  Lab 1 - VM set up
14:34:35 <suzanne> #info We are working on what labs we wish to develop for our course.
14:34:59 <suzanne> #info We are working on a list of labs
14:35:07 <suzanne> #info Lab 1 - VM Set up
14:35:17 <hjackson> cool... where will it live while you are developing the list?
14:35:56 <hjackson> you could put it on an etherpad, a wiki, etc.
14:36:11 <suzanne> good idea Stoney
14:37:54 <suzanne> What do you think @Mohsen and @alex_rmezei?  Should I create a titanpad right now?  We can move to a wiki later?
14:38:24 <Mohsen_> fine with me
14:38:57 <alex_rmezei> sure :)
14:39:58 <suzanne> anyone know how?  LOL!  I am looking at the one we used but dont see the create new option
14:40:12 <hjackson> just type anything you like into the urel
14:40:14 <hjackson> url
14:40:38 <hjackson> so titanpad.org/BLAH-BLAH creates a pad called BLAH-BLAH
14:41:21 <hjackson> (titanpad.com... sorry)
14:41:24 <suzanne> lol
14:42:26 <suzanne> #info titanpad link: https://titanpad.com/POSSE-Summer
14:43:02 <hjackson> #link titanpad link: https://titanpad.com/POSSE-Summer
14:44:28 <suzanne> #info We will use this titanpad link to document our lab list.
14:45:28 <suzanne> How many labs would you like to come up with for the Fall term?
14:46:19 <suzanne> We should come up with our homework for the next two weeks
14:46:54 <joanie> How long(ish) is a Lab in terms of 1) any lecture 2) the students actually doing the task?
14:47:44 <suzanne> I like to think of them about an hour long.  My labs are about 2 hours and I leave plenty of room for exploring and messing up
14:48:12 <suzanne> It is the students doing the task.
14:48:27 <joanie> so git 101 might be a full lab
14:48:36 <joanie> building a cloned module might be another
14:48:38 <suzanne> absolutely
14:48:42 <joanie> nothing JustBuilds(tm) :)
14:49:18 <joanie> Making a change to the code in a dev branch and creating a patch could easily be a 3rd
14:50:06 <joanie> bugzilla, etc. may or may not be lab-worthy. But it's something students need to know.
14:50:43 <suzanne> I think writing a good bug report that is repeatable is an important skill.
14:50:52 * joanie nods
14:50:56 <suzanne> They need to learn to communicate
14:51:12 <suzanne> I get a lot of “it doesn’t work” emails. LOL
14:51:43 <joanie> you'll get even more in a *nix dev environment ;)
14:52:05 <suzanne> #info List of labs that we are working on can be found on our etherpad: https://titanpad.com/POSSE-Summer
14:52:33 <hjackson> for bug reports... there are some good articles online they can read.... then they could review existing reports... then they could write one
14:53:02 <joanie> maybe first try to confirm a bug?
14:53:13 <hjackson> ooo... that's a good one
14:53:27 <hjackson> also could test a patch
14:53:30 <joanie> reading it is one thing. Trying to process it and identify what the heck the reporter is reporting is another task entirely.
14:53:42 <joanie> hjackson I like the test a patch
14:54:00 <joanie> Let the students suffer what we suffer. I mean, let them learn fun new stuff! ;)
14:54:12 <hjackson> joanie: lol
14:54:19 <suzanne> Should the testing a patch be apart of Lab 4 or 5 or do you think it could be a separate lab?
14:54:25 <joanie> because test a patch is a good pre-requisite to create your own patch
14:54:47 <suzanne> OK, I’ll switch Lab 4 and 5
14:55:58 <suzanne> Do we want to keep these meetings to an hour?  If so, we need to wrap up and come up with a task list
14:56:14 <joanie> (I can go either way)
14:56:28 <hjackson> to "testing a patch" you could add "reviewing a patch".... i.e., what makes a contribution good/bad/ugly
14:56:55 <hjackson> an hour is probably good
14:58:10 <hjackson> that list is looking good
14:58:12 <hjackson> :)
14:58:20 <joanie> indeed it is
14:58:48 <suzanne> #action Dig up the VM Set-up notes we have from the other titanpad and start to formalize into a proper lab.
14:59:05 <joanie> suzanne: usually actions have an assignee
15:01:36 <suzanne> thanks joanie, does anyone have the titanpad url that we used for the VM set up?  I was on another computer and can’t find it at the moment.  We can document here.
15:01:49 <suzanne> #action Dig up the VM Set-up notes we have from the other titanpad and start to formalize into a proper lab. @suzanne
15:01:53 <joanie> suzanne: I can grep through irc logs
15:02:16 <suzanne> thanks joanie, if you could post it on the pad when you find it.
15:02:46 <joanie> https://titanpad.com/POSSE-GNOME
15:02:53 <joanie> i'll put it in the pad too
15:03:10 <hjackson> #link https://titanpad.com/wAD3OD6ysC  GNOME groups pad at POSSE
15:03:55 <suzanne> @Mohsen_ and @alex_rmezei - what would you like your action items to be for the next two weeks?
15:03:57 <hjackson> although I don't see the link for the activity there
15:04:06 <joanie> hjackson: on which?
15:04:21 <joanie> the one I posted has the vm steps/notes we wrote and tried to follow
15:04:34 <joanie> though what worked for me didn't work for others :-/
15:04:46 <hjackson> ah... that's even better
15:04:54 <hjackson> didn't see your post sorry joanie
15:04:55 <hjackson> :)
15:04:59 <alex_rmezei> I am a bit behind preparing my CS 2 course. I plan to use some activities related to POSSE there. But I am not yet sure what.
15:05:25 <hjackson> CS 2... data structures?
15:05:26 <suzanne> I would like to try to follow the instructions again and clean them up.  I will then hand them over to Mohsen and Alex to test further.  And Joanie and Stoney can test if they feel like it  :)
15:06:03 <alex_rmezei> CS 2 includes data structures, yes :0
15:06:08 <joanie> suzanne: I think something important might be to verify they work as expected for all platforms (OS X, Windows, Linux)
15:06:30 <joanie> Because I assure you, my steps worked fine -- just not for non-Linux folks
15:06:36 <alex_rmezei> I can also help testing
15:07:01 <suzanne> yes, I am on a mac, I believe Alex can test for windows, etc
15:07:07 <joanie> cool beans
15:07:22 <alex_rmezei> I can test for windows and maybe ubuntu too
15:07:40 <alex_rmezei> I am still debating between ubuntu and fedora
15:07:42 <hjackson> alex_rmezei: I think there is a group working on identifying datastructures in HFOSS projects; you might want to get in touch with them
15:07:54 <alex_rmezei> that would be great
15:08:25 <joanie> alex_rmezei: for a host OS, up to you. For the dev guest, if you're doing GNOME stuff I'd suggest Fedora
15:08:36 <suzanne> #action @alex_rmezei Test Lab 1 instructions on Windows and possible Fedora - add hints for different platforms as needed
15:08:43 <joanie> the *buntus mix and match and heavily patch
15:09:05 <alex_rmezei> i had some challenges installing the drivers on Fedora
15:09:16 <alex_rmezei> sound and gpu drivers
15:09:27 <joanie> but that's the host (right?)
15:09:31 <joanie> or was it the guest?
15:09:36 <alex_rmezei> yes, that was the host
15:09:42 <joanie> though I'm deep diving. /me shuts up
15:10:31 <alex_rmezei> I am very interested in Fedora, but it may not be as friendly as ubuntu for a starter
15:12:00 <suzanne> We have our friend Brian at red hat that will be willing to help us.  He sent me an email that he would not participate in our project/meetings but he is available for questions etc
15:12:21 <joanie> are you all going to divvy up the rest of the labs and take a first stab at the activities/subtasks therein?
15:12:32 <joanie> it might impact the final order of the labs
15:12:59 <suzanne> that is what I was hoping Joanie
15:13:47 <joanie> So pick your victims and assign labs ;)
15:13:51 <suzanne> @alex_rmezei and @mohsen, if you could pick a lab to work on for the next two weeks.  We could then swtich off and test them
15:14:05 <hjackson> (I'm still here... but I'm getting distracted... ping me if you need me)
15:14:39 <alex_rmezei> I can test LAB 01 on two host OS's
15:16:13 <suzanne> Alex - that is great, but I wanted to clean it up first.  Do you want to take a stab at another one to get it started?  Once all three of us have a first stab at labs we can all switch off and test on our platforms.  What do you think?
15:16:54 <alex_rmezei> sure
15:18:03 <alex_rmezei> LAB 02 would be next :P
15:18:22 <joanie> I just lost my connection to titanpad.com
15:18:27 <alex_rmezei> me too
15:18:27 <suzanne> Cool Alex.  You can get most of the info from what we learned in Stage 1
15:18:44 <joanie> aha it's back
15:18:48 <suzanne> I lost the connection too
15:18:59 <alex_rmezei> I just got back too
15:19:17 * joanie mutters "technology" and rolls her eyes
15:19:31 <suzanne> #action @alex_rmezei Lab 2 rough draft to be ready for testing on July 9th
15:20:16 <joanie> if memory serves me Mohsen_ was doing well at the face-to-face with cloning and building
15:20:21 <joanie> maybe he'll take lab 3?
15:20:44 <suzanne> What do you think @Mohsen?  Are you up for lab 3?
15:22:03 <suzanne> What do you think @Mohsen_?  Are you up for lab 3?
15:24:22 <joanie> suzanne: you could just give him that action item now and if he doesn't like it trade later
15:24:32 <suzanne> exactly
15:25:29 <suzanne> #action @Mohsen_  Lab 3 rough draft - Bullding a Cloned Module -  Mohsen, if you want to switch to another lab let us know.
15:26:57 <suzanne> #info We have assigned our first three labs and are planning to write them for our student audience.  On or before July 9th, we will switch off and test each other labs and add information, test for different platforms, etc.
15:27:39 <suzanne> #info on July 9th we will divide up labs 4,5,6 and come up with more labs.
15:27:59 <joanie> #info Joanie tends to lurk here, so if you have any difficulties in accomplishing your action items you should ping her.
15:28:30 <Mohsen_> sorry , I was on the pad :)
15:28:35 <suzanne> #info in the meantime please use our etherpad to communicate, add what you want to see to each lab etc.
15:28:56 <suzanne> I will start lurking here for fun
15:29:02 <joanie> :)
15:29:21 <suzanne> Anything else before I close the meeting?
15:29:52 <Mohsen_> I will owrk on lab3
15:29:54 <Mohsen_> work
15:30:01 <suzanne> excellent Mohsen!
15:30:42 <suzanne> shalll I end the meeting?
15:30:53 <hjackson> end it, end it!
15:30:56 <joanie> heh
15:31:01 <suzanne> lol
15:31:06 <suzanne> #endmeeting