21:01:52 <lpostner> #startmeeting
21:01:52 <zodbot> Meeting started Thu Sep  3 21:01:52 2015 UTC.  The chair is lpostner. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:02:16 <lpostner> I hope everyone is having a nice last week of summer (or first/second week of the semester)
21:02:26 <lpostner> #topic roll call
21:02:43 <lpostner> let's start out with a quick roll call, name and institution would be great
21:03:05 <kbuffardi> Kevin Buffardi, CSU Chico. Present.
21:03:06 <DJBouvier> I’m Dennis Bouvier at Southern Illinois University Edwardsville (SIUE).
21:03:45 <lpostner> darci: you are up for roll call
21:03:56 <lpostner> cmacdonell: are you on?
21:04:01 <darci> Hi all...Darci Burdge Nassau Community College
21:04:04 <cmacdonell> Cam Macdonell, MacEwan University
21:04:13 <howardf> howard francis, Univ of Pikeville
21:04:22 <lpostner> Lori Postner, Nassau Community College
21:04:24 <lynnlambert> Lynn Lambert, Christopher Newport University
21:04:45 <andreatartaro> Andrea Tartaro, Furman University
21:04:51 <rsjodin> Rob Sjodin, Regis University
21:05:10 <lpostner> thanks everyone - I forgot to post the agenda
21:05:13 <lpostner> #link http://foss2serve.org/index.php/IRC_Meeting_3
21:05:18 <lpostner> #chair darci
21:05:18 <zodbot> Current chairs: darci lpostner
21:05:46 <lpostner> next item of business is progress
21:05:52 <lpostner> #topic Stage 1 progress
21:05:56 <lpostner> how is it going?
21:06:19 <rsjodin> Finishing up the Bug Tracker activity
21:07:08 <howardf> I'll confess, I haven't started Part C yet, but I should have time over the weekend to get it done
21:07:21 <lpostner> that's fine howardf
21:07:28 <andreatartaro> I haven't started part c either
21:07:33 <DJBouvier> I’m behind on Part B - the beginning of the term has been very time consuming. I haven’t posted everything I’ve done.
21:08:07 <kbuffardi> Finished B. Haven't started Part C, but I use Git/GitHub all the time so I don't anticipate it to take me long to finish it before Stage 2
21:08:17 <lpostner> DJBouvier: any questions or problems you are having?
21:08:19 <nanette> Nanette Veilleux, Simmons college
21:08:23 <andreatartaro> I got stuck on the part B activities because of some deadlinks, wo the last part is only partly done. But i hear the links are fixed (haven't had a chance to work on it since then)
21:09:07 <lynnlambert> I have started Bug Tracker Activity, but have not put anything on the wiki yet.
21:09:08 <DJBouvier> no questions; my problems are simply finding time (my support staff person was out for several days in the first week of classes)
21:09:09 <nanette> Haven't done C yet either. Still have to do "planet" exercise in B
21:09:55 <lpostner> DJBouvier: I totally understand, time is always difficult to find :)
21:10:17 <lpostner> is there anything we can help with?
21:10:28 <andreatartaro> as i do these assignments, i think of more courses it could be incorporated into, so that's cool
21:10:52 <lpostner> that is awesome!  looking forward to hearing more about your thoughts next week
21:10:58 <darci> andreatartaro: make a list, it would be good to explore next week!
21:11:33 <DJBouvier> I just met with a recent grad who now works at AT&T ... he says AT&T is adopting open source
21:11:48 <lpostner> really?  do you have more info?
21:12:24 * lpostner thinking how long should I wait before moving on?  don't want to rush, but never know the appropriate wait time for people to type...
21:12:36 <nanette> I had a question about the sourceforge exercise
21:12:39 <DJBouvier> AT&T has adopted open stack as a major component of their cloud services. He said AT&T is platinum supporter of open stack
21:13:02 <andreatartaro> lpostner: the "so-and-so" is typing would be a useful feature, though I suppose that could be a lot of people
21:13:28 <lpostner> andreatartaro: I agree
21:13:33 <lpostner> #link http://www.openstack.org/
21:13:42 <lpostner> nanette: what's your question?
21:13:51 <nanette> Some of the projects (I think I blogged about this) seem to have conflicting statuses ... are there some projects that are just not well documented?
21:14:25 <lpostner> nanette: yes, many projects are not well documented - that is one of the places where students can contribute
21:14:37 <darci> Not sure what statuses you are referring to...can you elaborate
21:14:50 <nanette> I'll have to find my blog for the details
21:15:13 <lpostner> #link http://foss2serve.org/index.php/FOSS_Field_Trip_Activity
21:15:20 <andreatartaro> I found source forge very hard to find the info I was looking for
21:15:32 <andreatartaro> I liked open hub significantly better!
21:15:53 <DJBouvier> it seemed to me that the posted status is not a good indicator of actual status. Some listed as planning were actually dead (empty and inactive).
21:15:56 <darci> That's good to hear. We've just started pointing people to Open Hub.
21:15:58 <cmacdonell> that's understandable.  Sourceforge is a bit antiquated
21:16:10 <cmacdonell> compared to openhub or github
21:16:18 <andreatartaro> I couldn't find statuses for some of the projects
21:16:39 * lpostner note to self (and darci) we may want to change the field trip activity
21:16:55 * nanette wrote in her notes for the blog :Well, one problem is that the status categories are not orthagonal, e.g. there are 3 projects that pass BOTH the alpha and beta status filters, 14 that are both beta and production stable. A sample of these pages were blank (non-existent? projects started but never implented)
21:17:04 <lpostner> #action consider removing sourceforge from the field trip activity
21:17:34 <cmacdonell> if none of our projects use it, then that's a good idea
21:17:57 <andreatartaro> lpostner: i think that's a good idea. I got very frustated with sourceforge, and the openhub part was so much better
21:18:05 <DJBouvier> poking around on SourceForge seems like a bit of busy work. However, I have a sense of what is out there
21:18:26 <lpostner> great feedback!  thanks!
21:18:32 <cmacdonell> Maybe the best outcome of exploring SourceForge is an appreciation that it's not the status quo anymore :)
21:18:40 <darci> :)
21:18:42 <nanette> Yes, I don't know if it's really worth having students examine something that's not relevant, even if to show them how lucky they are now.
21:19:11 <lpostner> other comments/thoughts?
21:19:51 * lpostner sensing wait time is enough...
21:19:57 <lpostner> moving on...
21:20:07 <lpostner> #topic project selection and installation
21:20:07 <darci> nanette: I would agree and find that these are okay places to start, but additional poking around if often necessary
21:20:10 <kbuffardi> I agree with the other comments… SourceForge has it's limitations. Seems that many projects are moving toward GitHub or BitBucket, but they aren't as good to search/find projects from my experience
21:20:38 <lpostner> has anyone figured out what project they would like to work on or have questions about projects?
21:21:31 <andreatartaro> OpenMRS seems relevant to one of my current classes and to be a very active project
21:21:41 <lpostner> would it be helpful to have information about projects POSSE participants and team members have worked on?
21:22:05 <rsjodin> Yes.
21:22:09 <lpostner> andreatartaro: OpenMRS is very active and we have had several faculty use it in class
21:22:21 <DJBouvier> I'm still leaning toward OpenMRS; but I haven't looked very deeply (so, no questions)
21:22:22 <lpostner> rsjodin: no problem
21:22:42 <lpostner> let's start with OpenMRS since a few people have mentioned it (and it is the one I know the most about)
21:22:57 <lpostner> OpenMRS is a medical records system used in developing countries
21:23:19 <lpostner> most of the code base is in Java and you can develop on Windows, Mac or Linux
21:23:52 <kbuffardi> Good question and one perhaps we need to discuss more during stage 2. There are several projects that look appropriate for my class, but given the size of my class (which currently is working in small teams on ~10 different projects), it probably wouldn't work to all concentrate on just one project. I might need to focus on 2-4 that are most appropriate
21:23:58 <darci> there is also the option of working on the OpenMRS Android app
21:24:28 * lpostner which is something that I'm interested in as I am teaching mobile app
21:24:41 <lpostner> darci: what else would you include about OpenMRS?
21:24:41 <rsjodin> Me too.
21:24:53 <andreatartaro> is there a iphone version too?
21:25:03 <darci> andreatartaro: not than I'm aware of
21:25:05 <lpostner> andreatartaro: I don't know
21:25:39 <rsjodin> Could we start development for an iOS app?
21:26:08 <lpostner> hmmm.... that would have to be posed to the OpenMRS community to see if it would be supported
21:26:13 <lpostner> cmacdonell: can you give a Ushahidi overview?
21:26:24 <cmacdonell> Sure
21:26:44 <cmacdonell> Ushahidi is a crisis mapping application that is a web application written in PHP
21:26:57 <cmacdonell> I've used it several times as have other POSSE attendees
21:27:13 <cmacdonell> don't be scared off by PHP, it's very similar in syntax to Java
21:27:36 <cmacdonell> Ushahidi has also just released Version 3 which was a complete rewrite
21:27:51 <cmacdonell> the community was also very open about the development process of version 3
21:28:10 <cmacdonell> http://www.ushahidi.com/blog/2013/03/21/building-ushahidi-3-0/
21:28:17 <lpostner> cmacdonell: there is a mobile app for this too, correct?
21:28:42 <cmacdonell> Yes there is https://github.com/ushahidi/platform-android
21:29:09 <cmacdonell> there is/was an ios version too https://github.com/ushahidi/Ushahidi_iPhone
21:29:14 <cmacdonell> Caveats:
21:29:41 <cmacdonell> Going with version 3 will undoubtedly have some "bleeding edge" challenges
21:29:50 <cmacdonell> since it is so new
21:30:05 <lpostner> darci: can you talk a little about GNOME/Mousetrap?
21:30:48 <cmacdonell> one last thing: Ushahidi has a separate repo just for documentation https://github.com/ushahidi/docs.ushahidi.com
21:30:54 <darci> The MouseTrap project is designed to allow the mouse to track head movement
21:31:02 <cmacdonell> another way to effectively contribute particularly with a new version out
21:31:14 <cmacdonell> over to darci...
21:31:18 <darci> sorry...
21:31:44 <andreatartaro> are there other components of gnome to work on besides mousetrap?
21:31:59 <darci> yes!
21:32:24 <darci> Heidi has had students work on caribou - a keyboard
21:32:32 <darci> as well as other projects
21:33:00 <darci> the GNOME community is generally very inviting and interested in having students participate
21:33:21 <lpostner> greg is the person who knows about Mifos and heidi about Sahana, but most of our POSSE participants have gravitated to these 3 projects
21:33:54 <lpostner> if would be helpful if you give some thought about what might would in your environment and try to install it before we meet next week
21:33:56 <lynnlambert> I had a student this summer contribute to Mifos, and found the community very welcoming.
21:34:13 <lynnlambert> He had a harder time getting feedback from Sahana Eden
21:34:26 <lpostner> I'm going to have to hand this off to darci in a few minutes to get my daughter, can we move on?
21:34:54 <darci> sounds good!
21:34:57 <lpostner> #topic Stage 2 questions/travel issues
21:35:01 <cmacdonell> about environments, I highly suggest using VMs for most projects except MouseTrap
21:35:20 <lpostner> you should have gotten an email from Greg on Tuesday with information about transportation in Raleigh, any questions?
21:35:20 <rsjodin> I have a question … I believe I’m the first one to arrive Wed at 6:00pm, and I believe I’ve been placed in a group by myself.  So, should I reserve a shuttle ride from the airport to the hotel?
21:35:38 <lpostner> yes
21:35:43 <rsjodin> Thanks.
21:36:04 <howardf> What's the travel budget again? Can it be used for car rental (for those of us close enough to drive?
21:36:27 * howardf suddenly does not have faith that his current vehicle should be used to drive that far
21:36:36 <darci> I think that is a question for Greg
21:36:50 <lpostner> I agree - email greg about that
21:36:54 <howardf> ok, thanks
21:37:09 <lynnlambert> I am also interested in knowing about rental cars, so I can email.
21:37:37 <lpostner> we've put a few cell phone numbers on the titan pad in case you have questions when you get to Raleigh
21:37:41 <darci> Hopefully everyone has been in contact with their travel "buddies"...yes?
21:37:45 <lpostner> #link https://titanpad.com/POSSETravel
21:38:02 <nanette> It's in process -- do you know if you can share if you arrive in two different terminals ?
21:38:12 <lpostner> I'm going to have to leave, I'm looking forward to meeting everyone next Thursday
21:38:14 <nanette> I'm also thinking about the rental car
21:38:20 <nanette> before we go I wanted to ask about MiFOS? It looked like it had a variety of on-ramps. But has anyone used it in a class? Should I switch to a different project ?
21:38:31 <darci> I think so, you can either agree on a place to meet or check with the shuttle company
21:38:32 <lpostner> Enjoy the weekend and safe travels!
21:38:44 <darci> bye lpostner
21:38:45 <lpostner> darci is going to finish up...
21:39:48 <darci> nanette: I don't recall if any of our POSSE alums have used it.
21:40:25 <darci> Other team members may know of someone who has, be sure to ask next week,
21:40:49 <darci> Are there other travel questions?
21:40:59 <rsjodin> No
21:41:02 <kbuffardi> none here
21:41:04 <nanette> Wondered since I thought the Part C had to do with our projects, so wanted to switch now if it was better
21:41:19 <lynnlambert> I have not used it in a class, but did use it this summer when Sahana Eden did not work. We hope to use it in a class.
21:41:20 <cmacdonell> people have switched at the POSSE before
21:41:30 <cmacdonell> we're flexible :)
21:41:38 <darci> nanette: You can switch at any point. We certainly have had people who switched multiple times at POSSE.
21:41:50 <darci> yes! :)
21:42:04 <nanette> I was looking for efficiency rather than permission ...
21:42:18 <cmacdonell> it won't make a huge difference
21:42:22 <darci> I don't think that is a problem
21:42:23 <nanette> thanks
21:42:51 <darci> Learning occurs that can be applied to another project...this is always useful
21:43:40 <darci> If there are no other questions, then I
21:43:50 <darci> 'd say let's end the meeting
21:43:56 <darci> oops...
21:44:19 <darci> Looking forward to meeting everyone!
21:44:27 <rsjodin> yep
21:44:32 <andreatartaro> see you next week!
21:44:35 <darci> And safe travels!
21:44:38 <kbuffardi> looking forward to it. Take care.
21:44:41 <rsjodin> You too.
21:44:44 <howardf> looking forward to it
21:44:52 <darci> #endmeeting