#fedora-meeting: Fedora Packaging Committee

Meeting started by spot at 16:02:44 UTC (full logs).

Meeting summary

  1. Roll Call (spot, 16:03:28)
  2. Systemd https://fedorahosted.org/fpc/ticket/31 (spot, 16:07:28)
  3. hMandate NEVR(F N) >= NEVR(F N-1) - https://fedorahosted.org/fpc/ticket/40 (spot, 16:18:24)
  4. Mandate NEVR(F N) >= NEVR(F N-1) - https://fedorahosted.org/fpc/ticket/40 (spot, 16:18:30)
    1. https://fedoraproject.org/wiki/Packaging:NamingGuidelines#Package_Version seems the most logical place (spot, 16:21:32)
    2. ACTION: Draft is approved (+1:6, 0:0, -1:0) (spot, 16:22:20)

  5. Version free changelogs - https://fedorahosted.org/fpc/ticket/38 (spot, 16:23:43)
    1. ACTION: Documenting both scenarios (multiple entries with the same V-R, appending additional items to existing V-R entry) approved (as opposed to permitting version-less changelog entries, which was not) - (+1:6, 0:0, -1:1) (spot, 16:50:43)

  6. Bundling Exception - shedskin - https://fedorahosted.org/fpc/ticket/39 (spot, 16:51:38)
    1. http://code.google.com/p/smhasher/source/browse/#svn/trunk (abadger1999, 17:05:24)
    2. ACTION: Exception granted. Package must document the murmurhash bunding, have appropriate bundled Provide, and if murmurhash ever is packaged as a standalone library in Fedora, this package must then use it. (+1:6, 0:0, -1:0) (spot, 17:06:48)

  7. Explain why rpmlint warns about executable files in %doc - https://fedorahosted.org/fpc/ticket/36 (spot, 17:08:22)
    1. http://code.google.com/p/smhasher/wiki/MurmurHash2Flaw (abadger1999, 17:10:40)
    2. https://fedoraproject.org/wiki/Packaging/Guidelines#PackageDocumentation (spot, 17:22:23)
    3. ACTION: "%doc files must not have executable permissions" passes (+1:5, 0:0, -1:1) (spot, 17:30:40)

  8. Open Floor (spot, 17:31:16)


Meeting ended at 17:35:05 UTC (full logs).

Action items

  1. Draft is approved (+1:6, 0:0, -1:0)
  2. Documenting both scenarios (multiple entries with the same V-R, appending additional items to existing V-R entry) approved (as opposed to permitting version-less changelog entries, which was not) - (+1:6, 0:0, -1:1)
  3. Exception granted. Package must document the murmurhash bunding, have appropriate bundled Provide, and if murmurhash ever is packaged as a standalone library in Fedora, this package must then use it. (+1:6, 0:0, -1:0)
  4. "%doc files must not have executable permissions" passes (+1:5, 0:0, -1:1)


People present (lines said)

  1. spot (141)
  2. tibbs|h (52)
  3. abadger1999 (50)
  4. racor (34)
  5. Rathann|work (25)
  6. rdieter (19)
  7. geppetto (18)
  8. nirik (4)
  9. zodbot (3)
  10. dgilmore (3)
  11. hicham (1)
  12. mjg59 (1)


Generated by MeetBot 0.1.4.