16:07:59 <spot> #startmeeting Fedora Packaging Committee
16:07:59 <zodbot> Meeting started Wed Dec  8 16:07:59 2010 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:07:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:08:01 <abadger1999> SmootherFrOgZ: ping FPC meeting
16:08:10 <spot> #meetingname fpc
16:08:10 <zodbot> The meeting name has been set to 'fpc'
16:08:15 <spot> #topic Roll Call
16:08:20 * abadger1999 here
16:09:24 <spot> i see tibbs, geppetto, abadger1999, rdieter_work, and me
16:09:39 <spot> oh, and i see racor, but he hasn't chimed in yet
16:09:54 <racor> sorry, I am here
16:10:55 <rdieter_work> brb, work emergency
16:11:18 <spot> okay, so we have quorum even with rdieter_work afk
16:11:24 <spot> so lets get right to systemd
16:11:41 <spot> #topic Systemd - https://fedorahosted.org/fpc/ticket/31 - https://fedoraproject.org/wiki/TomCallaway/Systemd_Revised_Draft
16:11:50 <abadger1999> I added comments to the page just now from experimenting with it last night.
16:12:02 <abadger1999> The Guidelines were usable for writing a unit file and scriptlets
16:12:47 <abadger1999> But there were errors in using the scriptlets that I don't know whether they're bugs in Guidelines/systemd or systemd "features".
16:13:03 <spot> abadger1999: okay...
16:13:18 <tibbs> I can put some time aside to try and write a unit file for denyhosts today.
16:13:26 <spot> abadger1999: although, i'm not sure i agree with the second note you added
16:14:08 <spot> abadger1999: but i think we can probably just drop the second bullet point from naming and be okay
16:14:41 <abadger1999> spot: What about adding it as a third bullet.
16:15:03 <abadger1999> I guess the second bullet point coiuld be a way of ensuring the sysv-init script is never invoked by mistake.
16:15:32 <abadger1999> But the original draft did seem to be about user compatibility which is what my comment talks about.
16:16:06 <spot> abadger1999: again, not sure i agree with that wording, and lennart isn't around to explain it
16:16:30 <tibbs> Is Lennart participating in development of this draft at all?
16:16:36 <spot> tibbs: not really.
16:16:48 <spot> tibbs: he's in india right now
16:17:02 <spot> tibbs: he said if we needed him in January, he'd be available.
16:17:13 <tibbs> Erm....
16:17:29 <geppetto> spot: So … is he planning on converting anything for F-15?
16:17:39 <tibbs> It would be nice to have most of this conversion done before F15 branch.
16:17:47 <tibbs> So 1st week in February.
16:17:49 <spot> geppetto: i have no idea.
16:17:58 <spot> geppetto: i do know that people are filing bugs against packages now
16:18:15 <geppetto> uh
16:18:19 <abadger1999> geppetto: He was for the people who talked about doing the conversion.
16:18:25 <Rathann|lappy> I'm here, sorry - got distracted
16:18:30 <abadger1999> but my impression is he is not driving it.
16:18:35 <tibbs> I'm afraid this whole thing is going just as expected.
16:18:45 <spot> abadger1999: i don't understand your notes under Format.
16:18:58 <geppetto> abadger1999: So who is driving it, apart from you?:)
16:19:18 <abadger1999> geppetto: hah!  /me tries to figure out how to not be saddled with that.
16:19:27 <abadger1999> johanbg was a name in there.
16:19:34 <abadger1999> Also Michel something.
16:19:54 * abadger1999 restarts firefox apologies
16:20:48 <tibbs> As usual with these things, we need to convert a couple of packages and then collect the questions that come up.
16:21:01 <tibbs> abadger1999 did one already as a test.
16:21:03 * spot is merging most of abadger1999's suggestions now (the ones I understand)
16:21:18 <abadger1999> http://toshio.fedorapeople.org/systemd/
16:21:56 <tibbs> I wonder if its possible to be relatively strict about the format we want people to use so that people don't try to get away with too much in package reviews.
16:22:17 <geppetto> At least for the first conversion, it seems reasonable
16:22:19 <tibbs> "use the exact case we specify", etc.
16:22:38 <tibbs> Is there a comment syntax in unit files?
16:22:42 <geppetto> If they really want to convert something that needs to be special, they can come and discuss it
16:22:58 <Rathann|lappy> Wants= vs Requires= is unclear
16:23:44 <tibbs> Actually, is there any technical documentation about unit files to which we can link?
16:23:58 <tibbs> I hope it's documented somewhere besides the systemd source.
16:23:58 <spot> tibbs: yes, and it is in the draft.
16:24:10 <abadger1999> spot: The Format => Organization note is simple, I can do that once you're done.  basically grouping the unitfile stuff together into one category.
16:24:31 <tibbs> Ah, there it is.
16:24:34 * abadger1999 wasn't able to save to the wiki last night for some reason so just took notes on things to change.
16:24:38 <tibbs> Sorry, I figured it would be at the top.
16:26:28 <spot> it is worth noting that the documentation lennart provides is pretty incomplete.
16:27:12 <spot> so i don't know whether the section items are case sensitive or not
16:27:30 <tibbs> Can we assume they are?
16:27:37 <spot> yeah
16:29:14 <tibbs> So where to we go from here?
16:29:37 <spot> so, i've now merged all of abadger1999's changes that i can
16:29:43 <tibbs> I'll try to convert denyhosts and see what I can come up with.
16:30:18 <spot> abadger1999: feel free to go ahead and make any other changes
16:30:26 <tibbs> Heh, denyhosts is going to be super un-fun.
16:30:51 <tibbs> It does not fit at all into the unit file model.
16:31:16 <geppetto> I thought there was a runonce type command
16:31:42 <tibbs> It's not that.
16:32:11 <tibbs> denyhosts can run from cron or as a daemon, and the init file sets up the right one depending on configuration.
16:33:08 <tibbs> I could do that with two unit files, but they can't be %config, so....
16:33:32 <tibbs> Oh, well, I'll try to figure it out later.
16:34:45 <abadger1999> Okay, easy portion changed.
16:34:57 <abadger1999> The rest are kind of questions without answers right now.
16:36:09 <spot> abadger1999: i answered one more question
16:36:09 <abadger1999> The main problem I have right now is verifying that the scriptlets do what they say they do.
16:37:16 <abadger1999> If someone else could try the supervisor packages that would at least verify that what I'm seeing is real:
16:37:30 * spot does not have a F15 instance yet
16:38:11 <tibbs> I do, but I'm not sure how to use the supervisor package to test.
16:38:11 <abadger1999> rpm -ivh http://toshio.fedorapeople.org/systemd/supervisor-3.0-0.2.a8.fc15.noarch.rpm ; systemctl start supervisorctl.service ; systemctl stop supervisorctl.service <= That worked in my testing but then:
16:39:12 <abadger1999> rpm -Uvh http://toshio.fedorapeople.org/systemd/supervisor-3.0-0.4.a8.fc15.noarch.rpm ; systemctl start supervisord.service  <= I got an error here I think that systemd could not find the unit file for supervisor
16:39:30 <abadger1999> tibbs: Sorry that should have been systemctl start supervisord.service in the first line too.
16:40:26 <abadger1999> Run /bin/systemctl daemon-reload manually, and then  systemctl start supervisorctl.service ; systemctl stop supervisorctl.service   should work.
16:41:10 <abadger1999> rpm -e supervisor ; rpm -ivh http://toshio.fedorapeople.org/systemd/supervisor-3.0-0.2.a8.fc15.noarch.rpm ; systemctl start supervisord.service  <= now this should fail with systemd unable to find the unit file.
16:41:42 <abadger1999> tibbs: And I did it again... s/supervisorctl.service/supervisord.service/  again
16:42:06 <tibbs> Is there any point in trying to do this during the meeting?
16:42:09 <spot> no.
16:42:12 <spot> i don't think so
16:42:18 <tibbs> I don't think we're going to vote on this anyway.
16:42:18 <abadger1999> Not if we aren't going to approve this now.
16:42:21 <spot> lets work on this outside the meeting
16:42:48 * spot is trying to figure out if there are other tickets ready for the meeting
16:43:03 <spot> there are plenty of bundling items, but i don't think _any_ of them have provided info
16:43:11 <racor> Don't see any reference to runlevels in the draft. how are they supposed to be converted rsp. what replaces them?
16:43:32 <spot> racor: bill nottingham gave that answer, i need to add that clarification
16:43:36 <spot> racor: thanks for the reminder
16:44:28 <spot> does anyone see a ticket that is ready for discussion?
16:45:04 <tibbs> Maybe stuff we can close out.
16:45:37 <abadger1999> Oh -- I pinged mattdm about systemd -- he's busy but if he gets a chance he'll look at the packaging draft and give feedback.
16:46:00 <abadger1999> There were other things -- like the tmpfiles.d stuff that came up i nthe mailing list.
16:46:28 <abadger1999> and the fesco question of what services get to start if they're installed
16:46:59 <spot> hmm
16:47:02 <spot> maybe https://fedorahosted.org/fpc/ticket/19
16:47:23 <spot> #topic Treatment of Bundled Libraries - https://fedorahosted.org/fpc/ticket/19
16:48:17 * spot ninja edits out the FESCo reference
16:48:42 <spot> https://fedoraproject.org/wiki/PackagingDrafts/Treatment_Of_Bundled_Libraries is the draft
16:49:48 * spot assumes the silence is from people re-reading this
16:49:58 * geppetto nods
16:50:05 <tibbs> There was a question recently about bundling software used only at build time.
16:50:17 <tibbs> Does that come into this in any way?
16:51:05 <rdieter_work> ie, as part of the pkg buildsystem ?
16:51:08 <tibbs> Yes.
16:51:13 <abadger1999> I'm conflicted I don't like this because it imposes unnecessary work on people but I do see that lots of times people assume that if the code doesn't ship, it must not be being used at build (to link or worse statically linking, etc).
16:51:14 <rdieter_work> ok, I think that's something we shouldn't touch (and clarify the current policy doesn't apply to it)
16:51:17 <Rathann|lappy> the question was mine
16:51:31 <abadger1999> tibbs: I've interpretted the guidelines as not allowing that.
16:51:35 <Rathann|lappy> and in the end it was easier to package the bundled tool separately anyway
16:51:48 <tibbs> abadger1999: Because, I mean, libtool is bundled in everything.
16:51:53 <rdieter_work> tibbs: +1
16:52:01 <rdieter_work> and auto*foo
16:52:16 <abadger1999> tibbs: For instance, a large amount of java claims that they use multiple versions of a single library (bundled)... but that's only necessary during the build.
16:52:21 <geppetto> Right, if someone had their own custom version of make, which they bundled to build their app. … I'd be like whatever
16:52:31 <geppetto> But if they are static linking to things … no.
16:52:31 <Rathann|lappy> yes, but you don't compile libtool as part of the build process
16:52:48 <abadger1999> tibbsauto  stuff is... something we don't treat as a library though... I suppose that we should make that an explicit exception.
16:52:57 <tibbs> I'm not sure compilation makes much difference here.
16:53:02 <spot> perhaps we can list auto* and libtool as exceptions here.
16:53:06 <abadger1999> (Since some people have claimed it should be)
16:53:28 * abadger1999 agrees with tibbs that compilation isn't the criteria
16:53:28 <spot> since i don't think we're going to solve that issue without enormous amounts of flames
16:53:33 * rdieter_work would rather leave buildsys stuff out of the equation, at least for now.  we've enough on our plate deailing with bundled code
16:53:34 <racor> spot: No, they are no bundled libraries, they are scripts
16:53:53 * spot is going to go ahead and add a section on build scripts
16:54:01 <tibbs> The specific example was, I think, some source preprocessor that was built first, then used to generate that actual source that was then compiled.
16:54:14 <abadger1999> rdieter_work: Note, I guess I dispute it since I've always included it in our current criteria.
16:54:14 <tibbs> Imagine a package that bundles a hacked CPP or something.
16:54:21 <Rathann|lappy> tibbs: dependency generator, actually
16:54:29 <rdieter_work> abadger1999: understood
16:54:31 <Rathann|lappy> but yes, something in that ballpark
16:54:34 <tibbs> Rathann|lappy: I've seen packages bundle ratfor, for example.
16:54:41 <abadger1999> So for me, no change would be not allowing build tools to be bundled.
16:55:17 * spot just added "Build scripts such as aclocal.m4 and libtool are exempt from these guidelines and are not considered bundled libraries."
16:56:08 <rdieter_work> abadger1999: so, here's an evil example:  qt and qmake.  qt first builds it's "bundled" qmake, to handle the rest of it's build.  should be unbundled then?
16:56:12 <abadger1999> I don't like it -- but it goes back to I consider build scripts except for those associated with autotools to be bundled libraries.
16:56:14 <racor> spot: In properly packaged auto* based packages, aclocal.m4 are sources-files, and are not actually used at all.
16:56:30 <abadger1999> rdieter_work: Is there a separate canonical upstream for qmake?
16:56:34 <spot> racor: okay, is that a bad example to go with libtool?
16:56:35 <rdieter_work> abadger1999: no
16:56:40 <spot> racor: should i just mention libtool then?
16:57:02 <abadger1999> rdieter_work: that seems more like simply bootstrapping then.
16:57:06 <rdieter_work> abadger1999: ok
16:58:22 <abadger1999> I guess with autotools is somewhat the same thing.... the tools (except for libtool?) are highly customized based on what you put in configure.in
16:58:25 <racor> spot: I am no sure. libtdl or gnulib could be cases of bundled code/libararies, but they are more copycode than libs.
16:58:48 <tibbs> gnulib already has a blanket bundling exemption.
16:59:14 <spot> "Build scripts such as libtool are exempt from these guidelines and are not considered bundled libraries. However, common build scripts such as libtool must not be packaged (except for in the "libtool" package, of course)."
16:59:23 * abadger1999 tentatively thinks libltdl should not be bundled
16:59:37 <racor> abadger1999: No, the autotools generate scripts and makefiles. Properly used, these scripts are selfcontained.
16:59:50 <spot> Can i propose that we consider this draft as is and then open separate tickets on additional exceptions?
17:00:12 <racor> spot: ack.
17:00:28 <abadger1999> ehh... -1
17:00:37 <abadger1999> I'd vote +1 without hte build scripts exception.
17:00:53 <abadger1999> That probably belongs on the no_bundled_library page anyway.
17:01:11 <spot> okay, i'll drop that and we can revisit it in a separate ticket
17:01:19 <racor> abadger1999: ack.
17:01:34 <spot> it is gone.
17:01:57 <abadger1999> +1
17:02:01 <spot> +1 from me
17:02:01 <racor> +1
17:02:02 <Rathann|lappy> looks good to me, +1
17:02:08 <geppetto> +1
17:02:14 <tibbs> +1
17:02:29 <rdieter_work> +1
17:02:47 <spot> #action https://fedoraproject.org/wiki/PackagingDrafts/Treatment_Of_Bundled_Libraries passes (+1:7, 0:0, -1:0)
17:03:39 <spot> #topic rpmlint maintenance - https://fedorahosted.org/fpc/ticket/32
17:03:47 <spot> I am now the rpmlint maintainer.
17:03:53 <rdieter_work> kudos
17:04:03 <abadger1999> spot: Great!
17:04:13 * spot has pushed an update which adds "el4-rpmlint" and "el5-rpmlint" and silences the errors about buildroot and cleaning
17:04:31 <Rathann|lappy> nice
17:04:34 <spot> tibbs: you proposed that someone on FPC should maintain rpmdevtools
17:04:46 <tibbs> I thought it worthy of discussion.
17:04:47 <spot> tibbs: can you follow up with the current maintainer and see if he/she is willing?
17:05:13 <tibbs> It's also scop, isn't it?
17:05:16 <abadger1999> That's probably also scop
17:05:25 <abadger1999> he's upstream at least.
17:05:47 <spot> would someone be willing to volunteer to help maintain there?
17:06:00 * spot would, but i'm already at 250% load
17:06:13 <tibbs> I think the problem is that he has some different ideas than I do about what those tools should do.
17:06:53 * spot does not see any willing volunteers
17:07:11 <spot> tibbs: maybe you should simply file bugs on the areas which are out of sync
17:07:17 <geppetto> spot: Are you asking for rpmdevtool volunteers?
17:07:22 <racor> spot: ask again next week.
17:07:22 <tibbs> They come back to the same thing, though.
17:07:23 <spot> geppetto: yes.
17:07:27 <abadger1999> I'll request comaint with scop for now
17:07:30 <Rathann|lappy> I'm sorry, but my backlog is too big for now, maybe in a month or two
17:07:33 <spot> abadger1999: thank you.
17:07:48 <spot> #action abadger1999 will request comaint with scop on rpmdevtools for now.
17:08:15 <limburgher> Bah, forgot we had a meeting today.  Apologies.
17:08:16 * abadger1999 just doesn't have much free time to actually work on it either
17:08:17 <tibbs> I just didn't want to start any kind of fight over these packages.
17:08:45 <tibbs> I don't think it requires much time investment; just tweaking templates to match changes in the guidelines.
17:08:46 <spot> i don't think we have any other tickets ready for today
17:08:50 <spot> so i am opening the floor
17:08:54 <spot> #topic Open Floor
17:09:35 <spot> i will close out the meeting at 17:12 if there are no items.
17:09:41 <Rathann|lappy> I have one issue
17:09:46 <tibbs> What does everyone think of the guy that insists on 5 space tabs?
17:09:57 * jsmith thanks the FPC committee for being willing to work on stuff that others find awful/boring/below them
17:10:02 <Rathann|lappy> I'd like to change my vote on https://fedorahosted.org/fpc/ticket/38
17:10:14 <Rathann|lappy> to -1
17:10:21 <spot> Rathann|lappy: okay, why?
17:10:46 <Rathann|lappy> I looked at kernel changelogs and noticed multiple version-less entries between builds
17:10:57 <spot> tibbs: aside from feeling sorry for anyone who cares that much about tab spacing, nothing
17:11:17 <spot> Rathann|lappy: i think in general, the kernel package is exempt from this
17:11:36 <tibbs> spot: I mean, I won't review that guy's packages, and if I ever have to touch them I'll fix the tabs.
17:11:39 <spot> i would not be opposed to documenting it.
17:11:47 <spot> tibbs: thats your call, i suppose.
17:12:18 <tibbs> It just seems that forcing folks to do weird things to their editors just to mess with his packages isn't in the spirit of having multiple people work on things.
17:12:36 <limburgher> tibbs: +5,000
17:12:58 <spot> tibbs: i just hate writing "don't be an idiot" in the guidelines.
17:12:59 <Rathann|lappy> well, I sometimes do the same thing - put some entries for changes I do for test builds which never get built in koji
17:13:08 <abadger1999> yeah, his attitude about the tabs makes me feel hesitant to review/approve/work on his stuff -- but it desn't make the specs unreadable or anything that I really want to establish a guideline about.
17:13:24 <limburgher> spot: Yeah, idiots aren't Excellent. ;)
17:13:25 <Rathann|lappy> it doesn't make sense to put a version on them
17:13:39 <tibbs> Do you think this falls under some general exemption like "specs must be readable" or something?
17:13:40 <spot> Rathann|lappy: my only concern is that I really do not want builds without n-v-r in the last changelog entry to end up in a repo (besides rawhide)
17:13:52 <spot> tibbs: sure, i could see that
17:13:53 <abadger1999> tibbs: It could... but they are readable.
17:14:13 <Rathann|lappy> spot: well, why not say that instead of banning version-less entries altogether?
17:14:15 <geppetto> Rathann|lappy: My opinion is that if you aren't doing a build, it doesn't need to be in the rpm changelog (but feel free to do a git commit, or in the GNU ChangeLog etc.)
17:14:18 <spot> tibbs: if you can propose a change that doesn't sound like "don't be an idiot"
17:14:27 <spot> Rathann|lappy: because i thought it would be painful to enforce
17:14:34 <spot> but i could get behind it.
17:14:44 * abadger1999 doesn't really
17:15:27 <abadger1999> I look at changelogs in order to tell what may have changed to cause something to stop working or to look for things that may have been fixed so I know if I should upgrade.
17:16:04 <geppetto> Rathann|lappy: Also, if you really want to put them in the rpm changelog ... what is wrong with just using the same version?
17:16:08 <abadger1999> it's easier if the entries correspond to a release -- ie if you make changes and don't build and then make more changes and make a build... it's easier for those to all be in one entry.
17:16:11 <tibbs> We have a "spec legibility" section; I'll see if I can come up with some way to minimally extend it.
17:16:16 <spot> tibbs: thanks
17:16:19 <Rathann|lappy> geppetto: because it's not the same version
17:16:23 <Rathann|lappy> it's the next version
17:16:39 <Rathann|lappy> which might end up being different when it gets built in koji
17:16:53 <abadger1999> Rathann|lappy: For you, the maintainer, it's the next version.  But for the consumer, its the same version.
17:17:12 <Rathann|lappy> no, the consumer doesn't see this until the next version
17:17:15 <abadger1999> Rathann|lappy: To me, the git commit messages are for the maintainer.  changelogs are for consumers.
17:17:45 <geppetto> Rathann|lappy: Right, by "same" I meant "same as the next version number you'll use" … and, yeh, if it changes then just go back and change them
17:18:08 * spot is about to have a hard stop here.
17:18:12 <abadger1999> Okay, I have to leave guys and gasls
17:18:16 <abadger1999> *gals
17:18:22 <Rathann|lappy> I don't like changing old changelog entries
17:18:23 <spot> so, let me ask this: does anyone else want to change their vote on #38?
17:18:36 <geppetto> no
17:18:37 * abadger1999 has no change.
17:19:04 <spot> i would support adding exception for the kernel, but i'm no change on the vote
17:19:04 <Rathann|lappy> also we usually use rpm changelog entries as git commit messages
17:19:43 <Rathann|lappy> I think I liked the original version in this ticket better
17:19:48 <spot> just thinking out loud, did this get sent to FESCo for ratification?
17:20:04 <tibbs> They didn't have time to consider it.
17:20:08 <spot> okay.
17:20:22 <spot> Rathann|lappy: i will note the change in your vote in the FPC ticket.
17:20:24 <tibbs> Their meeting last week was too close to ours for folks to have had a chance to read the drafts.
17:21:18 <spot> okay, if there are no other items i would like to close out
17:21:23 <Rathann|lappy> thank you
17:21:30 <spot> Thanks everyone.
17:21:32 <spot> #endmeeting