17:01:52 <spot> #startmeeting Fedora Packaging Committee
17:01:52 <zodbot> Meeting started Wed Jan 12 17:01:52 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:57 <spot> #meetingname fpc
17:01:58 <zodbot> The meeting name has been set to 'fpc'
17:02:14 <spot> #topic Roll Call
17:02:35 * abadger1999 here
17:02:52 * spot is here
17:03:38 <spot> geppetto, rdieter_work, tibbs, racor, SmootherFrOgZ: ping?
17:03:38 <abadger1999> geppetto, racor, rdieter_work, tibbs: fpc meeting if you're around
17:03:52 <tibbs> Yep.
17:04:03 <racor> Still here, but will have to quit soon ;)
17:04:13 <geppetto> yeh
17:04:28 * spot keeps getting the time confused.
17:04:57 <geppetto> I'm happier with it at this time, so if you want to change it it's fine by me
17:05:03 <abadger1999> Well, we have five for a little while.
17:05:06 <spot> geppetto: i don't think this time works well for racor
17:05:12 * nirik notes fesco is supposed to meet in about 25min
17:05:22 <spot> nirik: okay, we'll have a short meeting then. :)
17:05:23 <geppetto> Ahh, there's that too
17:05:33 <rdieter_work> here
17:05:35 <racor> spot: correct, I am having probs after 17:00 UTC
17:05:49 <spot> #topic Revisit %doc guideline - https://fedorahosted.org/fpc/ticket/36
17:06:14 * abadger1999 hopes we can get to tmpfiles.d as lennart doesn't want to update bugs until that's approved.
17:06:26 <spot> after reading the feedback on the %doc's must not be executable guideline, i've decided that i like one of the proposed alternative guideline wordings
17:06:42 <spot> "Files marked as documentation must not cause additional dependencies that aren't satisfied by the package itself or its dependency chain as it would be if none of its files marked as documentation were included in the package. One simple way to ensure this is to remove all executable permissions from %doc files (chmod -x)."
17:06:47 <rdieter_work> fine with me
17:07:07 <geppetto> +1
17:07:13 <tibbs> I kind of liked the simple approach, honestly.
17:07:34 <racor> +1 (Much better than chmod -x)
17:07:44 <geppetto> I think the reason we went with the other choice is that it's easier for rpmlint/etc. to point out problems
17:07:54 <abadger1999> Sentiment fine, how about slightly different wording: "Files marked as documentation must not cause the package to pull in more dependencies than it would without the documentation.
17:08:08 <abadger1999> One simple way to ensure this is to remove all executable permissions from %doc files (chmod -x)."
17:08:14 <spot> abadger1999: i'm fine with that.
17:08:18 <abadger1999> +1
17:09:00 <spot> okay, lets do a quick vote on abadger1999's wording:
17:09:01 <spot> +1
17:09:09 <rdieter_work> +1
17:09:19 <geppetto> what's the difference from your wording?
17:09:35 <spot> geppetto: his is shorter and means the same thing. ;)
17:09:46 <geppetto> Ahh … two lines, the later being identical
17:09:53 <geppetto> +1
17:10:51 <spot> i see +4, racor, tibbs?
17:11:04 <tibbs> I'm not a fan of changing this again.
17:11:18 <racor> +1 I am fine with either wording.
17:11:44 <spot> tibbs: we're at +5, would you like to vote for the record?
17:11:48 <tibbs> -1
17:12:16 <spot> #action abadger1999's minimal wording approved (+1:5, 0:0, -1:1)
17:12:26 <tibbs> That said, we've now changed it to that I was allowing in reviews all along, so....
17:12:38 <abadger1999> Yeah.
17:13:02 <spot> #topic https://fedorahosted.org/fpc/ticket/44 - tmpfiles.d packaging draft - https://fedoraproject.org/wiki/Tmpfiles.d_packaging_draft
17:13:03 <tibbs> It's not like I'm upset, it's just that we finally got it to where I thought it should be.
17:13:17 <spot> tibbs: *nod*
17:13:39 <abadger1999> spot: So I drafted this and lennart and dwalsh revieed it.
17:14:19 <spot> abadger1999: only thing i see is a naming inconsistency
17:14:24 <spot> apache.conf vs httpd.conf
17:14:25 <tibbs> Hmm, didn't realize tmpfiles.d was taking over tmpwatch functionality.
17:14:27 <abadger1999> I haven't had time to personally test it in a VM but that's the case with a lot of guidelines :-(
17:14:46 <spot> (the latter is probably more appropriate)
17:15:06 <tibbs> Can we enforce naming on the .conf file?  Should we?
17:15:21 <spot> tibbs: i just want the draft to be internally consistent
17:15:36 <tibbs> Indeed, it's not currently.
17:15:42 <spot> if it was goldfish.conf everywhere, i'd be fine. :)
17:15:43 <abadger1999> Hmm... For the proposed systemd guidelines, we wanted to get to apache.conf -- (Given Name of the service).  Do we want that here?
17:15:51 <tibbs> But I was wondering if it's worth saying "name it after the package"?
17:15:57 <abadger1999> <nod>
17:15:59 <spot> abadger1999: apache is not the name of the service, it is "apache httpd"
17:16:08 <tibbs> I guess not; rpm can tell you what package owns the file.
17:16:12 <spot> there are many apache projects (and many httpd implementations)
17:16:23 <abadger1999> Given Name like Toshio is my given name.
17:16:30 <abadger1999> That's true.
17:16:37 <geppetto> Yeh … just tlel people to install it as %{name}
17:16:44 <spot> abadger1999: yes, but in this specific case, the apache foundation is very touchy about it
17:16:46 <geppetto> as %{name}.conf … even
17:16:55 <spot> which is why we renamed the package many moons ago from "apache"
17:17:03 <abadger1999> spot: Okay -- we need to modify the systemd packaging guidelines too.
17:17:04 <spot> i think %{name}.conf is simplest.
17:17:12 * abadger1999 changing tmpfiles.d to %{name} right now
17:18:26 <spot> aside from that, this seems simple and straightforward.
17:18:34 <tibbs> I agree.
17:18:50 <geppetto> So … the page itself seems fine to me. However: the tmpwatch part makes me twitch, being completely different functionality. The fact systemd etc. breaks this, and requires fixing every package annoys me … and the config. file format is just … wow.
17:19:10 <geppetto> I guess we can't really complain about any of that stuff though … *sigh*
17:19:26 <tibbs> Yeah, this just documents the behavior of something others have decided to use.
17:19:50 <tibbs> Sure would have been nice to see it before all the crackrocks were smoked, though.
17:19:52 <geppetto> So, I guess +1
17:19:56 <spot> +1 from me
17:20:37 <abadger1999> +1
17:20:44 <tibbs> Did stuff change to use %{name} yet?  I'm still seeing the old content.
17:21:04 <spot> tibbs: i see the changed version
17:21:11 <tibbs> Also, in the example, it might be useful to call the Source1: something other than httpd.conf, to avoid confusion with, you know, httpd.conf.
17:21:18 <abadger1999> tibbs: Okay, refresh and see if Icaught every place: https://fedoraproject.org/wiki/Tmpfiles.d_packaging_draft
17:21:24 <tibbs> I'm seeing it now.
17:21:35 <spot> tibbs: pretty sure he did that. :)
17:21:45 <abadger1999> I called Source1: %{name}.conf now... might still conflict for that particular package.
17:21:51 <tibbs> Indeed.
17:21:55 <rdieter_work> +1
17:22:23 <spot> abadger1999: does it care about the naming or does it just parse any file in that {_sysconfdir}/tmpfiles.d/ dir?
17:22:45 <abadger1999> spot: Any file.
17:22:51 <abadger1999> We can choose any name we want.
17:23:19 <spot> then, perhaps dodging the obvious conflict makes sense
17:23:21 <tibbs> The text after the example leaves me wondering exactly what is optional.
17:23:36 <tibbs> Listing the files with %ghost or listing the files at all?
17:23:39 <spot> s/.conf/.tmpfile
17:23:51 <spot> or .tmpfile.conf
17:24:01 <spot> or something more clever.
17:24:11 * abadger1999 fixing tibbs's concern
17:24:35 <spot> %{name}.tmpfiles
17:25:19 * spot notes that we are almost out of time for today
17:25:37 <spot> is anyone opposed to %{name}.tmpfiles instead of %{name}.conf ?
17:25:42 <tibbs> Minor issues aside, +1 to this guideline
17:25:51 <abadger1999> Ugh.
17:25:52 <abadger1999> systemd uses /etc/tmpfiles.d/ to describe the creation, cleaning and removal of temporary files and directories which usually reside in /var/run or /tmp). Each configuration file is named in the style of /etc/tmpfiles.d/<program>.conf.
17:26:11 <tibbs> I thought this wasn't systemd-specific?
17:26:25 <abadger1999> I don't think, beyond *.conf, that has a technical meaning, it's just how tmpfiles.d is documented in the manpage
17:26:45 <abadger1999> That was a quote from the tmpfiles.d manpage
17:26:55 <spot> abadger1999: okay, fine, we'll leave it as is. hopefully packagers are smart enough to figure out how to avoid overlap issues
17:27:26 <spot> #action draft passes +1:5, 0:0, -1:0
17:27:37 <abadger1999> I can mes with install %{name}.tmpfiles.conf %{name}.conf if people want me to address that, it doesn't change the meaning of the draft any.
17:27:54 <spot> abadger1999: if you feel so inclined.
17:28:11 <tibbs> BTW, for me the issue wasn't what the file is named once it's in place; it's what the Source1: file was named.
17:28:17 <spot> tibbs: *nod*
17:28:32 <spot> Okay, we're really out of time. thanks everyone.
17:28:35 <spot> #endmeeting