15:14:21 <spot> #startmeeting Fedora Packaging Committee
15:14:21 <zodbot> Meeting started Wed Apr 20 15:14:21 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:14:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:14:23 <spot> hm.
15:14:25 * spot wonders if the bot is sick
15:14:27 <spot> anyways.
15:14:28 <spot> can we do a quick roll call?
15:14:30 <spot> #meetingname fpc
15:14:30 <zodbot> The meeting name has been set to 'fpc'
15:14:36 <spot> #topic Roll Call
15:14:44 * SmootherFrOgZ here
15:14:52 <tibbs|h> Howdy.
15:15:00 <Rathann> hi
15:15:06 <rdieter> yo
15:15:25 <spot> geppetto, limburgher: ping
15:15:30 * limburgher yo
15:16:05 <geppetto> pong
15:16:10 <spot> okay, thats 7
15:16:17 <spot> abadger1999 is on vacation
15:16:29 <spot> and racor, well, :)
15:17:14 <spot> okay, lets hit the oldies.
15:17:24 <spot> #topic Systemd Migration Guidelines - https://fedorahosted.org/fpc/ticket/31
15:17:37 * spot had 0 time to test this since we met last
15:18:13 <spot> anyone else have time to test?
15:18:32 <limburgher> no
15:18:35 <tibbs|h> Honestly I've been sick since we last met.
15:18:44 <tibbs|h> But I think folks have been talking about it on-list.
15:19:13 <Rathann> me neither, sorry
15:19:15 <spot> tibbs|h: yeah, i saw some of that, it looked like everything worked, but i'd still like to test them out
15:19:17 <tibbs|h> It's not as if all the testing has to be done by us anyway.
15:19:41 <SmootherFrOgZ> I did start but not finish the whole step. Should have more time this weekend hopefully
15:19:42 <spot> yeah, i just know this is rather important to get right
15:20:36 <spot> Okay, lets move on, please help test if you can.
15:20:41 <tibbs|h> I got the impression that some folks had already started using this in their packages.
15:20:55 <spot> #topic Perl paths @INC change - https://fedorahosted.org/fpc/ticket/73
15:21:16 <tibbs|h> Did we ever get anything back on this?
15:21:19 <spot> In keeping with my previous 0 free time, I did not have a chance to talk to Perl upstream about this.
15:21:53 <limburgher> Are we all having the same sort of week? :)
15:21:59 <spot> it looks that way
15:22:00 <tibbs|h> I sure am.
15:22:09 <spot> my free time pretty much drops to 0 between beta and final
15:22:22 <tibbs|h> I had a little time to work on my draft and deal with SCM requests; that's about it.
15:22:44 <spot> so, lets table this one, and i'll talk to perl upstream
15:23:37 <spot> #topic New Filtering Mechanisms - https://fedorahosted.org/fpc/ticket/76
15:23:55 <spot> tibbs|h, you opened this one, but i don't see specific proposed changes
15:24:06 <tibbs|h> I started on a draft, but I'm quickly running into more questions than I can answer.
15:24:12 <tibbs|h> I need to get with Panu for a bit.
15:24:27 <spot> okay, we'll look at it in a week, thanks.
15:24:38 <tibbs|h> https://fedoraproject.org/wiki/User:Tibbs/AutoProvidesAndRequiresFiltering
15:24:41 <tibbs|h> Should update the ticket.
15:24:53 <tibbs|h> Really, I just need to translate some examples and figure out a bit of magic.
15:24:56 <spot> #topic %defattr is no longer needed in Fedora - https://fedorahosted.org/fpc/ticket/77
15:25:14 <tibbs|h> Still +1 to this.
15:25:24 <spot> yeah, i'm +1 here too
15:25:35 <geppetto> Why didn't we approve this last week again?
15:25:36 <Rathann> +1
15:25:41 <tibbs|h> Just needs an rpmlint tweak, I think, along with someone updating all of our drafts.
15:25:43 <geppetto> I'm +1, IIRC
15:25:45 <SmootherFrOgZ> +1
15:25:50 <tibbs|h> I don't think this was filed before the meeting last week.
15:26:02 <rdieter> +1
15:26:33 <spot> I see +6, limburgher, if you want to go on the record, feel free to chime in
15:26:38 <tibbs|h> Toshio was +q in the ticket.
15:26:45 <spot> tibbs|h: yep, thats right
15:26:48 <geppetto> yeh, it was part of the open floor … so we didn't vote
15:26:49 <spot> so, +7
15:27:01 <limburgher> +1
15:27:16 <spot> #action Approved (+1:8, 0:0, -1:0)
15:27:46 <tibbs|h> Progress!
15:28:22 <spot> okay, this one has no ticket, but came up on the list
15:28:33 <spot> #topic Updating gsettings scriptlets
15:29:15 <tibbs|h> I'm not entirely sure what the issue is here, but if it's currently broken then we need to "just fix it".
15:29:21 <spot> several folks have pointed out that the GSettings scriptlets do not handle migrating from gconf to gsettings
15:30:04 <spot> Julian Sikorski suggested these as a replacement: http://lists.fedoraproject.org/pipermail/devel/2011-April/150641.html
15:30:42 * rdieter likes that version better
15:31:09 <spot> it looks reasonable to me.
15:31:47 <spot> So, lets vote on fixing the scriptlets
15:31:51 <spot> +1
15:31:51 <SmootherFrOgZ> +1 from me for this
15:32:07 <limburgher> +1.  Looks elegantish.
15:32:16 <tibbs|h> I'm curious as to what went wrong, since the desktop folks gave us what's currently in the guidelines.
15:32:42 <geppetto> +1
15:32:46 <tibbs|h> But, sure, +1 if what we have is wrong and this is better.  (I know very little about gnome.)
15:32:55 <rdieter> +1
15:33:13 <tibbs|h> I'd just hate to go from something that's broken to something else that's broken.
15:33:13 <geppetto> tibbs|h: AIUI it was to do with multilib
15:33:17 <spot> #action Approved (+1:6, 0:0, -1:0)
15:34:12 <spot> this is ticket 78 (quickly entered)
15:35:12 <spot> there is one more open ticket, the macro pathing one.
15:35:28 <spot> #topic Remove requirement to use macros for paths
15:36:08 <spot> So, i've been thinking about this a bit off and on
15:36:23 <tibbs|h> I'm still not buying the arguments that we might need to change _bindir one day.
15:36:34 <spot> Toshio's point about %configure is interesting
15:36:56 <spot> we have quite a few macros that use the pathing macros
15:37:15 <spot> both provided by rpm and custom macros that Fedora has created
15:37:30 <tibbs|h> I don't really see why that would block this, though.
15:37:51 <spot> well, it wouldn't.
15:38:08 <Rathann> there was something about macros making it easier to do cross-compilation
15:38:14 <spot> So, the big question is: what benefit do we get from this change?
15:38:35 <spot> i worry that we'll get sloppy spec files if we permit pathing without macros
15:39:03 <tibbs|h> Basically less line noise.
15:39:18 <tibbs|h> And avoiding some weirdness when people really do want to put files in bin.
15:39:32 <tibbs|h> Since they can't just say "/bin" now, they redefine _bindir.
15:39:36 <tibbs|h> Which is kind of loony.
15:39:50 <Rathann> huh? people do that?
15:39:52 <spot> do we actually say they can't say /bin ?
15:40:01 * spot has several packages that do say /bin /sbin
15:40:12 <geppetto> rpmlint?
15:40:22 <tibbs|h> To be honest it was an old merge review and might have changed.
15:41:11 <spot> "Use macros instead of hard-coded directory names (see Packaging:RPMMacros ). "
15:41:14 <tibbs|h> What really gets me is when we have macros that are pointlessly longer than what they replace.
15:41:16 <spot> thats what the guideline says
15:42:01 <spot> tibbs|h: e.g. %{_sysconfdir} and %{_localstatedir}
15:42:17 <tibbs|h> And sometimes you just want to know where a spec puts some files.  Right now you can't just look; you have to keep a mental table of what all of those macros expand do.
15:42:19 <tibbs|h> to.
15:42:47 <tibbs|h> It just seems that we have this level of indirection that doesn't appear to buy us much of anything.
15:43:28 <spot> another concern that i have is that we know we have to keep %{_libdir}
15:43:38 <tibbs|h> Certainly; that's mandatory.
15:43:57 <tibbs|h> Because that macro actually serves a purpose.
15:44:41 <tibbs|h> I'm curious as to how specs could be made sloppier by this, though.  I know people do weird things; I just wonder how forcing macros might prevent that.
15:44:47 <spot> I do think path macros help keep a spec file clean and legible
15:45:24 <tibbs|h> I'm having trouble understanding how.
15:45:38 <Rathann> I agree with tibbs|h on the part that says it's annoying to use macros that are long than their expansion
15:45:52 <tibbs|h> Maybe I'll fix up a couple of my specs and see how they look.
15:46:02 <spot> well, i think if you typo a manual path, it could succeed
15:46:09 <spot> if you typo a macro, it won't.
15:46:16 <Rathann> hm, true
15:46:18 <Rathann> good point
15:46:50 <spot> also, the use of macros makes custom directories and odd layout choices stand out a bit more
15:47:10 <tibbs|h> Just looked at one spec and now I have to run --showrc to look up one of the macros because I don't remember it.
15:47:21 <spot> if you see %{_bindir} and then below it /usr/arg/dinosaurs!/foo/
15:47:38 <tibbs|h> _datadir is defined to _datarootdir.  Great.
15:47:49 <Rathann> tibbs|h: rpm --eval
15:47:50 <tibbs|h> Which is _prefix/share.
15:48:04 <spot> but if that entry is surrounded by /usr/share/dinosaurs!/ and /usr/lib/dinosaurs!/
15:48:39 <spot> this just seems like a solution in search of a problem to me.
15:48:48 <tibbs|h> And _localstatedir is just /var.
15:49:23 * spot notes that %{_var} is also /var
15:49:24 <Rathann> tibbs|h: those long names come from autoconf configure options I think
15:49:49 <tibbs|h> Now there's a great example we should be following.
15:50:12 <geppetto> tibbs|h: Ahh, a joke, I've heard of those :)
15:50:21 <Rathann> no we just need %{_etc} ;)
15:50:34 <tibbs|h> My RSI does not thank you.
15:51:34 <tibbs|h> Anyway, I don't really know what remains to be said.
15:51:36 <spot> i would not be opposed to some improved wording that says that while the use of pathing macros is encouraged, in situations where the macro is longer than the path it represents or situations where the packager feels it is cleaner to use the actual path, they are permitted to use the actual path instead of the macro, however, they must do so consistently (no mixing of hardcoded paths and macros).
15:51:50 <tibbs|h> I could go for that.
15:52:12 <tibbs|h> But of course you have to be careful that folks don't think they can't use _libdir because they decided not to use _localstatedir.
15:52:17 <spot> does that logic parse for everyone here? i know thats a hell of a sentence. :)
15:52:37 <geppetto> I know what you both meant :)
15:52:42 <SmootherFrOgZ> I'm +1 on not mixing both
15:52:43 <spot> tibbs|h: yeah, that should be called out explicitly.
15:52:43 <geppetto> And I agree
15:53:17 <limburgher> SMootherFr0gZ: <nods>
15:55:17 <spot> "Packagers are strongly encouraged to use macros instead of hard-coded directory names (see Packaging:RPMMacros). However, in situations where the macro is longer than the path it represents, or situations where the packager feels it is cleaner to use the actual path, the packager is permitted to use the actual path instead of the macro. There are several caveats to this approach: * The package must be consistent, you must not mix hardcoded paths and macro
15:55:17 <spot> s * %{_libdir} must always be used, you may not substitute a hard-code path"
15:55:46 <spot> that would replace the first sentence of "Macros" in the guidelines
15:56:05 <spot> thoughts?
15:56:16 <tibbs|h> Did you intend those two starred statements to conflict?
15:56:35 <limburgher> I read it as an exception.
15:56:35 <tibbs|h> There have been differing interpretations of "don't mix" rules in the past.
15:56:42 <spot> hmm. no. perhaps I should be more clear.
15:57:12 <tibbs|h> "Don't use both the macro and its definition" is one interpretation.
15:57:13 <geppetto> I would say: "%{_libdir} must always be used for binary libraries, due to multilib.
15:57:16 <geppetto> Apart from that, +1
15:57:22 <tibbs|h> "If you use macros, you must use macros everywhere" is another.
15:57:28 <spot> * The package must be consistent, you must not use a hard-coded path in the spec and later in the same spec, use the macro for that path.
15:57:52 <tibbs|h> OK, so the first interpretation, which is fine.
15:58:12 * spot wonders if there is a simpler way to word that
15:58:15 <SmootherFrOgZ> geppetto, +1 for multilib
15:58:58 <tibbs|h> It's going to be tough to hash this out over IRC, I think.
15:59:45 <spot> tibbs|h: eh, i think we're pretty close
16:00:09 <spot> what about:
16:00:11 <spot> "Packagers are strongly encouraged to use macros instead of hard-coded directory names (see Packaging:RPMMacros). However, in situations where the macro is longer than the path it represents, or situations where the packager feels it is cleaner to use the actual path, the packager is permitted to use the actual path instead of the macro. There are several caveats to this approach:
16:00:11 <spot> * The package must be consistent, you must not use a hard-coded path in the spec and later in the same spec, use the macro for that path.
16:00:11 <spot> * %{_libdir} must always be used for binary libraries due to multi-lib, you may not substitute a hard-code path"
16:00:12 <limburgher> *  The package must be consistent.  For any given path, within the same spec, use either a hard-coded path or a macro, not a combination of the two.
16:00:22 <spot> limburgher: i like that
16:00:38 <limburgher> With your libdir clause.
16:00:48 <spot> okay, once more:
16:00:51 <spot> "Packagers are strongly encouraged to use macros instead of hard-coded directory names (see Packaging:RPMMacros). However, in situations where the macro is longer than the path it represents, or situations where the packager feels it is cleaner to use the actual path, the packager is permitted to use the actual path instead of the macro. There are several caveats to this approach:
16:00:51 <spot> * The package must be consistent.  For any given path, within the same spec, use either a hard-coded path or a macro, not a combination of the two.
16:00:51 <spot> * %{_libdir} must always be used for binary libraries due to multi-lib, you may not substitute a hard-code path"
16:01:44 <geppetto> +1
16:01:48 <spot> +1 from me
16:01:53 <SmootherFrOgZ> +1
16:01:54 <limburgher> +1
16:02:16 <rdieter> +1
16:02:16 <tibbs|h> Personally I'd prefer to axe the "strongly", but I can live with this.  +1
16:02:40 <spot> racor: i saw you sneak in, would you like to vote here?
16:02:59 <racor> spot: no, I am lacking context
16:03:06 <spot> racor: fair enough.
16:03:23 <spot> #action Approved (+1:6, 0:0, -1:0)
16:04:14 <spot> Okay, open floor time
16:04:15 <racor> spot: meetings now are at 15:00 UTC? I sneaked in because I thought a meeting was going to happen 16:00 UTC.
16:04:19 <spot> #topic Open Floor
16:04:35 <spot> racor: yes, sorry, we moved to 1500 UTC
16:04:36 <limburgher> racor: Correct.  1500 UTC.
16:04:40 <spot> i need to update the wiki
16:04:52 <spot> racor: hopefully 1500 will be a better time for you
16:05:13 <racor> spot: 15:00 UTC is much better!
16:06:16 <tibbs|h> spot: How do you generally communicate with Panu?
16:06:31 <spot> tibbs|h: irc usually works, but he's not terrible with email
16:06:49 <tibbs|h> I seem to keep missing him on IRC, because he's on the other end of the planet.
16:07:08 <spot> tibbs|h: you can always try tossing questions in #rpm.org
16:07:20 <tibbs|h> I never would have found that.
16:08:06 <tibbs|h> I'm trying to work out macro magic so that you can use the new filtering stuff additively.
16:08:28 <spot> tibbs|h: normally, the words "macro magic" summon toshio
16:08:32 <spot> tibbs|h: but he's on vacation
16:08:46 <tibbs|h> You could specify multiple filters with the old stuff, but the new ones are just defined once.
16:08:59 <limburgher> I just say abadger1999 abadger1999 abadger1999.
16:09:12 <geppetto> :)
16:09:24 <spot> asnake?
16:09:33 <geppetto> tibbs|h: I would probably just email the rpm list … but IRC might work, if you are around at the right times
16:09:35 <tibbs|h> But with macro magic, you could theoretically append to the existing regex.  Depending on the regex language in use and whether the macros are sufficiently expressive.
16:09:49 <spot> ooh, you lost me at "regex". :)
16:09:59 <tibbs|h> This is important to keep %perl_default_filter working, as that's really useful.
16:10:28 * spot nods
16:10:38 <spot> anyways, it sounds like there is nothing for the open floor
16:10:41 <spot> so i will close it out
16:10:47 <spot> we'll meet again next week at 1500 UTC
16:10:50 <spot> thanks everyone
16:10:54 <spot> #endmeeting