15:05:44 <spot> #startmeeting Fedora Packaging Committee
15:05:44 <zodbot> Meeting started Wed Apr 27 15:05:44 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:49 <spot> #meetingname fpc
15:05:49 <zodbot> The meeting name has been set to 'fpc'
15:06:13 <spot> #topic roll call
15:06:20 * limburgher here
15:06:25 <tibbs|h> Howdy.
15:06:40 <racor> here
15:06:46 * geppetto is here
15:07:16 * spot suspects abadger1999 might still be on vacation
15:07:27 <abadger1999> Hey,
15:07:29 * abadger1999 here
15:07:33 <spot> no, he's back!
15:07:36 <abadger1999> was catching up on email.
15:07:50 <spot> rdieter, SmootherFrOgZ: ping
15:09:53 <spot> okay, we have 6
15:09:55 <spot> lets go ahead
15:10:07 <spot> #topic Systemd
15:10:13 <llaumgui_zhukov> Pikachu_2015
15:10:23 <spot> notting has been commenting on ticket #31
15:10:56 <spot> he seems very strongly in the "don't package sysv initscripts at all" camp
15:11:31 <spot> as opposed to putting them in subpackages (which is what we already approved in the base guidelines)
15:11:51 <tibbs|h> I have no problem either way, honestly.  I'm not sure what benefit they have now.
15:11:58 <abadger1999> So -- if the direction we're taking is that the sysvinit to systemd transition is wiping the slate clean, I can see not telling people to run the state-saving script.
15:12:37 <abadger1999> But telling people they can't package the scriptlets at all doesn't seem right (and I don't think he's saying that).
15:12:51 <tibbs|h> But "wiping the slate clean" can mean breaking people's machines during the transition.
15:12:57 <abadger1999> <nod>
15:13:00 <rdieter> oh hi, here now
15:13:02 <tibbs|h> So certainly not during a release.
15:13:03 <abadger1999> I think that's already the case.
15:13:33 <abadger1999> Yeah -- ideally we'd convert every sysv script to systemd during one release cycle.
15:13:49 <limburgher> abadger1999: <nods>
15:13:57 <tibbs|h> Sure, F16 seems a good time.  Some folks are trying to do that before F15.
15:14:11 <tibbs|h> Witness the volume of bugs filed on it.
15:14:40 <spot> bochecha has been testing the migration scriptlets and reported that everything worked
15:14:58 <tibbs|h> But sgallagh reported that they were completely broken.
15:15:15 <rdieter> and some want to migrate asap due to pain around sysv emulation (bugs, need for added deps, yada yada)
15:15:16 <tibbs|h> And that Lennart told him to ignore what we had written entirely.
15:15:41 <geppetto> that's nice
15:15:53 <limburgher> <headdesk>
15:16:13 <tibbs|h> I'm somewhat at a loss.
15:16:41 <limburgher> Why are we here?  Gridlock! </Stockdale>
15:17:01 <tibbs|h> I only waded into that because my F15 machines broke when sssd migrated.
15:17:27 <geppetto> Well, I don't mind saying "no sysv scripts" and "moving to systemd resets what's running" … which should help the migration
15:17:34 <geppetto> tibbs|h: Why did it break?
15:17:56 <tibbs|h> I had to enable the service manually.
15:18:07 <tibbs|h> I mean, no huge deal, but....
15:18:22 * geppetto nods … so it wasn't broken, just defaulted badck to turned off
15:18:48 <tibbs|h> Well, the machine was broken, becuase it doesn't do much without a user database.
15:18:54 * geppetto shrugs … I guess I can live … assuming most of the services are converted at once
15:19:10 <tibbs|h> The whole point of our work here is to prevent that.
15:19:22 <tibbs|h> Otherwise we can ignore any concept of migration altogether.
15:19:55 <Rathann> hi folks
15:19:59 <Rathann> sorry for running late
15:20:19 <Rathann> but I'm on afternoon shift at work
15:20:35 <Rathann> also my connection is flaky, so forgive the drop-outs
15:20:38 <abadger1999> Rathann: np.  We're talking about: https://fedorahosted.org/fpc/ticket/31
15:20:47 <geppetto> tibbs|h: Well, if the set of running services being reset to default is the only problem … I'm pretty sure I'd call that success of migration to systemd :)
15:21:07 <geppetto> tibbs|h: But, as I said, I'd want it to be a one time thing … so everyone converts for F16 or something
15:21:21 <limburgher> So it's easly release-noteable in Bold, with blink tags.
15:21:27 <geppetto> yeh
15:22:24 <geppetto> Personally I'd prefer a much better/smoother migration … but unless anyone knows how to do "invasion of the body snatchers" on lennert, then I'll settle for this
15:22:34 <spot> i tell you, this systemd stuff just makes me exhausted
15:22:36 <limburgher> How long do I have?
15:23:15 <rdieter> maybe it's just not worth blocking on migration (for now, at least). ?
15:23:29 <tibbs|h> Folks have already put significant effort into migration. Some folks say it works.
15:23:33 <abadger1999> rdieter: I think we've already approved the non-migratin case.
15:23:34 <spot> We could ask FESCo for guidance on whether they want sysv scripts to be packaged and if they want settings to be saved.
15:23:40 <abadger1999> no.
15:23:45 <tibbs|h> I only have one report that it doesn't work, but that comes with no details at all.
15:23:47 <abadger1999> Well...
15:23:51 * abadger1999 ponders
15:25:27 <abadger1999> spot: There's multiple issues if we ask that... some of them may be FESCo material some may not.  Many of them seem like governance body vs maintainer pergoative issues which are always thorny.
15:26:18 <abadger1999> spot: The main one would be "Can we have alternate versions of core system services (examples: init systems, X Windows, cron,)"
15:27:38 <abadger1999> I suppose we could ask FESCo but I don't know that it would lead anywhere good anywhere fast.
15:28:13 <rdieter> the answer(s) may simplify or complicate our lives (but I'd hope the former)
15:28:32 <abadger1999> The thing is I think we've already answered that question long ago.
15:28:46 <abadger1999> The answer is yes, if a maintainer is there.
15:29:34 <abadger1999> But the out-of-box "support" in particular packages may not be there depending on how we've implemented them.
15:29:47 <tibbs|h> Bottom line is that we're certainly not going to require continued packaging of sysv scripts.
15:29:55 <tibbs|h> So anyone who wants that has their own uphill battle.
15:30:09 <spot> okay, so if we're operating on that assumption
15:30:11 <tibbs|h> Including simply maintaining their own packages containing such scripts.
15:30:21 <spot> lets use scriptlets that assume the sysv initscripts are no longer being packaged
15:30:43 <spot> that fact should simplify the scriptlets
15:31:04 <abadger1999> How is that different from what we already have, really?
15:31:43 <spot> abadger1999: well, we have scriptlets for the subpackage containing the sysvinit script
15:32:07 <spot> notting pointed out concerns with those scriptlets specifically
15:32:08 <abadger1999> spot: That could be moved out of the systemd guideline page but it's still good to exist.
15:32:30 <abadger1999> spot: because we do allow people to package for initng, minit, upstart...
15:32:54 <spot> abadger1999: yes, but as pointed out "the out-of-box "support" in particular packages may not be there depending on how we've implemented them"
15:32:55 <abadger1999> spot: It's information relevant to those alternative init systems.
15:33:44 * spot is just so tired of looking and arguing about systemd
15:34:31 <spot> i think systemd-sysv-convert is useful. i want to keep it.
15:35:27 <tibbs|h> I agree.
15:35:31 <spot> abadger1999: look over nottings comments in that ticket, starting at #56
15:35:32 <abadger1999> spot: What data does that script save exactly?
15:35:52 <tibbs|h> But simply keep it (which wouldn't be our business) or mandate it?
15:35:59 <abadger1999> Yeah, I read them this morning... a lot of the things he's arguing about were already decided when we passed the non-migration guidelines.
15:37:29 <spot> abadger1999: its python and short, so it should be easy for you to parse
15:37:49 <spot> abadger1999: but it basically stores the runlevels that a sysv service is enabled for
15:38:25 <abadger1999> spot: Okay... so one thing we could take from notting's critique is to separate that from systemd.
15:38:26 <spot> abadger1999: and if prompted later, restores them (across mappings) into systemd
15:38:40 <abadger1999> spot: And keep the saving of data separate from the restoring of data.
15:38:54 <spot> abadger1999: well, none of the scriptlets actually do the restoring
15:39:05 <spot> abadger1999: so we're already separating the saving from the restoring
15:39:13 <abadger1999> spot: Since we're only using the saving functionality in the scriptleets.. (Yeah, I think you're seeing the same thing I am).
15:39:47 <spot> at this point, my instinct is to do the following:
15:40:11 <spot> A) Separate out the scriptlet relating to a subpackage containing sysvinit script and considering it separately
15:40:22 <abadger1999> Really, we're just using a tool to save data that a sysadmin might want to use to configure their system.... whether it's restored to systemd or some other init system isn't part of the guidelines.
15:40:37 <spot> B) Vote on the rest of the scriptlets as is and address any tangible problems that arise
15:42:29 <spot> thoughts on that approach?
15:43:01 <tibbs|h> Sure.
15:43:02 <abadger1999> C) Whether to save the old settings.
15:43:26 <abadger1999> I guess that only applies if B) doesn't pass.
15:43:53 * abadger1999 +1's the (A), (B) approach
15:44:01 <spot> +1 from me
15:44:17 * rdieter likes
15:44:34 <limburgher> +1
15:45:04 <spot> (for the record, we are voting on (A) and (B) together)
15:45:35 <tibbs|h> That's five, isn't it?
15:45:46 <spot> well, if "likes" and "sure" map up to "+1"...
15:45:51 <rdieter> +1
15:45:53 <rdieter> :)
15:45:56 <racor> 0
15:45:57 <spot> thanks. ;)
15:45:59 <tibbs|h> +1
15:46:09 <spot> geppetto: wanna jump in here?
15:46:24 <spot> Rathann too, if you're with us
15:46:25 <tibbs|h> I would dearly love to get at least some guidelines written down.
15:46:30 <geppetto> +1
15:47:13 <spot> #action Migration scriptlets, with the subpackage scriptlet removed are approved (+1:6, 0:1, -1:0)
15:47:17 <abadger1999> err... I was just voting on whether to vote on A and B separately... I vote +1 to A .. What does B look like?
15:47:39 <spot> abadger1999: one sec
15:48:30 <spot> B looked like https://fedoraproject.org/wiki/User:Toshio/Systemd_scriptlet_options#Start_over_fresh
15:48:34 <spot> looks, rather
15:48:45 <spot> without the Subpackage with sysv initscripts section
15:49:06 <abadger1999> +1 B
15:49:24 <spot> okay. if this information changes anyone's vote, you have a minute or two to speak up
15:50:21 <tibbs|h> Looks good to me.
15:50:56 <spot> okay. the approval stands
15:51:16 <spot> we'll discuss the sysv subpackage handling next week. i'll open a separate ticket.
15:51:55 <abadger1999> We'll probably want to implement it by updating: https://fedoraproject.org/wiki/Packaging:SysVInitScript
15:52:01 <spot> abadger1999: *nod*
15:52:32 <tibbs|h> Are the regular systemd packaging guidelines written up yet?
15:52:42 <spot> tibbs|h: no, but i will write them both up today
15:52:45 <tibbs|h> OK.
15:52:47 <spot> right after this meeting
15:53:10 <spot> #topic %find_lang for packages that are dumb - https://fedorahosted.org/fpc/ticket/79
15:53:34 <spot> So, i have a package that is dumb, but uses locales.
15:53:47 <tibbs|h> Oh, you too?
15:53:50 <spot> IMHO, if %find_lang doesn't work, you need to %lang tag the files manually.
15:53:54 <spot> yes, it is a pain.
15:54:04 <tibbs|h> I do not see the benefit, honestly.
15:54:32 <tibbs|h> But if someone can actually figure out how to do that for django, I'd live to see it.
15:54:36 <abadger1999> Alternative is to patch the code to find the lang files under /usr/share/locale
15:54:44 <spot> its the same benefit of enabling %find_lang, either we care about permitting people to drop locale specific files they don't care about or we don't.
15:54:52 <abadger1999> which notting told me was preferable at one point.
15:54:58 <abadger1999> I don't remember the rationale though.
15:55:07 <tibbs|h> Well, there's the question of whether the code actually works with lang files not installed.
15:55:46 <spot> tibbs|h: hold your nose.
15:55:48 <spot> http://pkgs.fedoraproject.org/gitweb/?p=gambas2.git;a=blob;f=gambas2.spec;h=e20cf683988697403eb851e8cc8b31b83309958a;hb=HEAD
15:56:37 <spot> or, perhaps less horrifying: http://pkgs.fedoraproject.org/gitweb/?p=R.git;a=blob;f=R.spec;h=66f6c92c1320a0d2d2bdbe6d188b3fc11adbe508;hb=89573dec366780575a6034a154a03f904305b987
15:57:34 <tibbs|h> I just don't see the benefit versus the unmaintainability of that approach.
15:57:45 <spot> well, its not unmaintainable.
15:57:56 <tibbs|h> It gets that way the more files you have.
15:58:46 <spot> %find_lang isn't very bright. someone could probably either improve it or write a better one for specific cases like django
15:59:02 <geppetto> spot: So … what does marking files %lang do, rpm wise?
15:59:51 <tibbs|h> django puts the lang files in with the python files for each application.
16:00:11 <abadger1999> It allows the sys admin to exclude languages from installation.
16:00:17 <abadger1999> geppetto: ^
16:00:24 <spot> abadger1999: yes, but how?
16:00:35 <tibbs|h> And the django package has over 6000 files.
16:00:38 * spot wonders if modern rpm even supports that
16:00:45 <tibbs|h> That's an awfully long files list.
16:00:56 <spot> tibbs|h: they're not broken out by dir?
16:00:57 <tibbs|h> find_lang makes it easy to not include the directories you shouldn't include.
16:01:10 <geppetto> abadger1999: --excludedocs is barely usable/supported … I don't see a --excludelang or anything
16:01:22 <tibbs|h> spot: There's not one directory containing the lang files, no.
16:01:25 <geppetto> And the text at: http://fedoraproject.org/wiki/PackagingGuidelines#Why_do_we_need_to_use_.25find_lang.3F … doesn't say anything about that ability
16:01:32 <abadger1999> geppetto: It's a configuration file option, I don't think there's a command line switch
16:01:56 <geppetto> Ahh … %_install_langs … hmm
16:02:32 <tibbs|h> Honestly I think that find_lang is fine and should be used for packages that put their lang files in the usual place.
16:02:40 <abadger1999> spot: repoquery -ql Django |grep locale
16:03:37 <tibbs|h> But for other packages, it doesn't help at all, so our guideline that mandates its use is broken.
16:03:51 <tibbs|h> Does it even find lang files outside of /usr/share/locale?
16:04:04 <spot> yes
16:04:24 <spot> find_lang.sh is a fun mess of regex
16:04:25 <tibbs|h> Where does it look?  Anywhere?
16:04:48 <tibbs|h> Does it exclude the directories when it looks outside of /usr/share/locale?
16:04:54 <tibbs|h> Because if it does, then it's completely useless.
16:05:08 <tibbs|h> You have to go back in with a bunch of %dir whatever in your %files list.
16:05:29 <tibbs|h> Or you live with huge numbers of "file listed twice" complaints.
16:05:51 <spot> find-lang.sh is 12 year old shell script
16:06:03 <spot> it predates my involvement at that level
16:06:27 <racor> ... or you generate *.lang replacement files from inside of a custom scripts inside of the spec
16:06:32 <tibbs|h> Anyway, I tried for a couple of days to make a spec that properly %lang-tagged Django and had no file-listed-twice complaints, but it wasn't easy.
16:07:01 <tibbs|h> racor: I tried, but it gets really difficult because rpm post-processing generates more files (.pyc).
16:07:38 <geppetto> tibbs|h: But your problem is that the "lang" files are actually .py files, yeh?
16:07:41 <spot> tibbs|h: my sed-fu is not strong enough to really understand what find-lang.sh is doing
16:07:46 <tibbs|h> No, they're .mo files.
16:07:52 <racor> tibbs|h: Dunno about python, but I used this approach with non-python packages.
16:07:54 <geppetto> Oh, ok
16:08:04 <spot> tibbs|h: i suspect there is a way to trick find-lang.sh into working on django
16:08:39 <tibbs|h> Here's one django app in its installed state: http://fpaste.org/hg72/
16:09:35 <spot> possibly setting TOP_DIR to %{buildroot}%{python_sitelib}/django
16:10:06 <tibbs|h> Anyway, brainstorming over how to make django work wasn't really the intent of filing that ticket.
16:10:15 <tibbs|h> The problem is that %find_lang itself does not work.
16:10:27 <tibbs|h> So our mandating that it be used isn't the right thing to do.
16:10:44 <tibbs|h> I mean, to satisfy the guideline you could call it but not use the list it produces.
16:11:11 <tibbs|h> And I'm not sure that we actually have a guideline requiring that things be properly %lang-tagged.
16:11:16 <tibbs|h> Just that you use %find_lang.
16:11:20 <spot> my instinct is to say that the package should either manually %lang tag (either via a script or via human) or fix find_lang to handle the case.
16:11:32 <geppetto> I'd guess that's implied though, by the %find_lang text
16:11:47 <tibbs|h> I wouldn't guess.
16:11:51 <tibbs|h> But I'm not a lawyer.
16:11:54 <geppetto> fair enough :)
16:12:06 <tibbs|h> And fixing find_lang.sh goes back to us not being able to fix rpm.
16:12:22 <geppetto> that's not really true anymore
16:12:26 * spot isn't sure why find_lang doesn't work though
16:12:41 <spot> the django structure is pretty sane, just tiered out
16:12:53 <spot> and find-lang.sh doesn't have /usr/share/locale hardcoded in it
16:12:57 <tibbs|h> find_lang doesn't do directories.
16:13:05 <spot> i think it does
16:13:13 <tibbs|h> Because in the /usr/share/locale case, you aren't supposed to own the directories, just the files in them.
16:13:22 <spot> oh, i see
16:13:29 <spot> you mean directory ownership
16:13:42 <tibbs|h> #  Packages that use %{_datadir}/* to grab all the locale files in one line also grab ownership of the locale directories, which is not permitted.
16:13:47 <spot> i don't think i lose sleep over lang tagging directories as opposed to the .mo
16:15:06 <tibbs|h> I guess I'll experiment more.
16:15:13 <spot> tibbs|h: i think if you pass --all-name to find-lang.sh
16:15:16 <abadger1999> spot: I think that tibbs|h is saying that the directories won't be owned if %find_lang is used.
16:15:18 <spot> it will "just work"
16:15:32 <spot> you'll have to manually invoke it as opposed to calling %find_lang
16:16:07 <tibbs|h> That script is so horrible.
16:16:13 <spot> tibbs|h: yes. yes it is.
16:17:00 <tibbs|h> Anyway, I'll mess with it more.
16:17:03 <spot> ok
16:17:10 <spot> i don't see any other items for today
16:17:20 <spot> (I still havent talked to upstream Perl)
16:17:45 <spot> #topic Open Floor
16:17:53 <tibbs|h> Nothing from me.
16:17:56 <limburgher> ditto
16:19:10 <spot> alright then. thanks everyone.
16:19:14 <spot> #endmeeting