15:17:04 <abadger1999> #startmeeting fpc
15:17:04 <zodbot> Meeting started Wed May 25 15:17:04 2011 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:17:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:17:20 <abadger1999> #meetingname fpc
15:17:20 <zodbot> The meeting name has been set to 'fpc'
15:18:10 <abadger1999> #addchair limburgher tibbs_ racor SmootherFrOgZ
15:18:55 <tibbs> Ah.
15:18:57 <abadger1999> #addchair tibbs
15:19:08 <abadger1999> If we're all really here we have quorum.
15:19:20 <limburgher> i am
15:19:25 <tibbs> Sorry, I'm running really late today.
15:19:39 <abadger1999> #addchair rdieter
15:19:57 <rdieter> oh hello
15:20:06 <abadger1999> racor, SmootherFrOgZ: You guys around?
15:20:15 <abadger1999> We only have a few items that I see ready in trac.
15:20:15 <tibbs> Looks like I didn't miss anything.
15:20:46 <abadger1999> yeah, without spot, we spent a bit of time figuring out what to do :-)
15:20:58 <tibbs> If it's any of my stuff, I need to make sure it's set as not ready because I've barely had time to process SCM requests.
15:22:02 <racor> yep, ... lurking
15:22:36 <abadger1999> Well, that's five.
15:23:07 <abadger1999> #topic https://fedorahosted.org/fpc/ticket/85
15:23:38 <abadger1999> This is a small change to the systemd guidelines to add compat symlinks when changing the service name between sysvinit scripts and systemd unit files.
15:24:01 <limburgher> For things like httpd, named, etc?
15:24:11 <abadger1999> That way service httpd start would continue to work even though the srvice file is renamed to apache-httpd.service.
15:24:16 <limburgher> It looks reasonable.
15:24:16 <abadger1999> Correct.
15:24:29 <limburgher> How long do we keep the symlinks?
15:24:34 <tibbs> So systemd doesn't have any issues with having two names for one service?
15:25:14 <abadger1999> tibbs: according to notting, systemd will handle it fine.
15:26:38 <abadger1999> limburgher: I was going to leave how long up to maintainer discretion.
15:27:11 <limburgher> abadger1999: Reasonable.  I would imagine at least one RHEL release, but I see no issue with forever.
15:27:44 <abadger1999> <nod>
15:28:55 <tibbs> I just tested it.
15:29:18 <tibbs> It appears to work OK; when you query the symlinked name, systemd just treats it as an alias.
15:29:40 <limburgher> Exactly like I would expect.  Nice.
15:29:47 <tibbs> Well, not completely.
15:29:50 <tibbs> It must be a symlink.
15:29:58 <tibbs> hard links seem to confuse it.
15:30:03 <notting> tibbs: i think that's reasonable
15:30:18 <notting> (to document to use symlinks)
15:30:33 <tibbs> Yes, just making sure the draft is clear that symlinks must be used.
15:30:35 <tibbs> Which it is.
15:31:45 <tibbs> Anyway, this appears to be reasonable to me and in line with our general "follow upstream when whenever possible" rule.
15:32:03 <limburgher> tibbs: Even moreso than status quo.
15:33:40 <abadger1999> Shall we vote?
15:33:46 <limburgher> I think.
15:33:47 <tibbs> +1
15:33:51 <abadger1999> +1
15:34:14 <limburgher> +1
15:35:25 <abadger1999> rdieter, racor: have votes to cast?
15:35:31 <rdieter> +1
15:35:40 <rdieter> (sorry, I'll have to go afk for a bit)
15:35:48 <abadger1999> <nod>
15:36:14 <racor> -1
15:36:23 <racor> sorry typo: +1
15:36:40 <limburgher> That's like the worst possible typo in that context. :)
15:37:59 <geppetto> sorry I'm late … I guess +1 … although it might be nice to say something about the package name => unit name mapping?
15:38:03 <racor> yeah, I meant +1, but was using the keypad ...
15:38:41 <limburgher> geppetto: What do you have in mind?
15:39:08 <abadger1999> <nod>
15:39:38 <geppetto> Just it'd be nice to if you installed the package "foobar" and the service was called "foobar" and not "foobar-almost" or whatever
15:40:00 <limburgher> Should we make a matching symlink mandatory?
15:40:29 <limburgher> What about virtual provides?  Like httpd, webserver?  #spitballing
15:40:43 <limburgher> Probably messy.  #nm
15:40:59 <geppetto> Having a "httpd" unit is just going to create a war over what it refers to
15:41:32 <abadger1999> yeah -- you'd need to use alternatives or something to control the virtual provides.
15:41:35 <limburgher> So would be then have to rename httpd to apache?
15:41:43 <limburgher> ick.
15:42:27 <abadger1999> I don't think we demand that the package name and service name match presently.
15:42:29 <geppetto> Well in the case of httpd, I don't mind them having a symlink to match the package name … but I thought we were supposed to have renamed the package like 10 years ago :)
15:42:49 <geppetto> abadger1999: we don't … but whenever they don't match I want to hurt someone :)
15:42:57 <abadger1999> :-)
15:43:02 <limburgher> <sigh>
15:43:09 <limburgher> I totally get that.  Sadly.
15:43:35 <abadger1999> geppetto: How about we make a separate proposal to get that changed?  I need to think about it more.
15:43:43 <geppetto> sure, no problem
15:43:49 <abadger1999> Cool.
15:43:57 <geppetto> as you said, it's no different than now
15:44:03 <limburgher> Good idea, there's nothing in this that precludes that later.
15:45:02 <abadger1999> #agreed systemd symlink compat passes (+1: +5, +0: 0, -1: 0)
15:45:14 <abadger1999> #topic Open Floor
15:45:23 <abadger1999> I don't see any more tickets that are ready.
15:45:33 <abadger1999> Anyone have anything else they want to discuss?
15:45:46 <abadger1999> or point to a ticket that I missed?
15:47:37 <tibbs> Nothing from me.
15:48:03 <abadger1999> Okay, I'll close the meeting in 60
15:48:35 <abadger1999> 30
15:48:58 <limburgher> No, but one OT item.
15:49:32 <limburgher> notting, tibbs: How to I get an invite to cvsadmin?  I'm willing to pitch in, if that's feasible.
15:50:31 <tibbs> Honestly I don't know.
15:50:38 <tibbs> .members cvsadmin
15:50:38 * abadger1999 closes meeting and then goes on with the cvsadmin discussion
15:50:38 <zodbot> tibbs: Members of cvsadmin: ausil huzaifas @jkeating jwboyer kevin lmacken mikeb @mmcgrath @notting petersen spot tibbs toshio @wtogami
15:50:40 <abadger1999> #endmeeting