15:13:21 <abadger1999> #startmeeting fpc
15:13:21 <zodbot> Meeting started Wed Jun 22 15:13:21 2011 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:13:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:13:26 <abadger1999> #meetingname fpc
15:13:26 <zodbot> The meeting name has been set to 'fpc'
15:13:38 <tibbs|h> I'm in and out.
15:13:43 <abadger1999> #chair tibbs|h spot rdieter_work geppetto limburgher
15:13:43 <zodbot> Current chairs: abadger1999 geppetto limburgher rdieter_work spot tibbs|h
15:13:52 <tibbs|h> It's only six pieces of furniture so it will all be in soon.
15:13:59 <abadger1999> Cool.
15:14:08 <abadger1999> #topic gnome shell extension naming
15:14:14 <abadger1999> http://lists.fedoraproject.org/pipermail/packaging/2011-June/007816.html
15:14:49 <limburgher> So it's basically "s" vs. "no s"?
15:14:54 <abadger1999> Right.
15:15:46 <tibbs|h> Flip a coin.  As long as there's consistency, I can't imagine that it matters.
15:15:57 <abadger1999> I'm okay with just saying no "s" since bob  has some reason for that and put it on http://fedoraproject.org/wiki/Packaging:NamingGuidelines as another Addon Package Section.
15:16:45 <geppetto> yeh, I don't think we want multiple plugins in a package as a rule … and most other packaging for plugins use "no s" for the same reason
15:16:46 <EvilBob> Can I comment?
15:17:25 <rdieter_work> EvilBob: go ahead
15:17:38 <EvilBob> Yeah the idea was that someone could create a meta package pulling in a number of extensions as a group
15:18:13 <EvilBob> say all the "gnome-shell-extensions" git repo extensions
15:19:13 <EvilBob> or for me... gnome-shell-extensions-theevilcollection
15:19:18 <EvilBob> ;)
15:19:19 <tibbs|h> OK, back.
15:19:36 <limburgher> Hmmm.
15:19:48 * abadger1999 notes that that package is apparently already in Fedora and because they subpackage from that, it's the source of some of the  gnome-shell-extensions-foo packages
15:19:48 <geppetto> EvilBob: Will people really want to install a large random collection of them though?
15:19:56 <rdieter_work> otoh, do we really need -extension in there at all.  gnome-shell-<addon> may work too, and is shorter
15:20:15 <limburgher> gepetto:  I'd rather cherry-pick.  Sort of the point.  Customize.
15:20:35 <limburgher> rdieter_work: I think we do, for clarity.
15:20:56 <rdieter_work> ok
15:21:03 <EvilBob> geppetto: if it's well documented... sure most of us would not but some end users might like a simple package
15:21:19 <geppetto> Yeh, me too … I've installed a few extensions … but I wanted to know what they all did
15:21:40 * rdieter_work doesn't care what metapackages are called, though using those are generally a workaround for difficiencies elsewhere
15:21:42 <EvilBob> geppetto: I have some installed I am still not sure what they do, if anything
15:22:06 <rdieter_work> so, +1 for standardizing on gnome-shell-extension-*
15:22:15 <geppetto> +1
15:22:23 <limburgher> +1
15:22:29 <tibbs|h> +1
15:22:55 <EvilBob> +1 if my vote counts
15:23:03 <rdieter_work> (grandfather an exception for the existing subpkgs of gnome-shell-extensions, in case there's any confusion or ambiguity)
15:23:08 <EvilBob> Thanks for taking the time to talk about it
15:23:44 <rdieter_work> EvilBob: thanks for bringing itup
15:23:48 <limburgher> NP, better now than 4 releases from now when there's a mess to clean up.
15:23:56 <EvilBob> rdieter_work: they are "subpackages" from a repo so they continue to be named "incorrectly"?
15:24:00 <abadger1999> +1
15:24:34 <rdieter_work> well, we can debate the exception separately, if folks disagree
15:24:52 <tibbs|h> We don't generally pass ex post facto guidelines.
15:25:28 <abadger1999> with naming changes we generally grandfather.
15:25:33 <tibbs|h> But I'm sure someone who really cares could ask maintainers existing stuff with the other name to rename.
15:25:47 <EvilBob> IC
15:26:06 <tibbs|h> Renaming should be pretty trivial for packages which were just accepted.
15:26:12 <limburgher> tibbs|h: I can't imagine there are a ton.
15:26:34 <limburgher> What if as a special one-time incentive we don't make them re-review?
15:26:40 <limburgher> Just tossing that out there.
15:26:45 <limburgher> Not sure I like it.
15:26:56 <abadger1999> limburgher: Well -- they wouldn't even need a re-review probably
15:27:04 <abadger1999> since it's all subpackage naming.
15:27:09 <tibbs|h> True.
15:27:20 <limburgher> Oh, right, duh.  NM. E_COFFEE_FAIL
15:27:31 <abadger1999> hah --- they have a gnome-shell-extensions-common subpackage and no gnome-shell-extensions package.
15:27:46 <EvilBob> Would new packages coming from the same git repo be also exempt?
15:28:09 <tibbs|h> New packages should match the guidelines in place.
15:28:15 <limburgher> Why?  Why not just name them correctly?
15:28:48 <EvilBob> limburgher: Just checking for a "confusion point" argument for changing existing packages
15:29:15 <abadger1999> Yeah, new packages -- I think we should ask the maintainers of gnome-shell-extensions to rename their subpackages.... b/c I think they'll continue to name newly added subpackages with gnome-shell-extensions-* unless we do.
15:29:58 <limburgher> EvilBob:  If we get the guidline out there, announce, maybe comment on review bugs, and file rename bugs, I can't see where there'd me too much confusion.
15:30:10 <abadger1999> We want to let them know explicitly that the fact that its an addon overrides the fact that it's  a subpackage.
15:30:11 <limburgher> s/guidline/guideline/
15:30:21 <EvilBob> the whole "sub-package" idea is a bit unclear to me, I have not seen a gnome-shell-extensions package that these are split from.
15:30:43 <abadger1999> fedpkg clone gnome-shell-extensions
15:31:45 <abadger1999> that's the particular package that I'm looking at.  If there's other people packaging single extensions=>single packages, they can grandfather but any new srpms to be reviewed should correctly name without the "s".
15:31:54 <EvilBob> I'll back out, I know you guys will do what is best
15:33:52 <limburgher> I guess I'm wondering why we should grandfather.
15:34:10 <abadger1999> alright to wrap this up -- do other people agree that the addon guidelines should override the subpackage guideline in terms of naming?  So future subpackages of gnome-shell-extensions should be gnome-shell-extension-foo ?
15:35:24 <limburgher> +1
15:36:11 <geppetto> yeh, +1
15:36:17 <tibbs|h> Bottom line is that I just don't care either way as long as our users can depend on some sort of consistent naming going forward.
15:37:07 <tibbs|h> I guess that means +1.
15:39:20 <abadger1999> hehe :-) Well, I'll do this then  -- I'll file a bug against gnome-shell-extensions to say that the FPC wants the addon guideline to override the subpackage guideline for naming purposes.  Future subpackages of their package must use gnome-shell-extension ; we'd like but don't require that they rename the current subpackages to gnome-shell-extension-foo as well.
15:39:46 <abadger1999> #action abadger1999 to file bug against gnome-shell-extensions package
15:39:58 * EvilBob smiles
15:40:05 <EvilBob> thanks again
15:40:17 <abadger1999> #action Approved "gnome-shell-extension" naming (+1: 5, +0: 0, -1: 0)
15:40:52 <abadger1999> #topic helper script location
15:40:54 <abadger1999> http://fedoraproject.org/wiki/Packaging:NamingGuidelines
15:40:57 <abadger1999> err...
15:41:01 <abadger1999> http://lists.fedoraproject.org/pipermail/devel/2011-June/152276.html
15:41:15 <tibbs|h> Ugh.
15:41:24 <abadger1999> So there's a few different places helper scripts could go (since they're noarch)
15:41:57 <abadger1999> %{_datadir}/programname/  %{_libexecdir}/programname/  %{_libdir}/programname {%_prefix}/lib/programname
15:42:16 <tibbs|h> If FHS has no preference, go with upstream's preference?
15:42:32 <tibbs|h> That at least requires no patching as long as their preference is sane.
15:42:49 <abadger1999> FHS excluded libexecdir but we say to use libexecdir for things that are functionally equivalent but arch-dependent.
15:43:13 <tibbs|h> I think we say you can use libexec, not that you must.
15:43:20 <limburgher> Then we just list those options and say use upstream's choice, if not pick one of these.  If so, do we express a preference order?
15:43:31 <limburgher> Maybe libexec is top of the list?
15:43:37 <abadger1999> GNU coding standards directly say that /usr/lib (and likely %{_libexecdir} by extension) are not to be used for this purpose.
15:43:48 <tibbs|h> Hmm.  The guideline is sort of inconsistent.
15:44:35 <tibbs|h> First it says packages "can" put things there, then it says it "should" be used for "executable programs that are designed primarily to be run by other programs rather than by users".
15:44:55 <tibbs|h> Depending on how you interpret that, the answer to this question is already there.
15:45:06 <tibbs|h> But... meh.
15:45:26 <abadger1999> yeah.
15:45:36 <tibbs|h> "should only be used" would be clear (to me at least).
15:46:05 <tibbs|h> But "should be used" sounds like a mandate.
15:46:23 <tibbs|h> I think that guideline predates me, so I can't say what the original intent was.
15:48:13 <abadger1999> Yeah, I think that "should only" is the intent.
15:49:20 <tibbs|h> If that's the intent, then the original question remains.
15:49:40 <tibbs|h> And honestly, I think this is another "stick with upstream" thing.
15:49:42 <abadger1999> Alright -- so sounds like there's agreement that we're not as clear as we could be here and that we want to let packagers choose where to put the files as long as it makes sense.
15:50:07 <tibbs|h> Personally I prefer libexec if I have to pick, but that may be due to decades of having it there.
15:50:07 <abadger1999> I'll write up a draft and ticket it for the next meeting.
15:50:12 <abadger1999> <nod>
15:51:45 <tibbs|h> Sometimes I wonder if we could start afresh but tried to make things look like Unix, what would the result look like?
15:51:56 <abadger1999> #action abadger1999 to write up a draft to clarify the libexecdir section of the guidelines
15:52:00 <tibbs|h> I.e. not like whatever apple's "I love to type big pathnames" looks like.
15:52:15 <abadger1999> Yeah.
15:52:18 * SmootherFrOgZ here now
15:52:31 <abadger1999> #chair SmootherFrOgZ
15:52:31 <zodbot> Current chairs: SmootherFrOgZ abadger1999 geppetto limburgher rdieter_work spot tibbs|h
15:53:01 <abadger1999> Okay... I'll just summarize what I'm going to reply to Ville's message
15:53:05 <abadger1999> #topic systemd scriptlets
15:53:21 <abadger1999> http://lists.fedoraproject.org/pipermail/packaging/2011-June/007812.html
15:53:28 <abadger1999> So #1 is the big change he's proposing
15:53:44 <abadger1999> We discussed doing it that way when we designed the scriptlets
15:54:07 <abadger1999> and I believe the blocker was that people might install the sysv init script in a subpackage.
15:54:21 <abadger1999> so we can't hinge on the existence of the sysvinit script.
15:54:36 <rdieter_work> that matches my recollection too
15:54:38 <abadger1999> I'll bring that up and we'll see where it goes.
15:55:10 <abadger1999> #topic Open Floor
15:55:12 <geppetto> yeh, there was a lot of talk at one point about people having both units and sysv files
15:55:14 * geppetto sighs
15:55:29 <abadger1999> Anyone have anything to bring up?
15:56:29 <SmootherFrOgZ> nope. get the last topic. will read log and poke at trac instance if so
15:56:33 <tibbs|h> I was wondering,
15:56:46 <tibbs|h> If anyone is familiar with how to get stuff out of githubm,
15:56:59 <tibbs|h> perhaps they could consider adding a bit to the SourceURL guideline.
15:57:20 <tibbs|h> I see several questions about the best way to get tarballs out of github.
15:57:33 <tibbs|h> I don't really know the answers, though.
15:57:45 * abadger1999 doesn't know either
15:58:31 <tibbs|h> Not a lot of new stuff uses sourceforge these days so we should try to document what things are using now if we can.
15:59:50 <tibbs|h> Finally, I'm thinking of putting what remains of my free time into getting the package review SIG actually going.  If anyone would like to help with that, please let me know.
16:00:27 <rbergeron> tibbs|h: is there a wiki page for it? /me goes to look
16:00:47 <limburgher> There was.  I think I'm on it.
16:00:49 <rbergeron> yeah.
16:00:51 <rbergeron> 2008 ;)
16:00:51 <tibbs|h> There is one I put together during the last abortive effort.
16:01:03 <tibbs|h> The wiki and I don't really get along.
16:01:06 <rbergeron> http://fedoraproject.org/wiki/SIGs/Package_Review
16:01:29 <tibbs|h> What I'm looking for is two or three people who can really get involved and take care of things during the times when I'm not able to be around.
16:01:44 <tibbs|h> I'm a really poor organizer and motivator.
16:01:54 <rbergeron> is the scope still more or less what you have written out here?
16:02:01 <tibbs|h> Pretty much, I guess.
16:02:14 * rbergeron notes she apologizes for just headbutting into meeting
16:02:15 <tibbs|h> I mean, I think tool development comes into it as well but starting small makes sense.
16:02:24 * rbergeron nods
16:02:47 <tibbs|h> Anyway, I've wanted to do this for a very long time but I just don't have the ability to get it going by myself.
16:03:06 <tibbs|h> And package reviewing goes hand in hand with FPC stuff, so I'm hoping to get at least one other FPC person interested.
16:03:16 * abadger1999 loves when rbergeron butts into meetings
16:03:31 <rbergeron> yeah, I've always thought it would be great if there was something that could pair people up with similar types of review / packaging needs, or helpers with people needing help. anyway, i can barely package a box, but I'm happy to help out with the advertising/motivating end of things, if you want. ;)
16:03:37 <rbergeron> abadger1999: don't lie ;)
16:03:38 <abadger1999> It's like getting a surprise phone call from your favorite aunt.
16:04:06 <rbergeron> lol
16:04:21 <rbergeron> (the favorite aunt is usually the batty insane aunt, amirite?)
16:04:26 <tibbs|h> Anyway, that's all from me.
16:04:31 <rbergeron> tibbs|h: mailing list, or just sticking to fpc list for talk on it?
16:04:43 <tibbs|h> Or personal email; no big deal to me.
16:04:50 <rbergeron> or even devel
16:04:51 <rbergeron> okay
16:04:54 <rbergeron> sounds good
16:04:56 <tibbs|h> But given the state of -devel these days, I find it hard to keep up.
16:05:37 <limburgher> Yeah.
16:05:54 <limburgher> I might be willing to help with reviewsig, but I'm not much of a wrangler either.
16:07:25 <tibbs|h> That sums up my problem pretty well.
16:07:55 <tibbs|h> Anyway, I'll just try again and if the help appears then great; if not then it won't end up much worse than it is now.
16:09:20 <rbergeron> cool.
16:09:44 * rbergeron can pitch in and make noise, if nothing else. my pom-poms are shiny with glitter.
16:10:19 <rbergeron> i'll send you mail ;)
16:10:23 <limburgher> rbergeron:  Maybe brainstorm a list of things rhyming with "package review"
16:11:06 <pingou> beer brew
16:11:26 <rbergeron> aw, man. and here i was thinking "leveraging synergistic encapsulation opportunities"
16:11:44 <limburgher> maybe it's just not one of your core competancies.
16:12:45 <limburgher> cockatoo
16:13:04 <limburgher> toto too
16:13:18 <limburgher> kinkajou
16:13:26 <abadger1999> Okay, with that, I'll close the meeting in a minute unless someone brings up a new topic :-)
16:13:29 <limburgher> (potential mascot?)
16:14:27 <abadger1999> #endmeeting