15:03:26 <spot> #startmeeting Fedora Packaging Committee
15:03:26 <zodbot> Meeting started Wed Aug 17 15:03:26 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:32 <spot> #meetingname fpc
15:03:32 <zodbot> The meeting name has been set to 'fpc'
15:03:42 * spot is in Vancouver, not quite used to the time difference
15:03:55 <spot> #topic Roll Call
15:04:28 * abadger1999 here
15:04:46 * limburgher bang
15:04:51 * limburgher whooooosh
15:04:55 * limburgher cracke
15:04:57 <limburgher> l
15:05:18 <abadger1999> :-)
15:06:01 * geppetto is here
15:06:26 <spot> rdieter, SmootherFrOgZ, tibbs|h: ping?
15:06:58 * Rathann is semi-afk due to other issues
15:08:10 <spot> okay, well, that's barely quorum
15:08:22 <rdieter> here
15:08:30 <spot> #topic Explicit requires, rpm extraction, and updates - https://fedorahosted.org/fpc/ticket/102
15:10:10 <limburgher> So. . . I'm turned around.  Are we contemplating a guideline change as a temp fix until the tool change is done?
15:10:13 <spot> the only thing that I might like to see in that draft is a section on how to enable the magic that allows the ABI symbols to a library to get detected by RPM and added as provides
15:10:24 <spot> limburgher: yes, i believe so
15:10:38 <limburgher> spot: K.  Is there a timeline on the tool change?
15:10:45 <geppetto> spot: You mean symbol versioning?
15:10:50 <spot> geppetto: yes
15:10:51 <abadger1999> limburgher: with the one caveat that no one on devel list has said they've submited a bug.
15:11:05 <abadger1999> limburgher: which also means, no timeline for a tool change.
15:11:15 <abadger1999> or even... if a tool change will be accepted.
15:11:32 <limburgher> spot, abadger1999: So it's temporary for potentially large values of temporary? :)
15:11:36 <spot> i can ask for some attention to be put on this issue, but there is no guarantee
15:11:39 <abadger1999> yeah
15:11:56 <geppetto> What is the proposed "fix"?
15:13:01 <abadger1999> geppetto: From simo and mjg59 's emails, I think they want rpm to add versioned dependencies on libraries/library packages instead of/in addition to SONAMEs.
15:13:04 <spot> geppetto: i'm not sure, tbh. the proposal of having the dep include the full NEVR isn't right, because there are plenty of cases where you don't want that behavior.
15:13:13 <abadger1999> s/rpm/rpmbuild/
15:13:23 <spot> the only reason debian does it that way is because it has no concept of file deps
15:13:40 <limburgher> I'd think it would be good to have that capability but not require it, but I'm still mulling that.
15:13:47 <geppetto> yeh … a few years ago I suggest rpmbuild count the symbols … and make that a version of the implicit SO
15:14:10 <geppetto> So rpmbuild would auto do: Requires: libfoo.so.1 >= 42 … or whatever
15:14:16 <geppetto> I _think_ that would work
15:14:16 <Rathann> geppetto: just counting isn't enough
15:14:34 <geppetto> Rathann: Yes, it is … because you can never remove a symbol without bumping the major version
15:14:38 <Rathann> some libs delete symbols that are not in the public api between versions
15:14:45 <spot> honestly, my instinct says that the symbol versioning provides actually being used is probably the cleanest way
15:14:52 <limburgher> geppetto:  Can never?  Or should never? :)
15:14:57 <abadger1999> foo is linked to the library in the libfoo package.  So instead of rpm putting in a dep for libfoo.so.1(x86_64) it makes an automatic dep for  libfoo >= 1.0.1-1
15:15:13 <geppetto> limburgher: Well … if they do, it's not rpm's fault when the world breaks … how about that :)
15:15:30 <abadger1999> heh :-)
15:15:35 <geppetto> abadger1999: Yeh, we could change to .dpkg's at the same time :)
15:15:57 <abadger1999> I thought everyone was moving to conary?
15:16:06 <geppetto> meh … I'm good with just the wording change … +1
15:16:14 * spot is fine with this change for now
15:16:17 <spot> +1
15:16:27 <spot> and i will follow up with the rpm team and see what they think
15:16:35 <Rathann> I'm against blanket approval of manual explicit deps
15:16:48 <Rathann> what's the final wording of the proposal?
15:16:51 <geppetto> are they disallowed now?
15:16:58 <limburgher> geppetto: :)
15:17:13 <spot> Rathann: everything from "Here's a proposed change:" down, minus the strike-through bits
15:17:18 <abadger1999> Rathann: It's in https://fedorahosted.org/fpc/ticket/102
15:17:20 <Rathann> geppetto: they are not encouraged and need a comment in the spec
15:17:54 <spot> Rathann: they are still discouraged in this draft, if anything, there is more detail to explain the exception case
15:18:00 <abadger1999> Rathann: I included the strikethroughs because what's removed gives an idea of how the guideline is changing.
15:18:25 <Rathann> yeah, I'm against removing the first strikethrough part
15:18:44 <abadger1999> I don't htink it can be clear without the strikethrough part being modified.
15:19:00 <spot> the first strike through sentence could probably be retained
15:19:09 <spot> "Packages must not contain explicit Requires on libraries except when absolutely necessary."
15:19:41 <Rathann> I don't see the reason for removing the rest of the first part
15:20:10 <abadger1999> The only two lines that are actually removed (not relocated to later) are:  Packages must not contain explicit Requires on libraries except when absolutely necessary
15:20:10 <spot> Rathann: the other sentences just got moved down to the bottom of the draft, see the example block
15:20:23 <abadger1999> and "Explicit dependencies on specific package names may aid the inexperienced user, who attempts at installing RPM packages manually"
15:20:51 <spot> abadger1999: that second sentence just isn't very useful. if anything, it seems to encourage explicit requires
15:20:56 <abadger1999> I'm not liking the wording of that line.... "absolutely necessary" in particular.
15:21:03 <abadger1999> yeah.
15:21:15 <abadger1999> It wasn't very informative at all so I removed it.
15:22:27 <spot> abadger1999: i'm on the fence on the first sentence. i think we do want to strongly discourage explicit requires with the notable exception of this documented case.
15:22:48 <Rathann> I agree with removing the "aid the inexperienced user" part, but not the rest
15:23:19 <Rathann> ah
15:23:20 <spot> Rathann: do you see where the other strike-through lines just got moved (except for the first sentence)?
15:23:22 <Rathann> moved down
15:23:25 <Rathann> ok
15:23:31 <Rathann> I didn't notice before
15:23:45 <Rathann> ok then
15:23:57 <spot> abadger1999: you use the wording "When explicit library Requires are necessary" in the draft
15:24:24 <spot> that seems to fit in cleanly with the first sentence as is
15:24:36 <abadger1999> I'd be okay with "Packages must not contain unnecessary explicit Requires on libraries."
15:24:39 <abadger1999> for instance.
15:24:58 <spot> yeah, i'd be okay with that.
15:25:25 <limburgher> Right, as long as there's some discussion of necessary==??
15:25:50 <abadger1999> "absolutely necessary" makes it seem like its an extraordinary event that you'd use it in... but this case seems a little too common to keep that.
15:26:09 <tibbs> Ugh, I got stuck in traffic.
15:27:20 <abadger1999> Okay, so the revision would be: Explicit Requires are Requires added manually by the packager in the spec file. Packages must not contain unnecessary explicit Requires on libraries. [and then continue with what's drafted from there]
15:27:42 <limburgher> Well, it should be extraordinary, as well as possibly an impetus to fix the larger issue in that or another RPM,
15:29:18 <abadger1999> limburgher: It can''t be fixed on the packager level beyond adding the explicit require.
15:30:26 <limburgher> abadger1999: I guess I meant to include nagging upstream and/or other pacakgers as part of 'fix' :)
15:30:41 <abadger1999> limburgher: There's no fix there.
15:30:50 <abadger1999> upstream is doing the right thing.
15:30:56 <abadger1999> the other package is doing the right thing.
15:31:09 <limburgher> in this case or all cases of explicit requires?
15:31:18 <abadger1999> In this case.
15:31:33 <abadger1999> which seems to be a fairly common (currently largely ignored) case.
15:31:41 <limburgher> ah, IC, i meant generally.  Yes, here's correct.
15:32:05 <spot> So, I'm +1 with the Packages must not contain unnecessary explicit Requires on libraries. addition.
15:32:43 <abadger1999> +1 as well
15:32:53 <limburgher> +1
15:33:03 <geppetto> +1
15:33:41 <tibbs> Just to be clear, this restores the first bit of struck out text in the proposed change in the ticket?
15:33:53 <abadger1999> tibbs: First bit, slightly modified.
15:34:00 <spot> tibbs: it replaces the first bit with "Packages must not contain unnecessary explicit Requires on libraries."
15:34:01 <tibbs> And adds "unnecessary".
15:34:14 <tibbs> OK, seems good.
15:34:15 <tibbs> +1
15:34:35 <spot> Rathann, rdieter: would you like to vote on the record?
15:34:37 <Rathann> +1
15:34:52 <tibbs> Though this whole thing leaves me wanting to dig up the reasons why we disallowed the explicit requires in the first place.
15:35:22 <spot> tibbs: honestly, iirc, it was to prevent stupidity like "Requires: glibc, kernel"
15:35:34 <limburgher> LOL
15:35:59 <spot> but this section is rather old and my memory ain't what it used to be
15:36:02 <tibbs> I think the argument was "rpm does a good enough job most of the time; just trust it".
15:36:14 <tibbs> Except, of course, when it doesn't go a good enough job.
15:36:15 <limburgher> My favorite I've ever seen (not in Fedora) was Requires: kernel >= 2.2
15:36:52 <abadger1999> tibbs: That's my recollection too.
15:37:07 <limburgher> tibbs: At least it's gradually getting better.
15:37:13 <spot> #action Draft with " Packages must not contain unnecessary explicit Requires on libraries." first strike through replacement approved (+1:6, 0:0, -1:0)
15:37:58 <spot> #topic Open Floor
15:38:50 <limburgher> If I can get a few minutes to rub together this weekend I should have my bundling exception ready for discussion next week.  I've got word back from upstream, I just haven't written it up yet.
15:39:43 <spot> mmkay
15:43:05 <tibbs> I have nothing.
15:43:41 <abadger1999> nothing from me
15:43:46 <limburgher> ditto
15:44:00 <spot> okay, thanks everyone
15:44:02 <spot> #endmeeting