15:02:56 <spot> #startmeeting Fedora Packaging Committee
15:02:56 <zodbot> Meeting started Wed Oct 26 15:02:56 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:00 <spot> #meetingname fpc
15:03:00 <zodbot> The meeting name has been set to 'fpc'
15:03:21 <spot> #topic Roll Call
15:03:22 <tibbs|h> Just got called into work; I will miss most or all of the meeting.  Sorry; have to run now.
15:04:07 <spot> ping: abadger1999, geppetto, limburgher, racor, Rathann, rdieter, SmootherFrOgZ
15:04:27 * abadger1999 here
15:04:33 <rdieter> yo
15:04:50 <Rathann> I'm here, but I'm at work, so I might called away
15:05:00 <Rathann> *get called away
15:05:56 * racor is here
15:06:11 * geppetto is here
15:06:24 <spot> okay, that should be quorum
15:06:56 * SmootherFrOgZ is here
15:07:02 <spot> #topic Binutils library bundling - https://fedorahosted.org/fpc/ticket/109
15:07:21 <spot> As promised last week, lets take another pass on the binutils bundling issue.
15:07:59 <spot> Noteworthy is that gdb is already bundling a local copy of the binutils library, and has done so for some time now
15:09:17 * spot really hates trying to work through these nasty, long term, bundling situations
15:09:19 <geppetto> yeh, the weird binutils libs. have been weird for a _long_ time now … so I'm tempted to just give them a copylib exception, instead of trying to make anyone fix anything
15:09:30 <spot> geppetto: yeah, me too
15:09:33 <abadger1999> I think the root issue is that now, non-GNU projects want to use the libs
15:09:44 <abadger1999> and we need to determine what to do.
15:10:19 * abadger1999 can see that the GNU projects are special if they're all working on both the tool tree and the library tree.
15:11:28 <geppetto> So … which non-GNU projects
15:11:54 <abadger1999> but a third party coming in.... if they just want to consume the library, they aren't necessarily going to be as pro-active about porting to a new lib ver to get important fixes or capable of making the fixes on their own.
15:12:00 <spot> to be fair, the only items that seem to want the binutils libs right now are binutils, gdb, and insight
15:12:16 <spot> all of which are sourceware.org projects
15:12:17 <racor> spot: gcc ... uses libiberty
15:12:19 <geppetto> I'd be happy to say anything that is in the giant source tree of doom can copylib … but random packages, no.
15:12:28 <spot> racor: okay, and gcc, also sourceware.org
15:12:32 <abadger1999> ah, so insight is a GNU project?
15:12:39 <spot> abadger1999: sourceware.org
15:13:26 <racor> spot: is insight still alive? I thought it was dead
15:14:15 * limburgher here. . .-ish
15:14:27 * limburgher reading. . .
15:14:33 <spot> racor: no idea.
15:14:39 <spot> racor: someone packaged it
15:14:59 <racor> spot: OK, in this case, how about sourcenav?
15:15:16 <racor> rsp. snavigator?
15:15:43 <spot> racor: what is the relevance?
15:15:47 <racor> AFAICT, dead and gone from sourceware, but forked elsewhere
15:16:21 <abadger1999> racor: So, you're asking if it's okay for sourcenavigtor to bundle?
15:16:24 <racor> spot: it was part of the cygnus uberbaum (which is the actual origin of this issue)
15:17:40 <spot> racor: at a very quick glance, they don't seem to have bundled copies of the binutils libs
15:17:48 <spot> at least not in current svn
15:18:00 <racor> abadger1999: no, I am asking if snav is using these libs - I don't know about its current status
15:18:54 <spot> so, i think we can grant copylib status to gcc, gdb, and insight and if the problem becomes more pervasive, revisit it?
15:19:03 <limburgher> Probably.
15:19:05 <abadger1999> So... I'm pretty uncomfortable about a general copylibs exception for these libraries but I am okay with a specific exception when the same upstream org is originating them.
15:19:05 <spot> (for the binutils library)
15:19:28 <racor> snav, insight and gdb share a common history.
15:19:29 <geppetto> abadger1999: Yeh, so that's my feeling too
15:19:39 <abadger1999> question -- if insight is a gdb frontend, why do they need to bundle the same libs as gdb bundles?
15:19:45 * spot is fine with abadger1999's proposal
15:20:37 <spot> abadger1999: guessing, perhaps they swallow a forked gdb?
15:20:56 <abadger1999> bleagh.
15:20:57 <spot> as opposed to being a traditional front-end
15:21:10 <abadger1999> well, I guess  I can see that.
15:21:26 <abadger1999> but I'm looking cross-eyed
15:21:44 <spot> abadger1999: that usually happens to me whenever i try to use gdb. :)
15:22:25 <spot> Okay, so proposal: Projects from the same upstream source as binutils (sourceware.org) may treat the binutils libraries as copylibs.
15:23:06 <rdieter> +1
15:23:11 <spot> +1
15:23:24 <limburgher> +1
15:23:28 <SmootherFrOgZ> +1
15:23:37 <racor> +1
15:23:52 <Rathann> +1
15:24:16 <spot> abadger1999, i think you're the only missing voter.
15:24:30 <spot> oh, and geppetto;.
15:24:51 * spot really needs to teach the bot how to count votes
15:24:58 <abadger1999> +1
15:25:22 <geppetto> +1
15:25:32 <spot> #action Projects from the same upstream source as binutils (sourceware.org) may treat the binutils libraries as copylibs. (+1:8, 0:0, -1:0)
15:26:11 <spot> abadger1999: is there any update on the precompiled windows exec ticket?
15:26:17 <spot> (111)
15:26:28 <abadger1999> there is.
15:26:32 * abadger1999 figures out how to summarize
15:26:40 <abadger1999> I talked to epienbro on irc
15:26:44 <spot> #topic Precompiled Windows Executable programs exception
15:26:52 <spot> https://fedorahosted.org/fpc/ticket/111
15:27:09 <abadger1999> he says that on windows, compiler output is not necessarily compatible with each other; not just the C runtime library.
15:28:09 <abadger1999> so on the one hand, since most windows devs are using visual C, the precompiled stuff shipped by python upstream is the safest.
15:28:38 <abadger1999> otoh, we can recompile the code using mingw as a cross compiler.
15:28:42 <abadger1999> and it might work.
15:29:10 <limburgher> Has that not been tried?  If it does, that's the way we should go.
15:29:48 * spot agrees, we should only be considering exceptions in the cases where things are known to generally not work when built from source with mingw
15:30:07 <abadger1999> limburgher: No one so far has windows.
15:30:21 <abadger1999> limburgher: dmalcolm has windows so I can flag this to his attention.
15:30:39 <abadger1999> and he can spend some time figuring out if we have a valid way forward
15:30:52 * abadger1999 notes that we tried in wine and it seg faulted.
15:31:04 <spot> okay, so i propose we table this, unless abadger1999/dmalcolm undercover a valid concern for an exception
15:31:08 <abadger1999> but it also segfaulted with the upstream pyhton in wine.
15:31:17 <abadger1999> Yeah, +1 table.
15:31:22 <abadger1999> Oh actually
15:31:29 <abadger1999> one more corner case.
15:31:43 <abadger1999> we currently have mingw32 in Fedora
15:31:47 <abadger1999> not so mingw64
15:32:12 <abadger1999> So 64 bit windows crosscompiling is currently unavailable.
15:32:54 <abadger1999> What do we want to do about that?  Give it a fix-it ticket but let it continue until mingw63 is in?
15:33:05 <abadger1999> s/63/64/
15:33:14 <rdieter> I suspect now that the barn door for producing windows binaries is open, it may well be a lost-cause fighting this too much.
15:33:52 <abadger1999> I mean -- upstream python is shipping both win32 and win64 installer binaries.
15:34:05 <spot> abadger1999: so, to be clear, you're proposing that we permit pre-built win64 binaries and built win32 binaries from the source?
15:34:05 <abadger1999> we can potentially crosscompile the win32 binaries
15:34:26 <limburgher> abadger1999: hrm.
15:34:39 <abadger1999> spot: Yeah.  that's the proposal.  and then remedy that asymmetry whn we have a win64 crosscompiler.
15:35:03 <limburgher> Ecch.
15:36:17 <abadger1999> If we may be okay with that, I'll write something up that limits it to this case
15:36:53 * spot isn't thrilled about that baby-halfing, but we have no choice on the win64 side atm
15:37:04 <abadger1999> creating software installer bundles for windows.  (I'll come up with a definition of software installer bundle)
15:37:13 <racor> abadger1999: In acceptable. Allow windows, but ban foreign java or linux binaries, to me is "just absurd"
15:37:49 <limburgher> spot: Isn't it just a bootstrapping problem, essentially?
15:37:54 <abadger1999> well, java runs on the Fedora machine.
15:38:00 <racor> abadger1999: You are demanding Fedora to throw the freedoms it once was based on overboard
15:38:03 <abadger1999> and linux binaries do too.
15:38:11 <spot> limburgher: i don't think so, the binaries aren't being used to bootstrap.
15:38:13 <limburgher> but we disallow prebuilt jars.
15:38:23 <abadger1999> the closest we've come to thinking about this before is JavaScript.
15:38:36 <racor> Ok lets start repackaging Ubuntu and suse instead of building fedora from source
15:38:42 <limburgher> So I guess I don't see why we'd allow this if we might be able to build from source.
15:38:56 <abadger1999> where the code in question runs on the machine that is being served to from the fedora machine.
15:39:26 * spot would be just as happy saying "no prebuilt windows binaries, either build them from source with mingw or nothing", understanding that due to the current limitations of mingw32, this means 32bit only windows binaries
15:39:29 <limburgher> You can stick a win32 .exe on an apache server and run it on a remote machine, doesn't mean we should do it.
15:39:31 <Rathann> we can run win32 binaries under wine
15:39:40 <Rathann> and win64 too I guess?
15:39:55 <limburgher> And .COM under dosbox.
15:39:55 <spot> hopefully, mingw64 will clear legal before the sun explodes.
15:40:10 <limburgher> So we can play DNF on Fedora?
15:40:26 <abadger1999> spot: <nod>  If that's our consensus, then that's fine, I'll just not have to write up this draft :-)
15:41:01 <abadger1999> Instead, I'll need to lean on people packaging software installers to cross-compile what they can and abandon the features that they can't.
15:41:24 <spot> Okay, then i'll propose it for a vote: Prebuilt windows binaries are not permittted in Fedora. Windows binaries may only be included if they are built from source via koji.
15:42:05 <tibbs> Seems OK to me, but why single out windows?
15:42:09 <tibbs> (sort of around right now)
15:42:22 <spot> tibbs: we already have a section about prebuilt binaries, this is clarification at best.
15:42:34 <geppetto> I'm +1 to that
15:43:09 <rdieter> +1   (and anything more than that can lobby fesco for a policy change/exception)
15:43:15 <spot> +1
15:43:26 <racor> +1
15:43:28 <tibbs> +1
15:43:31 <limburgher> +1
15:43:55 <SmootherFrOgZ> +1 (ok with rdieter statement)
15:44:19 <spot> abadger1999, Rathann are the missing voters
15:44:43 <tibbs> Anyone can lobby FESCo for an exemption to anything at any time; that's pretty much a given.
15:44:46 <Rathann> +1
15:45:08 * abadger1999 abstains but is fine with the outcome
15:45:11 <abadger1999> +0
15:45:33 <spot> #action Prebuilt windows binaries are not permittted in Fedora. Windows binaries may only be included if they are built from source via koji. (+1:8, 0:1, -1:0)
15:47:15 <spot> There is one more ticket on the agenda technically, but Red Hat has asked for me to review some documentation before we consider it.
15:47:27 <spot> so i'm opting to table that ticket for a week
15:47:38 <tibbs> The /opt, /usr/local thing?
15:47:41 <spot> yes.
15:47:48 <tibbs> Interesting.
15:48:01 <tibbs> I'm definitely +1 to that one.
15:48:11 <limburgher> Odd.  Seems. . .pretty straighforwardly yesful.
15:48:22 <spot> I doubt they will be able to show me anything to convince me not to vote +1 on it, but i was willing to give it a week.
15:48:37 <abadger1999> okay.
15:48:44 <spot> #topic Open Floor
15:48:49 * rdieter had a bundling exception for iris
15:48:56 <spot> oh yes!
15:49:10 <spot> #topic Iris bundling exception - https://fedorahosted.org/fpc/ticket/112
15:49:34 <spot> i tend to agree with toshio here (although, i have not looked at the code)
15:49:46 <spot> it would be nice to simply convert the iris code into a library
15:50:26 <spot> i dont know what the iris upstream looks like
15:50:29 <limburgher> If not horrifically terrible to do so.
15:50:32 <rdieter> see also, what's currently upstream is (seems to be?): http://delta.affinix.com/iris/
15:50:41 <abadger1999> yeah.  static libraries are usually pretty easy to build.  it's just not auto* so there's a learning curve for me to do it.
15:50:42 <spot> is it a situation where they might be willing to move in that direction?
15:51:14 <rdieter> almost certainly they'd be ok with anyone willing to work toward that end.
15:51:41 <rdieter> it's just that I personally didn't have the time/energy to do so myself right now
15:52:14 <rdieter> and didn't want that to block reviews pending on this (as well as other software currently already in fedora currently bundling it)
15:52:30 <abadger1999> <nod>
15:52:45 <abadger1999> rdieter: how far along did you get?
15:53:03 * abadger1999 sees psi mentioned on the iris web page and sees that psi is in the distro.
15:53:05 <rdieter> I got stuck with insufficient qmake-fu too
15:53:12 <tibbs> Don't you just run ar on the compiled .o files?
15:53:31 <spot> i was about to volunteer, but then you said qmake
15:53:32 <rdieter> http://rdieter.fedorapeople.org/rpms/iris/
15:53:36 <spot> so i am now backing away slowly
15:54:02 <limburgher> :)
15:54:27 <spot> what the hell, i'm a masochist. i'll give it a try.
15:54:53 <rdieter> is granting a copylib exception really worse? :)
15:55:06 <spot> rdieter: ask me again after i try. ;)
15:55:18 <rdieter> ok, go for it
15:55:25 * spot doesn't want "the right thing is too hard" to be a valid copylib rationale
15:55:34 <abadger1999> rdieter: that would be a neat loophole.  "Upstreams built using qmake are defined as copylibs 'cuz we don't have the time" ;-)
15:55:48 * rdieter thought this satisfied the copylib definition pretty well
15:56:33 <spot> well, if someone wants to propose an exception vote right now, i'd let it ride
15:56:41 <spot> otherwise, i'll report back on what i find
15:57:15 * rdieter can wait, no rush
15:57:46 <rdieter> may the force be with you
15:57:46 <spot> okay.
15:57:48 <spot> hehe
15:57:52 <spot> #topic Open Floor
15:57:58 <spot> for the next, oh, 2 minutes or so
15:58:30 * abadger1999 has one thing to bring up
15:58:39 <abadger1999> UsrMove feature
15:59:36 <abadger1999> Any thoughts on that? -- I've put a note into the feature page that parts of it might need to go to fpc.  If we have definite thoughts, I can proxy them into any fesco discussion.
15:59:58 <spot> yeah. if fesco approves it, we'd have to... rewrite a lot.
16:00:23 <tibbs> Have a reference to that?
16:00:24 <abadger1999> spot: well... I'd say some of it... we have veto over.
16:00:30 <spot> abadger1999: possibly
16:00:37 <geppetto> From what I saw, the first part … just moving /bin => /usr/bin and /sbin to /usr/sbin … and having symlinks, didn't seem too bad … but some of the addon crack seemed … crack
16:00:55 <abadger1999> geppetto: there's a second part in the feature
16:01:02 <abadger1999> /usr/sbin => /usr/bin
16:01:06 <geppetto> yeh, that
16:01:08 <geppetto> crack
16:01:27 <geppetto> I thought there was one other thing too
16:01:27 <abadger1999> I think the first part is okay.  the second part I think violates FHS.
16:01:43 <racor> geppetto: ack, the silliest and dumbest stuff having ever been proposed in Fedora.
16:01:45 <abadger1999> geppetto: there was.  that one was separate already and has been withdrawn by the author.
16:01:59 <abadger1999> because it became clear quickly that it was entirely crack.
16:02:40 <abadger1999> (use #! /usr/bin/env sh  instead of #!/bin/sh   to protect against moving sh in the filesystem)
16:02:49 <racor> crack
16:02:53 <tibbs> Oh, my.
16:03:01 <abadger1999> pure, unadulterated crack, right there.
16:03:04 * spot rarely agrees so entirely with racor, but in this case, i think so.
16:03:20 <spot> crack indeed.
16:03:21 <racor> spot: ;)
16:03:27 <jdulaney> Cokaine?
16:03:27 <tibbs> Just move things to /Binaries.
16:03:31 <abadger1999> tibbs: https://fedoraproject.org/wiki/Features/UsrMove
16:03:45 <racor> no, ... fesco ... /me runs and tries to hide
16:03:51 <spot> /files /stuff /pr0n /execs
16:04:09 <tibbs> I do really like the first sentence.
16:04:17 <tibbs> After that, not so much.
16:04:24 <rbergeron> you guys runnin' over? /me can probably just move the fudcon meeting to #fudcon-planning
16:04:32 <spot> no, i think we're done smoking crack.
16:04:33 <abadger1999> So general consenus... let the /bin => /usr/bin stuff play out in fesco, then deal with it in guidelines.  Speak against the /usr/sbin /usr/bin merge?
16:04:42 <spot> abadger1999: sure.
16:04:46 <geppetto> abadger1999: sure
16:04:50 <tibbs> Looks like I picked the wrong day to quit smoking crack.
16:04:56 <SmootherFrOgZ> abadger1999: +!
16:04:58 <SmootherFrOgZ> 1
16:05:07 <abadger1999> Okay, I'll work that angle in fesco..   Thanks for the input.
16:05:12 <spot> okay, thanks everyone.
16:05:20 <spot> please throw your crack pipes out on the way
16:05:21 <SmootherFrOgZ> tibbs: never to late ;)
16:05:23 <spot> #endmeeting