17:00:25 <spot> #startmeeting Fedora Packaging Committee
17:00:25 <zodbot> Meeting started Wed Apr 4 17:00:25 2012 UTC. The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:28 <spot> #meetingname fpc
17:00:28 <zodbot> The meeting name has been set to 'fpc'
17:00:32 <spot> #topic Roll Call
17:00:48 * limburgher here
17:02:00 <limburgher> Hmmm. http://www.youtube.com/watch?v=1Cw1ng75KP0
17:02:14 * spot laughs
17:02:58 <spot> rdieter, geppetto, SmootherFrOgZ, abadger1999, tibbs|h: ping
17:03:08 <geppetto> here
17:03:39 <spot> wow, the 80s really threw up on that video
17:03:48 * abadger1999 here
17:03:56 <limburgher> Yeah. It's still no Total Eclipse of the Heart.
17:04:17 * abadger1999 has been talking to vondruch this morning... seing if he'll come in here.
17:04:26 <tibbs|h> Howdy.
17:04:27 <spot> abadger1999: ruby?
17:04:32 <Rombobeorn> May I ask you guys to have a look at ticket 154 first, and see if it can be processed quickly? If you can't vote on it within, say, 15 minutes, then you may suspend it and do things in the order you otherwise would.
17:04:48 <Rombobeorn> I'm here for the fourth Wednesday in a row, hoping that my proposal will be processed today.
17:04:49 <abadger1999> yeah
17:05:03 * spot has 154 as item #1 on the agenda already
17:05:13 <Rombobeorn> Great!
17:05:24 <limburgher> Cool, so if we get quorized we'll get on it. (lost count)
17:05:37 <spot> limburgher: we're at 5, so just barely.
17:05:58 * spot apologizes for missing last week, long string of events lead me to be without laptop. :/
17:06:10 <limburgher> Goldberg'd!
17:06:17 <vondruch> Hi guys
17:07:00 <spot> okay guys, lets try to knock out 154 quickly
17:07:10 <limburgher> Don't call it a comeback. . .
17:07:16 <spot> #topic Ada Guidelines changes - https://fedoraproject.org/wiki/User:Rombobeorn/Ada_Guidelines_Changes
17:07:45 <spot> the only item in the proposal that i have any issue with is the one about permitting source packaging
17:07:55 <spot> i just don't see the point in packaging source files
17:08:13 <limburgher> spot: lzma-sdk? :)
17:08:30 <limburgher> (ducks)
17:08:31 <spot> limburgher: eh, thats a nasty case, but even that is a library and headers now
17:08:36 <Rombobeorn> If it were C, those sousce files would be .h files.
17:08:38 <limburgher> spot: Fair point.
17:08:56 <spot> Rombobeorn: are other ada packages trying to use them in the same sort of way as .h files?
17:08:57 <tibbs|h> Rombobeorn: Can you elaborate?
17:09:01 <limburgher> And all could be used by my Ada app to build?
17:09:14 <tibbs|h> The full source of a library is required just to build something else?
17:09:59 <tibbs|h> How have we been getting by without that so far?
17:10:03 <Rombobeorn> Ada programs using a library will need the .ads files, like a C program needs .h files. In some cases some .adb files are also needed.
17:10:34 <limburgher> Rombodeorn: at build or at runtime?
17:10:44 <tibbs|h> OK, that seems to be well described by the first bullet point under "Devel package".
17:10:53 * abadger1999 adds "respectively" to the gnatmake compilation change
17:11:10 <Rombobeorn> The problem is that it's hard to manually keep track of exactly which .adb files are needed, so some makefiles just install them all.'
17:11:23 <Rombobeorn> limburgher, at buld time.
17:11:43 <limburgher> Romboeorn: Ok.
17:11:48 <spot> hmm, okay
17:12:00 <spot> so i think i'm fine with the proposed wording change given that context
17:12:12 <spot> "Ada library packages MUST have a -devel subpackage containing all the files that are necessary for compilation of code that uses the library. This includes Ada specification files (*.ads), Ada body files (*.adb), Ada library information files (*.ali) and GNAT project files (*.gpr). (There is no requirement to include all body files. Typically only some body files are needed.) "
17:12:13 <limburgher> So BuildRequiring would involve splitting them out and it gets ickier from there, so this is probably better.
17:12:43 <limburgher> And which .adb is left to maintainer discretion?
17:12:49 <spot> limburgher: makes sense
17:13:18 <spot> So, I'm +1 here
17:13:34 <limburgher> Me too, +1.
17:13:56 <Rombobeorn> The point is to just let the maintainer use the upstream buildsystem instead of forcing him to rewrite the whole thing.
17:14:23 <abadger1999> Does anyone recall how we dealt with something similar to the gnat arches stuff before?
17:14:27 <spot> Rombobeorn: there may still be cases where the upstream buildsystem is throwing the kitchen sink into the filesystem
17:14:40 <spot> Rombobeorn: so we still expect maintainers to use common sense and nuke useless files
17:14:42 <abadger1999> I think it was in regards to mono but it could have been ocaml, java, or something else.
17:15:00 <Rombobeorn> spot: Yes, of course.
17:15:21 * abadger1999 can remember a lot of discussion but not whether we decided it was good to do that way or good to not do it that way
17:15:29 <spot> abadger1999: i think it was mono, and i think we okayed it
17:15:50 <spot> %{mono_arches}
17:16:29 <tibbs|h> Does any supported release have fedora-gnat-project-common < 2?
17:16:37 <Rombobeorn> abadger1999, there are already several other *_arches macros.
17:16:59 <spot> tibbs|h: not in fedora
17:17:32 <tibbs|h> We have other rules about dropping version-dependent dependencies when there's no point, so....
17:18:20 <spot> tibbs|h: yeah, that line could probably be dropped safely.
17:18:38 <Rombobeorn> tibbs|h, OK, so: If the "directories" project is used, then the -devel package MUST have an explicit "Requires: fedora-gnat-project-common".
17:18:49 <tibbs|h> I note that the Note at the end was removed; did that change happen or does it not really matter?
17:18:49 <spot> Rombobeorn: *nod*
17:18:54 * spot ninja edits it in.
17:19:17 * rdieter back from lunch, sorry i'm late
17:19:28 <tibbs|h> Oh, doh, that's answered earlier in the document.
17:19:39 * spot sees +2 on the draft
17:20:00 <geppetto> +1
17:20:06 * rdieter reads quickly
17:20:10 <tibbs|h> I'm going through a visual diff.
17:20:14 * spot needs to teach the bot to handle voting
17:20:39 <tibbs|h> We should probably make a requirement to actually provide some sort of diff we can look at when folks propose guideline changes.
17:21:39 <rdieter> +1 worksforme
17:21:50 <spot> vote is at +4
17:21:54 <tibbs|h> +1
17:22:02 <Rombobeorn> tibbs|h: Is there a better way than the diff that the wiki provides?
17:22:06 <spot> abadger1999: want to vote on the record?
17:22:08 <abadger1999> +1
17:22:20 <spot> #action draft approved (+1:6, 0:0, -1:0)
17:22:27 <tibbs|h> Does the change of project_dir imply a rebuild?
17:22:32 <spot> Rombobeorn: sorry for the delay, thanks for your patience. :)
17:22:48 <tibbs|h> I guess that's not our domain, but otherwise I expect that things would be busted.
17:23:29 <Rombobeorn> tibbs|h, yes, a rebuild of all Ada libraries, in Rawhide, but it can be done gradually.
17:23:30 <tibbs|h> And I don't really know of a better way to do a diff. Generally you copy the original document, edit it and give us a link to the diff.
17:24:53 <spot> okay, lets dive into ruby (again)
17:24:56 <Rombobeorn> OK, thanks guys!
17:25:13 <spot> #topic Ruby guidelines - https://fedorahosted.org/fpc/ticket/134 - https://fedoraproject.org/wiki/User:Toshio/RubyPackagingDraft
17:25:31 <spot> before we get too deep into this, i actually spent some time last week fixing some broken ruby packages
17:25:36 <spot> i am not a ruby guru by any means
17:25:46 <tibbs|h> Did this change from last time? Doesn't look like it.
17:25:48 <spot> but using the old model, i simply was unable to patch anything sanely
17:26:10 <spot> switching to toshio's draft model got it to a place where i could apply patches and get alexandria working again
17:26:16 <abadger1999> Excellent.
17:26:25 <abadger1999> tibbs|h: It hasn't from last week.
17:26:38 <spot> so, minor points of contention aside, this is a notable improvement from my perspective
17:26:48 <limburgher> spot: <nods emphatically>
17:26:56 <rdieter> is everyone on the same page now? I seem to recall seeing some mail back-n-forth onlist recently.
17:27:17 <limburgher> abadger1999: My vision went all blurry on the last few comments, does it need any more changes in light of that exchange?
17:27:18 <abadger1999> So at the moment, vondruch (via IRC) and bkabrda (on the ml) have talked about the (I think it's the) last remaining point
17:27:21 <rdieter> (though I agree the draft is better than any other alternative atm)
17:27:38 <abadger1999> Whether to special case the rubygem module and place it in its own special directory.
17:27:52 <tibbs|h> Is there any chance we could leave that for later? This whole thing has taken long enough.
17:27:59 <spot> abadger1999: as opposed to /usr/share/rubygem/ ?
17:28:03 <abadger1999> Right.
17:28:23 <limburgher> What's the argumnt for special-casing, in a nutshell?
17:28:23 <abadger1999> rubygem seems to just be a non-gem ruby library.
17:28:29 * spot thinks that is perhaps the most minor issue of them all (and i am aware that i may have originally raised it)
17:28:40 <vondruch> spot, alexandria is not gem if I am not mistaken
17:28:50 <spot> vondruch: no, but the three broken rubygem deps were. :)
17:28:51 <abadger1999> That our ruby maintianers are actively working on to make interpreter independent (although it's not there yet and there's resistance from upstream).
17:28:59 <limburgher> Would not special-casing it introduce any potential bootstrapping issues?
17:29:24 <abadger1999> since it's standard, there doesn't seem to be any reason not to just leave it in the ruby stdlib (or in vendorlib).
17:29:53 <abadger1999> The arguments I've heard are that we'd have two copies of the same code on the filesystem.
17:30:31 <limburgher> Symlink?
17:30:38 <limburgher> Ugly hack?
17:30:52 <vondruch> limburgher, systematic solution? :)
17:30:53 <spot> abadger1999: does upstream prefer /usr/share/rubygems ?
17:31:07 <limburgher> vondruch: pfft. :)
17:31:11 <spot> or is that a fedora-ism?
17:31:13 <vondruch> spot, there have been no response
17:31:20 <abadger1999> spot: afaict, and condruch might be able to tell more -- the answer is no.
17:31:29 <abadger1999> *vondruch
17:31:47 <abadger1999> it seems like they're perfectly happy with rubygem module living in the std library path.
17:31:54 <spot> where would it be if we moved it into the std lib path?
17:32:02 <spot> and would %{gem_dir} move too?
17:32:49 <spot> or is the whole issue here that "rubygems" is sitting in %{gem_dir} when it isn't a gem?
17:32:59 <vondruch> spot: We would like to convince upstream that optional placement of RubyGems is advantage
17:33:11 <vondruch> spot, This proposal was nor accepted nor rejected
17:34:10 <spot> if this is the only remaining contention in the draft, i say leave it as is, and if upstream rejects the placement in /usr/share/rubygems, we'll revisit it.
17:34:51 <vondruch> %{gem_dir} is different topic ... actually I am not sure if I am confused now or the abadger1999's draft is wrong?
17:34:59 <spot> the rest of the draft works very well and improves ruby packaging significantly (IMHO)
17:34:59 <abadger1999> spot: --with-rubygemsdir='%{rubygems_dir}' \ controls where we place the rubygem module (this looks like it's added to ruby's configure by our patch)
17:35:06 <limburgher> spot: Given your experience using this as is. . .+1
17:35:21 <spot> +1 to the draft as is now
17:35:23 <vondruch> abadger1999, yes, somewhere close to the patch should be link to upstream issue
17:35:28 <geppetto> +1
17:35:28 <tibbs|h> Still +1 on this.
17:35:40 <limburgher> +1 to the draft.
17:35:41 * spot sees +4 on this draft
17:35:42 <rdieter> +1
17:35:49 <vondruch> spot, there again arose the issue with virtual provides on Ruby-SIG
17:36:20 <abadger1999> spot: +1 on my own draft
17:36:36 <vondruch> http://lists.fedoraproject.org/pipermail/ruby-sig/2012-April/000954.html
17:36:55 <spot> vondruch: at this point, i think it would be most productive to have the ruby sig propose specific changes to the guidelines
17:37:03 <abadger1999> I'm still willing to talk about this rubygems module path but... so far no one's presented an argument that seemed to warrant special casing.
17:37:13 <tibbs|h> I need to step away for a few minutes.
17:37:15 <vondruch> spot, ok, np
17:37:16 <spot> we've held up on this for long enough
17:37:18 <limburgher> vondruch: that way we can get the rest in practice.
17:37:29 <spot> #action Draft approved (+1:6, 0:0, -1:0)
17:37:57 <limburgher> playsound("Cork_pop.ogg");
17:38:00 <geppetto> yah!
17:38:09 <spot> abadger1999, vondruch: thank you for the effort on this, not fun at all, i know. :)
17:38:35 <spot> #topic Clarification for bootstrap compilers - https://fedorahosted.org/fpc/ticket/157
17:38:42 * limburgher hoists abadger1999, vondruch on shoulders, runs around room, dumps gatorade on them
17:38:46 <spot> imho, this is obvious easyfix stuff. +1
17:39:02 <abadger1999> vondruch: That looks like it could be something -- could you get me more information (maybe srpms of slimgems?) asap?
17:39:19 <limburgher> +1
17:39:20 <rdieter> +1
17:39:21 <tibbs|h> +1 to 157.
17:39:33 <abadger1999> +1
17:40:27 * spot gives geppetto a moment to vote on 157
17:41:44 <limburgher> He might be rusty, it's been awhile since we discussed more than one or two tickets in a meeting.
17:42:06 <geppetto> +1
17:42:09 <vondruch> abadger1999, will try, but I have no better leverage then mailing list :)
17:42:24 <vondruch> Getting late here, so I'm leaving
17:42:27 <vondruch> bye
17:42:34 <abadger1999> vondruch: (Quick look at slimgems -- it looks somewhat like python's setuptools vs distribute ... where we decided that for something so core we would need to
17:42:41 <abadger1999> vondruch: just choose one or the other.
17:42:52 <limburgher> vondruch: Bye, thanks!
17:42:56 <abadger1999> vondruch: (Curently python-setuptools ships distribute rather than setuptools)
17:43:17 <abadger1999> vondruch: so I'll need to see a packaging implementation to start asking questions.
17:43:54 <spot> #action Draft approved (+1:6, 0:0, -1:0)
17:44:03 <spot> now, on to the fun one
17:44:24 <spot> #topic libexecdir guideline does not allow for /usr/lib/%{name} fallback
17:44:31 <spot> #topic libexecdir guideline does not allow for /usr/lib/%{name} fallback - https://fedorahosted.org/fpc/ticket/158
17:44:35 <geppetto> -1
17:44:50 <spot> well, here's the problem.
17:45:15 <spot> systemd is not using %{_libdir}/%{name} or %{_libexecdir}/%{name}
17:45:28 <spot> so either systemd is violating the guidelines or we need to permit this use case.
17:45:59 <tibbs|h> I'm not sure that systemd violating the guidelines has ever really been a concern for those involved.
17:46:09 <abadger1999> It's likely systemd.
17:46:15 <limburgher> spot: Is there a compelling reason for systemd not to follow the guidelines here?
17:46:30 <tibbs|h> Obviously at least the unit stuff belongs in /usr/share, except of course that before there was no /share so /lib made (some) sense.
17:46:41 <abadger1999> if i'm thinking back on past discussions correctly, I think this was argued about when systemd lived in "/" and there wasn't a /libexec
17:46:51 <abadger1999> and wasn't a /share
17:46:55 <spot> limburgher: aside from kay's belief that everything should be in /usr/lib/%{name} instead of libexecdir or %{_libdir}
17:47:23 <limburgher> spot: So not really.
17:47:28 * spot refers to ticket 139
17:47:32 <spot> https://fedorahosted.org/fpc/ticket/139
17:48:07 <spot> From that ticket, from Kay: "Recommending %{_libdir}/%{name} is just utterly wrong. It must be %{_prefix}/lib/%{name}. Using /usr/lib64/foo/ for anything that is not *.so makes absolutely no sense at all. "
17:48:12 <tibbs|h> To be honest, I'm not sure that we have to do anything here.
17:48:25 <geppetto> yeh, well -1 on that too
17:48:34 <spot> well, the logical step would be to ask FESCo to fix systemd
17:48:42 <tibbs|h> The systemd folks will just keep right on doing whatever they feel like regardless of what we say.
17:48:53 <geppetto> Do we generally do that?
17:49:17 <spot> geppetto: this is the only case i can think of where someone has been aware of the guidelines and flagrantly disregarded them
17:49:25 <abadger1999> geppetto: I think we generally open a bug -- if the bug is closed wontfix we/the bug reporter escalates to fesco.
17:49:37 <spot> abadger1999: we could ask the ticket reporter to do that.
17:49:44 <geppetto> abadger1999: really? … fair enough.
17:49:47 <tibbs|h> I'm not sure it's so flagrant when the pre-usermove history is considered.
17:49:49 <geppetto> spot: sounds like a plan :)
17:50:06 <abadger1999> not saying whether that's a good way of doing business or not -- just that's how it usually happens.
17:51:05 <spot> okay, so i propose that we answer 158 with: "Based on the information available, systemd is violating Fedora Packaging Guidelines by placing compiled executables in /usr/lib/%{name}/ for all architectures as opposed to using %{_libdir}/%{name}. Please file a bug against systemd, and if they do not resolve the issue, then escalate it to FESCo."
17:51:34 <geppetto> +1
17:51:36 <abadger1999> so probably the first question to be asked in excalation will be -- does this violation actually break anything.
17:51:39 <spot> +1
17:51:41 <limburgher> +1
17:51:54 <tibbs|h> abadger1999: Well, systemd pretty obviously can't be multiarch.
17:52:03 <tibbs|h> Unless I'm missing something.
17:52:16 <geppetto> abadger1999: lots of violations won't break things …
17:52:28 <rdieter> +1
17:52:39 <spot> +1
17:52:52 <tibbs|h> Personally I just don't see the point in picking another fight.
17:52:53 <spot> hehe, i can vote twice. (sorry)
17:53:13 <spot> tibbs|h: if fesco wants to give them an exception, they can.
17:53:17 * abadger1999 is with tibbs|h...
17:53:22 <geppetto> tibbs|h: we aren't … we are asking gholms to
17:53:41 <spot> he asked if it violated the guidelines and we're saying that it does.
17:53:52 <abadger1999> I guess I'm willing to vote +1 here but someone else will need to champion it/explain the rationale if it escalates.
17:54:17 <spot> so, with abadger1999's +1, we're at +5
17:54:38 <spot> tibbs|h: want to go on the record?
17:54:44 <tibbs|h> I guess there's no harm in simply acknowledging the fact that systemd is doing whatever they like.
17:54:47 <tibbs|h> So +1.
17:55:16 <spot> #action resolution text approved (+1:6, 0:0, -1:0)
17:55:17 <rdieter> I suppose we could complicate matters by allowing /usr/lib/%{name} for pkgs that aren't multilib'd, but... meh.
17:55:45 <spot> 159 came in right before the meeting
17:55:52 <spot> so i haven't had a chance to look at it at all
17:56:19 <limburgher> abadger1999: Since I'm also on FESCO, I could make the argument, that it's in violation and we don't have a compelling reason to allow it to.
17:56:52 <geppetto> spot: we can table it then, right?:)
17:56:54 <spot> limburgher: that would be my case. we know that using /usr/lib/%{name} universally is a bad idea. Just because it doesn't break in the systemd case isn't a valid rationale.
17:57:07 <tibbs|h> Well, more usermove-style disruption is kind of a reason.
17:57:28 <abadger1999> Yeah, it came about when I was talking to vondruch about whether it was okay for ruby to have a copy of a library and jruby to have a separate copy of the same library.
17:57:29 <limburgher> spot: Right.
17:57:34 <abadger1999> (ticket 159)
17:57:46 <abadger1999> You can look at the diff to see what I changed.
17:57:54 <abadger1999> https://fedoraproject.org/w/index.php?title=User%3AToshio%2FDuplication_of_System_Libraries_clarifications&action=historysubmit&diff=282441&oldid=282437
17:58:01 <rdieter> +1 159
17:58:04 <spot> abadger1999: okay. looking at the diff I'm +1
17:58:07 <limburgher> I think it looks straightforward, +1
17:58:24 <abadger1999> +1
17:58:51 <spot> #topic Duplication of system library clarifications - https://fedorahosted.org/fpc/ticket/159
17:58:59 <spot> vote is at +4
17:59:11 <spot> geppetto, tibbs|h: ?
17:59:15 <tibbs|h> It doesn't break anything except the rules.
17:59:25 <tibbs|h> Erm, that was dumb
17:59:40 <tibbs|h> Scrolling back and then replying to the line at the bottom of the window.
17:59:46 <tibbs|h> ANyway, +1 to 159.
17:59:53 <spot> tibbs|h: hehe, i think i get what you were trying to say though. i still think if fesco wants to grant it an exception they can.
17:59:53 <geppetto> +1 too
18:00:08 <geppetto> tibbs|h: I think that's a terrible rationale
18:00:32 <spot> even if the exception is granted on the grounds of "fixing this will break the world, so we're letting their bad behavior continue as a one off"
18:00:43 <tibbs|h> It's not a rationale; it's just a statement of fact.
18:00:53 <spot> #action 159 changes approved (+1:6, 0:0, -1:0)
18:01:10 <spot> #topic Open Floor
18:01:14 <tibbs|h> Others might try to use it as rationale, I suppose.
18:01:24 <spot> i think we actually had a rather productive meeting today. :)
18:01:32 <limburgher> It was nice.
18:01:32 <tibbs|h> Indeed.
18:01:37 <abadger1999> We certainly cleared a lot of tickets :-)
18:01:40 <tibbs|h> But we do need to talk about doing a time shift.
18:01:59 <tibbs|h> Personally I'm good with this time and will miss next week if we move up an hour.
18:02:02 <spot> oh, peter robinson emailed something to me
18:02:03 <geppetto> yeh, I assume we can follow DST ?
18:02:07 <tibbs|h> But normally it doesn't really matter.
18:02:28 <spot> apparently, cmake needs -DCMAKE_SKIP_RPATH:BOOL=ON for some packages to build without embedded rpaths
18:02:31 <geppetto> going back one hour is better for me
18:02:43 <spot> anyone have a problem with me adding that to the section on rpath?
18:02:45 <tibbs|h> Which direction is back?
18:02:52 <tibbs|h> Earlier or later?
18:02:55 <spot> tibbs|h: 1600 UTC would be back an hour
18:03:10 <geppetto> Earlier
18:03:17 <limburgher> Either is OK for me.
18:03:20 <geppetto> But now is also ok
18:03:21 <rdieter> spot: I thought that's already in the cmake page... lemme check
18:03:25 * abadger1999 can make either
18:03:31 <geppetto> But I thought it was really bad for racor
18:03:32 <limburgher> spot: Seems logical.
18:03:38 <rdieter> (arguably, any pkg requiring that is ... broken somewhere though)
18:04:08 <abadger1999> here's another easy ticket: https://fedorahosted.org/fpc/ticket/157
18:04:20 <tibbs|h> I thought we had two members with mutually exclusive availability.
18:04:24 <spot> abadger1999: we did 157 today
18:04:26 <abadger1999> I didn't start with the vanilla guideline, though, so there's no nice diff
18:04:35 <spot> abadger1999: i just didn't flip it to accepted
18:04:38 <abadger1999> oh belagh
18:04:53 <abadger1999> I should get out of this racket -- I don't even know what I'm voting on ;-)
18:05:05 <spot> ;)
18:05:15 <limburgher> You're no Admiral Stockdale.
18:05:17 <kalev> rdieter: couldn't the -DCMAKE_SKIP_RPATH:BOOL=ON be included in the default %cmake macro?
18:05:19 <spot> we did 134, 154, 157, 158, 159.
18:05:22 <rdieter> spot: ok, guess not, http://fedoraproject.org/wiki/Packaging:Cmake, says not to use it. Either way, we do have a %{_cmake_skip_rpath} macro, available
18:05:27 <rdieter> kalev: no
18:05:33 <limburgher> And the powerball was 23.
18:05:39 <rdieter> kalev: it unconditionally disables rpath, even when it's needed
18:06:13 <kalev> ah, that doesn't sound like a good default, indeed.
18:06:31 <spot> rdieter: thanks, that seems fine then as is. i'll just point peter to that doc
18:06:33 <rdieter> cmake is generally smart enough these days to not rpath system paths, and any pkg's buildsys that does usually is broken somehow
18:07:06 <rdieter> I'm still fighting a few upstreams to fix stuff like that.
18:07:10 <spot> okay, back to the timeshift
18:07:27 <spot> i'll send out an email to the fpc seeing if anyone has an issue with moving to 1600 UTC
18:07:38 <rdieter> if any cmake-based pkg requires -DCMAKE_SKIP_RPATH:BOOL=ON these days, poke me, and I'll take a look
18:08:30 <spot> rdieter: he didn't mention what package was broken to me, if you want to know, you might be better off just poking him
18:09:00 <rdieter> ok, though I was saying that for everyone's benefit not just you and probinson
18:10:16 <spot> if there are no other items of business, we'll close out in 2 minutes.
18:19:28 <limburgher> Looks like that's it then?
18:22:25 <limburgher> (taps mic)
18:23:47 <vchris314> \quit
18:24:09 <limburgher> spot:
18:24:25 <limburgher> Is this thing on?
18:34:12 <abadger1999> #endmeeting
18:34:30 <abadger1999> spot: need you to #endmeeting
18:36:03 <nirik> .addchair #fedora-meeting-1 freenode abadger1999
18:36:03 <zodbot> nirik: Chair added: abadger1999 on (#fedora-meeting-1, freenode).
18:36:11 <abadger1999> #endmeeting