#fedora-meeting-1: Fedora Packaging Committee
Meeting started by spot at 16:01:19 UTC
(full logs).
Meeting summary
- Roll Call (spot, 16:01:28)
- Follow-up: Software Collections in Fedora - https://fedorahosted.org/fpc/ticket/339 (spot, 16:06:49)
- ACTION: Table SC
until next week when abadger1999 is around (spot, 16:07:49)
- Follow-up: Go Packaging Guidelines Draft - https://fedorahosted.org/fpc/ticket/382 (spot, 16:08:14)
- ACTION: Waiting on
submitter to reply to last week's comments (spot, 16:09:29)
- Exception for bundled library FoX in exciting - https://fedorahosted.org/fpc/ticket/400 (spot, 16:09:53)
- ACTION: spot will try
to make a FoX package that has both "normal" and "pretty-print"
libraries (spot, 16:20:44)
- ruby193 in SCL - https://fedorahosted.org/fpc/ticket/419 (spot, 16:21:01)
- ACTION: Tabled to be
addressed along with other SCL ticket with abadger1999 next
week (spot, 16:23:48)
- systemd or systemd-units should not be required if a spec file does a %systemd_post command - https://fedorahosted.org/fpc/ticket/425 (spot, 16:24:18)
- ACTION: if mattdm
confirms that they are working around this issue with a fakesystemd
package, spot will close, otherwise, we will revisit. (spot, 16:28:32)
- Bundling exception request for nodejs-weak-map - https://fedorahosted.org/fpc/ticket/424 (spot, 16:29:15)
- ACTION: Bundling
request approved (+1:5, 0:0, -1:0). Must be unbundled when Harmony
standard is finalized and code is available in Node.js core.
(spot, 16:34:22)
- Need policy and macros for binfmt.d file handling - https://fedorahosted.org/fpc/ticket/426 (spot, 16:35:12)
- https://fedoraproject.org/wiki/User:Spot/binfmtd-draft
(spot,
16:47:19)
- ACTION: Spot's draft
approved (+1:5, 0:0, -1:0) (spot,
16:50:44)
- Bundling exception requests for new julia package - https://fedorahosted.org/fpc/ticket/427 (spot, 16:52:00)
- ACTION: Temporary
exception for libuv bundling in Julia granted, until system libuv is
a practical option. (+1:5, 0:0, -1:0) (spot,
16:58:35)
- ACTION: Temporary
bundling of Rmath is approved until it is no longer needed by Julia
(0.4). (+1:6, 0:0, -1:0) (spot,
17:03:26)
- ACTION: SmootherFrOgZ
will make a dSFMT package, and Julia can use that. :) (spot,
17:14:50)
- Exception for bundling css in infrastructure application - https://fedorahosted.org/fpc/ticket/428 (spot, 17:16:08)
- ACTION: Temporary
bundling exception granted for bootstrap-fedora css resources until
bootstrap-fedora is in Fedora. (+1:6, 0:0, -1:0) (spot,
17:19:37)
- Bundling exception request for apitrace: libbacktrace - https://fedorahosted.org/fpc/ticket/429 (spot, 17:20:18)
- ACTION: Tabled
pending more info from Jakub Jelinek (spot,
17:29:23)
- mod_cluster EPEL package conflict with product - https://fedorahosted.org/fpc/ticket/432 (spot, 17:30:47)
- ACTION: Rathann will
answer with suggestions and close ticket when he has time.
(spot,
17:37:29)
- Add %{python3_version} and %{python3_version_nodots} to Packaging:Python Macros section - https://fedorahosted.org/fpc/ticket/433 (spot, 17:37:54)
- ACTION: new macros
approved (+1:5, 0:0, -1:0) (spot,
17:40:28)
- ACTION: new macros
approved (+1:6, 0:0, -1:0) (spot,
17:40:32)
- Open Floor (spot, 17:41:14)
- ACTION: Bundling
exception for libbacktrace approved, Provides:
bundled(libbacktrace). (+1:6, 0:0, -1:0) (spot,
17:45:55)
Meeting ended at 17:46:31 UTC
(full logs).
Action items
- Table SC until next week when abadger1999 is around
- Waiting on submitter to reply to last week's comments
- spot will try to make a FoX package that has both "normal" and "pretty-print" libraries
- Tabled to be addressed along with other SCL ticket with abadger1999 next week
- if mattdm confirms that they are working around this issue with a fakesystemd package, spot will close, otherwise, we will revisit.
- Bundling request approved (+1:5, 0:0, -1:0). Must be unbundled when Harmony standard is finalized and code is available in Node.js core.
- Spot's draft approved (+1:5, 0:0, -1:0)
- Temporary exception for libuv bundling in Julia granted, until system libuv is a practical option. (+1:5, 0:0, -1:0)
- Temporary bundling of Rmath is approved until it is no longer needed by Julia (0.4). (+1:6, 0:0, -1:0)
- SmootherFrOgZ will make a dSFMT package, and Julia can use that. :)
- Temporary bundling exception granted for bootstrap-fedora css resources until bootstrap-fedora is in Fedora. (+1:6, 0:0, -1:0)
- Tabled pending more info from Jakub Jelinek
- Rathann will answer with suggestions and close ticket when he has time.
- new macros approved (+1:5, 0:0, -1:0)
- new macros approved (+1:6, 0:0, -1:0)
- Bundling exception for libbacktrace approved, Provides: bundled(libbacktrace). (+1:6, 0:0, -1:0)
Action items, by person
- Rathann
- Rathann will answer with suggestions and close ticket when he has time.
- SmootherFrOgZ
- SmootherFrOgZ will make a dSFMT package, and Julia can use that. :)
- spot
- spot will try to make a FoX package that has both "normal" and "pretty-print" libraries
- if mattdm confirms that they are working around this issue with a fakesystemd package, spot will close, otherwise, we will revisit.
- UNASSIGNED
- Table SC until next week when abadger1999 is around
- Waiting on submitter to reply to last week's comments
- Tabled to be addressed along with other SCL ticket with abadger1999 next week
- Bundling request approved (+1:5, 0:0, -1:0). Must be unbundled when Harmony standard is finalized and code is available in Node.js core.
- Spot's draft approved (+1:5, 0:0, -1:0)
- Temporary exception for libuv bundling in Julia granted, until system libuv is a practical option. (+1:5, 0:0, -1:0)
- Temporary bundling of Rmath is approved until it is no longer needed by Julia (0.4). (+1:6, 0:0, -1:0)
- Temporary bundling exception granted for bootstrap-fedora css resources until bootstrap-fedora is in Fedora. (+1:6, 0:0, -1:0)
- Tabled pending more info from Jakub Jelinek
- new macros approved (+1:5, 0:0, -1:0)
- new macros approved (+1:6, 0:0, -1:0)
- Bundling exception for libbacktrace approved, Provides: bundled(libbacktrace). (+1:6, 0:0, -1:0)
People present (lines said)
- spot (158)
- geppetto (67)
- Rathann (49)
- SmootherFrOgZ (22)
- RemiFedora (19)
- tibbs|w (11)
- zodbot (8)
Generated by MeetBot 0.1.4.