17:01:45 <geppetto> #startmeeting fpc
17:01:45 <zodbot> Meeting started Thu Feb 9 17:01:45 2017 UTC. The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:45 <zodbot> The meeting name has been set to 'fpc'
17:01:46 <geppetto> #meetingname fpc
17:01:46 <zodbot> The meeting name has been set to 'fpc'
17:01:46 <geppetto> #topic Roll Call
17:02:02 <ignatenkobrain> .hello ignatenkobrain
17:02:03 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <ignatenko@redhat.com>
17:02:07 <mbooth> Hi
17:02:12 <orionp> hello
17:02:18 <geppetto> #chair mbooth
17:02:18 <zodbot> Current chairs: geppetto mbooth
17:02:20 * limburgher here
17:02:21 <geppetto> #chair orionp
17:02:21 <zodbot> Current chairs: geppetto mbooth orionp
17:02:23 <geppetto> #chair limburgher
17:02:23 <zodbot> Current chairs: geppetto limburgher mbooth orionp
17:02:31 <geppetto> Hey ppl
17:03:21 <racor> hi
17:04:22 <geppetto> #chair racor
17:04:22 <zodbot> Current chairs: geppetto limburgher mbooth orionp racor
17:04:24 <Rathann> hi
17:04:29 <geppetto> #chair Rathann
17:04:29 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp racor
17:05:57 <linuxmodder> .hello linuxmodder
17:05:58 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
17:06:26 <geppetto> No tibbs?
17:06:58 <geppetto> #topic Schedule
17:07:01 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/VUDX6QGQJCY4ZCOE7XHEQNIQL3IFIWE7/
17:07:19 <geppetto> #topic #669 Request (uid, gid) = 389 for the 386 Directory Server
17:07:21 <geppetto> .fpc 669
17:07:22 <zodbot> geppetto: #669 (Request to allocate (uid, gid) = (389, 389) for the 389 Directory Server user "dirsrv") – fpc - https://fedorahosted.org/fpc/ticket/669
17:08:37 <geppetto> I guess I'm mostly fine with this.
17:08:51 <orionp> rhel7 has done this
17:08:55 <linuxmodder> seems logical
17:09:05 <limburgher> Looks good to me.
17:09:15 <geppetto> I'm not sure it 100% needs it, but it seems logical/sane to enforce the uid/gid everyone expects.
17:09:30 <geppetto> +1
17:09:39 <linuxmodder> would make ansible and other scrpting easier I'd think
17:09:42 <linuxmodder> +1
17:10:03 <Rathann> +1 from me
17:10:52 <mbooth> Sure, +1
17:11:00 <limburgher> +1
17:12:02 <geppetto> racor: vote?
17:12:22 <orionp> +1
17:12:56 <racor> geppetto: Sorry, I was distracted and couldn't follow :(
17:13:36 <geppetto> racor: static uid/gid for directory server
17:13:52 <racor> yeh, I am reading
17:14:08 <racor> +1
17:14:27 <geppetto> #action Request (uid, gid) = 389 for the 386 Directory Server (+1:6, 0:0, -1:0)
17:14:42 <geppetto> #topic #672 Python guidelines: change example spec
17:14:48 <geppetto> .fpc 672
17:14:49 <zodbot> geppetto: #672 (Python guidelines: change example spec to match guidelines) – fpc - https://fedorahosted.org/fpc/ticket/672
17:15:48 <geppetto> diff: https://fedoraproject.org/w/index.php?title=User%3AToshio%2FPython&diff=484331&oldid=484330
17:15:57 <ignatenkobrain> I think this is why I came today
17:16:15 <ignatenkobrain> I personally like diff
17:16:37 <ignatenkobrain> because current example is too confusing and actually violates same guidelines on the same page ;)
17:17:01 * geppetto nods … seems fairly simple change
17:17:38 <limburgher> Indeed.
17:18:11 <Rathann> ok, +1
17:18:19 <linuxmodder> I'm fine with the diff as well +1
17:18:39 <limburgher> +a
17:19:01 <geppetto> +1
17:19:22 <orionp> +1
17:19:37 <geppetto> linuxmodder: Hey, it's cool to give opinions and stuff … but it's confusing for me to count chair votes if you vote too.
17:20:01 <linuxmodder> noted
17:21:09 <geppetto> racor: mbooth: Still reading?
17:21:27 <mbooth> python guidelines are hard for me to grok :-)
17:21:29 <mbooth> +1
17:22:03 <racor> no, distracted again ... *&% phone
17:23:24 * geppetto nods … you want me to wait a few more minutes racor or just move on as we have 5 already?
17:25:16 <geppetto> #action Python guidelines: change example spec to match guidelines (+1:5, 0:0, -1:0)
17:25:24 <geppetto> #topic #673 Clarify when (not) to use alternatives
17:25:29 <geppetto> .fpc 673
17:25:30 <zodbot> geppetto: #673 (Clarify when it is (not) appropriate to use alternatives) – fpc - https://fedorahosted.org/fpc/ticket/673
17:25:49 <geppetto> diff: https://fedoraproject.org/w/index.php?title=User%3AToshio%2FAlternatives&diff=484335&oldid=484332
17:26:27 <limburgher> Reminds me of Ringo's grandfather.
17:26:30 <limburgher> VEry clean.
17:27:37 <geppetto> Not sure I 100% agree with the vi part … but it's probably better to not alternative that
17:27:49 <geppetto> I'm +1 in general though
17:28:56 <orionp> I like it +1
17:29:27 <Rathann> ok, +1
17:31:56 <mbooth> +1
17:32:21 <geppetto> limburgher: I assume you are +1?
17:32:36 <limburgher> I am.
17:32:37 <limburgher> +1
17:32:59 <racor> I am back
17:33:10 <geppetto> ok, I'll give you a couple of minutes
17:33:18 <geppetto> at +5 though, if you want to skip
17:38:12 <racor> 0, I am not sure about the consequences of this change, nor am I sure I like them
17:38:58 <ignatenkobrain> racor: that's basically why python-sphinx is broken on f24
17:39:20 <racor> e.g. I do understand why the "user" is being mentioned at all
17:39:52 <racor> alternatives are about system-wide settings
17:40:22 <racor> furthermore, I never found these "modules" helpful.
17:40:37 <geppetto> racor: Exactly … but with most people being the sysadmin of a single person machine it is easy to confuse, I think
17:41:01 <geppetto> Hence the new language to discourage using alternatives for that.
17:41:05 <geppetto> Anyway...
17:41:11 <geppetto> #action Clarify when it is (not) appropriate to use alternatives (+1:5, 0:1, -1:0)
17:41:20 <geppetto> #topic #675 Updated guidelines for per-edition divergent config
17:41:25 <geppetto> .fpc 675
17:41:26 <zodbot> geppetto: #675 (Updated guidelines for per-edition divergent config) – fpc - https://fedorahosted.org/fpc/ticket/675
17:42:16 <racor> Hmm, I am not a native English speaker, ... do native English speaker find the new wording clearer?
17:44:20 <orionp> I think I would switch the ordering of the clauses of the first two new bullet points
17:44:22 <geppetto> diff: https://fedoraproject.org/w/index.php?title=Sgallagh%3APer-Product_Configuration&diff=485317&oldid=485316
17:44:45 <orionp> if the configuration will be symlinked in place, The product-specific configuration file <b>must</b> be located in an appropriate part of the /etc hierarchy
17:45:21 <orionp> also, we capitalize MUST
17:45:40 <orionp> I'll make a new version
17:45:48 <geppetto> cool
17:46:29 <sgallagh> /me is around to answer questions
17:48:45 <geppetto> sgallagh: You fine with orionp's proposed change?
17:49:05 <sgallagh> The bullet-point ordering doesn't matter to me.
17:49:38 <sgallagh> Oh, one thing I meant to check on.
17:49:45 <sgallagh> "atomichost" may not be exactly right...
17:49:58 <sgallagh> We should make sure this matches whatever VARIANT_ID that team is using.
17:49:58 <Rathann> why make a distinction between symlinked and copied configs?
17:49:58 * orionp still editing...
17:50:00 <sgallagh> /me goes to check
17:50:15 <sgallagh> Rathann: Because their location on disk is different...
17:50:17 * geppetto nods … probably good to put the right name in there :)
17:50:30 <Rathann> sgallagh: but why is it different?
17:51:05 <sgallagh> They're using "atomic.host"
17:51:29 <orionp> my proposed additional changes: https://fedoraproject.org/w/index.php?title=Sgallagh%3APer-Product_Configuration&diff=485803&oldid=485317
17:51:50 <sgallagh> Rathann: I'm not sure I understand the question.
17:52:14 <Rathann> sgallagh: why are some configs in /usr/share and some in /etc
17:52:16 <Rathann> ?
17:52:32 <Rathann> and why does it matter if they're going to be symlinked or copied
17:52:48 <sgallagh> Rathann: If they are symlinked, then the place they are stored on-disk must be editable
17:52:56 <sgallagh> (or rather, not removed by RPM on package update)
17:53:16 <sgallagh> If they are copied, then the originals are reference versions and therefore belong in /usr/share and effectively immutable
17:53:33 <sgallagh> I left it up to the package maintainer which approach they prefer
17:53:49 <sgallagh> If FPC wants to dictate that one or the other approach is superior, I'll defer to them on that matter.
17:54:50 <geppetto> I think copied is probably better … esp. as dnf doesn't have the fs diff command still … but I'm happy with it as is, no need to mandate either
17:54:52 <geppetto> +1
17:55:05 <sgallagh> Oh, one more thing
17:55:15 <racor> I prefer symlinks
17:55:29 <sgallagh> The Provides: variant_config() bit should include Atomic as well.
17:55:41 <racor> openly said, I see many similarities to "alternatives"
17:55:45 <sgallagh> I am annoyed with myself that I didn't keep that in sync with VARIANT_ID originally.
17:55:45 <geppetto> Do you want to quickly fix that?
17:56:09 <sgallagh> So I guess the best convention now is just to capitalize the first letter in keeping with the others.
17:56:23 <sgallagh> So `Provides: variant_config(Atomic.host)`
17:57:29 <geppetto> looks fine to me
17:57:50 <Rathann> sgallagh: ok, makes sense, thanks
17:58:40 <limburgher> +1
17:58:47 <sgallagh> racor: That was my original model (alternatives) but that was predicated on the idea that we might want to be able to move the symlink.
17:59:09 <sgallagh> But later on I realized that would be a really bad idea.
18:00:38 <Rathann> anyway, I'm +1 to orionp diff
18:01:02 <sgallagh> I just added the variant_config change
18:01:35 * geppetto nods … +1
18:01:47 <mbooth> +1
18:02:30 <orionp> full changes https://fedoraproject.org/w/index.php?title=Sgallagh%3APer-Product_Configuration&diff=current&oldid=485316
18:02:37 <orionp> +1
18:03:13 <sgallagh> Thanks for the useful feedback, folks.
18:04:20 <geppetto> racor: I think that just leaves you, you want to vote?
18:05:42 <Rathann> I'm afraid I have to drop off now
18:05:47 * geppetto nods
18:05:54 <Rathann> sorry
18:06:02 <geppetto> Rathann: You want ot take a quick look at 678?
18:06:11 <Rathann> hm, ok I guess I can
18:06:44 <geppetto> It's the last new ticket, so would be cool if we can deal with them all today … esp. as I won't be here again next week.
18:08:04 <Rathann> I partially agree with tibbs, and I think the wording should be something like: don't depend on a directory if there's a foo-filesystem package that provides it
18:09:34 <geppetto> Yeh, I assume it would be simple … but more reading looks like nothing we can vote on today
18:10:20 <geppetto> nevermind … see you in a couple of weeks
18:10:31 <Rathann> vacation?
18:10:48 <geppetto> alas. no … medical thing next thursday
18:11:01 <Rathann> oh, good luck, then
18:11:07 * geppetto nods, thanks.
18:11:22 <Rathann> ok, I'm out now, sorry
18:11:25 <Rathann> thanks folks
18:11:29 * geppetto waves
18:11:44 <orionp> later, thanks everyong
18:11:51 <geppetto> racor: Did you want to vote on 675?
18:12:56 <geppetto> #action Updated guidelines for per-edition divergent config (+1:5, 0:0, -1:0)
18:13:00 <geppetto> #topic #678 Ban use of directory Requires
18:13:05 <geppetto> .fpc 678
18:13:06 <zodbot> geppetto: #678 (Ban use of directory Requires) – fpc - https://fedorahosted.org/fpc/ticket/678
18:13:26 <racor> grr, I regret, I was distracted once more ...
18:13:27 <ignatenkobrain> Rathann: agree with your sentence
18:13:49 <geppetto> So … yeh, mostly agree with tibbs. Any draft should probably also put something in about reducing the number of packages that provide random dirs.
18:14:07 <geppetto> racor: Yeh, no problem.
18:14:24 * limburgher nods
18:14:49 <geppetto> Eg. /usr/lib64/girepository-1.0 really looks like it should only be owned by the single package.
18:15:17 <racor> I said everything I have to say about this in https://bugzilla.redhat.com/show_bug.cgi?id=1420399#c1
18:15:29 <racor> i.e. I am with tibbs, too.
18:15:30 <geppetto> gucharmap-libs has no need to be owning it.
18:15:38 <limburgher> Sounds like a lot of things are configured wrong. You should require a package that provides a dir you need, or own it, but not both.
18:15:49 <limburgher> No guideline change needed.
18:16:28 <geppetto> I think there might be a few cases where it's fine for a couple of packages to own a dir. … but the GIrepo one just looks bad/lazy.
18:17:40 <ignatenkobrain> limburgher: you don't get it..
18:17:56 <limburgher> Educate me.
18:18:07 <ignatenkobrain> the thing is that when you have Requires: /usr then it will pull any package which provides this directly
18:18:14 <ignatenkobrain> s/directly/directory/
18:18:14 <geppetto> #info Minimal guideline change needed, if any. Mostly agree that solving this should happen by fixing the packaging that has many many owners of dirs. that are really owned by a single package.
18:18:28 <ignatenkobrain> and this will pull any dependency (most probably not -filesystem)
18:18:48 <geppetto> ignatenkobrain: But there is only a single package that provides /usr … filesystem
18:19:02 <geppetto> ignatenkobrain: This is how it should be for /usr/lib64/girepository-1.0 too
18:19:04 <ignatenkobrain> geppetto: /etc/httpd/conf.d is better example
18:19:15 <limburgher> And the bug you filed for gallery3 is correct, it shouldn't own the dir. It should require the dir.
18:19:15 <ignatenkobrain> it's provided by httpd-filesystem and gallery3
18:19:44 <geppetto> But that's a bug in gallery3, right?
18:19:45 <limburgher> Yes. And it should be fixed.
18:19:53 <limburgher> The maintainer is an idiot.
18:20:16 <limburgher> But the guideline is ok. If it's fixed the problem evaporates.
18:20:19 <ignatenkobrain> limburgher references himself :D
18:20:37 <limburgher> *see recursion
18:20:39 <geppetto> Can anyone think of a way to test this automatically?
18:20:47 <geppetto> IRC selfie?
18:21:11 <ignatenkobrain> for gobject-introspection we probably should add it to some filesystem package, since it's quite often that you don't want to depend on package, but you need directory
18:21:27 <ignatenkobrain> geppetto: not at this moment, but I can think about it
18:21:31 <geppetto> just printing a warning on build "you own this dir XYZ that is also owned by FOO" … not sure how helpful that'll be
18:21:43 <tomspur> Hi
18:21:54 * geppetto nods
18:21:57 <geppetto> #chair tomspur
18:21:57 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp racor tomspur
18:21:58 <geppetto> Hey
18:22:36 <ignatenkobrain> Unfortunately, I have to run.
18:22:47 <ignatenkobrain> geppetto: I will try to think what we can do about this in automatic way
18:22:50 * geppetto nods … about to end anyway
18:23:18 <tomspur> My train connection has changed... Half an hour later than earlier, so it is now worse for the meetings as before
18:23:32 <geppetto> #action ignatenkobrain To think about a way we could automatically detect this on the provider side, and have a autoQA/taskotron thing.
18:23:54 <geppetto> tomspur: Only another month or so before DST changes again
18:24:06 <geppetto> or will that still be bad?
18:24:33 <geppetto> #topic Open Floor
18:24:38 <tomspur> I think when DST change, it works one time for me and then it is bad again
18:25:07 <geppetto> Ahh :(
18:25:21 <geppetto> Ok, so migrating away from trac: https://fedorahosted.org/fpc/ticket/662
18:25:46 <geppetto> I spoke to tibbs yesterday about it and he said it all looks ready to go now, we just aren't migrating tags
18:25:57 <geppetto> As those caused all the problems
18:26:26 <geppetto> So I'd guess that we'll probably be migrating in the next month or so.
18:26:58 <geppetto> That was it from me though, anything from anyone else?
18:31:29 <geppetto> Ok, thanks for coming everyone
18:32:02 <geppetto> #endmeeting