17:02:08 <geppetto> #startmeeting fpc
17:02:08 <zodbot> Meeting started Thu Jan 14 17:02:08 2021 UTC.
17:02:08 <zodbot> This meeting is logged and archived in a public location.
17:02:08 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:08 <zodbot> The meeting name has been set to 'fpc'
17:02:08 <geppetto> #meetingname fpc
17:02:08 <geppetto> #topic Roll Call
17:02:08 <zodbot> The meeting name has been set to 'fpc'
17:02:16 <mhroncok> .hello churchyard
17:02:18 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:02:21 <geppetto> limburgher: Hey
17:02:21 * limburgher still here
17:02:23 <geppetto> #chair limburgher
17:02:23 <zodbot> Current chairs: geppetto limburgher
17:02:25 <mhroncok> I am here but I might need to run away soon
17:02:25 <geppetto> #chair mhroncok
17:02:25 <zodbot> Current chairs: geppetto limburgher mhroncok
17:03:29 * carlwgeorge waves
17:03:43 <geppetto> #chair carlwgeorge
17:03:43 <zodbot> Current chairs: carlwgeorge geppetto limburgher mhroncok
17:04:04 * limburgher waves at geppetto
17:04:28 <geppetto> hey
17:04:29 * decathorpe waves
17:04:33 <geppetto> #chair decathorpe
17:04:33 <zodbot> Current chairs: carlwgeorge decathorpe geppetto limburgher mhroncok
17:08:59 <geppetto> #topic Schedule
17:09:02 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/ISDMVCMBGBYCJQRA22RB5LOIXOKMKALA/
17:09:09 <tibbs> Hey, folks.
17:09:15 <geppetto> #chair tibbs
17:09:15 <zodbot> Current chairs: carlwgeorge decathorpe geppetto limburgher mhroncok tibbs
17:09:18 <geppetto> Hey, just in time :)
17:09:19 <tibbs> Sorry I had to make a pit stop.
17:09:23 <geppetto> no problem
17:09:38 <geppetto> So we have the same issue and PR open we've had for the last month
17:09:46 <geppetto> AFAIK there's no movementon either
17:09:53 <geppetto> *movement
17:09:59 <mhroncok> the nodejs one is new
17:10:03 <tibbs> Lots of movement in the nodejs one.
17:10:38 * geppetto is looking at tagged meeting ones
17:11:11 <tibbs> Yeah, we need to get better about that.
17:11:40 <geppetto> Which issue #?
17:11:44 * geppetto can't find it
17:11:55 <geppetto> But I'm running mostly on red bull today, so it could just be me
17:12:10 <tibbs> It's PR 1034
17:12:11 <mhroncok> it is a PR
17:12:17 <tibbs> https://pagure.io/packaging-committee/pull-request/1034
17:12:33 <geppetto> Ahh
17:12:35 <tibbs> Which is something else we need to figure out how to deal with: PRs without tickets.
17:13:01 <geppetto> #topic PR#1034 -  Change the prefered method of nodejs packaging to bundle nodejs libraries.
17:13:03 <tibbs> I think the smart thing is really to just deal with every ticket not otherwise tagged.
17:13:18 <geppetto> #link https://pagure.io/packaging-committee/pull-request/1034
17:14:27 <tibbs> I mean, obviously we're going to be sad that the end result is "bundle everything" but the ecosystem is just so broken and it's not our call in any case.
17:15:41 <limburgher> At least the npm ecosystem has a good security track record.
17:15:44 * limburgher ducks
17:16:01 <decathorpe> limburgher: gnihihi
17:16:02 <limburgher> But yeah, it is what it is.
17:16:37 <limburgher> Better to do the bad thing well than badly.
17:16:44 <geppetto> So as a PR, anyone have any objections to merging?
17:16:58 <tibbs> It's had a lot of work and it's pretty good.
17:16:59 <geppetto> Or … what was the reason to disuccs it vs. just merging it?
17:17:17 <limburgher> I say merge. +1
17:17:23 <decathorpe> no objections to merging. PR has gone through a lot of work. although converting to sembr at some point would be nice. right now some lines are really long.
17:18:00 <mhroncok> +1 for the guidelines
17:18:02 * geppetto nods
17:18:02 <tibbs> They were long in the original because we hadn't fixed it up yet and I assume Troy just followed suit.
17:18:09 <geppetto> yeh
17:18:15 <mhroncok> I don't care if we merge it as is or reformat, but I am not volunteering
17:18:32 <tibbs> Only other thing is perhaps we can pull out the example spec into the examples directory.
17:18:37 <tibbs> But we can fix all of that after merging.
17:18:53 <decathorpe> tibbs: +1
17:19:06 <tibbs> My question is whether we should actually do this now, or if it's contingent on the change being approved or something like that.
17:19:39 <tibbs> Fesco issue was approved, so I do think we're good.
17:19:47 <decathorpe> .fesco 2523 was approved, yes.
17:19:47 <zodbot> decathorpe: Error: '2523 was approved, yes.' is not a valid integer.
17:19:56 <decathorpe> bad zodbot.
17:20:02 <geppetto> lol
17:20:45 <tibbs> So I guess +1 to merge and then I'll fix up with sembre and lifting out the example.
17:21:01 <tibbs> sembrs?  line breaks?
17:23:12 <tibbs> We lost Miro?
17:23:14 <geppetto> Yeh, I'm fine with that … you want to click the merge button tibbs ?
17:24:02 <tibbs> II can, but did we get sufficient votes?  Or does it matter?
17:25:01 <tibbs> If it does, I think I see +3.
17:25:13 <geppetto> for PRs I didn't think we stuck to +5
17:25:27 <geppetto> which is why I just asked if anyone had an objection
17:26:01 <geppetto> But I'm fine to +1
17:26:11 <decathorpe> +1 as well
17:26:18 <tibbs> I don''t really see why we'd treat them any differently than a ticket, honestly.
17:26:34 <geppetto> tibbs: I guess thinking more on it that was supposed to be smaller PRs
17:26:38 <tibbs> I never understood why the github model separates tickets and PRs.  They really should just have the same interface.
17:27:01 * geppetto <- still on red bull
17:27:21 <tibbs> Yeah I'm feeling pretty terrible this morning myself.  Not really sure why, either.
17:27:27 <limburgher> geppetto: w or wo vodka?
17:27:33 <geppetto> #action Change the prefered method of nodejs packaging to bundle nodejs libraries (+1:5, 0:0, -1:0)
17:27:34 <sgallagh> tibbs: They do have the same interface in the API, FWIW
17:28:07 <geppetto> limburgher: just red bull … although maybe scotch later
17:28:22 <geppetto> sgallagh: huh, interesting
17:28:28 <limburgher> geppetto: ok, but don't mix those. ew.
17:28:55 <tibbs> If there ever was a year to start consuming alcohol, 2020 was it but I managed to resist.
17:28:55 <carlwgeorge> there's even an api call you can do that converts an issue into a pull request, but it has weird side effects
17:30:17 <limburgher> tibbs: Impressive.
17:30:45 <tibbs> 50 years of watching other people get drunk.
17:31:39 <tibbs> OK, merge button clicked.
17:32:43 <tibbs> I'll work on the other stuff today since I don't have much else to do (for the moment, at least).
17:33:33 <geppetto> Ok, cool
17:33:37 <geppetto> #topic Open Floor
17:33:42 <limburgher> I have to go grab lunch before an afternoon of $dayjob meetings, do we have anything else?
17:34:03 <geppetto> limburgher: I don't think so … about to close in 2 minutes unless anyone brings anything up
17:34:25 <limburgher> Ok, you'll have quorum if you need it. Toodles!
17:35:40 <geppetto> And on that note …
17:35:44 <geppetto> #endmeeting