17:00:20 <geppetto> #startmeeting fpc
17:00:20 <zodbot> Meeting started Thu Dec  1 17:00:20 2022 UTC.
17:00:20 <zodbot> This meeting is logged and archived in a public location.
17:00:20 <zodbot> The chair is geppetto. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:20 <zodbot> The meeting name has been set to 'fpc'
17:00:20 <geppetto> #meetingname fpc
17:00:20 <zodbot> The meeting name has been set to 'fpc'
17:00:21 <geppetto> #topic Roll Call
17:00:40 <tibbs> Hello.
17:00:52 <geppetto> #chair tibbs
17:00:52 <zodbot> Current chairs: geppetto tibbs
17:01:13 <GwynCieslasheher> here
17:01:19 <geppetto> #chair GwynCieslasheher
17:01:19 <zodbot> Current chairs: GwynCieslasheher geppetto tibbs
17:04:04 <decathorpe> good evening, morning, whatever :)
17:04:37 <tibbs> It's always Tuesday morning.
17:04:40 <geppetto> #chair decathorpe
17:04:40 <zodbot> Current chairs: GwynCieslasheher decathorpe geppetto tibbs
17:05:13 <geppetto> tibbs: only in texas
17:11:59 <kalev> before I forget: I asked for an ldc bootstrap exception in a ticket a few months ago, does it need more votes or is it approved now? it had 3 +1's last time I looked
17:12:25 <tibbs> I thought that was approved, but it's been a while.
17:12:50 <kalev> ah, nice
17:13:04 <decathorpe> .fpc 1209
17:13:05 <zodbot> decathorpe: Issue #1209: Bootstrap Exception for ldc on ppc64le - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/1209
17:13:08 <tibbs> I guess not; just the three acks.  https://pagure.io/packaging-committee/issue/1209
17:13:17 <decathorpe> looks like I missed this ticket. +1 for the record ...
17:13:28 <tibbs> No idea why that didn't move forward.
17:13:46 <kalev> I wasn't in a particular hurry, so it's fine :)
17:15:04 <geppetto> Alwaus a good plan with the FPC 👀
17:15:35 <decathorpe> it's probably not going to get many more votes than that anyway, is it?
17:16:07 <geppetto> it got 5 now, so someone get the done stamp out
17:16:23 <geppetto> 🚢
17:16:25 <decathorpe> 🦭 of approval
17:16:31 <GwynCieslasheher> Yiss
17:17:23 <kalev> awesome, thanks everybody!
17:17:53 <tibbs> Thanks for pinging, and sorry for the delay.
17:18:02 <geppetto> #topic Open Floor
17:18:37 <decathorpe> who's going to push the "Close: Accepted" button? :)
17:18:51 <geppetto> No movement on any of the open tickets, but …
17:18:53 <geppetto> .fpc 1159
17:18:54 <zodbot> geppetto: Issue #1159: Ban use of %configure in %prep - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/1159
17:19:16 <geppetto> We said we'd come back to it when F37 progresses … and it's out now
17:19:40 <geppetto> F36 isn't EOL (or that close), so not sure if we need to wait another 5 months or so?
17:19:42 <tibbs> So that's about discussing the %conf section.
17:20:33 <decathorpe> but the ticket was about banning "%configure" in %prep, and that was pretty much uncontroversial anyway?
17:20:36 * geppetto nods
17:20:51 <tibbs> I suspect that due to EL it just won't see any kind of wide adoption for ages, but we should probably at least think about what we would do with it at some point.
17:20:52 <decathorpe> whether we document the new %conf section or not is kind of orthogonal
17:21:18 <geppetto> I think it kind of morphed
17:21:34 <tibbs> The problem is that every time we wade into an issue like the one that started the ticket, we get into a mess of whether to run autoreconf and that kind of thing.
17:21:45 <geppetto> Maybe we just want to change the wording to ban, as asked … and then change again for the %conf section?
17:22:52 <tibbs> But it should be easy to just say "pre-build configuration, such as calls to the %configure macro, should not be placed in the %prep section but instead either the %build or %conf sections" and kind of leave it at that.
17:24:11 <decathorpe> Asterisk: %conf section is only supported with RPM 4.18+
17:24:49 <decathorpe> And I haven't seen any package use it, so I'm not even sure if it's tested or even works
17:24:56 <decathorpe> So I'd be hesitant to document it yet
17:26:35 <tibbs> I'm in that weird zone where I probably wouldn't use it yet just in case I have to push something back that far, but it works fine.
17:26:57 * geppetto nods
17:28:27 <decathorpe> I don't know why we're making this so complicated. Banning %configure in %prep is easy and uncontroversial. Conflating it with the issue of whether %conf section should be documented or not is not really helpful right now
17:29:11 <geppetto> #action decathorpe will fix up wording to ban use of %configure in %prep
17:29:22 <decathorpe> :D
17:29:43 <geppetto> ᕕ( ᐛ )ᕗ
17:29:50 * decathorpe goes looking for the end of his TODO list
17:30:00 <decathorpe> 📜
17:30:34 <geppetto> % 📜
17:30:35 <geppetto> zsh: command not found: 📜
17:30:46 <geppetto> Looks like you're free
17:31:11 <decathorpe> 🧦
17:31:30 <tibbs> The real problem here is that the guidelines around autoconf are just really poor.
17:31:40 <tibbs> So touching on that subject at all brings up all of the other stuff that needs doing.
17:32:13 * geppetto nods
17:32:16 <decathorpe> I'll look into it. Maybe look at the CMake / Meson guidelines and make a simple new page for Autotools ..
17:32:25 <tibbs> I spent some time on it and realized that anything we could do would anger someone somewhere.
17:32:39 <geppetto> We probably need to be better at changing enough to be better instead of getting stuck on perfect
17:32:39 <tibbs> I had written most of such a new page.
17:32:59 <geppetto> decathorpe: That seems like a lot
17:33:30 <geppetto> I'd be fine with a warning somewhere just saying "don't put %configure in %prep"
17:33:50 <decathorpe> yeah that would be first step
17:34:00 <decathorpe> and if I still got motivation after that ...
17:34:06 * geppetto nods
17:34:07 <geppetto> +1
17:35:10 <geppetto> Anything anyone else wants to talk about?
17:35:31 <tibbs> A couple of new tickets came in recently.
17:36:02 <tibbs> I thought about them but didn't think my responses would be productive.
17:36:10 <tibbs> .fpc 1230
17:36:11 <zodbot> tibbs: Issue #1230: [master] Doc issue in file guidelines/modules/ROOT/pages/Versioning.adoc - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/1230
17:36:18 <tibbs> .f0c1231
17:36:24 <tibbs> .fpc1231
17:36:37 <tibbs> Or whatever.  Not sure what is wrong with my keyboard.
17:36:43 <geppetto> .fpc 1231
17:36:44 <zodbot> geppetto: Issue #1231: [master] Doc issue in file guidelines/modules/ROOT/pages/Versioning.adoc - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/1231
17:37:11 <decathorpe> most of these look like they expected contents of the RPM docs dumped in the Packaging Guidelines
17:37:16 <tibbs> I want to say "none of that belongs in the packaging guidelines".
17:38:29 <geppetto> feel free to say that and close
17:38:58 <tibbs> I can do that.
17:42:04 <geppetto> Anything else, or you want 15 minutes back?
17:45:06 <tibbs> I'm responding to those two tickets.
17:45:15 <geppetto> #endmeeting