21:00:37 <pravins> #startmeeting g11n (l10n focused)
21:00:37 <zodbot> Meeting started Wed May  4 21:00:37 2016 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:37 <zodbot> The meeting name has been set to 'g11n_(l10n_focused)'
21:00:41 <pravins> #meetingname g11n (l10n focused)
21:00:41 <zodbot> The meeting name has been set to 'g11n_(l10n_focused)'
21:00:48 <pravins> #topic agenda and roll call
21:00:48 <pravins> #link https://fedoraproject.org/wiki/G11N/Meetings/2016-05-04
21:00:59 <noriko> hi
21:01:00 <pravins> Do we have quorum today? :)
21:01:12 <pravins> hi noriko and very good morning.
21:01:19 <pravins> #chair noriko
21:01:19 <zodbot> Current chairs: noriko pravins
21:01:24 <pravins> hi Jobava :)
21:01:27 <pravins> #chair Jobava
21:01:27 <zodbot> Current chairs: Jobava noriko pravins
21:01:29 <linuxmodder> .hello linuxmodder
21:01:30 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
21:01:35 <noriko> pravins, good evening :-)
21:01:44 <linuxmodder> its 1700 hrs here
21:01:55 <pravins> hi linuxmodder :)
21:02:09 <pravins> linuxmodder: in that case noriko good evening suite more for you ;)
21:02:17 <pravins> here 02.30am
21:02:26 <linuxmodder> dear god
21:02:32 <pravins> #chair linuxmodder
21:02:32 <zodbot> Current chairs: Jobava linuxmodder noriko pravins
21:02:33 <linuxmodder> that is  early for a mtg
21:03:11 <linuxmodder> no time to browse the agenda today  anyone have the link handy ?
21:03:16 <pravins> yeah.
21:03:21 <pravins> https://fedoraproject.org/wiki/G11N/Meetings/2016-05-04
21:03:21 <Jobava> the bane of dispersed teams, someone's got to wake up at 2AM :p
21:03:34 <pravins> exactly !!
21:03:55 <pravins> hi jonatoni :)
21:03:59 <pravins> #chair jonatoni
21:03:59 <zodbot> Current chairs: Jobava jonatoni linuxmodder noriko pravins
21:04:02 <pravins> just in time !!
21:04:18 <linuxmodder> famna meetings have gone to  midnight for us before :)
21:04:21 <jonatoni> Hey pravins :)
21:04:54 <linuxmodder> !  open floor request later
21:04:58 <pravins> i often miss Fedora marketing meeting due to this horrible time, i think it starts at 03:30 IST.
21:05:02 <pravins> sure, lets start with agenda
21:05:09 <pravins> #topic Upcoming schedule
21:05:09 <pravins> #link https://fedoraproject.org/wiki/Releases/24/Schedule
21:05:13 <pravins> #info 2016-05-10  	Beta Release
21:05:13 <pravins> #info 2016-05-31  	Final Freeze (*)
21:05:13 <pravins> #info 2016-06-14 	Fedora 24 Final Release (GA)
21:05:20 <pravins> If you might have noticed earlier..
21:05:24 <pravins> In last Go/No-Go meeting, its decided slip Beta release by 1 week.
21:05:44 <pravins> So final release is in 14th June now.
21:05:48 <pravins> #link https://meetbot.fedoraproject.org/fedora-meeting/2016-04-28/f24-beta-go_no_go-meeting.2016-04-28-17.00.html
21:05:53 <linuxmodder> on the first note anyone with the spins / labs teams  I would love some input for  f24 talkingpoints
21:06:43 <pravins> AFAIK no one looks around from spins/labs teams. did i missed anyone?
21:07:35 <pravins> #info jibecfed is not feeling well today and provided updates via email earlier.
21:07:45 <pravins> aeng: hey :)
21:07:48 <pravins> #chair aeng
21:07:48 <zodbot> Current chairs: Jobava aeng jonatoni linuxmodder noriko pravins
21:08:04 <pravins> looking complete team now !!
21:08:06 <aeng> hi
21:08:21 <pravins> #topic  Mismatch in Zanata username and FAS name
21:08:21 <pravins> #link  https://fedorahosted.org/G11N/ticket/22
21:08:42 <pravins> aeng: this action item pending on you ;)
21:08:56 <cydrobolt> Hi
21:08:59 <aeng> ok
21:09:15 <pravins> Do we have any update? sorry if you are still settling down with laptop :)
21:09:38 <aeng> i havent looked at it at to be honest
21:09:51 <pravins> no problem.
21:09:56 <aeng> in my todo list
21:10:12 <pravins> In last meeting, we decided to fix first login issue at Zanata side. https://zanata.atlassian.net/browse/ZNTA-855
21:10:25 <pravins> and then find out users with different usernames by running sql script.
21:10:47 <pravins> lets discuss about it offline during this week.
21:10:47 <aeng> yeah..... so its related
21:11:09 <pravins> hi cydrobolt_ )
21:11:44 <pravins> cydrobolt_:  feel free to introduce yourself :)
21:12:15 <pravins> moving to next topic
21:12:17 <pravins> #topic  Fedora 24 L10N test day planning
21:12:25 <pravins> #link https://fedorahosted.org/G11N/ticket/18
21:12:25 <pravins> #link https://fedorahosted.org/fedora-qa/ticket/480
21:12:34 <Southern_Gentlem> .hello jbwillia
21:12:35 <zodbot> Southern_Gentlem: jbwillia 'Ben Williams' <vaioof@yahoo.com>
21:12:57 <pravins> hi Southern_Gentlem :)
21:12:59 <pravins> #chair Southern_Gentlem
21:12:59 <zodbot> Current chairs: Jobava Southern_Gentlem aeng jonatoni linuxmodder noriko pravins
21:13:12 <pravins> noriko: action item pending on you for this :)
21:13:21 <pravins> Did you able to do bug triaging for this?
21:13:42 <pravins> Also not sure if Ani planning to write report on community blog or not.
21:13:44 <noriko> pravins, just started, but not complete yet :-)
21:14:06 <noriko> https://fedoraproject.org/wiki/Test_Day:2016-03-29_Translation_Test_Day#Fedora_24_Test_Day_Report
21:14:09 <pravins> I think once we done this, we can close the ticket.
21:14:25 <noriko> nah, here, https://fedoraproject.org/wiki/Test_Day:2016-03-29_Translation_Test_Day#Fedora_24_Bug_Triage
21:14:40 <pravins> yeah, so many bugs reported. Great work !!
21:14:52 <noriko> pravins, it looks decent actions required to fix bugs.
21:15:11 <noriko> it is good preparation for f25
21:15:35 <Jobava> oh, today is the translation deadline? can I sneak in some last minute strings?
21:15:55 <pravins> noriko: good point !!
21:16:11 <pravins> #info Translation test day bug report can be useful for F25 planning.
21:16:34 <pravins> Jobava: Translation deadline was on 5th April.
21:16:47 <pravins> noriko: Can we now?
21:16:47 <Jobava> ah, American dates :p
21:16:52 <pravins> ha ha
21:17:04 <pravins> words are better than number ;)
21:17:44 <noriko> deadline was 5-Apr
21:18:09 <noriko> pravins, correct ;p
21:18:18 <Jobava> anyway, anaconda should be fine, I guess the websites have a little more leeway
21:18:19 <pravins> #action pravins to ping Ani for post in community blog for test days.
21:18:39 <Jobava> Romanian anaconda at least
21:18:41 <noriko> Jobava, agree, anaconda might have a chance, just no guarantee
21:19:10 <pravins> feel free to ping Anaconda team.
21:19:15 <pravins> moving to next topic
21:19:24 <pravins> #topic  Localization Fedora Developer Portal to other languages
21:19:47 <pravins> #link https://fedorahosted.org/fedora-infrastructure/ticket/5265
21:20:16 <pravins> jibecfed following this closely and provided update
21:20:27 <pravins> "The developer portal will also be translatable but it's still a work in progress. Two tickets on the subject :"
21:20:32 <pravins> #link https://github.com/developer-portal/content/issues/131
21:21:37 <pravins> aeng: might be you can help into above issue.
21:22:11 <aeng> hmm.. whats the issue?
21:22:47 <pravins> There is still not process implemented for translation.
21:22:53 <pravins> i.e. generating .pot file etc.
21:23:02 <aeng> well.. that i18n
21:23:21 <aeng> need to check their project type
21:23:24 <aeng> and their repo
21:23:40 <pravins> right.
21:24:23 <pravins> they are working on it presently, lets keep eye on it.
21:25:44 <pravins> looks like still no project in zanata for Developer portal.
21:25:51 <pravins> lets move ahead.
21:25:57 <pravins> #topic  G11N infrastructure requirements
21:25:57 <pravins> #link https://fedorahosted.org/G11N/ticket/1
21:26:15 <pravins> While clean trac, i found this ticket still open.
21:26:25 <pravins> one of the reason it our Wiki is still in Draft mode.
21:26:33 <pravins> #link https://fedoraproject.org/wiki/G11N
21:26:50 <pravins> We did number of cleanups recently
21:27:01 <pravins> at least i feel good to move it as a stable
21:27:11 <pravins> please provide your opinion..
21:28:16 <pravins> #chair
21:28:16 <zodbot> Current chairs: Jobava Southern_Gentlem aeng jonatoni linuxmodder noriko pravins
21:28:21 <Jobava> BTW, g11n-wise I am partial to moving websites off Zanata and into Pontoon, since it allows localizers to translate directly from the website's interface, the best context is the actual UI
21:28:52 <Jobava> https://pontoon.mozilla.org/
21:30:20 <Jobava> the release cycle of websites is also different and and can be more flexible
21:30:33 <pravins> looks interesting, is it different tool? or Each website need to add some hooks for it?
21:30:41 <pravins> I am sure people must be having lots of questions on this.
21:31:01 <pravins> #idea Of using Pontoon for Website translation
21:31:13 <pravins> Jobava: i think, good to start thread with this on trans.
21:31:17 <Jobava> sure, I can discuss this in more detail and some more complex apps (stateful or very dynamic) may need to adjust a little
21:32:16 <jonatoni> +1 with Jobava
21:32:27 <Jobava> for example, Firefox follows a 6 week release cycle: development, beta, alpha, giving 18 weeks between versions, Mozilla websites can be updated every day
21:32:57 <Jobava> development, beta, release*
21:33:15 <aeng> Pontoon is a in website translation tools
21:33:25 <aeng> basically.. you can see the context in there
21:33:49 <Jobava> also less hassle for developers to leave adequate comments
21:34:01 <aeng> my opinion, its good for static html translations, but when you got server interaction to change the content....
21:34:07 <aeng> it might not work
21:34:18 <Jobava> yep, stateful or very dynamic would have to adapt to pontoon
21:34:42 <aeng> Most of the fedora package is dynamic content
21:34:45 <Jobava> but IMO, it's still a good exercise since it's an incentive to modularize a little bit and should increase testing too
21:35:03 <aeng> but that would mean you will need to train translators on different platform
21:35:09 <Jobava> I mean dynamic as in single-page apps or stuff that's very stateful
21:35:17 <aeng> and there;s no statistic you can get from it
21:35:43 <pravins> aha, you means FedBus etc..
21:35:50 <aeng> and no integration with Fedora openid
21:36:12 <Jobava> it's got Persona integration for now, although persona is 'sunsetted' at the end of this year
21:36:22 <aeng> but anyway.. as I mentioned.. is only good for static content.. and there's google webtool kit that already does that
21:37:18 <Jobava> Pontoon doesn't care what generated the content, as long as the strings are marked in a certain way (attribute data-l10n-id to the particular html element)
21:37:20 <pravins> Lets discuss this idea on trans list and see what other people has opinion about it.
21:37:41 <Jobava> it doesn't care if it was server-generated or ajax, as long as it stays put and isn't stateful :)
21:37:56 <noriko> +1 pravins
21:38:05 * pravins need to do learn about it :)
21:38:25 <Jobava> if stateful then it needs some mocks or splayed out layout for testing (which is good in general, for better testability)
21:38:51 <noriko> here not enough translators are attending, cz simply this is not translators meeting.
21:39:06 <noriko> it would be good to discuss on ML first?
21:39:20 <Jobava> and when statefulness can't be fixed, Pontoon still allows the classic 'list of strings' localization, even for strings not visible in the webview
21:39:32 <pravins> Jobava: thanks for bringing this idea in.
21:40:16 <pravins> coming back to topic
21:40:38 <pravins> Can we move https://fedoraproject.org/wiki/G11N from Draft to ready?
21:42:33 <pravins> 18min to go for meeting..
21:43:31 <aeng> i think it can go to ready
21:43:40 <aeng> we can always improve that as we getting more feedback
21:43:41 <noriko> yup, +1
21:43:51 <noriko> ypyp, aeng
21:43:51 <jonatoni> +1
21:44:03 * pravins also things same :)
21:44:05 <pravins> +1
21:44:31 <pravins> 4+ are good enough !!
21:44:34 <pravins> next topic
21:44:36 <pravins> #topic Live media with langpacks included
21:44:40 <pravins> https://fedorahosted.org/G11N/ticket/17
21:44:47 <pravins> This issue is still open.
21:44:54 <pravins> No reply on email from Server WG.
21:46:00 <pravins> #topic Topic from mailing list
21:46:13 <pravins> #info  strings in Comps
21:46:33 <pravins> #link  https://bugzilla.redhat.com/show_bug.cgi?id=1332181
21:46:40 <pravins> This is resolved now. :)
21:47:02 <pravins> thanks to Parag and Kevin for fixing this quickly.
21:47:50 <pravins> #info Make the work of translator teams easier
21:48:01 <pravins> I have not followed this thread that well.
21:48:26 <pravins> But it mentions we almost done with Webhook. aeng do you have any update on it?
21:48:52 <aeng> yes, getting there.. so waiting for last review and it will be ready in Zanata 4.0
21:48:58 <aeng> should be done in this sprint
21:49:06 <aeng> https://github.com/zanata/zanata-server/pull/1137
21:49:06 <pravins> excellent
21:49:25 <pravins> #info  Translation Gnome Boxes
21:49:39 <pravins> Thanks Jobava for answering query on mailing list itself :)
21:50:43 <pravins> #info Release Notes translation
21:51:09 <pravins> There is not clear information about process.
21:51:21 <pravins> jibecfed has sent email on docs list earlier. jibecfed
21:51:28 <pravins> #link https://lists.fedoraproject.org/archives/list/docs@lists.fedoraproject.org/thread/ZKZAMX3EZYEPHCOLQWRL6M3NTPQBINJS/
21:52:32 <pravins> moving to next topic
21:52:46 <pravins> #topic  Next Meeting Date and Time
21:53:18 <pravins> As we follow, it should be 2016/05/18 and at 04:30 UTC
21:53:50 <pravins> If anyone interested to host, please feel free :)
21:54:04 <pravins> I would be more happy, if can get someone to host this time meeting ;)
21:54:42 <pravins> Almost done with all topics
21:54:43 <pravins> #topic Open Floor
21:55:05 <Jobava> I would propose putting fedora website on a different release cycle
21:55:18 <Jobava> since updating them does not necessarily involve code changes
21:55:51 <pravins> even docs has a different schedule.
21:55:54 <Jobava> and it would allow localizers to see their contributions live sooner than the longer distro cycle
21:56:13 <pravins> indeed, it will be very useful for trans, if we can get more clear idea on website and docs schedule.
21:56:27 <noriko> https://fedorapeople.org/groups/schedule/f-24/f-24-web-tasks.html
21:56:42 <noriko> web team has their own task schedule, which include translation schedule.
21:57:22 <noriko> they usually post the notification when they push POT/POs to zanata.
21:57:23 <Jobava> I would change string freeze to "suggested translation deadline" while still allowing updates throughout
21:57:49 <noriko> ?
21:57:55 <Jobava> and when new strings appear to just automatically notify people
21:58:08 <Jobava> just for websites
21:59:13 <noriko> I don't think we can change the web team string freeze date by ourselves??
21:59:19 <Jobava> not sure how easy such a more would be for fedora itself, to automatically update the iso after a locale has localized past deadline
22:00:05 <Jobava> because right now, with the 6-9 month release cycle, it takes a long time between contributions and actual product results
22:00:05 <pravins> Yes, it can be better word for "Website String Freeze"
22:00:55 <pravins> for GA its not possible.
22:01:01 <Jobava> i.e. if we can shorten the time between contributions and release it can help engage people more
22:01:23 <Jobava> this is just for localization and not actual core development
22:02:32 <pravins> Fedora schedule is 6 months, though for F21 we took almost a year.
22:02:44 <noriko> Jobava, pravins I think this topic should be discussed at fedora-g11n channel, rather than meeting.
22:03:02 <pravins> right, almost closing time :)
22:03:05 <Jobava> sure, I won't delay this longer, it was a good meeting :)
22:03:34 <pravins> Few quick update
22:03:39 <pravins> from Jeans
22:03:47 <pravins> He asked fedora-hubs team about translation :https://pagure.io/fedora-hubs/issue/163
22:04:12 <pravins> #info We are improving the sync asknot to make it automatic https://github.com/fedora-infra/asknot-ng/issues/69
22:04:24 <pravins> Lets close in 1 minutes if nothing more..
22:05:26 <pravins> thanks everyone for meeting.
22:05:31 <pravins> #endmeeting