14:00:14 <banas> #startmeeting
14:00:14 <zodbot> Meeting started Wed Oct  1 14:00:14 2014 UTC.  The chair is banas. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:37 <banas> #meetingname GlitterGallery Weekly Meeting Oct 1 2014
14:00:37 <zodbot> The meeting name has been set to 'glittergallery_weekly_meeting_oct_1_2014'
14:00:50 <banas> #chair rohitpaulk
14:00:50 <zodbot> Current chairs: banas rohitpaulk
14:00:58 <banas> #topic Rollcall
14:01:17 <banas> rohitpaulk: if you haven't been to a zodbot run meeting before, we do this:
14:01:23 <banas> .fasinfo sarupbanskota
14:01:24 <zodbot> banas: User: sarupbanskota, Name: Sarup Banskota, email: sbanskota08@gmail.com, Creation: 2013-03-28, IRC Nick: banas, Timezone: Asia/Kolkata, Locale: en, GPG key ID: , Status: active
14:01:27 <zodbot> banas: Unapproved Groups: summer-coding
14:01:29 <zodbot> banas: Approved Groups: ambassadors designteam cla_done cla_fpca
14:01:44 <rohitpaulk> .fasinfo rohitpaulk
14:01:45 <zodbot> rohitpaulk: User: rohitpaulk, Name: Rohit Paul Kuruvilla, email: rohitkuruvilla@yahoo.co.in, Creation: 2014-02-25, IRC Nick: , Timezone: Asia/Kolkata, Locale: en, GPG key ID: , Status: active
14:01:48 <zodbot> rohitpaulk: Approved Groups: fedorabugs cla_done cla_fpca
14:01:59 <banas> cool, moving on
14:02:01 <rohitpaulk> that it?
14:02:02 <rohitpaulk> ok
14:02:17 <banas> #topic GG status
14:02:49 <banas> so Emily's travelling, so she'll probably help with the design team demo once she's bac
14:02:51 <banas> back
14:03:10 <rohitpaulk> cool
14:03:23 <banas> in the meanwhile, should we look around the app, remove any stray links of features that aren't fully built yet?
14:03:29 <rohitpaulk> I was hoping for the newcomers to open a ton on issues
14:03:39 * banas hasn't looked at gg for a bit now ;)
14:03:41 <rohitpaulk> We should. I think i fished out the svg_edit links
14:03:48 <rohitpaulk> not sure though.
14:04:30 <banas> ok, we don't have much to discuss anyway, so let's use this time to find out stray links and report them on an issue?
14:04:40 <banas> after the meeting, we can remove them
14:05:04 <rohitpaulk> sure
14:05:16 * banas fires rails server
14:06:27 <banas> also Paul, could you precompile once and push a commit to your demo? I think I have some stuff here that I precompiled and pushed, but didn't add to the public repo yet
14:06:43 <rohitpaulk> Isn't the precompile automatic?
14:07:37 <banas> no, i think we disabled it, lemme check
14:08:22 <rohitpaulk> ok yes we did
14:08:26 <rohitpaulk> I'm precompiling now
14:08:29 <banas> yep we have disable_asset_compilation marked
14:08:47 <banas> #link https://github.com/glittergallery/GlitterGallery/issues/166
14:09:07 <rohitpaulk> shall I pull off the master itself?
14:09:17 <rohitpaulk> or do you want me to take the redesign branch or something?
14:09:45 <banas> no just do it through master
14:09:51 <banas> it's ok
14:10:02 <rohitpaulk> okay
14:10:36 <banas> i think i removed redesign for now also - there's just a slideshow branch
14:10:47 <banas> which we decided to ingnore for a while
14:10:52 <rohitpaulk> aah yh what happened to that? I haven't seen it yet... functional?
14:10:54 <rohitpaulk> okay cool
14:11:44 <banas> it was semi-functional, and then emily and i were discussing how that causes some problems: 1) variable sizes 2) have to load comments too which makes it too cluttered
14:11:59 <banas> so we decided to ignore that for now
14:11:59 <rohitpaulk> ok
14:13:06 <rohitpaulk> That was quick :D
14:13:30 <rohitpaulk> Asset compilation is super slow on a vagrant machine :/
14:14:11 <banas> lol yeh :D
14:14:27 <banas> ooh, why on vagrant ;)
14:15:03 <rohitpaulk> Some bundler conflicts with rugged
14:15:27 <banas> alright
14:15:39 <banas> i added two things to #166
14:15:59 <rohitpaulk> I'm pushing to the demo now.
14:16:32 <banas> ok, thanks!
14:16:53 <banas> #action banas remove stray links from #166
14:17:03 <banas> #action rohitpaulk remove stray links from #166
14:17:22 <rohitpaulk> I've got the AJAX comments setup left, I'll get that done this weekend.
14:17:34 <rohitpaulk> #action rohitpaulk fix AJAX comments
14:19:16 <banas> cool! i've added about 6 things to be removed now
14:19:37 <rohitpaulk> Where did you mention that the CSS would update if I precompile?
14:20:49 <banas> um, i thought i had made changes - i didn't?
14:20:54 <rohitpaulk> I've pushed to master on GlitterGallery/GlitterGallery too.
14:21:44 <banas> #info we are 500 commits now \o/
14:21:49 <rohitpaulk> woah :D
14:22:42 <banas> for eg, i think your demo had a navbar on the login page
14:22:57 <banas> ah, now it's gone
14:23:15 <banas> so something did compile that wasn't earlier
14:23:47 <rohitpaulk> and the offcanvas is working, i dont' think it was before
14:24:17 <banas> yes, that too
14:24:27 <banas> that was because of some js not being compiled
14:24:52 <rohitpaulk> right
14:25:00 * banas is on /inspire page and notices some folks have tried out the project!
14:25:45 <rohitpaulk> ah banas - there is one serious usability issue
14:25:54 <banas> shoot!
14:26:06 <rohitpaulk> the nav buttons on each page
14:26:08 <rohitpaulk> the grey ones
14:26:14 <rohitpaulk> You can only click on the text.
14:26:30 <rohitpaulk> I always click on the button area and wait for the page to load
14:26:32 <rohitpaulk> and then remember.
14:26:33 <banas> oh thanks for reminding of that, i'll fix that!
14:26:54 <rohitpaulk> Ideal fix would be to make the whole thing clickable... if not that, atleast give the text an underline on hover :)
14:27:20 <banas> yeh, i will make the box clickable. i wanted to do it when i first made it, but then ah :P
14:27:30 <banas> could you start an issue for it?
14:27:35 <rohitpaulk> And remember you'd mentioned that you wanted to get rid of the bold on hover for the other links?
14:27:39 <rohitpaulk> and go with teh underline..
14:27:43 <rohitpaulk> Yh on it
14:28:39 <banas> yep, i will make some improvements to it while im on that issue :) if you have ideas, just put them on the issue!
14:28:53 <rohitpaulk> sure :)
14:29:24 * banas notices another stray link
14:30:18 <banas> cool, so this stuff should be easy to fix.
14:31:42 <rohitpaulk> yep
14:31:57 <banas> rohitpaulk: iirc, we planned to think of next set of features etc in this meeting
14:32:15 <rohitpaulk> We need more features for the release?
14:32:26 <banas> nope, not for this one, for the next one
14:32:35 <banas> i think with this set we're good for the release
14:32:35 <rohitpaulk> I think we should concentrate on this one first.
14:32:44 <rohitpaulk> Let's hear people out, see how they use it etc.
14:33:00 <banas> okay, i agree let's do that.
14:33:14 <banas> we might want to work on the notifications bit though
14:33:31 <rohitpaulk> What improvements to you think we need?
14:33:49 <rohitpaulk> okay dots in the username seems to still be a problem
14:33:54 <banas> i'm thinking lets improve that a little bit. currently we just have notifs when people join gg, isn't it?
14:34:22 <rohitpaulk> Umm I'm not sure... wait
14:34:23 <banas> #topic Bugs & Improvements with the current stuff
14:35:22 <banas> my suggestion => let's move notifications to root (like github does) and provide notifs for comments, newly created public projects and newly added files
14:35:32 <rohitpaulk> Okay, currently notifications is only for comments.
14:35:50 * banas goes to check source, brb
14:35:57 <rohitpaulk> https://github.com/glittergallery/GlitterGallery/blob/master/app/models/notification.rb
14:36:31 <rohitpaulk> banas: I've gotta run for dinner
14:36:36 <banas> okay, so can we test it once - it's supposed to give me a notif when someone comments on one of my projsright?
14:36:39 <rohitpaulk> Can we wrap this up quick?
14:36:45 <banas> rohitpaulk: ok, five mins?
14:36:50 <rohitpaulk> Yes, and also on a thread taht you've commented on
14:36:55 <rohitpaulk> Basically - any project that you follow.
14:37:09 <banas> woot, i had never tried that. i'll try that tonight
14:37:13 <rohitpaulk> :)
14:37:18 <banas> so what i think makes sense (for now)
14:37:34 <banas> oh btw, do notifs always send out emails
14:37:36 <banas> ?
14:37:59 <rohitpaulk> yep, we've gotta change that
14:38:19 <banas> i don't think it's a notif as such, but since it's going to be a new demo, let's create a space where newly created projects, comments and uploads are mentioned
14:38:22 <banas> a feed actually
14:38:33 <rohitpaulk> Good idea
14:38:42 <banas> so that people have something to involve with
14:38:57 <banas> else it's just them creating a project and hoping someone discovers
14:39:10 <rohitpaulk> yep.
14:39:24 <rohitpaulk> and we should do something about the default pic for every project
14:39:37 <rohitpaulk> the inspire page looks kinda boring with the same pic repeated over and over again
14:39:41 <banas> oh yeh, that too.
14:39:52 <banas> we will need the thumbnails back
14:40:05 <banas> can you start an issue for that, ill take it up?
14:40:34 <banas> and the feed, do you think it's a lot of work? there's the gem we could use, but im not sure we really need it
14:40:36 <rohitpaulk> done.
14:40:41 <banas> it's called public_activity
14:40:46 <rohitpaulk> I'll have a look
14:40:59 <banas> ok, ill start an issue for the feed after the meeting
14:41:09 <rohitpaulk> oh, well I'll see if it actually adds value to our setup and decide :)
14:41:27 <banas> yep, i'll assign that to you for now :)
14:41:44 <banas> #action banas rohitpaulk have a look at respective issues
14:42:17 <banas> i'll see what needs to be done to associate user activities on gg with fedora infra
14:42:21 <rohitpaulk> :)
14:42:29 <banas> maybe not for this release though
14:42:37 <rohitpaulk> yep ,not essential methinks
14:42:41 <banas> yep
14:42:54 <banas> ok, you go run for dinner!
14:43:02 <banas> i have noodles ;)
14:43:09 <rohitpaulk> I've really got to get this vagrant thing out of the way . it takes me like 30 mins to make a one line fix :/
14:43:13 <rohitpaulk> sure, cya ltaer!
14:43:16 <rohitpaulk> #endmeeting