02:14:34 <johnmark> #startmeeting
02:14:34 <zodbot> Meeting started Fri Aug 24 02:14:34 2012 UTC.  The chair is johnmark. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:14:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
02:14:43 <Technicool> #action send note to sampath and hagarth on major site maintenance
02:14:56 <johnmark> Technicool: and then it automagically is included
02:15:19 <johnmark> I've never had a hiccup on a Debian live upgrade :)
02:15:30 <johnmark> let's live dangerously!!!!
02:15:32 <johnmark> or not
02:15:44 <johnmark> #halp
02:15:44 <Technicool> #info johnmark just doom-jinxed us all
02:15:49 <johnmark> teehee
02:16:33 <Technicool> ok, agreed that maintenance is needed, we may want to hold off until next weekend to allow them ample time
02:16:51 <Technicool> otherwise, i know a guy (not me) whose motto is "its just data"
02:16:52 <johnmark> Technicool: sur
02:16:54 <johnmark> sure
02:16:56 <Technicool> so, lets go nuts
02:16:57 <johnmark> haha!
02:17:17 <johnmark> the good news is that I believe we have two servers
02:17:32 <johnmark> so we can upgrade one and then cut over the DNS
02:17:41 <Technicool> we do, but i don't think they are failover
02:17:44 <johnmark> lh: greetings, earthling
02:17:52 <johnmark> Technicool: they're not failover anymore
02:18:00 <johnmark> but only one responds to gluster.org
02:18:08 <lh> johnmark, and to thee
02:18:17 <johnmark> so we just switch the CNAME when the upgrade is complete
02:18:17 <Technicool> greeting as well mojavelinux
02:18:26 <johnmark> mojavelinux: howdy, howdy
02:18:27 <mojavelinux> hey there!
02:18:30 <johnmark> :)
02:18:32 <lh> mojavelinux, ^5
02:18:39 <mojavelinux> I was debugging :/
02:18:44 <johnmark> mojavelinux: we were just debating the merits of an in-place upgrade of gluster.org
02:18:45 <Technicool> mojavelinux, you missed it but you are going to do a live upgrade on the website tomorrow morning
02:18:50 <johnmark> hahaha
02:19:00 <mojavelinux> oh, more debugging
02:19:24 <johnmark> well, not really live. Using the backup server - I think they're identical
02:19:27 <Technicool> no, johnmark has given assurances that no issues will arise
02:19:32 <johnmark> Technicool: er, yeah
02:19:35 <Technicool> johnmark, we can confirm
02:19:43 * Technicool begins confirming
02:19:46 <johnmark> Technicool: and we will.
02:20:05 <johnmark> Technicool: can you send a note to hagarth and Sampath?
02:20:31 <Technicool> johnmark, yes thats what i tried to log with the #action above ^
02:20:43 <johnmark> oh right. that :)
02:20:49 <johnmark> #halp
02:21:10 <johnmark> #action Technicool to run upgrade plans by hagarth and Sampath
02:21:24 <johnmark> I forgot how to grant admin privs to others
02:21:39 <johnmark> Technicool: anyway, anything new in docs?
02:22:20 <Technicool> johnmark, a few more stub entries, on the actual substance front, I was working on the hadoop plugin and UFO
02:22:35 <johnmark> Technicool: awesome. yeah, it's a busy week, and next week, too
02:22:43 <Technicool> the hadoop plugin doc is experiencing technical difficulties as you know
02:22:49 <johnmark> indeed :(
02:23:03 <johnmark> Technicool: did you look at the official red hat docs? they might be slightly better
02:23:11 <johnmark> but I'm guessing probably not
02:23:16 <Technicool> the UFO one is moving in stride, with some good ideas generated from the meetup
02:23:33 <Technicool> johnmark, am i allowed to say in semi-public?  ;)
02:23:34 <johnmark> Technicool: that's excellent
02:23:42 <johnmark> haha
02:23:52 <johnmark> Technicool: you can say whatever you want :)
02:24:19 <Technicool> in that case, no doc of any sort enabled me to be successful
02:24:20 <johnmark> ok, and I need unleash teh hounds on community.gluster.org
02:24:30 <johnmark> in the time while we still have it, it needs to get more action
02:24:47 <johnmark> #action johnmark to send unanswered Q's list to gluster-users
02:24:54 <Technicool> ah, yes
02:24:58 <johnmark> Technicool: eek
02:25:04 <johnmark> tres sad
02:25:08 <Technicool> will scour that as well
02:25:20 <Technicool> a direct question last night was "does it work"
02:25:31 <johnmark> haha!
02:25:32 <Technicool> (the hadoop plugin)
02:25:32 <mojavelinux> i'm starting to get scared of more heartbreak trying to get the hadoop integration setup :0
02:25:35 <johnmark> hillarious
02:25:42 <mojavelinux> hehehe
02:25:50 <Technicool> to which my answer was to eat my pride in full view of all attending
02:25:54 <johnmark> mojavelinux: Yeah, unfortunately, it's looking like it will need a rebase before it's usable for common folk
02:25:56 <mojavelinux> I think I like to try everything hard first, but as they say, eat the frog first
02:26:07 <johnmark> :)
02:26:17 <johnmark> I've never been told that, but hey, YMMV
02:26:20 * Technicool ate the frog, his goat friend and what appeared to be a chupacabra
02:26:33 <johnmark> mojavelinux: what have the French ever done to you???
02:26:36 <Technicool> schmoozing the goat of course
02:26:47 <johnmark> mojavelinux: good luck with the move
02:27:24 <johnmark> and I think we'll defer talk of replacement web parts until next week
02:27:35 <johnmark> mojavelinux: oh, I was supposed to ask you about project management software
02:28:02 <johnmark> #action johnmark to discuss project mgmt software with mojavelinux
02:28:22 * Technicool would like to attend
02:28:57 <johnmark> Technicool: which? project management software discussion?
02:29:00 <Technicool> yes
02:29:08 * johnmark rubs evil hands together. evilly.
02:29:25 <johnmark> #action johnmark to discuss PM software with mojavelinux AND Technicool
02:29:30 <Technicool> im so in
02:29:36 <Technicool> first, i emailed the president
02:29:37 <Technicool> now, this
02:29:40 <johnmark> cool. let's do that tomorrow, since next week is so f'd up
02:29:42 <johnmark> haha
02:29:45 <mojavelinux> nice. i'm no expert on pm software, but i've got some ideas
02:29:52 <johnmark> mojavelinux: excellelnt
02:30:02 <zodbot> lh: Error: Can't start another meeting, one is in progress.
02:30:04 <mojavelinux> if there's one requirement I do think we should stick to, it's that it should be OSS software :)
02:30:16 <lh> wrong window
02:30:18 <lh> sorry
02:30:21 <mojavelinux> hahaha
02:30:30 <mojavelinux> zodbot was like "no"
02:30:31 <johnmark> mojavelinux: werd
02:30:32 <Technicool> lh is using my 1400 baud modem from 1990
02:30:38 <johnmark> lh: ah hahaha
02:30:49 <johnmark> mojavelinux: so yes, agreed. let's stick with FOSS
02:31:00 <Technicool> oops, wrong window i meant...i just assumed it was delayed
02:31:32 <johnmark> Technicool: do you know what quaid refers to when he says "I'm looking for a wiki space where I can use my user area to do  something like this:
02:31:35 <johnmark> "
02:31:46 <johnmark> http://fedoraproject.org/wiki/User:Quaid/Community_metrics
02:31:54 <Technicool> thats a big chunk of sentence
02:32:01 <Technicool> ah...sort of, not really
02:32:16 <johnmark> afaik he should be able to do that now
02:32:30 <Technicool> i am unclear how the stats and the wiki are integrated
02:32:36 <mojavelinux> as a friend of mine often says "I can't parse that"
02:32:38 <johnmark> #action johnmark and Technicool to corner quaid on his metrics desires
02:32:45 <Technicool> mojavelinux, that was perfect
02:32:51 <johnmark> heh
02:33:00 <Technicool> johnmark, i think the request is twofold
02:33:01 <johnmark> #link http://fedoraproject.org/wiki/User:Quaid/Community_metrics
02:33:07 <johnmark> ok
02:33:12 <Technicool> on one hand, he wants the metrics tracking
02:33:20 <Technicool> on the other hand, a place to publish them
02:33:21 <johnmark> Technicool: right, that I understand
02:33:26 <Technicool> thats my understanding
02:33:33 <Technicool> then you and i are tied
02:33:39 <johnmark> right. but he can create an account. there's nothing standing in his way :)
02:33:52 <Technicool> correct, that's where i am disconnecting as well
02:34:06 <johnmark> ok. we'll just ask him to 'splain sumtin' lucy
02:34:15 <johnmark> anyhoo
02:34:19 <johnmark> anything else pressing?
02:34:21 <Technicool> even if the request is to do some sort of automation, he has sudo on the server
02:34:31 <mojavelinux> oh, got it, parser retry success
02:34:31 <Technicool> #agreed
02:35:00 <Technicool> #parser.retry(true)
02:35:03 <johnmark> haha
02:35:06 <johnmark> hagarth: howdy
02:35:29 <johnmark> hagarth: tomorrow, Technicool and I need to gang up on you and Sampath to discuss gluster.org upgrade
02:35:31 <Technicool> why has noone ever seen hagarth and lh in the same room?
02:35:38 <johnmark> it's a mystery :)
02:35:59 <hagarth> johnmark: howdy
02:36:08 <hagarth> johnmark: sure
02:36:09 <johnmark> hagarth: so we need to work out a backup strategy and schedule some downtime
02:36:20 <johnmark> which I'm hoping we could do by next weekend
02:36:37 <johnmark> say September 1
02:36:52 <hagarth> johnmark: ok
02:37:01 <johnmark> hagarth: and I can't get anyone from RHIT to answer my emails now.
02:37:13 <mojavelinux> that's what Google+ is for
02:37:25 <mojavelinux> and twitter, you just need some public shaming
02:37:33 <Technicool> Google+ is for something? ;)
02:37:35 <johnmark> mojavelinux: haha. oh yes, never fails
02:38:06 <johnmark> hagarth: so migration is on hold until we can kick them in the shins
02:38:21 <johnmark> hagarth: oh, speaking of. what kind of memory requirements do you need for jenkins + gerritt + git?
02:38:29 <johnmark> and CPU reqs, too
02:38:38 <johnmark> hagarth: that's something I wasn't sure of as we're spec'ing things out
02:38:42 <mojavelinux> why not use openshift for jenkins (or has that already been discussed?)
02:38:59 <hagarth> johnmark: 8G + 12 cores should do
02:39:03 <johnmark> mojavelinux: haven't discussed it. I have to admit that the prospect scares me :)
02:39:10 <johnmark> hagarth: ok. I'll run with that
02:39:52 <mojavelinux> they give projects larger resources than the free accounts...so it's like having a full blown hosting...however, that said
02:40:04 <johnmark> #action johnmark so send more server specs to RHIT and other competing hosts
02:40:06 <Technicool> eek!  we also need the cpu's to be better than Core 2 Duo...
02:40:14 <mojavelinux> i'm used to using jenkins to build java projects, not fs tests
02:40:32 <johnmark> :)
02:41:02 <Technicool> Core 2 Quad, my apologies...either way, something built in the last 4 years
02:41:05 <johnmark> hagarth: do you have time to work with Sampath on backup and upgrade plan? one of us can also do it
02:41:46 <johnmark> hagarth: nevermind - I'll send a note to you and Sampath, and we'll work it out in email
02:41:53 <hagarth> johnmark: sounds good
02:42:00 <johnmark> hagarth: cool. thanks :)
02:42:37 <johnmark> ok. those are the hot-button things. many of us are traveling next week, so I'm thinking we'll cancel and pick this back up the following week
02:43:06 <mojavelinux> i'll really be traveling...I'll be on a 3 day drive out west
02:43:15 <johnmark> ha. please be safe
02:43:16 <mojavelinux> by the end I may ditch the Prius and come in on horseback
02:43:18 <Technicool> mojavelinux, just did that drive
02:43:19 <mojavelinux> woooo!
02:43:27 <Technicool> except from east back west
02:43:45 <Technicool> my wife totalled an SUV on the trip out, so yes, be careful
02:43:50 <johnmark> ouch :(
02:43:53 <mojavelinux> oh, shoot
02:43:58 <Technicool> deer ...not as friendly as they look
02:44:01 <johnmark> #endmeeting