16:03:44 <johnmark> #startmeeting
16:03:44 <zodbot> Meeting started Fri Oct 26 16:03:44 2012 UTC.  The chair is johnmark. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:56 <johnmark> #chair Technicool
16:03:56 <zodbot> Current chairs: Technicool johnmark
16:05:12 <johnmark> pasted from email:
16:05:16 <johnmark> Today we will discuss
16:05:16 <johnmark> 1. outcome of server migrations
16:05:16 <johnmark> 2. recommendations for developer collaboration services - github, et al.
16:05:19 <johnmark> 3. wiki madness - the wiki needs help. It's a bit of a sprawl
16:05:21 <johnmark> 4. case study project
16:05:31 <johnmark> #topic server migrations
16:05:33 <Technicool> ooh@#4
16:05:36 <johnmark> I think we're mostly done here
16:05:41 <johnmark> :)
16:05:50 <johnmark> Technicool: that's where we ping semiosis. I think
16:06:13 <Technicool> i just liked the sound of it
16:06:19 <johnmark> heh :)
16:06:32 <johnmark> anyone notice server oddities? anything we should be doing differently
16:06:50 <johnmark> we will be closing out everything on iWeb shortly and moving the rest of the stuff over to rackspace
16:07:33 <Technicool> do we have any sort of strategery in place so that in the event of another failure, we can recover within hours or minutes?
16:08:09 <Technicool> as far as the site itself, haven't noticed anything in particular
16:08:36 <johnmark> STRATEGERY! who do you think this is?
16:08:47 <johnmark> Why my middle name is...
16:08:50 <johnmark> not strategery
16:09:10 <johnmark> that sounds like standing up a mirrored server on rackspace
16:09:12 <Technicool> mission accomplished...
16:09:21 <johnmark> and implementing some type of failover
16:09:28 <Technicool> ok, we need to make sure it is a gen1 server then
16:09:30 <JoeJulian> That's what automagic backups are for.
16:09:30 <johnmark> which I know nothing about
16:09:35 <johnmark> Technicool: yup, exactly
16:09:36 <Technicool> i can take care of the mirror and backups
16:09:41 <johnmark> you r0x0r
16:10:08 <Technicool> #action Eco to handle server mirroring and image backup scheduling once iWeb migration is complete
16:10:08 <johnmark> Technicool: is that all we need? or does rackspace also offer some type of hot HA?
16:10:49 <Technicool> they have a load balancing service, you need to pay for their "premium service" but the cost wasn't too high
16:10:50 <johnmark> or would we just need to use some heartbeat tool
16:10:54 <johnmark> ok
16:11:39 <johnmark> that also means making sure the data is consistent between the two
16:11:41 <Technicool> the load balancing includes failover, I assume heartbeat which means they probably don't have heartbeat for some reason just to make things interesting
16:11:55 <johnmark> hrm... pretty sure I've heard of a tool that does replication... let me look it up
16:12:07 <Technicool> rsync?
16:12:10 <johnmark> heh
16:12:11 <johnmark> LOL
16:12:12 <johnmark> :P
16:12:20 <Technicool> im here all week folks
16:12:56 <johnmark> ok, can you find out how much it costs? probably better to farm out as much of that as possible
16:13:08 <johnmark> so we're not always in the position of maintaining crap
16:13:17 <JoeJulian> That's what puppet's for.
16:13:26 * johnmark is looking to delegate as much as possible away from us
16:13:33 <Technicool> i can work up a total cost but it recall i never winced looking at the prices
16:13:35 <johnmark> JoeJulian: that, too
16:13:42 <johnmark> Technicool: a good sign :)
16:13:51 <johnmark> otherwise, I think we're set.
16:14:12 <Technicool> IIRC, it would be about 3X the price of the server instances we are using now, so still better than the competition
16:14:28 <johnmark> JoeJulian: if you want to check out puppet recipes, I won't turn you down :)
16:14:30 <Technicool> and the less anyone here needs to do to manage it, the better
16:14:36 <johnmark> cool
16:14:37 <johnmark> ok
16:14:50 <johnmark> next topic
16:14:54 <johnmark> unless there's something else to add here
16:15:00 <johnmark> #topic dev collab
16:15:10 <johnmark> there are all sorts of services we can use here
16:15:35 <johnmark> github, bitbucket, a few others
16:15:57 <johnmark> that allow us ot use vanity URLs and our own logos/branding
16:16:56 <johnmark> in the spirit of minimizing our work, we'll compare online services to DIY
16:17:30 <johnmark> but I gotta tell ya, online services we pay for sounds awfully attractive at the moment
16:17:37 <johnmark> which is not to say that's what we'll do
16:18:08 <johnmark> if we can get support for our stuff from engineers in-house, then the weighting is equal, I think
16:18:24 <johnmark> that should read "IT folks" not engineers
16:18:35 <Technicool> ah, ok
16:18:45 <johnmark> ie. not us
16:19:01 <johnmark> but this is something I'd like to have up on gluster.org before the end of the year
16:19:11 <johnmark> because I'm discovering new projects each and every day, and we don't have a place for them
16:19:23 <Technicool> im ok with the RHIT folks if we can get it done the way we need within a decent timeframe
16:19:50 <semiosis> pong
16:19:53 <johnmark> #action jmw to draw up comparisons between online services and self-hosted
16:19:57 <johnmark> semiosis: yeehaw
16:19:58 * semiosis catches up
16:20:13 <johnmark> semiosis: greetings, salutations, etc. etc.
16:20:15 <Technicool> otherwise, the pace of what happens here is fairly rapid, so that may mandate that we need to work up our own solution with an outside vendor
16:20:25 <johnmark> ok
16:20:37 <johnmark> Technicool: agreed
16:20:56 <johnmark> I'll send around whatever comparison points I can find
16:21:14 <johnmark> if any of you have a favorite online service for dev collaboration, please send it my way
16:21:53 <johnmark> ok, anything else before we move to the next topic?
16:22:41 <johnmark> #topic wiki mania / wiki madness
16:22:53 * Technicool quakes with fear
16:23:13 <johnmark> this is something we'll have to think about, but we're starting to get to the point where there are too many projects on the wiki competing for space on the front page
16:23:32 <johnmark> this is a natural by-product of doing more stuff
16:23:54 <johnmark> but we need to think about redesigning the front page so that people can find the information they want/need
16:24:07 <johnmark> Technicool: I'm inclined to ping garrett for his expertise
16:24:25 <johnmark> #action JMW to ping Garrett for design help
16:24:26 <Technicool> johnmark, yes, we should get him onboard asap if he is done with the ovirt project
16:24:31 <johnmark> word
16:24:36 <Technicool> please include me in any meetings with him
16:24:41 <johnmark> you bet
16:24:55 <johnmark> no one has ever accused me of being a designer
16:24:59 <johnmark> :)
16:25:23 <johnmark> ok
16:25:23 <Technicool> from an osas stance, it would also be good to brainstorm what types of effort are reusable across projects
16:25:33 <johnmark> Technicool: excellent suggestion
16:25:54 <johnmark> ok, last topic
16:26:04 <johnmark> #topic case studies
16:26:18 <johnmark> so we're getting a case study done with the Rock the Vote project, thanks to our fine furry friends at the OSL
16:26:19 * Technicool ear lifted, face aglow
16:26:29 <johnmark> and we need more, more, MOAR
16:26:30 <Technicool> very nice
16:26:55 <JoeJulian> I've never been much for studying.
16:26:57 <johnmark> at some point, we discussed throwing together a form that people could fill out and describe what they're doing with GlusterFS
16:27:01 <johnmark> JoeJulian: heh heh :)
16:27:09 <Technicool> JoeJulian, i think here we made someone else do the studying
16:27:14 <johnmark> semiosis: I think you talked about doing something along those lines
16:27:20 * johnmark looks at semiosis
16:27:32 <johnmark> Technicool: exactly!
16:28:08 <johnmark> anyhoo, if someone wants to put up a braindead form, such as on survey monkey or elsewhere, I would welcome it
16:28:31 <Technicool> ick @ survey monkey but intent noted
16:28:42 <johnmark> and I am, of course, available for help and consultation
16:28:53 <Technicool> johnmark, what is the purpose exactly of the form?
16:28:59 <semiosis> Technicool: could you recommend something else?  i've heard of survey gizmo & polldaddy as well but never used any
16:29:03 <Technicool> "are you using gluster and how"?
16:29:13 <johnmark> #action jmw to find suck... er volunteer for case study project
16:29:28 <johnmark> Technicool: get people to fill out what they're using GlusterFS for, what their setup looks like, etc. et.c
16:29:39 <Technicool> semiosis, not offhand i just didn't like the trolly feel of surveymonkey
16:29:46 <johnmark> and then we'd follow up with further questions and churn out some type of thing on the web site
16:29:59 <johnmark> semiosis: I've heard of all sorts of things, I just can' tremember what they were
16:30:02 <Technicool> johnmark, gotcha....we discussed something similar awhile back
16:30:09 <johnmark> semiosis: some people use google docs for this.
16:30:18 <johnmark> semiosis: I'm not recommending it, just noting that ti's been done
16:30:22 <semiosis> interesting
16:30:32 <Technicool> it would be nice if we could have users fill this out themselves via the wiki
16:30:54 <johnmark> Technicool: good point. can you do forms with mediawiki?
16:30:58 <Technicool> then we can capture and poll the data directly without having overhead
16:31:05 <johnmark> Technicool: if not, we could just hand them a template and tell them to use it
16:31:11 <Technicool> you can, but we need to modify the install i think
16:31:12 <johnmark> and hope they don't screw up the template
16:31:12 <johnmark> :)
16:31:20 <johnmark> Technicool: cool
16:31:48 <Technicool> either way, i think this is a very powerful tool
16:32:03 <johnmark> semiosis: any ideas on what we should use? if we can get away with mediawiki, might as well use the tools we have
16:32:07 <johnmark> even if they're not perfect
16:32:09 <Technicool> to be able to show specific use cases, on specific hardware
16:32:16 <johnmark> yup
16:32:42 <Technicool> i think alot of people avoid Gluster just based on not knowing if it will work for them
16:32:54 <Technicool> and, i personally would like to see a list of fail cases
16:32:59 <JoeJulian> Me too
16:33:04 <johnmark> yup
16:33:28 <johnmark> hmm... "fail studies?"
16:33:39 <JoeJulian> I think that's supposed to be called bugzilla
16:33:42 <johnmark> would let us utilize a popular meme
16:33:43 <Technicool> then we can show over time that we either addressed the issue and turned it around to success, or else can say "well, you can try it if you want, but <X> others already did and died according to our cool data"
16:33:46 <johnmark> heh
16:33:50 <semiosis> time is the most scarce resource... if we can get this going with less effort using a 3rd party service that gets my vote
16:33:58 <johnmark> JoeJulian: in a perfect world, yes
16:34:07 <johnmark> semiosis: cool
16:34:19 <johnmark> semiosis: I think that's a good point
16:34:33 <Technicool> JoeJulian, bugzilla gives you the parts, but case studies give you the STORY!
16:34:38 * Technicool waxes poetic
16:34:58 * Technicool likes the cut of semiosis jib
16:35:00 <johnmark> semiosis: but then it has to be a service that allows for easy migration to our web site
16:35:04 <johnmark> either via RSS or something
16:35:08 <semiosis> leave my jib outta this :{
16:35:11 <semiosis> :P
16:35:13 <Technicool> jiblets
16:35:16 <JoeJulian> If you're throwing money at the problem... what about offering grants to students to survey and write case studies?
16:35:17 <johnmark> semiosis: ha!
16:35:32 <Technicool> JoeJulian, genius!
16:35:38 <semiosis> JoeJulian: +11111!!11ONEELEVEN
16:35:42 <johnmark> JoeJulian: interesting. there are things like mechanical turk from amazon for this
16:35:48 <johnmark> and other services
16:35:56 <Technicool> i also like the thought of using Mechanical Turk
16:36:06 <johnmark> ok.
16:36:18 <Technicool> if we can find a sort of repetitious job
16:36:26 <johnmark> so if someone can volunteer to investigate the online service for creating a form
16:36:27 <semiosis> i dont think mturk is good for this
16:36:30 <semiosis> mturk -1
16:36:37 <Technicool> offer 50 cents for each iteration, the turk monkeys would be all over that like white on rice
16:36:45 <johnmark> and someone else can look at mechanical turk alternatives
16:36:47 <johnmark> then we're set
16:36:49 <Technicool> semiosis, not for this, but if there is somethign else
16:36:49 <johnmark> semiosis: ok
16:36:59 <semiosis> Technicool: well yeah for lots of other things...
16:37:00 <Technicool> like re-importing data from said 3rd party service
16:37:14 <semiosis> waaaaay too complicated
16:37:25 <Technicool> semiosis, yes....i used mturk to refinance my house and it was a disaster
16:37:42 <johnmark> semiosis: I remember hearing about some service where you farmed out small jobs
16:37:45 <johnmark> but the name escapes me
16:37:57 <johnmark> Technicool: haha.... ouch!
16:37:59 <Technicool> semiosis, crackers use it to get past captcha so there has to be something fun we can do with it
16:38:09 <johnmark> :)
16:38:10 <semiosis> if we use a 3rd party survey service we'll likely get an XML doc or something we can use a script to get into mwiki easily
16:38:11 <johnmark> awesome
16:38:18 <johnmark> semiosis: that's what I assume/hope
16:38:22 <semiosis> mturk is good for spotting nipples in photos...
16:38:38 * Technicool points a browser toward amazon....
16:38:39 <johnmark> semiosis: not that you have any previous experience with that
16:39:05 * Technicool digresses before he gets in real trouble
16:39:07 <semiosis> mturk, find me ALL the...
16:39:33 <Technicool> mturk, type in a password into this form field from a list
16:39:37 <semiosis> but seriously, it's for turning an intractible problem into a manageable problem
16:39:47 * Technicool glances at the clock
16:39:48 <semiosis> importing data from a survey service is an easy problem
16:39:51 <johnmark> ok, I can look for other services
16:39:54 <johnmark> semiosis: yup
16:40:12 <Technicool> surveyces...
16:40:14 <johnmark> #action jmw to look at services for farming out simple tasks
16:40:32 <johnmark> semiosis: can you look at survey services?
16:40:47 <semiosis> sure hit me with an #action
16:40:52 <johnmark> you do it!
16:40:55 <johnmark> heh
16:40:59 <johnmark> ah ok
16:41:12 <johnmark> #action semiosis to look at survey services not called surveymonkey
16:41:18 <semiosis> ha
16:41:20 <Technicool> #action semiosis to look at non Family Fued based survey services
16:41:27 <johnmark> ha
16:41:30 <johnmark> ok, I have to run
16:41:36 <johnmark> and I think Technicool does, too
16:41:43 * Technicool also has to run and/or walk fast
16:41:44 <johnmark> any burning issues we're missing?
16:41:49 <johnmark> going once
16:41:51 <johnmark> going twice
16:41:53 <johnmark> ...
16:41:54 <Technicool> the packages
16:41:59 <johnmark> Technicool: doh
16:42:04 <johnmark> older versions, you mean?
16:42:19 <Technicool> and non RHEL
16:42:33 <johnmark> we can pull the tarballs from git and then just rpmbuild via existing .spec files
16:42:36 <johnmark> I think
16:42:38 <Technicool> what ever happened to that debian packager req?
16:42:39 <johnmark> right?
16:42:52 <johnmark> Technicool: not sure. need ot ask quaid
16:42:53 <semiosis> Technicool: he's on vacation
16:42:55 <Technicool> for rhel, im not concerned since we have most of what we need
16:42:57 <johnmark> heh
16:43:03 <johnmark> yeah
16:43:13 <Technicool> but for the non rhel stuff, i think it looks bad to have gone this long without addressing it
16:43:19 <johnmark> Technicool: ok
16:43:33 <semiosis> Technicool: kkeithley set up a debian repo and i set up an ubuntu ppa, what's your issue specifically?
16:43:41 <Technicool> and, for things like hadoop plugin, but yes that should be a simple rpmbui.d
16:43:45 <johnmark> Technicool: since kkeithley did the builds, we should bribe him to do the others
16:43:55 <johnmark> semiosis: +1
16:43:56 <Technicool> johnmark, issues are
16:44:03 <johnmark> I think it's about getting older versions on the download server
16:44:08 <Technicool> 1) is that available via download.gluster.com
16:44:11 <johnmark> right
16:44:28 <Technicool> 2) do we know whether the packages were built with real debain expertise
16:44:37 <Technicool> in semiosis case i think we can rest assured
16:44:43 <semiosis> lol
16:44:46 <johnmark> yeah, and we can mirror his repo pretty easily
16:44:51 <johnmark> semiosis: I stifled my laughter ;)
16:44:53 <Technicool> it was a compliment...
16:45:05 <semiosis> appreciated :)
16:45:07 <johnmark> Technicool: but for the debian stuff, we had complaints the first day
16:45:09 <johnmark> and then none
16:45:17 <johnmark> whihc tells me that they're probably fine
16:45:19 <Technicool> technically i was able to build the deb packages, but i sure didn't rush out and say "here everyone!"
16:45:21 <Technicool> ;)
16:45:21 <johnmark> although it wouldn't hurt to sak
16:45:26 <johnmark> er ask
16:45:27 <JoeJulian> Or both debian users gave up.
16:45:33 <Technicool> lol@both
16:45:35 <johnmark> JoeJulian: also a possibility
16:45:43 <johnmark> ok, we need to ask
16:45:49 <semiosis> ask what?  who?
16:45:51 <Technicool> well, i know of at least one very very very large debian customer
16:45:53 <JoeJulian> Technicool got it.
16:46:09 <johnmark> semiosis: send out a note to gluster-users saying "we have multiple debian version support now"
16:46:13 <Technicool> but since they are paying, they will probably get direct support on it
16:46:15 <johnmark> ...please let us know if they actually work
16:46:23 <Technicool> ok, that works for me
16:46:24 <johnmark> Technicool: ah, good point
16:46:29 <johnmark> ok?
16:46:30 <johnmark> cool
16:46:41 <Technicool> just want to make sure that non-RHEL users feel loved too
16:46:51 <johnmark> #action jmw to send out message to gluster-users informing everyone of new debian repos and asking for feedback
16:46:56 <johnmark> yup
16:46:58 <johnmark> Technicool: +1
16:47:01 <johnmark> ok.. cool
16:47:04 <johnmark> now I *really* have to go
16:47:06 <Technicool> ok, cool, gotta run
16:47:09 <JoeJulian> johnmark: See if any of those very very ... large paying customers want to sponsor some of those educational grant case studies.
16:47:15 <semiosis> johnmark: hold off on that email
16:47:19 <johnmark> semiosis: ok
16:47:20 <semiosis> lets chat before you do
16:47:23 <johnmark> semiosis: sure thing
16:47:26 <semiosis> but doesnt have to be now, we both have to go
16:47:30 <semiosis> but it will be quick
16:47:31 <johnmark> yup, no worries. ttyl
16:47:37 <johnmark> #endmeeting