15:01:30 <hagarth> #startmeeting
15:01:30 <zodbot> Meeting started Wed Jan  8 15:01:30 2014 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:30 <glustermeetbot`> Meeting started Wed Jan  8 15:10:35 2014 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:30 <glustermeetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:37 <hagarth> hello all
15:01:46 <hagarth> welcome to the first community meeting in 2014 :)
15:02:10 <hagarth> who do we have here today?
15:03:18 <lalatenduM> hi hagarth
15:03:20 * kkeithley is here
15:03:25 * ndevos is here
15:03:30 * msvbhat is here
15:03:31 * lalatenduM is here
15:03:41 <hagarth> johnmark mentioned that he will be on shortly
15:03:47 <johnmark> sorry
15:03:54 <johnmark> was writing up a blog post :)
15:03:55 <hagarth> let us get rolling
15:04:03 <hagarth> #agenda
15:04:20 <hagarth> #topic  AI follow up
15:04:21 <johnmark> w00t
15:04:27 <hagarth> has been a while since our last meeting
15:04:37 <hagarth> digging up the notes to see what all we had agreed to do :)
15:05:09 <hagarth> 3.5.0 tracking bug was on me  - #link https://bugzilla.redhat.com/show_bug.cgi?id=1049981
15:05:13 <glusterbot> Bug 1049981: unspecified, unspecified, ---, vbellur, NEW , 3.5.0 Tracker
15:05:26 <hagarth> please add whatever you think is needed to be fixed for 3.5.0 in there
15:06:24 <hagarth> I still am lagging on 2 AIs from the last meeting - one on purpleidea's format changes and tentative schedule for 3.6
15:06:37 <hagarth> we can discuss more about 3.6 when we get to the topic today
15:06:46 <johnmark> hagarth: cool
15:07:00 <hagarth> moving on
15:07:02 <hagarth> #topic 3.5.0
15:07:19 <hagarth> 3.5.0 is on a day to day slip at the moment
15:07:44 <hagarth> I updated the 3.5 Planning page to reflect the current schedule - #link http://www.gluster.org/community/documentation/index.php/Planning35
15:08:03 <hagarth> since we are in a day to day slip, GA date happens to be unknown at this point in time
15:08:19 <hagarth> reasons for the schedule to slip:
15:08:30 <hagarth> 1. Geo-replication is unusable on mainline right now
15:08:55 <hagarth> 2. A few more patches are needed for quota to work fine
15:09:20 <hagarth> 3. http://review.gluster.org/6638 needs to get in
15:09:40 <johnmark> ugh
15:09:45 <johnmark> ok
15:09:46 <hagarth> 3. is blocking beta1 as well
15:10:01 <johnmark> hagarth: do we have the needed resources to do this?
15:10:10 <hagarth> if we address 3., I am willing to push out beta1
15:10:20 <johnmark> without a working geo-rep?
15:10:24 <kkeithley> 6638 doesn't pass regression
15:10:33 <hagarth> johnmark: the holiday season amongst other reasons have slowed us down
15:10:39 <johnmark> hagarth: understood
15:11:12 <hagarth> johnmark: if we do not get geo-replication fixes in shortly, I think we'll need to make a hard call on to drop geo-replication from being packaged in 3.5
15:12:09 <hagarth> in any case I plan to take stock of what is necessary to be addressed in geo-rep tomorrow and will send out an email
15:12:27 <hagarth> kkeithley: yeah, I will see if we can get 6638 to work fine
15:13:03 <hagarth> any other questions on 3.5.0?
15:13:28 <johnmark> ouch. ok
15:13:44 <hagarth> guess not, let us move on
15:13:49 <ira> hagarth: Is there anyone who will adopt 3.5.0 w/o georep?
15:14:22 <ira> Or will it being broken be too big a red flag?
15:14:23 <kkeithley> can we (would we want to) roll back to 3.4.x geo-rep?
15:14:31 <johnmark> ira: sure, but I don't think that's appropriate bar/test
15:14:33 <hagarth> ira: we have other features in 3.5.0 which is of interest to others
15:14:53 <lalatenduM> hagarth, I like kkeithley idea
15:14:53 <johnmark> ira: it would be a huge red flag and, IMHO, be embarrassing
15:15:00 <johnmark> kkeithley: +1
15:15:05 <hagarth> rolling back to 3.4.x geo-rep is definitely an option
15:15:11 <lalatenduM> kkeithley +1
15:15:41 <johnmark> hagarth: I think there are really only two options: 1. new geo-rep or 2. 3.4.x geo-rep
15:16:06 <hagarth> johnmark: yes, I agree. we would not want to package a broken geo-rep for sure in 3.5.0
15:16:10 <kkeithley> new geo-rep that works.
15:16:33 <hagarth> johnmark: I will analyse both options and send out an email either tomorrow or day after
15:16:41 <johnmark> hagarth: thanks
15:16:54 <hagarth> #action hagarth to send out analysis on plan for geo-replication in 3.5.0
15:17:15 <hagarth> anything else to discuss on 3.5.0?
15:17:57 <hagarth> moving on
15:18:01 <hagarth> #topic 3.4.3
15:18:02 <lalatenduM> hagarth, I think http://review.gluster.org/#/c/6313/ should go to 3.5.0
15:18:36 <hagarth> lalatenduM: sure, can you please send a backport to release-3.5 after it gets merged in master?
15:18:48 <lalatenduM> hagarth, will do
15:18:54 <hagarth> 3.4.2 got released last week, thanks to all who contributed to it.
15:19:14 <hagarth> we have knocked of most of the requested bug fixes from the backport wishlist.
15:19:30 <hagarth> there are a few pending fixes, we'll need to carry them over for 3.4.3
15:19:53 <hagarth> I will clean up the backport wishlist to indicate what is complete and we can get started with plans for 3.4.3
15:19:56 <johnmark> yay
15:20:20 <hagarth> unless there are a lot of requests, we can have 3.4.3 going out sometime in February
15:20:41 <johnmark> hagarth: can we appoint someone to be 3.4.x caretaker while you head up the 3.5 release plan?
15:20:41 <hagarth> does that seem fine?
15:20:48 <johnmark> hagarth: sounds great
15:21:10 <johnmark> I nominate kkeithley :)
15:21:16 <kkeithley> I would be willing (for some definition of willing) to be the 3.4.3 (and 3.3.3 if we want to do that) caretaker
15:21:21 <kkeithley> dang, you beat me
15:21:23 <johnmark> LOL
15:21:24 <hagarth> kkeithley: great!
15:21:40 <hagarth> nominated and accepted in 6 seconds ;)
15:21:42 <johnmark> "for some definition of willing" lol
15:22:15 <kkeithley> beat me, whip me, make me write back cheques/checks/czechs
15:22:26 <hagarth> cool, kkeithley - let us discuss over the week on how we want to take 3.4.3 and 3.3.3 out
15:22:35 <hagarth> I don't think we have inevity here
15:22:36 <kkeithley> sure
15:22:54 <hagarth> but he wanted readdir-ahead in 3.3.3
15:23:20 <hagarth> and hence sent out a backport .. we could follow up with him on that
15:23:41 <hagarth> #action hagarth and kkeithley to discuss plans for 3.4.3 and 3.3.3
15:23:56 <johnmark> #winning
15:24:27 <hagarth> anything more on 3.4.x?
15:24:47 <hagarth> guess not, moving on.
15:24:54 <hagarth> #topic release management strategy
15:25:11 <johnmark> cool
15:25:23 <hagarth> current situation - we had problems with bits.gluster.org
15:25:35 <hagarth> rather problems with rpms built on bits.gluster.org for 3.4.2
15:26:12 <hagarth> I think we ought to stop our release script from uploading RPMs to bits.gluster.org
15:26:27 <kkeithley> agree!
15:26:30 <hagarth> and only use download.gluster.org.
15:26:31 <ndevos> +1
15:26:59 <ndevos> IMHO, bits.gluster.org should only contain a signed tar.gz
15:27:11 <hagarth> ndevos: yeah, I agree
15:27:15 <kkeithley> signed? How do you sign a tgz?
15:27:16 <johnmark> +1
15:27:26 <ndevos> well, detached .sig
15:27:31 <kkeithley> an MD5sum or a SHA256sum
15:27:45 <ndevos> and/or that, yes
15:27:47 <ira> or even a pgp sig from an accepted maintainer.
15:28:06 <johnmark> right - multiple ways to do it. let's settle on one and go from there
15:28:22 <johnmark> md5sum is fine, I think
15:28:25 <hagarth> right. this also means that we would need RPMs to be built for qa (or other non-ga) releases.
15:28:30 <kkeithley> speaking of which I've created a user named "gluster packager" on download.gluster.org, with a pub key for signing RPMs
15:28:40 <johnmark> kkeithley: ah, that was you. sweet
15:28:57 <hagarth> ndevos, kkeithley: would it be possible for you folks to build RPMs for all tagged releases that we do?
15:28:58 <kkeithley> just need to upload the key to a keyserv and get a few people to sign it
15:29:14 <jclift> .sha256sum
15:29:22 <ndevos> hagarth: I think we're trying to do that already?
15:29:37 <hagarth> #info bits.gluster.org to contain only source tarballs
15:30:07 <ndevos> hagarth: but, we could also have packages build automatically by mock, for different distributions (like the rpm.t test does)
15:30:11 <johnmark> ndevos: can we please include semiosis on this, so that he can help us automatically include .debs for all of our releases?
15:30:18 <johnmark> semiosis: ^^^
15:30:28 <hagarth> ndevos: yes, I have observed that and appreciate your help on that.
15:30:32 <jclift> hagarth: ... and associated checksums ?
15:30:37 <johnmark> ndevos: nice
15:30:42 <hagarth> automating everything would be great
15:30:54 <hagarth> we can start exploring how we can get there.
15:31:03 <hagarth> jclift: of course that too!
15:31:20 <hagarth> #info bits.gluster.org to contain only source tarballs and associated md5sums
15:31:22 <kkeithley> automating the Fedora koji builds is... tricky
15:31:50 <hagarth> johnmark: what is going to be the process for other packages that we started supporting from 3.4.2?
15:31:51 <kkeithley> Which is where we've/I've been doing the el5 and el6 builds
15:32:01 <jclift> hagarth: Just to be pedantic, we should _not_ be using md5sum
15:32:05 <kkeithley> scratch builds since taking gluster out of epel
15:32:16 <jclift> sha1 (non optimal) or sha256 only
15:32:29 <johnmark> ah ok
15:32:42 <johnmark> hagarth: that's a good question. I assumed kkeithley was behind the *SUSE builds
15:32:43 <hagarth> jclift: agree
15:32:45 <ndevos> kkeithley: I'm not talking about koji builds, but builds from the glusterfs.spec that is included in the tar.gz
15:33:17 <kkeithley> yes, I build the SuSE rpms
15:33:24 <kkeithley> s/build/built/
15:34:17 <hagarth> I think we need to evolve a process for our release management (for builds across various distributions)
15:34:35 <johnmark> hagarth: +1
15:34:46 <ndevos> so, for any tagged build, we want to provide packages for fedora/*EL/ubuntu/SLES/.. ?
15:35:11 <hagarth> ndevos: that sounds ideal
15:35:16 <johnmark> ndevos: agreed
15:35:30 <hagarth> but we can live with RPMs only when we start
15:35:39 <ndevos> phew
15:35:43 <hagarth> since we only provide RPMs in addition to source for all tagged builds
15:35:48 <hagarth> as of today i.e.
15:36:37 <johnmark> hagarth: right. but let's work with our DEB-building friends ot figure out a way to automate that process for non-RPM distros
15:36:39 <kkeithley> not sure I'm on the same page. When I've built rcX and alpha/beta RPMs for Fedora I do it in Koji and then put the RPMs on download.gluster.org. el5 and el6 builds that I do are done in Koji too.
15:37:01 <hagarth> any volunteers for evolving a write up on release management?
15:37:10 <kkeithley> SLES/OpenSuSE builds I do on SLES and OpenSuSE vms
15:37:15 <jclift> johnmark: From memory semiosis mentioned a while ago that automating the build for Gluster .deb packages is a pita.
15:37:31 <kkeithley> jclift, I can vouch for it being a pita
15:37:34 <johnmark> jclift: ok. but we need to figure out why and how to fix
15:37:48 <kkeithley> But I still want to get his scripts and files into the source tree.
15:37:57 <jclift> Good idea.
15:38:00 <hagarth> kkeithley: +1 that would be great to have
15:38:03 <johnmark> hagarth: I can write up a proposal on what shoudl happen, and then we can come up with a plan for how to implement
15:38:24 <hagarth> johnmark: sounds good, let us discuss more on this in next week's meeting.
15:38:31 <kkeithley> We know why, it's because it's majorly convoluted and just a pita
15:38:39 <johnmark> and include semiosis, the debian guy (forgot his nick) and manu
15:38:40 <hagarth> another topic related to releases
15:38:43 <johnmark> :)
15:38:46 <hagarth> pmatthai
15:38:50 <hagarth> for debian
15:38:51 <johnmark> hagarth: yes! thanks
15:39:20 <hagarth> should we also start doing nightly builds?
15:39:40 <lalatenduM> hagarth, +1
15:39:49 <hagarth> these builds could only be from master?
15:40:01 <kkeithley> do we have anyone who wants to consume nightly builds?
15:40:08 <jclift> If we do it, lets do for all of the "supported" branches
15:40:08 <ndevos> nightly builds is doable for fedora/*el rpms, not sure about others
15:40:49 <hagarth> kkeithley: not too many, but I have got occasional requests
15:40:51 <ndevos> (not koji builds, but ones from mock running on build.gluster.org or something)
15:41:14 <johnmark> hagarth: I think some type of regular builds is a good idea, whether daily or weekly
15:41:26 <hagarth> ndevos: yeah, RPMs from mock should be fine for nightly builds (it should just be a jenkins job)
15:41:33 <lalatenduM> hagarth, kkeithley , we can run some automation in future on the nightly builds of master
15:41:37 <kkeithley> we'd need a _good_ mock on build.gluster.org then. Word is that the fedora mock builds are not very good
15:42:08 <ndevos> kkeithley: koji just builds in mock too...
15:42:09 <kkeithley> for automated qa then, I agree with nightly builds
15:42:16 <hagarth> jclift: that's a good thought too .. once we get started with master, we can include other release branches too.
15:42:23 <jclift> How much storage space will/would we need?
15:42:41 * jclift guesses it depends on "how long do we keep them for"
15:42:48 <kkeithley> I have more faith in Koji mock builds for Fedora than in <cough>CentOS</cough> mock builds for Fedora
15:42:48 <jclift> Keep for 2 weeks maybe?
15:43:04 <hagarth> jclift: good question, maybe a month?
15:43:18 <kkeithley> but maybe I'm wrong about it. I'm just repeating what I've heard
15:43:18 <jclift> k, let's try for a month, and see how it works out
15:43:32 <kkeithley> more than build.gluster.org has now
15:43:39 <lalatenduM> jclift, hagarth , a month souds good
15:43:52 <hagarth> all our RPMs put together is roughly around 10 MB I think
15:44:13 <hagarth> so a month means we need less than a GB worth of storage
15:44:16 <jclift> kkeithley: build.gluster.org is prob still running CentOS 6.3 _original release_ though, with no patches or updates since installation?  <-- expect it to be borked for some stuff
15:44:29 <kkeithley> exactly my point
15:44:47 <kkeithley> well, we know that crypto libs have been updated, but apart from those
15:44:56 <jclift> kkeithley: So lets get a new build host happening, that actually keeps updated with patches?
15:45:19 <jclift> build2.gluster.org?  newbuild.gluster.org?  buildbot.gluster.org?  <-- potential names
15:45:57 <kkeithley> cat /etc/redhat-release
15:45:57 <kkeithley> CentOS release 6.3 (Final)
15:46:25 <johnmark> hrm
15:46:38 <johnmark> we can spin up new VMs on rackspace if needed
15:46:57 <jclift> Side note, the "hardlink" program _may_ be useful to keep storage space down.  Used to use it for Aeolus, where is kind-of-dedupe's files (not really, but similar).
15:47:00 <hagarth> release.gluster.org?
15:47:17 <kkeithley> yeah, probably need to, because the machines we have in-house are only coming on-line very slowly.
15:47:20 <jclift> release.gluster.org doesn't sound right
15:47:21 <ndevos> well, I guess we need not only *el-6 builds, but for that crypto-lib update, <= *el-6.4 and >= *el-6.5
15:47:43 <hagarth> jclift: I don't seem to like it now too
15:47:46 <ndevos> other than that, I really dont see an issue with mock....
15:47:51 <jclift> Linode VM's have a bunch of disk space and are very cheap
15:47:56 <kkeithley> and there'll be el7 before too long too
15:48:08 <jclift> 42GB or something with cheapest one (I still have a Linode)
15:48:26 <johnmark> jclift: we already have an account with rackspace cloud and can spin up VMs at any time - and then trash them
15:48:34 <jclift> johnmark: Cool. :D
15:48:58 <hagarth> I think we can carry out further discussion on making nightly builds operational in gluster-infra ML
15:49:07 <jclift> Makes sense
15:49:35 <hagarth> #topic hagarth to start a discussion on nightly builds in gluster-infra
15:49:46 <hagarth> #AI hagarth to start a discussion on nightly builds in gluster-infra
15:49:56 <hagarth> i seem to be losing it :)
15:50:00 <hagarth> #action hagarth to start a discussion on nightly builds in gluster-infra
15:50:08 <hagarth> #topic 3.6.0 plan
15:50:36 <hagarth> I have created a planning page for 3.6.0 - #link http://www.gluster.org/community/documentation/index.php/Planning36
15:50:43 <hagarth> comments on the schedule welcome
15:50:56 <johnmark> hagarth: +1
15:51:01 <johnmark> awesome
15:51:07 <hagarth> I'll hit the mailing lists soon with the planning page
15:51:44 <hagarth> any questions on this topic ?
15:52:16 <hagarth> guess not
15:52:22 <hagarth> moving on
15:52:27 <hagarth> #topic open discussion
15:52:44 <hagarth> there's a topic on Gluster Docs Project and documentation standards
15:52:52 <hagarth> johnmark: did you add that topic?
15:52:56 <johnmark> hagarth: my only comment is that I will be extremely happy if we actually have all features added to the plan by Feb 6
15:52:59 <johnmark> hagarth: yes
15:53:01 <kkeithley> ndevos: want to mention rolling glusterfs-geo-rep subpackage back into glusterfs-server?
15:53:10 <johnmark> kkeithley: good point
15:53:15 <johnmark> so documentation
15:53:23 <johnmark> #topic documentation
15:53:38 <johnmark> right now, we're workingon a new web site that's asciidoc-based and is deployed via middleman
15:53:39 <ndevos> kkeithley: no, its not really that important, is it?
15:54:01 <hagarth> johnmark: ok..
15:54:08 <johnmark> and, for the first time, we'll have a global web site and not disjointed
15:54:13 <kkeithley> </offtopic>maybe that's all the discussion we needed? ;-)</offtopic>
15:54:18 <jclift> One confusing this about this...
15:54:26 <jclift> Are we doing asciidoc or middleman?
15:54:31 <hagarth> johnmark: sounds great!
15:54:41 <johnmark> all of the howtos and other docs will be in the gluster-docs-project - forge.gluster.org/gluster-docs-project
15:54:48 <jclift> Everything I've seen so far says "Asciidoc", except one email today from hagarth saying middleman
15:54:50 * jclift is confused now
15:54:58 <lalatenduM> johnmark, looking forward to the new website
15:54:59 <johnmark> jclift: asciidoc is a format. middleman is a toolkit for deploying web sites
15:55:04 <jclift> s/middleman/markdown/
15:55:04 <Technicool> jclift middleman consume asciidoc
15:55:07 <jclift> Sorry, typo
15:55:08 <johnmark> lalatenduM: as am I :)
15:55:12 <johnmark> Technicool: exactly
15:55:26 <johnmark> so as I see it, core docs are in the glusterFS repo
15:55:29 <johnmark> in the /docs dir
15:55:38 <hagarth> johnmark: right
15:55:45 <jclift> Yeah, but hagarth says they're markdown not asciidoc ?
15:55:48 <johnmark> and other complementary docs are in the gluster-docs-project
15:55:50 <johnmark> right
15:56:01 <johnmark> so I *think* that middleman can handle markdown as well as asciidoc
15:56:19 <johnmark> and it *should* be as simple as just including the markdown docs in the web site tree as is
15:56:20 <jclift> Ok gotcha.  So markdown for core docs, and asciidoc for the website hosted docs?
15:56:20 <hagarth> jclift: markdown is what we have today .. but I think it will not be a hard switchover to asciidoc when we decide to do
15:56:32 <jclift> k
15:56:33 <johnmark> hagarth: yeah, and we may not need to switch
15:56:44 <johnmark> hagarth: it may *just work* but we'll have to see
15:56:50 <hagarth> johnmark: right
15:57:00 <johnmark> I don't want to place any burden on the dev team, ie. you, so we'll use it as is for now
15:57:23 <johnmark> but in general, we're pushign docs into gluster-docs-project which will then be deployed via the gluster-site project
15:57:30 <hagarth> johnmark: cool, that sounds like a good idea
15:57:45 <johnmark> and if I can get the damn thing to work today, we'll have a full staging area in a couple of hours
15:57:48 <johnmark> :)
15:57:53 <hagarth> johnmark: that would be awesome!
15:58:01 <johnmark> Technicool: speaking of, I need your help with that :)
15:58:10 <Technicool> johnmark, sounds good
15:58:15 <johnmark> hagarth: yes, thank Technicool for all his work converting docs
15:58:30 <hagarth> Technicool: thank you!
15:58:47 <hagarth> johnmark: do we want to talk about the community hangout?
15:58:51 <johnmark> yeah - Technicool has spearheaded the effort to turn the new web site into reality
15:58:55 <johnmark> hagarth: ah, good point
15:59:17 <johnmark> so I've scheduled semiosis for a hangout tomorrow
15:59:30 <johnmark> ...which I need to send out an announcement for
15:59:46 <johnmark> and then Daniel Mons for the following week
15:59:53 <johnmark> and after that, the schedule is open
15:59:56 <hagarth> johnmark: great, what time is the hangout scheduled for?
16:00:03 <johnmark> see https://docs.google.com/a/johnmark.org/spreadsheet/ccc?key=0AotMS5iCVD_6dDU3WC11a0hBY1ZTUG9DUGUwNzlaSkE&usp=drive_web#gid=0
16:00:23 <johnmark> Thursday at 16:00 GMT
16:00:41 <johnmark> or 11AM EST, which is, frankly, a terrible time for you
16:01:05 <johnmark> we'll try to schedule them every week witha variety of topics
16:01:23 <johnmark> obviously, I'd like everyone here to participate at some point :)
16:01:40 <hagarth> not a very bad time, can live with it ;)
16:01:51 <jclift> Same
16:02:03 <johnmark> cool :)
16:02:05 <hagarth> folks on the far east will miss out, but we will anyway have this archived in youtube right?
16:02:11 <johnmark> hagarth: yup
16:02:16 <hagarth> johnmark: cool!
16:02:22 <johnmark> will be "hangout on air" which means live broadcast on youtube
16:02:37 <johnmark> and then will be available afterwards
16:02:39 <lalatenduM> johnmark, cool
16:02:43 <johnmark> yeah :)
16:02:50 <hagarth> awesome, look forward to that.
16:02:59 <johnmark> yup yup
16:03:06 <jclift> Next topic yet?
16:03:17 <hagarth> that was the last topic on the agenda
16:03:19 * jclift thinks we need a "Who's Who in Gluster" page on the site.  Initial list could be extracted from git log and mailing list skim
16:03:26 <kkeithley> johnmark: need to get with kbsingh and plan better gluster and nfs-ganesha integration in CentOS. Maybe Samba too.
16:03:44 <ndevos> jclift: there is a MAINTAINERS file in the glusterfs.git now ;)
16:03:52 <kkeithley> And I wish we were making some progress on glusters-swift and glusterfs-hadoop packaging
16:03:59 <lalatenduM> ndevos, nice job
16:04:00 <hagarth> kkeithley: +1, maybe we have the perfect release vehicle for a gluster community distribution now! :)
16:04:15 <hagarth> ndevos: thanks for that!
16:04:47 <hagarth> okay, will be ending today's meeting.
16:04:56 <hagarth> look forward to meet you all next week.
16:05:03 <hagarth> #endmeeting