15:01:48 <jclift> #startmeeting
15:01:48 <zodbot> Meeting started Wed Apr  9 15:01:48 2014 UTC.  The chair is jclift. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:13 * kkeithley is here
15:02:21 <jclift> Hi all.  There was mention of cancelling this one due to Summit, but we seem to be going ahead anyway. ;)
15:02:24 * purpleidea is here
15:02:30 * ndevos is here too
15:02:35 <kkeithley> summit is next week?
15:02:37 <purpleidea> jclift: it's next week to cancel for summit
15:02:37 * lpabon here
15:02:46 <jclift> purpleidea: Ahhh, k
15:03:20 <circ-user-IrsMl> critter
15:03:43 <jclift> So, lets get this started
15:03:47 <dbruhn> here
15:03:54 <jclift> # topic Action items from last meeting
15:04:07 <jclift> #topic Action items from last meeting
15:04:11 <ndevos> link?
15:04:25 <jclift> ndevos: http://goo.gl/NTLhYu
15:04:26 <glusterbot> Title: glusterpad - Google Drive (at goo.gl)
15:04:27 <kkeithley> GlusterFS Community Meeting agenda is at https://docs.google.com/document/d/1ieA23wQdUY8HMKwl1kVSP6KqT64AueccrQZGjJzVyNU/edit?pli=1
15:04:28 <glusterbot> Title: glusterpad - Google Drive (at docs.google.com)
15:04:34 <jclift> ndevos: We're trying Google Docs today
15:04:46 <ndevos> ok
15:04:55 <jclift> Tab and Shift-tab are useful there, to indent and un-indent.
15:05:05 <dlambrig> shorter URL is goo.gl/NTLhYu
15:05:18 <jclift> "hagarth to send out an email on abandon policy for gerrit patches."
15:05:24 * jclift hasn't seen it
15:05:38 <jclift> "hagart to start upstream discussion on what to do with old bugs"
15:05:44 <jclift> Haven't seen that one either
15:05:54 <jclift> "johnmark to start the conversation with the docs team about getting docs ready for 3.5 release"
15:06:03 <johnmark> jclift: that's not goi ngto happen
15:06:14 <jclift> Describe
15:06:29 <ndevos> start the discussion, or the docs?
15:06:38 <jclift> Exactly
15:07:57 <jclift> johnmark: ?
15:08:30 <jclift> "johnmark to send note to gluster-devel reminding devs about feature docs and tests"
15:09:39 * jclift falls asleep waiting
15:09:52 <jclift> "jclift to send out email on mailing lists around 3.5 documentation."
15:10:05 <jclift> Didn't happen, as I completely forgot. :(
15:10:12 <jclift> I'll do it after this meeting though.
15:10:30 <jclift> "semiosis will add java projects to jenkins"
15:10:45 <jclift> Hmmm, semiosis isn't here is he?
15:11:10 <jclift> I'll email him after this meeting, to find out the fully status of his action items
15:11:14 <jclift> full
15:11:36 <jclift> "msvbhat to send draft of new geo-rep docs to interested ppl. purpleidea is one such"
15:12:10 <jclift> purpleidea: Did you receive the draft?
15:12:27 <purpleidea> msvbhat: he did send me some stuff, but i'm punting on doing work on geo-rep because i've been a bit busy with new job. but i did something else which i'll push to ml shortly.
15:12:47 <jclift> k, he sent it, so that's the action item done anyway. ;)
15:13:09 * jclift skips semiosis other items
15:13:17 <jclift> "kshlm to investigate Gluster Forge replacement options"
15:13:47 <jclift> kshlm: That gist is looking useful.  Have you got it to the stage you can email the list for voting?
15:14:40 <lpabon> who is leading the meeting?
15:14:40 <jclift> #action jclift to ping kshlm to find out where the gluster forge replacement investigation is up to
15:14:52 <tdasilva> jclift: what's the url for the gist?
15:14:58 <ndevos> #link https://gist.github.com/kshlm/fd884ae1df1e9b982252
15:15:01 <glusterbot> Title: What should be done for GlusterForge? (at gist.github.com)
15:15:14 <jclift> lpabon: /me is trying to ;)
15:15:23 <jclift> "jclift to investigate getting more storage for build.gluster.org"
15:15:24 <lpabon> sweet
15:15:43 <jclift> So, I emailed Avati last week, asking if it's possible to get storage added
15:15:48 <jclift> Didn't get a response.
15:16:11 <lpabon> i agree with doing that when we get to Rackspace
15:16:17 <jclift> It seems like the better approach anyway will be to just migrate build.gluster.org to a new VM in Rackspace
15:16:30 <lpabon> jclift: +1000 :-)
15:16:31 <jclift> We can pick a suitable VM size there, and it's easy to add new storage to VM's
15:16:33 <jdarcy> +1 on that
15:16:50 <jclift> Cool, so we'll do that. :)
15:17:00 <ndevos> makes perfect sense to me too
15:17:13 <lpabon> jclift: it would be nice to be able to run the tests on another VM other than the one on build.gluster.org ..hint hint
15:17:32 <lpabon> jclift: :-)
15:17:41 <jclift> lpabon: I've actually gotten a long way with being able to run VM's on demand in rackspace
15:17:50 <lpabon> jclift: nice
15:18:02 <jclift> I just need to update the scripting to it can be told how to grab a change set, then hook it up to Jenkins
15:18:25 <jclift> It'll probably take about another week of insane effort.  But I don't be doing it this week.
15:18:38 <jclift> So, at a guess, 2-3 weeks from now
15:18:43 <jclift> Anyway, moving on
15:18:49 <jclift> #topic Gluster 3.5.0
15:19:00 <jclift> Anyone know how the docs for 3.5 are looking?
15:19:34 <jclift> Yeah, me neither ;)
15:19:52 <ndevos> lala and sas were working on release notes, I think
15:19:56 <jclift> Does anyone have the time/inclination to check the doc status for 3.5?
15:20:11 <jclift> k, we can ask lala and sas as starters
15:20:50 <jclift> For the memory leak issue affecting NetBSD, hagarth last week mentioned it sounded like a NetBSD fuse issue
15:21:00 <jclift> Anyone know if that's been confirmed?
15:21:25 <jclift> If it's a NetBSD fuse issue, not sure why it would only be showing up for our 3.5 release, and not older stuff
15:22:01 <jclift> k, so we'll have to wait for hagarth for 3.5.x status in depth ;)
15:22:08 <jclift> #topic Gluster 3.4.3
15:22:20 <jclift> 3.4.3 shipped.  Thanks kkeithley. :)
15:22:46 <jclift> Announcements were made, but as kkeithley is pointing out in the Google Doc, we have the wrong kind of key for signing EL5 RPMs
15:22:56 <jclift> kkeithley: Is that something we can resolve?
15:23:18 <kkeithley> maybe. Let's discuss after
15:23:56 <jclift> #action kkeithley to discuss the EL5 RPM signing key
15:24:10 <jclift> #topic Documentation Update
15:24:16 <jclift> "GlusterFS & OpenStack"
15:24:42 <jclift> I didn't put that on the Agenda.  Who's is this one? :)
15:25:10 <ndevos> dlambrig maybe?
15:25:25 <dlambrig> no, was not me
15:25:36 <jclift> lpabon: Not yours?
15:25:51 <jclift> k, moving on
15:25:58 <lpabon> lpabon: not that i know of
15:26:03 <ndevos> or maybe deepakcs...
15:26:04 <hchiramm__> jclift, This is Humble :)
15:26:04 <lpabon> jclift: not that i know of
15:26:23 <jclift> #topic Other Agenda items...
15:26:37 <jclift> Welcome Humble :)
15:26:41 <jclift> "Cancel next week meeting because of summit?"
15:26:50 <hchiramm__> jclift, thanks guys :)
15:27:03 <circ-user-IrsMl> makes sense, who is going?
15:27:06 <jclift> No objection here.  Ppl are likely going to be busy on their items and tasks
15:27:34 <jdarcy> I'll be at Summit, and I'm getting signed up for more random stuff left and right.
15:27:35 * kkeithley will be at the Hack-a-thon on Sunday, and at Summit
15:27:49 <johnmark> hrm... where is hagarth?
15:27:56 <jclift> No idea
15:28:14 * jcuff waves, and wants to say quickly thanks for looking at the performance regression pieces that popped up on the list today: http://www.gluster.org/pipermail/gluster-users/2014-April/039865.html
15:28:29 <jclift> jcuff: :)
15:28:37 <jcuff> ya'll are superstars!
15:28:45 <hchiramm__> johnmark, Tim is here, so almost everyone is out for dinner :)
15:28:54 <jclift> Ahhh
15:29:02 <jdarcy> Coming from a star in his own field.  ;)
15:29:07 <jclift> Ok, anyway, let's postpone next weeks meeting to the week after
15:29:35 <jclift> Last other item on the written agenda: "Question about thin-p"
15:29:37 <purpleidea> +1
15:29:44 <jclift> Who's is that? :)
15:29:50 <purpleidea> me
15:30:00 <jclift> You have the floor
15:30:29 <johnmark> hchiramm__: tell Tim to stop messing with our community schedule ;)
15:30:51 <jclift> purpleidea: Eg go for it
15:30:53 <johnmark> jcuff: thank you for giving us such great feedback!
15:31:06 <purpleidea> damn, i was going to post the link from the ml. just posted it. Basically, I added some patches to support thin-p. Feedback welcome.
15:31:35 <hchiramm__> johnmark, \o/ .. sure :)
15:31:42 <jclift> purpleidea: So, what does it let people do?
15:31:47 <purpleidea> one point though: with thinp/gluster snapshots, they seem to be quite limited. eg: one volume max, and lots of other issues. wouldn't it be better to do this on top of btrfs to avoid such limitations?
15:32:03 <jclift> purpleidea: Thin provisioning of Gluster volumes using puppet-gluster?
15:32:35 <purpleidea> jclift: puppet-gluster can now build LVM thin pools for thin LV's.which is needed for doing the current gluster snapshots in 3.5.0
15:32:48 <ndevos> #link http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6041
15:32:49 <glusterbot> Title: Gmane Loom (at thread.gmane.org)
15:32:58 <kkeithley> gluster thin-p will work with whatever underlying thin-p is available. There's probably some work to do to hook up btrfs thin-p
15:32:59 <jclift> purpleidea: Cool. :)
15:33:04 <purpleidea> ndevos: thanks!!
15:33:21 <semiosis> :O
15:33:34 <purpleidea> semiosis: hey!
15:33:52 <jclift> Sounds very useful then.  Guess we should try and promo it a bit to get testers
15:34:16 <jclift> purpleidea: Is it the kind of thing you could write a blog post about, for going on the blog.gluster.org site?
15:34:27 <purpleidea> jclift: not recommended
15:34:38 <jclift> ?
15:35:13 <purpleidea> jclift: still _very_ untested for one
15:35:18 <jclift> Heh
15:35:37 <jclift> Gotcha.  Wait until it's a bit more stable/known-to-actually-work :)
15:35:39 <dbruhn> purpleidea, a blog post on your own blog then?
15:36:10 <ndevos> purpleidea: basically your question is 'should we use btrfs instead of lvm for thin-p'?
15:36:10 <purpleidea> i was more curious to hear about if there were plans to do snapshots with btrfs instead, because i've identified what i think are some unfortunate issues using LVM thinp.
15:36:19 <jclift> purpleidea: Feel free to do the blog post thing when you feel it's stage and ready for more people
15:36:25 <purpleidea> ndevos: i'm proposing that, yes.
15:36:51 <ndevos> for all I know, btrfs is not enterprise ready, and lvm is, at least RHEL deployments should use lvm, and not btrfs
15:37:14 <purpleidea> ndevos: btrfs is in fedora, so there's no reason gluster can't do it :)
15:37:27 <purpleidea> i'll probably add btrfs support to puppet-gluster within the week :)
15:37:40 <jclift> We'd definitely want to see full regression testing passing on it.  No idea if that's easy or not though. :)
15:37:49 <purpleidea> right. anyways, moving on :)
15:37:52 <jclift> :)
15:37:58 <ndevos> yes, it is possible to use btrfs, but it may not be stable enough for real usage yet
15:38:09 <jclift> #topic other items people want to raise?
15:38:14 <jclift> So, anything else?
15:38:47 <semiosis> getting back to my items...
15:38:51 <ndevos> I was wondering about closing bugs when a release is done...
15:38:55 <jclift> Ahh, cool.
15:39:03 * ndevos waits in line
15:39:13 <semiosis> adding java projects to jenkins isn't a priority for me, since i've got travis-ci working.
15:39:25 <jclift> So, we can just drop the action item?
15:39:30 <semiosis> i found a ppa with samba built with glusterfs-vfs enabled, but it's outdated
15:39:33 <kkeithley> btrfs  in RHEL and CentOS too, but the btrfs fsck util has only recently emerged into the full light of day, so now it can be considered slightly more stable
15:39:46 <semiosis> i pinged the maintainer (monotek) in #gluster but he hasn't responded.
15:40:07 <semiosis> if/when glusterfs gets into Ubuntu Main then samba will automatically support it without any additional changes
15:40:22 <semiosis> no update on the MIR yet, i'll ping the ubuntu devs about it today
15:40:24 <jclift> Cool
15:40:44 <semiosis> last i heard there's "still reason to be hopeful" but afaict it's stalled in a security review (w/e that is)
15:41:20 <jclift> k
15:41:36 <jclift> ndevos: Your turn
15:42:01 <ndevos> when a release is done, when should bugs get closed?
15:42:36 <ndevos> for Fedora there is a strict MODIFIED -> ON_QA -> CLOSED/ERRATA workflow, I do not think we have that
15:42:58 <jclift> Hmmm, lala pointed out a doc we have on the wiki about BZ lifecycle
15:42:59 <jclift> 1 sec
15:43:10 <ndevos> yes, this is a continuation from that
15:43:35 <hchiramm__> http://www.gluster.org/community/documentation/index.php/Bug_report_life_cycle /?
15:43:37 <glusterbot> Title: Bug report life cycle - GlusterDocumentation (at www.gluster.org)
15:43:48 <ndevos> yes
15:44:23 <ndevos> from a quick view, we have many bugs that have patches merged, and some of those bugs/patches should have been resolved in current (tagged) releases
15:44:50 <jclift> It's a good question.  I'm definitely not sure of the answer.
15:44:59 <jclift> How do other teams do it?
15:45:13 <ndevos> I guess I'll draft something to the devel ml
15:45:20 <jclift> Yeah, was just about to say that. :)
15:45:53 <jclift> #action ndevos to Send email to devel mailing list, to clarify "when a release is done, when should bugs get closed?"
15:46:05 <jclift> So, anyone else?
15:47:03 <jclift> k, sounds like a wrap then! :)
15:47:05 <jclift> #endmeeting