15:00:14 <JustinClift> #startmeeting Weekly Gluster Community Meeting
15:00:14 <zodbot> Meeting started Wed Jun 18 15:00:14 2014 UTC.  The chair is JustinClift. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:27 <JustinClift> #topic roll call
15:00:34 * jdarcy 
15:00:36 * Eco_ present
15:00:42 <JustinClift> Etherpad URL: https://public.pad.fsfe.org/p/gluster-community-meetings
15:00:44 <glusterbot> Title: FSFE Etherpad: public instance (at public.pad.fsfe.org)
15:00:59 * hagarth present
15:01:11 * xavih is here
15:01:17 * partner just observing
15:01:18 <JustinClift> Hmmm, does anyone have IRC ops here to change the channel title?
15:01:45 * raghug is here
15:01:46 <JustinClift> #topic Action items from last meeting
15:01:57 <hagarth> founder of this channel happens to be porkrind, wonder who that is!
15:02:03 <JustinClift> Welcome all.  Let's get on with it.  Attempt not to run over time this time. :)
15:02:08 <JustinClift> "hagarth to send an email to professor in ihep.ac.cn"
15:02:21 <hagarth> JustinClift: all my AIs from last week get moved to this week
15:02:28 <JustinClift> hagarth: np
15:02:34 <hagarth> and I certainly mean to do it this week
15:02:34 <JustinClift> #action  my AIs from last week get moved to this week
15:02:39 <JustinClift> 11:02Gah
15:02:43 <JustinClift> 1 sec
15:02:55 <JustinClift> #action hagarth to send an email to professor in ihep.ac.cn
15:03:07 * JustinClift should learn not to badly cut-n-paste into #action items ;)
15:03:23 <JustinClift> "JustinClift or hagarth to ask Rodrigo Gonzalez if he'd like to assist with the prominent users page"
15:03:31 * JustinClift emailed him, but hasn't heard anything back
15:03:53 <hagarth> JustinClift: ok
15:03:53 <JustinClift> So, guessing no interest.  Didn't hurt to ask though. :)
15:04:49 <JustinClift> "JustinClift to start the discussion on gluster-infra about updating links on the main gluster.org website. re 3.5.x links in template & the new Prominent Gluster Users page"
15:05:08 <JustinClift> Haven't gotten it done yet.  I'm get it done this week instead
15:05:12 <JustinClift> #action JustinClift to start the discussion on gluster-infra about updating links on the main gluster.org website. re 3.5.x links in template & the new Prominent Gluster Users page
15:05:28 * JustinClift didn't actually get much of the AI's done this week :(
15:05:33 <JustinClift> "JustinClift to get the Westford lab mac mini doing nightly GlusterFS build tests happening (cron). Failure emails to gluster-devel I guess"
15:05:36 <JustinClift> Moving to this week
15:05:39 <JustinClift> #action JustinClift to get the Westford lab mac mini doing nightly GlusterFS build tests happening (cron). Failure emails to gluster-devel I guess
15:05:49 <JustinClift> "JustinClift to look into the "other Mac Mini's" we might have lying around"
15:05:52 <JustinClift> Ditto
15:05:54 <JustinClift> #action JustinClift to look into the "other Mac Mini's" we might have lying around
15:06:07 <JustinClift> "JoeJulian to test extra patch on top of 3.4.4 and report success/failure"
15:06:15 <JustinClift> Anyone know how that went?
15:06:47 <hagarth> JustinClift: I do
15:07:01 <hagarth> JoeJulian was able to verify that in his deployment
15:07:03 * lalatenduM is here
15:07:14 <JustinClift> hagarth: Great :)
15:07:15 <hagarth> he provided a +1 verified vote on the release-3.4 backport
15:07:25 <hagarth> this patch will be part of 3.4.5
15:07:50 <kkeithley> Humble and Lala are building 3.4.4-2 rpms for download.gluster.org right now
15:07:54 <kkeithley> with that patch
15:07:55 <JustinClift> hagarth: Thanks. :)
15:07:57 <lalatenduM> yeah
15:08:00 <JustinClift> "kkeithley to release 3.4.4-2 (with the extra patch) if JoeJulian's testing succeeds"
15:08:04 <hchiramm_> :)
15:08:05 <JustinClift> Heh, that answers that
15:08:06 <JustinClift> :)
15:08:26 <JustinClift> "JustinClift to look into Gitorious alternatives"
15:08:30 <JustinClift> Didn't even start on this
15:08:39 <lalatenduM> kkeithley, however we nned ur help to verify we have done the right thing to create 3.4.4-2
15:09:25 <JustinClift> I'd like to push this (Gitorious alternative) back a few weeks.  It just doesn't seem as urgent/immediately needed as other things we need done atm
15:09:46 <JustinClift> johnmark around?
15:09:47 <hagarth> JustinClift: we might need JMW's inputs on gitorious alternatives
15:09:55 <JustinClift> Sure
15:10:04 <hagarth> JustinClift: JMW is away on vacation
15:10:08 <JustinClift> Ahhh
15:10:44 <kkeithley> lalatenduM: yes
15:10:49 <JustinClift> He wanted it sorted out sooner rather than later due to Gluster++.  I don't think Gluster++ is really dependant on having alternative sorted out though
15:11:05 <hagarth> JustinClift: right, let us hear back from him on these two topics.
15:11:09 <JustinClift> #action JustinClift to discuss Gitorious alternative with JMW when he's back from vaction
15:11:46 <JustinClift> "JustinClift to canvas for people to pick up the FreeBSD port code and get it merged/working with master"
15:11:53 <JustinClift> Moving to next week
15:11:55 <JustinClift> #action JustinClift to canvas for people to pick up the FreeBSD port code and get it merged/working with master
15:12:05 <JustinClift> "hagarth to email gluster-users and gluster-devel with the details of the new Port Maintainers"
15:12:14 <JustinClift> ?
15:12:18 <hagarth> JustinClift: doing that by tomorrow
15:12:39 <JustinClift> #action hagarth to email gluster-users and gluster-devel with the details of the new Port Maintainers by tomorrow
15:12:52 <JustinClift> "JustinClift to think through then wiki-ise what steps we should do for getting more thorough beta testing, and draw up likely list of candidates to ping directly"
15:12:58 <JustinClift> Haven't thought about this at all yet
15:13:01 <JustinClift> #action JustinClift to think through then wiki-ise what steps we should do for getting more thorough beta testing, and draw up likely list of candidates to ping directly
15:13:18 <JustinClift> "JohnMark to initiate conversation about Gluster++ on gluster-devel"
15:13:26 <JustinClift> He'll have to do that when back from vacation
15:13:28 <JustinClift> #aciton JohnMark to initiate conversation about Gluster++ on gluster-devel
15:13:35 <JustinClift> #action JohnMark to initiate conversation about Gluster++ on gluster-devel
15:13:40 <jdarcy> Gluster++?
15:14:11 <JustinClift> jdarcy: JM's name for a Gluster er... "distribution"
15:14:22 <jdarcy> Aha.
15:14:24 <kkeithley> Gluster++ is a "gluster distribution" that has all the various projects from the forge built in
15:14:25 <hagarth> jdarcy: Gluster++ = Gluster + related projects bundled together in a distribution
15:14:31 <JustinClift> Sort of like a collection of Gluster + associated tools all packages together
15:14:52 <JustinClift> "pranithk to add information about EasyFix to the existing Developer page"
15:15:06 <JustinClift> Anyone know ?
15:15:12 <lalatenduM> Gluster++, which distribution it will be based on ?
15:15:16 <hagarth> JustinClift: have not seen that happening
15:15:25 <JustinClift> lalatenduM: Guessing it's without an OS
15:15:26 <hagarth> lalatenduM: most likely on centos
15:15:30 <JustinClift> lalatenduM: But I don't know
15:15:36 <Eco_> lalatenduM, most likely CentOS if it has a platform
15:15:41 <raghug> JustinClift: no progess on that
15:15:51 <JustinClift> hagarth raghug: Thanks.
15:16:00 <JustinClift> Yeah, he's been a bit busy with other stuff. ;)
15:16:27 <JustinClift> Do we have anyone else who'd be interested with adding the EasyFix info to the Developer page?
15:16:29 <lalatenduM> we have CentOS SIG already :) but yes GlusterFS++ will have more from forge
15:16:43 <JustinClift> We could just put this EasyFix task aside until later
15:17:22 <JustinClift> #action pranithk to add information about EasyFix to the existing Developer page (not urgent though)
15:17:35 <JustinClift> "hagarth to send out an email on abandon policy for gerrit patches"
15:17:36 <JustinClift> hagarth: ?
15:17:43 <JustinClift> That's moved to next week now isn't it
15:17:46 * JustinClift forgot
15:17:57 <JustinClift> #action hagarth to send out an email on abandon policy for gerrit patches
15:18:03 <JustinClift> "hagarth to start upstream discussion on what to do with old bugs"
15:18:04 <JustinClift> Ditto
15:18:06 <JustinClift> #action hagarth to start upstream discussion on what to do with old bugs
15:18:14 <JustinClift> #topic 3.4
15:18:30 <JustinClift> So, it sounds like 3.4.4-2 is coming along, and we'll have rpm's shortly
15:19:00 <JustinClift> Is there other candidate stuff for 3.4.5 yet, apart from the patch going into 3.4.4-2?
15:19:18 <hagarth> JustinClift: not aware of any
15:19:24 <JustinClift> k, np
15:19:38 <hagarth> maybe we should send a reminder on gluster-users asking to update the tracker bug?
15:19:46 <kkeithley> https://bugzilla.redhat.com/show_bug.cgi?id=1110456 is the tracker bug
15:19:50 <glusterbot> Bug 1110456: unspecified, unspecified, 3.4.5, kkeithle, ASSIGNED , GlusterFS 3.4.5 Tracker
15:19:52 <JustinClift> Good idea
15:20:06 <JustinClift> kkeithley: Can you sent out that email?
15:20:24 <kkeithley> yeag
15:20:26 <kkeithley> yeah
15:20:51 <JustinClift> hchiramm_ lalatenduM kkeithley: When the 3.4.4-2 rpms are ready, would one of you guys be ok to put up a short blog post about it, encouraging people to update?
15:21:06 <hchiramm_> yep..
15:21:12 <JustinClift> hchiramm_: Thanks. :)
15:21:20 <lalatenduM> hchiramm_++
15:21:25 <JustinClift> #action kkeithley to send a reminder on gluster-users asking to update the tracker bug?
15:21:28 <JustinClift> 11:19 < kkeithley> https://bugzilla.redhat.com/show_bug.cgi?id=1110456 is the tracker bug
15:21:32 <glusterbot> Bug 1110456: unspecified, unspecified, 3.4.5, kkeithle, ASSIGNED , GlusterFS 3.4.5 Tracker
15:21:35 <JustinClift> Damn, did it again
15:21:36 <JustinClift> 1 sec
15:21:48 <JustinClift> #action kkeithley to send a reminder on gluster-users asking to update the 3.4 tracker bug
15:22:12 <JustinClift> Not only do we have spurious failures, we now have spurious action items... ;)
15:22:42 <JustinClift> #action hchiramm_ to make blog post about 3.4.4-2 when the rpms are on download.gluster.org
15:22:46 <hagarth> JustinClift: lol
15:23:04 <jdarcy> Spurious spuriosity.
15:23:15 <JustinClift> Is there more stuff we need to address for 3.4.x this meeting?
15:23:37 <hagarth> JustinClift: don't think so
15:23:51 <JustinClift> Cool
15:23:56 <JustinClift> #topic 3.5.1
15:24:24 <JustinClift> So, 3.5.1 beta 2 is getting some fairly in depth testing
15:24:42 <JustinClift> Pranith and other guys are fixing the bugs
15:25:09 <hagarth> thanks bennyturns for the effort on 3.5.1 testing!
15:25:14 <bennyturns> np!
15:25:19 <bennyturns> hth
15:25:25 <JustinClift> But there are some definitely non-trivial ones still present in 3.5.x series
15:25:35 <hagarth> bennyturns: it certainly does
15:25:52 <hagarth> JustinClift: how many blockers do we have for 3.5.1?
15:26:28 <lalatenduM> bennyturns, nice job!
15:26:41 <JustinClift> hagarth: Good question.  I was hoping Pranith would be in the meeting to answer that, as he's been leading the effort with Corvid Tech to resolve them
15:27:10 <JustinClift> hagarth: We've been in several-emails-and-logs-per-day contact with them for about the last two weeks
15:27:35 <hagarth> JustinClift: maybe we can email pranith and get an update
15:27:39 <JustinClift> Sure
15:27:56 <hagarth> ndevos is also going to be back on Monday
15:28:01 <JustinClift> #action JustinClift to email Pranith to get an update on the 3.5.x show stoppers
15:28:14 <hagarth> we can aim for an ETA after he is back
15:28:59 <JustinClift> I'm kind of wondering if we should release 3.5.1 pretty much as soon as he's back, or if we should get the rest of the 3.5.x show stoppers resolved first
15:29:49 <JustinClift> The main problem we're facing at the moment is the time juggling due to prioritising of 3.6 stuff due to the upcoming feature freeze
15:29:56 <hagarth> JustinClift: I am inclined to have 3.5.1 out soon
15:30:03 <JustinClift> hagarth: Agreed
15:30:24 <hagarth> it has a few very nice fixes
15:30:26 <JustinClift> #action ndevos to devise 3.5.1 release timeline upon his return
15:31:07 <JustinClift> Yeah.  I'm kind of thinking we get 3.5.1 asap, and then 3.5.2 out asap after that with the crashing bugs and other show stoppers fixed that we identify in the meantime
15:31:58 <JustinClift> We really need ndevos here to discuss this though
15:32:05 <JustinClift> Lets wait until next week for that I guess
15:32:18 <hagarth> JustinClift: yes, we need quick minor release cycles to stabilize 3.5.x
15:32:31 <JustinClift> #topic 3.6
15:32:59 <JustinClift> I'd like to propose we push back the feature freeze date for 3.6 by at least two weeks
15:33:46 <hagarth> JustinClift: rationale for that?
15:33:52 <JustinClift> There are bugs with 3.5.x that need immediate developer attention, but they're not able to be focused on and fixed due to the 3.6 feature freeze
15:34:20 <hagarth> JustinClift: anything apart from the problems reported by Corvidtech?
15:34:21 <JustinClift> People are helping out where they can, but we need quality focus time, not after-hours-killing-our-devs type time
15:34:59 <JustinClift> I don't think we'll need the whole team's focus.  It'll just be a few people working on things like AFR and DHT bugs
15:35:19 <JustinClift> hagarth: I'm only mostly aware of the Corvid Tech bugs that are showing up
15:35:25 <hagarth> JustinClift: I am open to pushing the dates - what do others feel about this?
15:35:49 <kshlm> +1
15:35:51 <kdhananjay> +1
15:36:21 <JustinClift> The things I'm uncertain of is "how much time" do we need
15:36:32 <hagarth> JustinClift: I'd like this extension to be final
15:36:43 * JustinClift would have liked the last one to be final too ;)
15:36:59 <JustinClift> Lets make it 3 weeks then, to be on the safe side?
15:37:13 <hagarth> JustinClift: no, 2 seems like the upper bound to me
15:37:28 <JustinClift> k.  2 weeks it is then ;)
15:38:01 <jdarcy> Sounds good.
15:38:19 * jdarcy has a dozen small but hard-to-review patches that could benefit from extra baking time.
15:38:21 <hagarth> JustinClift: will you post this on to the MLs?
15:38:29 <jdarcy> Half dozen.  Darn fingers.
15:38:34 <JustinClift> #action 3.6 Feature Freeze date is being pushed out two weeks, so dev focus on important 3.5 bug fixes can happen
15:38:43 <JustinClift> hagarth: Yeah
15:39:04 <JustinClift> #action JustinClift will email gluster-devel and gluster-users about the 3.6 Feature Freeze date being pushed out
15:39:05 <hagarth> jdarcy: yeah, looking for some quality time to go through the pending review queue for 3.6
15:39:21 <JustinClift> hagarth: Are you ok to update the Planning36 page with the new dates?
15:39:41 <hagarth> JustinClift: yes, shall update that
15:39:51 <JustinClift> #action hagarth to update Planning36 page with new dates
15:39:55 <JustinClift> Thanks. :)
15:40:17 <JustinClift> Are there other items for 3.6 we need to discuss this meeting?
15:41:13 <JustinClift> Sounds like "no"
15:41:14 <JustinClift> ;)
15:41:15 <JustinClift> Moving on
15:41:24 <JustinClift> #topic Regression testing
15:41:40 <jdarcy> Lots of very welcome activity there.
15:41:47 <JustinClift> Well, we've made some good progress there in removing the immediate bottleneck
15:42:25 <JustinClift> It's still sucking hours out of every day though, keeping and eye on the slave vm's, cleaning them up, and re-running jobs due to spurious failures
15:42:42 <jdarcy> I'm going to start adding a TITLE bash comment to my new regression tests, and have run-tests print it out.
15:42:52 <hagarth> should we add a file that contains known regression failures
15:43:05 <JustinClift> It would be good to backport the spurious failures to release-3.5 where applicable too
15:43:14 <JustinClift> kkeithley at least was bitten by one fixed in master
15:43:42 <JustinClift> I made a backport for it, but I guess we need to wait for ndevos to return before it'll get merged?
15:43:44 <hagarth> JustinClift: right
15:43:48 <jdarcy> Should some people, e.g. Justin and Pranith, be empowered to add a V+2 if the only failures are in tests known to have a problem?
15:44:05 <jdarcy> V+1
15:44:13 <JustinClift> What's a V+1?
15:44:49 <jdarcy> Set the Verify flag in Gerrit.
15:44:55 <JustinClift> Ahhh
15:45:14 <jdarcy> Normally Jenkins would do it, and it kind of sucks when it's missing because of a problem that's not real.
15:45:32 <jdarcy> I for one am more likely to review patches that have a V+1.
15:45:45 <JustinClift> The way I've been doing this so far, is to just re-run the jobs several times.  If the failures are in different spots every time, then they're spurious failures (and needs another rerun).  When it's the same failing test(s) every time, there's something non-spurious going on
15:46:46 <JustinClift> My way is kind of manually intensive though. (eg pita)
15:47:01 <jdarcy> Re-running is good too, but two successive spurious failures might still cause someone to lose a day's worth of possible reviews.
15:47:02 <JustinClift> I'd prefer we get the spurious failures solved instead
15:47:47 <JustinClift> In all cases they seem to be either something wrong with a) the test that's failing, or b) something wrong with Gluster that occasionally causes a test to fail
15:48:09 <JustinClift> But, I'm definitely open to suggestions
15:48:37 <jdarcy> Many seem timing-related.  We just don't know how long some things are going to take, so really no timeout is foolproof.
15:49:05 <JustinClift> jdarcy: If Pranith and myself are empowered to add V+2 to a job due to spurious failures, will that help get reviews for things?
15:49:47 <hagarth> JustinClift: I think so
15:50:10 <jdarcy> JustinClift: I think so.  We sort of need V+1 to mean "looks OK" and V+2 to mean "it really ran cleanly" (prereq for merge) but not sure how feasible that is.
15:50:24 <hagarth> I like the idea of empowering you and Pranith to override known regression failures
15:50:47 <JustinClift> k.  No objection from me then.  We can try it out, and see if it's works as we want it to
15:51:16 <JustinClift> k, so how do we do this?
15:51:37 <jdarcy> I think it's technically possible already, just a social convention that people not do it.
15:51:53 <hagarth> jdarcy: right
15:51:58 <jdarcy> I've added +1 to manually tested patches before.
15:52:15 <JustinClift> k.  Lets discuss in more depth on gluster-devel then, so we get more input and I can understand better what I need to do differently in practical terms
15:52:24 <JustinClift> (#gluster-meeting isn't the place to educate me for that :>)
15:53:05 <JustinClift> #JustinClift to start conversation on #gluster-devel about V+2
15:53:34 <JustinClift> I should start it after this meeting, but that's a reminder just in case ;)
15:53:55 <JustinClift> #topic Leaderboard
15:54:05 * JustinClift hasn't done much work on it in the last few days
15:54:30 <JustinClift> hagarth has SQL that can be run on the Jenkins DB directly to extract some of the needed stats though
15:55:01 <hagarth> sample o/p : http://fpaste.org/110384/
15:55:02 <glusterbot> Title: #110384 Fedora Project Pastebin (at fpaste.org)
15:55:17 <hagarth> JustinClift: it runs on gerrit db
15:55:34 <JustinClift> hagarth: Maybe you should use that on build.gluster.org, calling it from a CLI and output the results to a web visible text file or something
15:55:37 <JustinClift> Gah
15:55:38 <JustinClift> Yeah
15:55:50 <hagarth> JustinClift: should this file be on gluster.org?
15:56:03 <JustinClift> We can put it anywhere
15:56:07 <hagarth> JustinClift: ok
15:56:25 <JustinClift> On www.gluster.org would be useful, but we can put it on build.gluster.org or anywhere that's easy to do
15:56:29 <JustinClift> Up to you :)
15:56:35 <hagarth> JustinClift: ok :)
15:56:56 <JustinClift> #action hagart will get initial functional leaderboard online
15:56:57 <semiosis> jenkins is a good job scheduler
15:57:15 <semiosis> we use it for nightly stats/reporting stuff
15:57:43 <JustinClift> Cool.  I don't have that much depth with it really, apart from recent adventure to get this slave stuff working.
15:58:10 <JustinClift> #topic Other Agenda items
15:58:19 <JustinClift> Any other agenda items people want to raise?
15:59:04 <JustinClift> Guess not
15:59:06 <JustinClift> #endmeeting