15:03:34 <hagarth> #startmeeting
15:03:34 <zodbot> Meeting started Wed Jul  2 15:03:34 2014 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:56 <hagarth> s/chair is hagarth/chair is kkeithley/
15:03:58 <hagarth> :)
15:04:09 <kkeithley> thanks
15:04:27 <kkeithley> Okay, run through action items from last week
15:05:22 <kkeithley> #action JustinClift to contact Rodrigo Gonzalez about Prominent Users page
15:05:38 <kkeithley> oh, wait, roll call
15:05:41 <kkeithley> #rollcall
15:05:50 * hagarth is here
15:05:52 * bennyturns is here
15:05:58 * hchiramm__ here
15:05:58 * jdarcy is here
15:06:03 * xavih is here
15:06:08 * NuxRo is just stalking you
15:06:16 * ndevos is here, but might not stay 'till the end
15:07:13 <kkeithley> okay, all the lurkers can keep their heads down
15:07:37 <kkeithley> Justin working on updating links
15:07:54 <kkeithley> #action Justin still needs to add FreeBSD slave to Jenkins
15:08:13 <kkeithley> I've reviewed the FreeBSD patch. Are we close to getting it merged?
15:08:57 <hagarth> kkeithley: we should get it in soon
15:09:11 <kkeithley> okay
15:09:37 <kkeithley> #action, hagarth email on abandon policy for gerrit patches
15:09:44 <hagarth> kkeithley: moved to this week
15:09:46 <hagarth> right
15:10:11 <kkeithley> #action JustinClift to scan old meeting for action items past their expiration date
15:10:40 <kkeithley> #action hagarth to get functional leaderboard online, pushed back to this week
15:10:55 * kkeithley wonders if he needs to continue this
15:11:15 <hagarth> kkeithley: we can probably pick up the ones that have not been updated in the agenda
15:11:37 <kkeithley> okay
15:12:10 <kkeithley> skipping ahead, documentation for dht by pranithk and Nithya
15:12:24 <kkeithley> neither of them is here
15:12:50 <jdarcy> I volunteered to help with that, but haven't done anything yet.  :(
15:13:03 <kkeithley> #action pranithk, Nithya, and jdarcy to document dht
15:13:44 <kkeithley> we have updates on all the remaining action items
15:14:04 <kkeithley> any other comments on action items from last week?
15:14:20 <kkeithley> going once?
15:14:27 <kkeithley> going twice?
15:14:51 <kkeithley> moving on to 3.4
15:14:57 <bennyturns> kkeithley, 1 sec
15:14:59 <bennyturns> on:
15:15:11 <bennyturns> Pranith to find out if there's a way to run regression tests on a timed basis. Google, lpabon and bennyturns as info sources
15:15:43 <bennyturns> I have this going, only question is where should I shoot out results email to?
15:16:20 <kkeithley> mailto:gluster-devel@gluster.org
15:16:25 <hagarth> bennyturns: gluster-devel might be a good place to start
15:16:38 <bennyturns> kk
15:17:10 <kkeithley> ready to move on?
15:17:17 <bennyturns> I'll send emails there starting tomorrow.  I am ogod
15:17:21 <bennyturns> *good
15:17:32 <kkeithley> #topic 3.4
15:17:50 <kkeithley> Anyone know if 3.4.5beta1 has been tested by anyone?
15:18:16 <kkeithley> anyone have any other patches to add to 3.4.5?
15:18:37 <hagarth> kkeithley: I think there was one proposal on gluster-users ?
15:18:50 <kkeithley> https://bugzilla.redhat.com/show_bug.cgi?id=1110456 is the tracker bug
15:18:51 <glusterbot> Bug 1110456: unspecified, unspecified, 3.4.5, kkeithle, ASSIGNED , GlusterFS 3.4.5 Tracker
15:20:09 <kkeithley> okay, I'll look for it and add it to the tracker.
15:20:24 <kkeithley> then we should have a beta2
15:20:42 <kkeithley> will anyone test it?
15:21:05 <hagarth> bennyturns: would it be possible to schedule a test run with 3.4.5beta2?
15:21:12 <bennyturns> hagarth, yep can do
15:21:21 <bennyturns> was just about to volunteer :)
15:21:28 <kkeithley> #action bennyturns will test 3.4.5beta2
15:21:43 <kkeithley> #action kkeithley will release 3.4.5beta2 on 9 July
15:21:54 <hagarth> bennyturns: thanks!
15:21:58 <kkeithley> #action hchirmm_ will build 3.4.5beta2 rpms
15:22:06 <hchiramm__> done
15:22:14 <kkeithley> s/hchirmm_/hchiramm_
15:22:35 <hchiramm__> yep, done..
15:22:41 <kkeithley> anything else on 3.4?
15:23:26 <kkeithley> moving on to 3.5
15:23:29 <kkeithley> #topic 3.5
15:24:04 <kkeithley> ndevos, anything to say about 3.5, 3.5.2, etc.?
15:24:23 <ndevos> 3.5.2 is in progress, no eta for a beta
15:24:51 <kkeithley> okay
15:24:51 <ndevos> bugs/patches are still accepted, tracker is here: https://bugzilla.redhat.com/showdependencytree.cgi?hide_resolved=1&id=glusterfs-3.5.1
15:24:53 <glusterbot> Title: Dependency tree for Bug 1071800 (at bugzilla.redhat.com)
15:25:04 <ndevos> no, here: https://bugzilla.redhat.com/showdependencytree.cgi?hide_resolved=1&id=glusterfs-3.5.2
15:25:07 <glusterbot> Title: Dependency tree for Bug 1104511 (at bugzilla.redhat.com)
15:25:51 <kkeithley> anything else on 3.5?
15:26:05 <kkeithley> okay, moving on
15:26:10 <kkeithley> #topic 3.6
15:26:26 <hagarth> feature freeze is scheduled for end of this week
15:26:41 <hagarth> so any & all review help on features in gerrit are very welcome
15:27:04 <hagarth> i plan to go through erasure coding tomorrow
15:27:08 <jdarcy> Reviewing the EC stuff is still at the top of my list.
15:28:33 <hagarth> kshlm: will we have your peer identification work land in gerrit soon?
15:29:12 <kshlm> I need to test it, which I'm planning on doing tomorrow.
15:29:17 <hagarth> kshlm: ok
15:29:29 <kshlm> I'll push it to gerrit when I'm happy it works at least a little.
15:29:47 <hagarth> others, if you plan to send major code chunks over the next few days - please let us know on gluster-devel
15:30:52 <hagarth> any other queries on 3.6?
15:31:31 <hagarth> guess not
15:31:40 <kkeithley> okay
15:31:50 <kkeithley> #topic Other Items
15:32:18 <kkeithley> Any word from pranithk about the clienttable expand bug?
15:32:29 <hagarth> kkeithley: I added a minor comment in gerrit
15:32:40 <kkeithley> okay
15:32:41 <hagarth> rather a clarification
15:33:14 <kkeithley> but no word on the testing that his user was going to do?
15:33:24 <hagarth> kkeithley: no idea about that
15:33:28 <kkeithley> okay
15:33:45 <hagarth> Joseph Fernandes is looking for comments on his proposal in gluster-devel around compliance
15:34:44 <kkeithley> #topic Open Floor
15:34:52 <kkeithley> Any other topics?
15:35:38 <hagarth> happy US independence day weekend to all folks out there :D
15:35:51 <jdarcy> Thanks!  :)
15:35:58 <bennyturns> woot!
15:36:06 <kkeithley> fireworks
15:36:23 <kkeithley> okay, ready to end the meeting?
15:36:46 <kkeithley> going once
15:36:47 <hagarth> think so
15:37:02 <kkeithley> going twice
15:37:17 <kkeithley> #endmeeting
15:37:26 <kkeithley> thanks everyone
15:37:27 <jdarcy> Great timing.  ;)
15:37:31 <kkeithley> ;-)
15:37:51 <hchiramm__> thanks , bye :)
15:38:04 <hagarth> thanks, bye
15:38:13 <ndevos> kkeithley: I think only hagarth can do the #endmeeting
15:38:16 <hagarth> pranithk: right on the dot ;)
15:38:20 <hagarth> #endmeeting