12:02:04 <hagarth> #startmeeting
12:02:04 <zodbot> Meeting started Wed Nov  5 12:02:04 2014 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:02:22 <hagarth> #topic roll call
12:02:27 <hagarth> who do we have here today?
12:02:36 * Humble is here
12:02:49 * ndevos is here
12:03:05 * overclk is here
12:03:14 * hagarth expects some difficulties in attendance owing to the DST flip
12:03:32 <hagarth> in any case, let us get started
12:03:47 <ndevos> kkeithley is just arriving in the parking at the office, he'll be online soon to
12:03:50 <ndevos> o
12:04:16 <hagarth> ndevos: you seem to be accurate with his co-ordinates :)
12:04:23 <hagarth> #topic AI Review
12:04:41 <hagarth> davemc to contact Craig Butler
12:04:55 <hagarth> done as far as I understand. did notice some exchanges on twitter.
12:05:10 <ndevos> lol, twitter!
12:05:28 <hagarth> Craig might join one of these meetings and provide us an update on the FreeBSD port
12:06:08 <hagarth> moving on to next AI, hagarth to update maintainers file
12:06:36 <hagarth> yet to be done, we will probably add more maintainers (at least for DHT) and then I'll proceed to update the file
12:06:40 <hagarth> so this AI stands
12:06:43 <hagarth> #action hagarth to update maintainers file
12:07:01 <hagarth> moving on to next AI, ndevos to send email about the solution for rhel6.6 glusterfs version issue with upstream
12:07:12 <ndevos> does http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019333.html count?
12:07:31 * lalatenduM is late to the party :)
12:07:40 <ndevos> it does not mention how to use 3.4 or 3.5 though, that still somewhere on someone's TODO
12:07:48 <hagarth> ndevos: I think so
12:08:04 <hagarth> lalatenduM: better late than never :)
12:08:27 <hagarth> ndevos: should we wikify the solution?
12:08:37 <hagarth> and add details about 3.4/5 too?
12:08:52 <lalatenduM> a blog abt it will be better
12:08:53 <ndevos> hagarth: yes, wiki/blog/email
12:09:13 <hagarth> ndevos: ok, would you be willing to do that?
12:09:29 <ndevos> sure
12:09:43 <hagarth> #action ndevos to wiki/blog/email about solution for rhel6.6 glusterfs version issue with upstream
12:10:05 <hagarth> next AI - ndevos to send out email detailing solution to the RHEL-6.6 issue
12:10:12 <Humble> ndevos, yep.. its better blog about it
12:10:27 <hagarth> I think the email addresses it
12:10:40 <ndevos> yeah, you have a duplicate topic there
12:10:54 <hagarth> let us discuss about the larger packaging implications in the topic on 3.6
12:11:08 <hagarth> next AI - review Humbles suggestion for moving to 3.6.1 quickly
12:11:25 <hagarth> reviewed and we are all for it - let us discuss again in 3.6
12:11:46 <hagarth> that completes AIs from last week, moving on
12:11:51 <hagarth> #topic Gluster 3.6
12:12:22 <hagarth> we need to move all dependent bugs on the 3.6.0 tracker to 3.6.2
12:12:49 <hagarth> Once Raghavendra Bhat becomes active with release-3.6 maintenance, I expect this to happen.
12:13:14 <ndevos> and close the bugs that should be fixed?
12:13:36 <Humble> k.. I am requesting the tag for 3.6.2 in bugzilla
12:13:42 <hagarth> ndevos: do you mean - close the ones that are already fixed?
12:14:24 <ndevos> hagarth: bugs that have their patch in 3.6.1?
12:14:24 <lalatenduM> hagarth, there is no mail confirming Raghavendra Bhat as the 3.6 maintainer in MLs or did I miss it?
12:14:49 <lalatenduM> I think you can confirm him on top of his mail
12:14:52 <hagarth> ndevos: right
12:15:02 <ndevos> we did not vote about Raghavendra Bhat either - and should he be joining the meeting?
12:15:16 * kshlm is here
12:15:20 <hagarth> lalatenduM: I intend doing that, thanks for the reminder
12:15:33 <ndevos> in any case, a +1 from me :D
12:15:39 <hagarth> ndevos: he will be joining these meetings after a cpl of weeks
12:15:45 <lalatenduM> yes , +1 for Raghavendra Bhat
12:15:53 <ndevos> hagarth: ah, good!
12:15:59 <hagarth> since I haven't heard any -1s so far, I took it as a +1 from everyone :)
12:16:04 <kkeithley> +1 from me
12:16:06 <Humble> +1
12:16:36 <lalatenduM> #action hagarth to send an announcement abt Raghavendra Bhat as 3.6 maintainer
12:16:36 <hagarth> #action hagarth to send an email about release maintainer for 3.6
12:16:37 <lalatenduM> :)
12:16:55 <Humble> please mention the irc nick and email .etc in the same mail.
12:16:59 <Humble> it will be useful I think
12:17:34 <hagarth> Humble: sure, we should also create a page in the wiki that captures all details about maintainers .
12:17:37 <Humble> because we have lots of Raghavendras : )
12:17:46 <hagarth> s/all/relevant/
12:18:10 <Humble> yep.. we could do taht
12:18:33 <Humble> #action create a maintainer wiki page
12:18:39 <Humble> #action Humble create a maintainer wiki page
12:18:48 <hagarth> I think davemc had a topic on optimal days for announcing a release
12:19:01 <hagarth> we could hold that discussion while he's around here next week.
12:19:19 <hagarth> moving on to next topic
12:19:27 <hagarth> #topic GlusterFS packaging in CentOS/RHEL
12:20:03 <hagarth> I think all of us are aware of the problems that we have encountered by RHS packages of glusterfs client stack appearing in CentOS/RHEL
12:20:21 <hagarth> we need to find solutions for two problems around that.
12:20:29 <hagarth> 1. near term remedy for 3.6 packages
12:21:05 <hagarth> 2. long term solution that lets upstream and RHS packages work in harmony
12:21:22 <hagarth> for 1., the remedy is in pushing out 3.6.1 asap
12:21:36 <Humble> yep..
12:21:38 <ndevos> + include the libgfapi with symbol-versioning
12:21:43 <hagarth> and folks can update to 3.6.1
12:21:54 <Humble> yeah..
12:21:55 <ndevos> otherwise we need to rebuild qemu and other packages
12:22:06 <hagarth> ndevos: right, thanks to you and kkeithley for all the hard work on that!
12:22:19 <Humble> the symbol versioning has to be in 3.6.1
12:22:32 <kkeithley> Don't forget Anders Blomdell. He helped too
12:22:33 <ndevos> the RHEL-6.6 packages use libgfapi.so.0 for some reason, 3.6.0 provides libgfapi.so.7
12:22:51 <hagarth> so, I propose that we do 3.6.1 with symbol versioning and any critical fixes. ETA to be tomorrow.
12:22:55 <ndevos> indeed, we need to get him a present of some kind
12:23:12 <Humble> +1 to that
12:23:25 <lalatenduM> +1
12:23:35 <ndevos> so, PLEASE REVIEW AND TEST http://review.gluster.org/9036
12:23:35 <hagarth> ndevos: yeah, let us route this request to davemc
12:23:36 <Humble> even compat package was a good idea ..
12:24:04 <hagarth> #info 3.6.1 packages to be available this week
12:24:18 <hagarth> moving on to the long term solution
12:24:24 <ndevos> #agreed Anders Blomdell should receive a present for his help with libgfapi symbol-versioning
12:25:15 <lalatenduM> we should a release a update just after RHEL release if required
12:25:18 <hagarth> how do we ensure that the same problem doesn't happen when we release 3.7.0 and RHS has its next gen packages in RHEL/CentOS?
12:25:38 <ndevos> well, RHEL normally does not rebase, so if they stick with 3.6.0 we'll be good for a few years ;)
12:25:54 <hagarth> one possibility would be to advise RHS to come up with a different package naming scheme
12:25:56 <Humble> a thought here.  rhs should be a even number release ..
12:25:58 <lalatenduM> ndevos, it might in RHEL 6.7
12:26:19 <ndevos> +1 on advising them to do the versioning correctly
12:26:21 <hagarth> ndevos: however there is RHEL7 also looming around and we can have newer packages there
12:26:27 <lalatenduM> ndevos, atleast if you see rhel 6.5 vs 6.6
12:26:35 <Humble> which is < upsteam running version
12:26:41 <ndevos> RHEL7 has been released already, hagarth
12:26:55 <lalatenduM> ndevos, 7.1 is coming
12:27:02 <hagarth> ndevos: I meant newer RHS client packages on RHEL7
12:27:12 <ndevos> they are there too, I think?
12:27:16 <ndevos> in 3.6.0
12:27:33 <ndevos> but maybe in a child-repository
12:27:43 <hagarth> ndevos: I don't think RHEL will stick to 3.6 in both 6 & 7
12:27:44 <ndevos> uhm *channel*
12:27:53 <kkeithley> I'll resubmit 9036 with a BZ. Is there already a BZ open?
12:27:54 <hagarth> they have already moved from 3.4 to 3.6 in RHEL6
12:28:01 <lalatenduM> it is rh-common channel fo rrhel7
12:28:25 <lalatenduM> also in the base I think
12:28:39 <hagarth> Humble: hmm, not sure if we can insist RHT to do that
12:28:39 <ndevos> hagarth: yeah, RHS seems to have a magick button to push for newer versions
12:28:54 <hagarth> if RHS changes package names in RHEL
12:28:54 <Humble> hagarth, :( ..
12:29:20 <ndevos> ew, changing names would make things even more complicated
12:29:22 <hagarth> the implication would be that qemu etc. which have a dependency on glusterfs client stack
12:29:29 <hagarth> will only work with those packages
12:29:48 <hagarth> ndevos: yeah
12:29:56 <Humble> hagarth, if w can explore something on that line , it can help I think
12:30:13 <hagarth> JustinClift mentioned the possibility of using an Epoch tag or something like that
12:30:16 <ndevos> who ever wants to change the names of the packages, should probably not be in the packaging business
12:30:17 <hagarth> any idea about that?
12:30:49 <ndevos> epoch would work, until RHS rebases and takes our .spec again
12:31:03 <ndevos> it is very fragile too
12:31:33 <hagarth> phew
12:31:48 <ndevos> I am more in favour to describe the problem well, and give solutions like yum-plugin-priorities and exclude/includepkgs in .repo files
12:32:06 * lalatenduM checking fedora to see any example pkg which uses epoch tag
12:32:31 <lalatenduM> ndevos, +1
12:32:34 <hagarth> ndevos, Humble, lalatenduM, kkeithley: since you are the packaging gurus, would you want to take on this problem and propose possibilities & recommendations?
12:32:51 <ndevos> Epoch is generally used for packages that need to get downgraded because of a major flaw in the recent version (I think bind9 had one)
12:32:54 <lalatenduM> and blog abt it :)
12:32:55 <Humble> yeah.. I think we can discuss some more and come up with a solution
12:33:02 <hagarth> ndevos: oh ok
12:33:17 <ndevos> we have different repositories, so we can do the tuning in the .repo files
12:33:19 <lalatenduM> hagarth, =1
12:33:24 <lalatenduM> +1*
12:33:48 <hagarth> #action ndevos, lalatenduM, kkeithley and Humble to propose a long term solution to the packaging problem in CentOS/RHEL
12:33:49 <ndevos> that is something most users should understand too, epoch is a little less known and might confuse our users
12:34:33 <hagarth> there's an ongoing thread with the GlusterFS board, kbsingh and RHS management. I will add you folks to the thread.
12:34:46 <Humble> ok..
12:34:53 <ndevos> #agreed We should advise the RHS/glusterfs packagers to "do it right"
12:35:26 <hagarth> in any case, let us release 3.6.1 as agreed and enable our users!
12:35:41 * kkeithley was, oh, surprised, shall we say. RHS management was certainly aware that there was an issue
12:35:57 * kkeithley also thought that the GlusterFS board was aware too
12:36:12 <ndevos> #info Normally a pre release of a version (like RHS/glusterfs) would be versioned like glusterfs-3.6.0-0.1.something.bla.el6rhs...
12:36:21 <hagarth> ndevos: +!
12:36:28 <hagarth> s/!/1/
12:36:38 <kkeithley> not just pre-releases, all the releases. yes?
12:36:39 * Humble kkeithley  :)
12:36:42 <hagarth> anything more on 3.6?
12:36:54 <ndevos> kkeithley: note the -0.1 as "release tag"
12:37:12 <kkeithley> ndevos: yes
12:37:18 <ndevos> a real release would have -1
12:37:39 <lalatenduM> I think RHS should change the minor version if required right?
12:37:44 <ndevos> RHS still ships a pre-release of 3.6.0, so in that case the -0.1 will always stay
12:38:14 <lalatenduM> ndevos, actually the git tag should also come into pic
12:38:53 <hagarth> ok, we can discuss this in #gluster-dev later. . shall we move on to 3.5.0?
12:38:59 <ndevos> lalatenduM: yes! but that is up to how the rhs packagers would like to do it, git-hash, date, ... whatever, its the .something.bla in the above :)
12:39:15 <hagarth> #topic 3.5.0
12:39:20 <ndevos> correction, the next topic is 3.5.3
12:39:26 <hagarth> yes
12:39:30 <hagarth> #topic 3.5.3
12:39:48 <hagarth> ndevos: all yours
12:39:51 <ndevos> wohoo, beta2 has been released and is ready for *your* testing!
12:40:13 <hagarth> ndevos: awesome!
12:40:14 <ndevos> please verify any of the bugs that you are concerned about
12:40:36 <ndevos> #link http://blog.nixpanic.net/2014/11/glusterfs-353beta2-release-notes.html
12:40:48 <ndevos> not sure if it is on blog.gluster.org yet
12:40:49 <hagarth> ndevos: any ETA for 3.5.3 GA?
12:40:52 <kkeithley> ndevos: yes, sorry, I'm thinking of the glusterfs-3.6.0.29-2.el6.x86_64.rpm that's in RHEL6.6.   3.6.0.29-2, versus, e.g. community 3.6.0-1 or soon 3.6.1-1
12:41:12 <hagarth> ndevos: yes, blog.gluster.org features this entry
12:41:20 <ndevos> #link http://blog.gluster.org/2014/11/glusterfs-3-5-3beta2-is-now-available-for-testing/
12:41:54 <ndevos> kkeithley: yeah, inventing a new version (3.6.0.0) should not have been done
12:42:30 <ndevos> if there are no major issues with the beta2, we'll make a glusterfs-3.5.3 release somewhere next week
12:42:44 <hagarth> ndevos: that sounds fantastic!
12:42:59 * ndevos "next!"
12:43:22 <hagarth> #topic 3.4
12:43:47 <hagarth> kkeithley: are we still awaiting Pranith's patch?
12:44:05 <kkeithley> No, we got it. "And made the beta2 release last week
12:44:11 <kkeithley> I should add a blog entry
12:44:25 <kkeithley> was waiting for packages on d.g.o.
12:44:38 <kkeithley> Maybe they're there. I haven't looked. (was pretty busy. ;-))
12:44:44 <lalatenduM> kkeithley, I and Humble working on it
12:44:44 <hagarth> kkeithley: cool, let us do that. Is this the final beta for 3.4.7?
12:44:55 <kkeithley> and can release whenever we think we're ready
12:45:07 <lalatenduM> kkeithley, will let you know once it available in d.g.o
12:45:08 <kkeithley> no, beta2 for 3.4.6
12:45:16 <hagarth> kkeithley: oops, right
12:45:19 <kkeithley> haven't started 3.4.7 yet
12:45:39 <hagarth> #action kkeithley to add a blog entry on 3.4.6 after packages are available in d.g.o
12:46:10 <hagarth> #info 3.4.7 and 3.5.3 tentatively targeted for next week
12:46:16 <hagarth> #topic Gluster next
12:46:35 <hagarth> small file performance
12:46:39 <kkeithley> #info correction, 3.4.6 targetted for next week
12:46:46 <hagarth> kkeithley: thanks!
12:47:07 <hagarth> Ben England and Shyam have put together a feature page on small file perf. improvements
12:47:40 <hagarth> this was the #1 sought after requirement as per davemc based on initial survey responses
12:47:46 <jdarcy> I think we need to have a separate meeting to discuss exactly which of these features will become part of the 3.7 and 4.x plans.
12:48:01 <Humble> kkeithley, ndevos better if we push releases in a different date :)
12:48:02 <kkeithley> s/targetted/targeted/
12:48:21 <kkeithley> Humble: +1, yes
12:48:29 <hagarth> jdarcy: +1, feasibility and scheduling of all ideas that we have would be good to discuss in that meeting.
12:48:44 <hagarth> jdarcy: would you want to convene that meeting?
12:48:47 <krishnan_p> Would it be possible for us to publish the summary of the survey?
12:49:05 <hagarth> krishnan_p: dave intends doing that after the survey closes
12:49:12 <ndevos> Humble: I could not care less, but I'm also not a marketing guy :)
12:49:23 <hagarth> ndevos: lol
12:49:24 <jdarcy> hagarth: Sure.
12:49:29 <Humble> ndevos, :)
12:49:49 <hagarth> #action jdarcy to convene a meeting to discuss improvements in small file performance
12:50:02 <Humble> ndevos,  iic last friday was blessed with 3 releases . :)
12:50:13 <hagarth> other targets for Gluster.next
12:50:33 <ndevos> jdarcy: I think I have some things that I would like to see  in md-cache to improve meta-data heavy workloads
12:50:49 <ndevos> does that fit the small-files topic?
12:51:11 <hagarth> a smaller group is working on plans and messaging for Gluster.next. I expect announcements to happen to the community next week.
12:52:05 <hagarth> tentatively we are planning to have GlusterFS 3.7 release in April 2015
12:52:10 <jdarcy> I'm going to be at LISA next week, so scheduling might be a bit awkward, but we'll work something out.
12:52:41 <hagarth> jdarcy: ok
12:53:04 <hagarth> any questions on Gluster.next?
12:53:26 <hagarth> figure not .. moving on
12:53:47 <hagarth> #topic Other Agenda items
12:54:09 <hagarth> davemc wants to have a series of 10 minute GHO (Gluster Hangout) video recording on topics pertaining to GlusterFS
12:54:25 <hagarth> davemc has a few listed on the etherpad
12:54:36 <hagarth> s/few/few topics/
12:55:00 <hagarth> if you are interested, can you please drop davemc a note about your interest and the topic of choice?
12:55:09 <ndevos> whats so interesting about NFS?
12:55:30 <kkeithley> NFS-Ganesha NFSv4 perhaps?
12:55:45 <ndevos> oh, that!
12:55:56 <ndevos> you can talk about it then :D
12:56:06 <kkeithley> lol. Anand
12:56:11 <ndevos> +1
12:56:14 <Humble> :)
12:56:17 <lalatenduM> :)
12:56:21 <hagarth> ndevos: how about performance improvements in the gluster fsal for NFS Ganesha?
12:56:23 <jdarcy> Once we firm up the 4.x plans a bit, I'd love to do one about that.
12:56:35 <hagarth> jdarcy: +1
12:57:23 <hagarth> should we alter the time slot for this meeting given the DST flip in US?
12:57:43 <jdarcy> I kind of like having a reason to get up earlier.
12:57:48 <kkeithley> It's borderline for me. davemc might like it though
12:58:20 <hagarth> yeah, let us run it through davemc and figure out what works better for him
12:58:47 <hagarth> any other topics for today?
12:58:53 <jdarcy> It's pretty much davemc vs. BLR.  It's easier for those in the middle to cope either way.
12:59:04 <Humble> may be about GlusterFS meetup we are planning
12:59:04 <ndevos> \o/
12:59:05 <kkeithley> I'll resubmit gfapi symbol versions with a BZ
12:59:13 <Humble> we are planning to have a meetup here in Bangalore.
12:59:20 <Humble> http://www.meetup.com/glusterfs-India/events/197675922/
12:59:24 <ndevos> kkeithley: just update the commit message in the Gerrit webui
12:59:28 <kkeithley> backport to 3.6 at least. What about 3.5 and 3.4?
12:59:29 <jdarcy> Plus the 4.x summit in Goa, right?
12:59:38 <hagarth> jdarcy: yes, of course!
12:59:47 <kkeithley> +1 for summit in Goa.
12:59:55 <lalatenduM> +1 for Goa :)
13:00:13 <krishnan_p> jdarcy, +1 for Goa design summit!
13:00:13 <ndevos> kkeithley: ah! backporting the symbol-versioning was indeed something I wanted to discuss too
13:00:13 <kkeithley> On the beach even?
13:00:13 * jdarcy just wants to keep that in people's minds.  ;)
13:00:31 <hagarth> I think we need to have more meetups everywhere :)
13:00:41 <hagarth> ndevos: can we plan one alongside dockercon EU?
13:00:49 * krishnan_p wants to be in the Goa meetup definitely
13:01:05 <hagarth> ndevos: dockerconEU happens in Amsterdam, first week of December
13:01:13 <ndevos> hagarth: I'm sure we can, but I might not be the right person to arrange that?
13:01:20 <lalatenduM> WILL /ME get an invite for Goa?
13:01:21 <ndevos> oh, Amsterdam, interesting
13:01:25 <hagarth> ndevos: we can always seek davemc's help for that
13:01:41 * ndevos would rather go to Goa than to Amsterdam
13:01:42 <hagarth> lalatenduM: as long as you promise to contribute your pound of flesh to 4.0 :)
13:01:45 <Humble> lalatenduM, Goa looks to be a tourist place :)
13:01:46 <kkeithley> ndevos: I don't see how to do that
13:01:52 <hagarth> ndevos: lol
13:02:03 <lalatenduM> hagarth, :)
13:02:15 <hagarth> ndevos: let us discuss that offline
13:02:30 * ndevos disconnects
13:02:34 <hagarth> maybe we could do a meetup in Westford/Boston too
13:02:50 <lalatenduM> hagarth, +1 also bay area
13:02:50 <Humble> hagarth, +1
13:02:53 <ndevos> there is the Vault conference in March next year?
13:03:10 <hagarth> ndevos: right. maybe something before that too .. let us see.
13:03:15 <kkeithley> submit papers/talks to Vault!!!
13:03:22 <krishnan_p> I would like to be there for the Vault conference!
13:03:27 <JustinClift> Arrrgh
13:03:29 <JustinClift> I'm out by an hour
13:03:33 <kkeithley> DevConf in Brno, in February
13:03:35 <hagarth> yeah, everybody please send your submissions to Vault.
13:03:44 <ndevos> FOSDEM?
13:03:54 * JustinClift forgot TZ changes
13:04:05 <hagarth> FOSDEM cfp is closed I think
13:04:05 * krishnan_p is definitely doing that! But don't know on what though.
13:04:15 <kkeithley> CFP for FOSDEM is closed. I'm waiting to see if my lightning talk is accepted though
13:04:20 <ndevos> oh, and DockerCon in December in Amsterdam - let me know if you'll be there!
13:04:20 <hagarth> krishnan_p: get your creativity going ;)
13:05:01 <hagarth> ndevos: my submission got tanked in DockerCon .. won't be there.
13:05:16 <ndevos> hagarth: ah, thats sad
13:05:22 <kkeithley> ndevos: nm, I found how to edit the commit message
13:05:24 <hagarth> that should be it for now.
13:05:31 <hagarth> thanks everybody for being here today. Talk to you all next week.
13:05:36 <hagarth> #endmeeting