12:01:35 <hagarth> #startmeeting
12:01:35 <zodbot> Meeting started Wed Jan 21 12:01:35 2015 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:47 <hagarth> agenda: https://public.pad.fsfe.org/p/gluster-community-meetings
12:01:58 <hagarth> #topic roll call
12:02:02 <hagarth> who do we have here today?
12:02:15 * raghu is here
12:02:33 * aravindavk is here
12:02:38 * lalatenduM is here
12:02:51 * hchiramm_ is here
12:03:06 * xavih is here
12:03:12 * jdarcy is.
12:03:16 <hagarth> #topic Action Items from last meeting
12:03:18 * ndevos is here, but also in a confcall, so might be responding slow
12:03:32 <hagarth> AI - hchiramm will try to fix the duplicate syndication of posts from blog.nixpanic.net
12:03:40 <hagarth> hchiramm_: any progress on this one?
12:03:50 <partner> hep
12:03:58 <hchiramm_> hagarth, unfortunately no
12:04:00 * jimjag is here
12:04:24 <hagarth> hchiramm_, ndevos: wonder if we need more assistance to sort this out
12:04:41 <hchiramm_> hagarth, its always better :)
12:04:52 <hagarth> ndevos: probably time for you to test this duplication by posting a new blog post again :)
12:04:59 <hchiramm_> yeah
12:05:18 <ndevos> hagarth: sure, I can post something later this week
12:05:25 <hagarth> ndevos: cool, thanks!
12:05:36 * JustinClift is here
12:05:37 <hagarth> AI - Debloper to write  a blog post about complete website revamp
12:05:41 <JustinClift> Bit late. ;)
12:05:53 <hagarth> this is still TBD but however I have some updates on the website revamp
12:06:26 * spot is here too
12:06:28 <hagarth> tigert worked on a revamp of the website. The staging site link was shared on gluster-infra a while back.
12:06:40 <hagarth> spot: would you want to talk about the revamp?
12:07:00 <hchiramm_> http://glustermm-tigert.rhcloud.com/ hagarth this one right?
12:07:13 <hagarth> hchiramm_: right
12:07:25 <hagarth> thanks for the link btw
12:07:31 <hchiramm_> np :)
12:07:47 <spot> hagarth: i'd be interested to know if there are any concerns about tigert's work
12:08:19 <hagarth> yes, it would be great if we check the staging area and send out feedback on infra or users ML
12:08:21 <JustinClift> spot: Prob needs a link to the Blog in the top header too
12:08:22 <spot> there are some minor technical details to figure out, but the overall look and feel is done
12:08:47 <JustinClift> Yeah
12:09:05 <hagarth> +1 for the look and feel
12:09:12 <spot> Maybe instead of the header, making the "From the Blog" a link to it?
12:09:18 <JustinClift> spot: If we can get some sort of way to distinguish the companies that contribute to GlusterFS for the "Support and Consultants" page, that would be good too
12:09:29 <hagarth> I would like to change the "Write Once, Read Everywhere" message though
12:09:31 <JustinClift> eg DataLab and RH do.  I'm unsure about the other two
12:10:01 <ndevos> hagarth: +1 we're not like Java
12:10:10 <hagarth> I don't understand what the message attempts to convey ;)
12:10:20 <hchiramm_> hagarth, +1
12:10:29 <hagarth> neither we are a WORM storage solution
12:10:29 <spot> hagarth: how about "Prepare your storage for the cloud" ? :)
12:11:05 <hagarth> spot: something like that would be better, maybe we could invite suggestions from the community? :)
12:11:12 <JustinClift> "Enterprise Scale out storage on Community hardware"
12:11:12 <spot> hagarth: thats a good idea.
12:11:15 <lalatenduM> hagarth, +1
12:11:24 <JustinClift> Yeah, lets ask on the Community venues
12:11:41 <jdarcy> I think it's trying to get at the "data unification" concept - same data, accessible multiple ways.
12:12:04 <hchiramm_> will we have a check on broken links (ex:http://glustermm-tigert.rhcloud.com/documentation/community/Presentations )  before pushing from staging area?
12:12:05 <hagarth> spot: shall I put an AI  on you for this?
12:12:22 <spot> hagarth: sure
12:13:02 <kkeithley> Yes, johnmark coined that phrase when UFO (now swift-on-file) and Hadoop were on everyone's radar
12:13:06 <spot> hchiramm_: i'll work with tigert to try to make sure we get as many as possible
12:13:14 <hchiramm_> spot, thanks!
12:13:30 <hagarth> #action spot to reach out to community about website messaging
12:13:35 <jdarcy> We could have a new-tagline competition, maybe even offer some swag.
12:14:00 <hagarth> jdarcy: +1
12:14:04 <hchiramm_> +1
12:14:37 <hagarth> moving on to #AI - hagarth to open a feature page for (k)vm hyperconvergence
12:14:59 <hagarth> this is still pending, I am awaiting the ovirt folks to open a corresponding feature page
12:15:18 <hagarth> this is expected to happen sometime over the week and I will have this page ready by next meeting
12:15:24 <hagarth> #action hagarth to open a feature page for (k)vm hyperconvergence
12:15:37 <hagarth> next AI - hagarth to share results of community survey and solicit feature proposals from the community
12:15:51 <hagarth> I have done a basic scrub of the community survey responses
12:15:58 <hagarth> intend writing a blog post about this
12:16:16 <hagarth> the responses have been quite positive - thanks to everyone who did participate!
12:16:38 <hagarth> here's a list of features that community requested for - https://public.pad.fsfe.org/p/glusterfs-user-survey-features
12:17:25 <hagarth> I intend to have a blog post and mail soliciting features tomorrow
12:17:33 <hagarth> so, this AI carries forward
12:17:45 <hagarth> #action hagarth to share results of community survey and solicit feature proposals from the community
12:18:04 <hagarth> AI - spot to investigate repetitive posts on social networking sites
12:18:14 <jdarcy> "Make it a replacement for SAN and you win"   I love the smell of victory.
12:18:24 <hagarth> :)
12:18:38 <spot> hagarth: best i can tell, this is wordpress weirdness.
12:19:18 * spot is still looking into it, but i don't have access to the wordpress blog bits
12:19:22 <hagarth> spot: yeah, seems like. let us see if this repeats again. haven't noticed in the recent past but again our social media channels have not been buzzing with a lot of activity in this period.
12:19:34 <hagarth> JustinClift: would you be able to help spot with wp-admin?
12:20:18 <jdarcy> Maybe I could look into it.  I used WordPress myself for several years, hacked on it a bit.
12:20:38 <hagarth> jdarcy: thanks!
12:20:42 <hagarth> #action JustinClift to help spot and jdarcy with wp-admin
12:20:42 * jdarcy . o O ( Did I just admit in public that I've hacked on PHP code? )
12:20:57 <hagarth> jdarcy: we could highlight it in the meeting minutes ;)
12:21:10 <spot> jdarcy: we were all young and misguided once. ;)
12:21:36 <hagarth> lol
12:21:42 <hagarth> next AI - spot will send out an email with upcoming Gluster events and meetups
12:22:13 <hagarth> spot: ndevos created this to help in such an endeavor - https://public.pad.fsfe.org/p/gluster-events
12:22:23 <kkeithley> and other events, etc., where we should put in an appearance?
12:22:51 <spot> kkeithley: exactly. i'm working on a list of places that it seems like we should try to be at
12:22:55 <ndevos> thats only temporary, just to get a start until we have something like a real calendar
12:23:11 <hagarth> spot: shall we carry on the AI?
12:23:12 <spot> and at the same time, putting together budget for them
12:23:16 <spot> hagarth: sure
12:23:25 <hchiramm_> hagarth, ndevos amy be we could have this in website http://glustermm-tigert.rhcloud.com/community/
12:23:31 <hchiramm_> amy/may :)
12:23:32 <hagarth> #action spot will send out an email with upcoming Gluster events and meetups
12:23:42 <JustinClift> hagarth: Hmmm, I can give admin access to WordPress to jdarcy if needed?
12:23:53 <hagarth> hchiramm_: looks like a good idea
12:24:04 <hagarth> JustinClift: yes please and to spot too.
12:24:19 <JustinClift> Yep, no worries
12:24:49 <hagarth> next AI - raghu to open a 3.6.3 tracker and move dependent bugs from the 3.6.2 tracker to that.
12:25:03 <hchiramm_> ther is already a title called "Gluster Meetups"
12:25:14 <hchiramm_> may be we can expand it to announce events
12:25:27 <raghu> ahh. yes. Missed that. Will do it tomorrow.
12:25:32 <hagarth> raghu: ok
12:25:43 <hagarth> #action raghu to open a 3.6.3 tracker and move dependent bugs from the 3.6.2 tracker to that.
12:26:10 <hagarth> next AI - ndevos to create a feature page for more portable POSIX ACLs
12:26:20 <hagarth> this is WIP as per the update on etherpad
12:26:32 <ndevos> yes, indeed, still needs some extra work
12:26:55 <hagarth> ndevos: ok, I don't think we need a reminder on this one for next week right?
12:27:05 <ndevos> hagarth: no, not really
12:27:19 <hagarth> ndevos: cool, will drop this AI then
12:27:23 <hagarth> next AI - carry forward discussion on automated builds for various platforms in gluster-infra ML.
12:27:37 <hagarth> we still need to do this
12:27:47 <hagarth> #action hagarth to carry forward discussion on automated builds for various platforms in gluster-infra ML.
12:28:03 <hagarth> that completes our list of AIs
12:28:08 <hagarth> moving on to 3.6
12:28:11 <hagarth> #topic Gluster 3.6
12:28:25 <raghu> I have made 3.6.2 release.
12:28:49 <hagarth> raghu: you mean the tag is pushed and the tarball is available on bits.gluster.org?
12:28:52 <raghu> yeah
12:29:12 <raghu> Have sent the mail to ndevos, lalatenduM, kkeithley and hchiramm_
12:29:15 <kkeithley> did we get any testing of 3.6.2beta2?
12:29:26 <kkeithley> any reports of testing?
12:29:33 * kkeithley is just curious
12:29:36 <partner> did not yet have the change, thanks for the debs thought
12:29:44 <partner> chance to test..
12:30:14 <raghu> Ran some tests. And also got feedback from a user. There was a crash in dht. Backported that patch and have merged it
12:30:28 <hagarth> partner: would you be able to build debs for 3.6.2 or do we need semiosis' assistance for that?
12:30:37 <partner> i think i didn't find the packages ? not on download.gluster.org?
12:30:49 <hagarth> raghu: can you please send a link to partner?
12:31:01 <partner> nvm, i was on the wrong path :)
12:31:03 <hagarth> s/a link/appropriate link to 3.6.2/
12:31:09 <partner> this for the record: http://download.gluster.org/pub/gluster/glusterfs/qa-releases/3.6.2beta2/
12:31:30 <raghu> hagarth: sure, will do it
12:31:47 <raghu> partner: can you let me know your email?
12:32:51 <hagarth> I think we could announce 3.6.2 after both debs and rpms are available, thoughts?
12:32:52 <kkeithley> I did the 3.6.2beta2 .debs.
12:33:34 <hchiramm_> hagarth, yep
12:33:35 <kkeithley> If semiosis can't get to them in short order I'll do them.
12:33:42 <hagarth> kkeithley: cool
12:33:56 <hagarth> or should we announce 3.6.2 once RPMs are available tomorrow?
12:35:25 <partner> i have no access to build infra other than the one at the company nor any means to upload anything anywhere
12:35:46 <hagarth> if we don't have a strong bias on this one, we can continue to operate as we've been doing and try to sort out the packaging problem for 3.6.3
12:35:48 <hagarth> partner: ok
12:36:03 <hagarth> any more thoughts on 3.6?
12:36:07 <raghu> hagarth: seems ok to me
12:36:32 <hagarth> guess not, moving on
12:36:43 <hagarth> #topic GlusterFS 3.5
12:37:06 <hagarth> ndevos: any updates here?
12:37:15 <ndevos> no, nothing
12:37:44 <hagarth> ndevos: ok
12:37:58 <hagarth> #topic GlusterFS 3.4
12:38:13 <hagarth> kkeithley: anything to discuss here?
12:38:41 <partner> some memory leaks still to be fixed and released?
12:38:48 <kkeithley> correct
12:38:51 <kkeithley> nothing
12:39:18 <hagarth> kkeithley: ok
12:39:29 <hagarth> #topic Gluster next
12:39:42 <hagarth> 3.7 feature freeze is set for Feb 28th
12:40:03 <hagarth> please intend getting your features in sooner so that reviewers do not get burdened on Feb 28th :)
12:40:25 <hagarth> trash xlator and netgroups enhancements have already appeared
12:40:43 <jdarcy> Would it be worth asking 3.7 feature authors to update status on their feature pages?
12:41:07 <hagarth> jdarcy: good idea
12:41:25 <ndevos> do we have a 3.7 blocker for feature 'bugs'?
12:41:28 <jdarcy> I have *no idea* which features are in good shape and which are at risk.
12:41:29 <hagarth> we could also ask others who are working on 3.7 features to open feature pages sooner than later
12:42:10 <hagarth> #action hagarth to do a sanity check on status of features for 3.7 in gluster-devel
12:42:21 <jdarcy> BTW, I'll be doing something similar for 4.0 features.  Maybe even set up a tracking board.
12:42:22 <ndevos> I guess if there is no feature page before beginning of February, the feature will get denied for 3.7?
12:42:24 <hagarth> ndevos: not yet, intend creating one after we branch release-3.7
12:42:54 <hagarth> ndevos: yes, maybe we can propose that
12:43:04 <ndevos> hagarth: it would be nice to have one earlier, so that we can start tracking the progress of features through bugzilla
12:43:53 <hagarth> ndevos: tracking features has been a tough nut to crack.. we have too many places - feature pages, bugzilla etc.
12:44:03 <hagarth> and keeping all of them in sync might be tough
12:44:17 <hagarth> we were trying to determine how we can simplify this process for developers
12:44:31 <hagarth> we did explore a few tools too, mainly for 4.0
12:44:44 <ndevos> and I am thinking of the users that are interested in features for 3.7 :)
12:44:57 <hagarth> we = jdarcy, me and krishnan_p :)
12:45:23 <hagarth> ndevos: how about the 3.7 planning page for users?
12:45:38 <hagarth> #link - http://www.gluster.org/community/documentation/index.php/Planning37
12:46:12 <ndevos> hagarth: that does not really get updated automatically - but each feature needs a bug to post patches, those bugs get updated when a patch is available for testing
12:47:26 <hagarth> ndevos: yes, we need a better process for managing features. I am not sure if bugzilla is appropriate to manage our entire feature backlog and display lifecycle status like "design ready", "implementation started", etc.
12:48:20 <ndevos> hagarth: bugzilla is not sufficient, but that is what our users check first if they want to file an RFE
12:48:33 <jdarcy> I think our best bet is to start with a manual process run by the release czar, then try to automate that as the process/format settles.
12:49:04 <jdarcy> Just having a page with feature/status/est_time_remaining would be helpful.
12:49:24 <jdarcy> Ang bug links.
12:49:45 <hagarth> jdarcy: more like a report/dashboard, good idea
12:50:09 <hagarth> it could even be a bugzilla report :)
12:50:15 <ndevos> \o/
12:50:32 <hagarth> let's attempt something for 3.7 and see how it goes
12:50:45 <hagarth> #topic GlusterFS 4.0
12:50:55 <hagarth> jdarcy: any updates here?
12:51:10 <jdarcy> I'll be collecting the kind of information we just discussed, and will post to the ML this week.
12:51:48 <jdarcy> Xavier has written a document on the caching feature, which should be available for general review this week.
12:52:02 <jdarcy> That's it.
12:52:24 <hagarth> jdarcy: neat, my mail should also be out tomorrow with the etherpad link for features from the survey.
12:52:39 <hagarth> interested in getting to know more about what the community needs.
12:53:08 <hagarth> ok, moving on to Other items
12:53:11 <hagarth> #topic Unit test / cmockery
12:53:21 <hagarth> kkeithley: would you want to frame this topic?
12:54:18 <hagarth> kkeithley had a thought about the necessity to continue cmockery in the src repo given lack of uptake for it.
12:54:35 <hagarth> any thoughts or opinions on this?
12:55:10 <ndevos> unit tests would be good, but yeah, well, nobody seems to write them
12:55:36 <JustinClift> Perhaps if we mandate all 3.7/4.0 features have to use it?
12:55:45 <JustinClift> eg "else they don't get accepted" ?
12:56:09 <ndevos> and, cmockery2 is a fork of cmockery, very similar to the more adapted cmocka (samba etc.)
12:57:11 <JustinClift> lpabon doesn't seem interested in just using cmocka.  I still don't understand why, but hey, it's not my project... ;)
12:57:24 <hagarth> JustinClift: not a bad idea, I think this warrants a larger discussion on gluster-devel though.
12:57:30 <JustinClift> Good point
12:57:41 <JustinClift> Who's the right person to start that?  I kinda doubt it's me
12:57:42 <hagarth> JustinClift: AI this for yourself? :)
12:57:57 <JustinClift> Sure, I can if you reckon I'm the right person to start that
12:57:59 <ndevos> and a good guideline/suggestion on what kind of functions need unit tests
12:58:06 <JustinClift> lpabon is on leave soon from memory tho
12:58:35 <hagarth> JustinClift: let us get started, lpabon will be available for a while before he goes on a break
12:59:51 <hagarth> ok, anything else for today?
13:00:35 <hagarth> figure not, thanks everyone for attending. Talk to you all next week.
13:00:42 <hagarth> #endmeeting