12:04:37 <ndevos> #startmeeting
12:04:37 <zodbot> Meeting started Tue Feb 24 12:04:37 2015 UTC. The chair is ndevos. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:04:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:04:43 <ndevos> #info Agenda: https://public.pad.fsfe.org/p/gluster-bug-triage
12:04:51 <ndevos> #topic Roll Cal
12:04:54 <ndevos> Hi all _o/
12:05:01 <ndevos> who's attending today?
12:05:15 <ndevos> lalatenduM, hchiramm__ ?
12:05:31 <lalatenduM> ndevos, I am around
12:06:04 <ndevos> hi lalatenduM!
12:06:17 <lalatenduM> ndevos, I dont see Kaleb :/
12:07:00 <lalatenduM> ndevos, lets go ahead , see what we can do
12:07:20 <ndevos> lalatenduM: Kaleb is in California, I hope he's still asleep
12:07:41 <lalatenduM> ndevos, is he attending any conf?
12:08:23 <ndevos> lalatenduM: connectathon - like NFS client/server testing
12:08:32 <lalatenduM> cool
12:09:55 <ndevos> #topic Last weeks open standing action item(s)
12:10:02 <ndevos> #info subtopic: lalatenduM will send a reminder to the users- and devel- ML about (and how to) fixing Coverity defects
12:10:13 <ndevos> hah! such a coincidence, lalatenduM is here!
12:10:25 <lalatenduM> ndevos, I have some update on this
12:10:33 * ndevos is amazed :)
12:10:54 <ndevos> #chair lalatenduM
12:10:54 <zodbot> Current chairs: lalatenduM ndevos
12:10:57 <lalatenduM> ndevos, we were trying to do the Coverity runs through travis , gem was working on this
12:10:57 <hchiramm> ndevos, I am in
12:11:08 <ndevos> #chair hchiramm
12:11:08 <zodbot> Current chairs: hchiramm lalatenduM ndevos
12:11:28 <lalatenduM> but looks like we dont need travis as its purpose is mostly CI
12:11:51 <lalatenduM> so now the question is how we want to do Coverity runs in an automated way
12:11:59 <lalatenduM> it can be a Jenkins job
12:12:03 <lalatenduM> or a cron job
12:12:11 <hchiramm> lalatenduM, u mean gem's effort was not needed ?
12:12:12 <lalatenduM> to start the Coverity run
12:12:24 <ndevos> Jenkins allows scheduled jobs too, that would be best, IMHO
12:12:49 <lalatenduM> hchiramm, kind of , gem did RnD around Travis
12:13:03 <lalatenduM> and Travis is mostly used for CI
12:13:13 <lalatenduM> like for each commit to git repo
12:13:24 <lalatenduM> which is not possible for glusterfs
12:13:37 <lalatenduM> as we can only do 2 Coverity runs each week
12:13:50 <hchiramm> lalatenduM, I thought she started the work after we had a solid plan :)
12:13:55 <ndevos> isnt there a plugin for Jenkins to start Travis-CI jobs?
12:14:27 <lalatenduM> hchiramm, nope. We wanted to her to explore Travis to see if we can use it for Coverity run
12:14:56 <lalatenduM> ndevos, not sure. andway we cant do Coverity runs for each commit
12:15:31 <lalatenduM> RE "Jenkins allows scheduled jobs too, that would be best, IMHO" , I agree
12:15:38 <ndevos> lalatenduM: no, Coverity should be a scheduled job - but thats different from Travis, right?
12:15:44 <hchiramm> hmmmm.. any way gem++ :)
12:16:27 <lalatenduM> ndevos, yes
12:16:42 <lalatenduM> I am agreeing to Jenkins to schedule Coverity runs
12:16:56 <ndevos> #agreed use Jenkins to schedule Coverity runs
12:17:43 <ndevos> and do we still want to use Travis-CI too?
12:17:58 <lalatenduM> ndevos, nope
12:18:11 <ndevos> okay, good, that makes things easier :)
12:18:12 <lalatenduM> ndevos, because we have our own CI stuff
12:18:34 <ndevos> yeah, if we want to test on Debian/Ubuntu, we should setup a VM for that
12:18:50 <lalatenduM> Who would be the right person to create a jenkins job , hchiramm is it you?
12:18:56 <hchiramm> no :)
12:18:57 <lalatenduM> soemone with admin access rights
12:19:12 <ndevos> gem :)
12:19:31 <lalatenduM> ndevos, someone needs to give gem access to jenkins
12:19:41 <gem> lalatenduM, ndevos hchiramm :)
12:19:53 <ndevos> lalatenduM: hchiramm can do that
12:19:58 <ndevos> I think?
12:20:12 * lalatenduM thinks the same
12:20:20 * ndevos hands gem a few bits of CI
12:20:54 <ndevos> gem: would you be willing to setup a scheduled Coverity job in Jenkins?
12:21:04 <hchiramm> ndevos, gem is busy with logging patches
12:21:39 <ndevos> ah, ok, who would you suggest, hchiramm?
12:21:59 <hchiramm> JustinClift, ? :)
12:22:15 <lalatenduM> If no one is taking it up, I will do it :)
12:22:27 <hchiramm> ndevos, u have a volunteer :)
12:22:28 <ndevos> I doubt JustinClift has time for that
12:22:42 <ndevos> lalatenduM: oh, yes please! WE LOVE YOU <3
12:22:55 <hchiramm> \o
12:23:14 <lalatenduM> #action lalatenduM to create a jenkins job to do Coverity runs
12:23:53 <ndevos> oh, I wanted to #action lalatenduM deserves a lot of love from all of us because he will setup a scheduled Jenkins job for automated Coverity runs
12:24:04 <lalatenduM> :)
12:24:42 <ndevos> lalatenduM: is there anything you need to get that done?
12:24:57 <lalatenduM> ndevos, nope, I think Jenkins access
12:25:05 <lalatenduM> I have jenkins access*
12:25:34 <ndevos> lalatenduM: can you access this? http://build.gluster.org/view/All/newJob
12:25:53 <lalatenduM> checking
12:25:57 <ndevos> ah, and your access includes sufficient permissions?
12:25:58 <lalatenduM> yes I haveaccess
12:26:35 <lalatenduM> created http://build.gluster.org/job/Automated%20%20Covscan%20runs/
12:26:37 <ndevos> okay, good
12:27:18 <ndevos> #info subtopic: hchiramm will get version 3.6.2 in Bugzilla
12:27:46 <hchiramm> done
12:27:55 <ndevos> thanks!
12:28:02 <ndevos> #info subtopic: lalatenduM will look into using nightly builds for automated testing, and will report issues/success to the mailinglist
12:28:13 <hchiramm> ndevos, yw
12:28:16 <lalatenduM> ndevos, working on it
12:28:43 <ndevos> okay, good
12:28:48 <ndevos> #info subtopic: lalatenduM initiate a discussion with the RH Gluster team to triage their own bugs when they report them
12:28:58 <lalatenduM> ndevos, thast done I think
12:29:07 <ndevos> lalatenduM: nice!
12:29:41 <hchiramm> Is it ?
12:29:44 <ndevos> the other topics in the list are either not done, or the assignee isnt there
12:29:57 <hchiramm> lalatenduM, didnt notice that ..
12:30:05 <ndevos> well, we'll see if they do it too
12:30:05 <hchiramm> may be my mistake
12:30:18 <lalatenduM> hchiramm, yeah the mail was in storage-eng
12:30:28 <lalatenduM> hchiramm, and QE is going to follow that
12:30:37 <hchiramm> oh.. its in storage-eng
12:30:41 <ndevos> "initiate a discussion" is surely done, the effect is what we can check while triaging
12:30:57 <hchiramm> ndevos, true
12:31:00 <lalatenduM> yeah
12:31:03 <ndevos> #topic Group Triage
12:31:38 <ndevos> wohoo, 10 bugs to triage: http://goo.gl/0IqF2q
12:31:50 <ndevos> please take an IRC lock as usual
12:32:14 * hchiramm lock my bug 1193474
12:32:29 * ndevos 1194306
12:32:46 * lalatenduM 1195646
12:32:47 * hchiramm lock 1194559
12:33:56 <lalatenduM> ah sorry clicked on a wrong bug
12:34:13 * ndevos 1193970
12:34:23 * hchiramm locks 1194306
12:34:46 * hchiramm locks 1195646
12:35:17 * ndevos 1195415
12:35:34 <ndevos> hchiramm: doesnt look like you got that last lock?
12:35:36 <hchiramm> ah.. mid air
12:35:43 <hchiramm> ndevos, yeap.. I didn
12:35:48 <hchiramm> didn/did
12:35:52 * lalatenduM 1193767
12:37:21 * lalatenduM 1195668
12:38:19 * ndevos 1193636
12:39:03 * lalatenduM 1194380
12:40:30 <hchiramm> ndevos, clear zstream from 1193636 :)
12:40:47 <ndevos> hchiramm: yeah, just did :)
12:40:54 <hchiramm> :)
12:42:22 <ndevos> lalatenduM: you're done with the last bug?
12:42:41 <ndevos> #topic Open Floor
12:42:43 <lalatenduM> yes
12:42:53 <ndevos> anything more to discuss?
12:43:00 <hchiramm> no from me :)
12:43:11 <lalatenduM> nothing from me as well
12:44:06 <ndevos> okay, thanks for joining!
12:44:09 <ndevos> #endmeeting