12:01:35 <kshlm> #startmeeting
12:01:35 <zodbot> Meeting started Wed Jul 29 12:01:35 2015 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:45 <kshlm> #topic Roll call
12:01:55 * poornimag is here
12:01:56 * rafi is present
12:02:06 * raghu is here
12:02:13 * rtalur is here
12:02:17 * jarrpa is here
12:02:22 * obnox is here
12:02:23 * anoopcs is here
12:02:34 * hagarth is here
12:02:36 * overclk is here
12:02:59 <kshlm> Okay. We've go enough attendees.
12:03:24 <kshlm> As always the agenda is at https://public.pad.fsfe.org/p/gluster-community-meetings
12:03:24 * kotreshhr is here
12:03:31 * pranithk is here
12:03:32 * kdhananjay1 is here.
12:03:35 <kshlm> #topic Last week's action items
12:03:41 * ira_ is here.
12:03:55 <kshlm> I'll be skipping items already addressed in the etherpad.
12:04:20 <kshlm> #topic
12:04:22 <kshlm> * tigert summarize options for integrating a calendar on the website,
12:04:23 <kshlm> call for feedback
12:04:41 <kshlm> #topic tigert summarize options for integrating a calendar on the website, call for feedback
12:04:49 <kshlm> is tigert around?
12:04:55 * samikshan is here
12:05:03 <hagarth> kshlm: unsure about that
12:05:36 <kshlm> Okay. Carrying this forward to next week.
12:05:40 <kshlm> #action tigert summarize options for integrating a calendar on the website, call for feedback
12:05:57 <kshlm> #topic raghu to reassess timeline for next 3.6 release
12:06:24 <kshlm> raghu I don't remember you being here last week.
12:06:45 <kshlm> Do you have any update on this?
12:06:56 <raghu> kshlm: I wanted to make the release this week itself. But, there are not much patches that were sent for review. Vijaykumar has backported some patches some time ago.
12:07:18 * ndevos looks around
12:07:27 <hagarth> I wonder if we should publish a calendar for all our minor releases
12:07:29 <raghu> I want to include those changes and there is one more ACL patch sent by ndevos. I want to have that as well
12:07:38 <kshlm> The issue was that you were planning releases too quickly
12:07:53 <kshlm> The opinion was that we should have a little more time between releases.
12:07:59 * skoduri is here
12:08:12 <kshlm> It's just been 2 weeks since 3.6.4
12:08:23 * jiffin is here
12:08:23 <raghu> kshlm: Yes. But I think only 2-3 patches were merged for release-3.6 after 3.6.4 and there were no more patches.
12:08:27 * kkeithley i shere
12:08:35 <hagarth> kshlm: what would be an optimal frequency? once per month?
12:08:36 * msvbhat joins the meeting
12:08:49 <ndevos> I wanted to ask the same thing, hagarth
12:09:24 <kshlm> hagarth, Yeah.
12:09:27 <raghu> I mainly want to include ACL patch by ndevos, as that was something asked by one of the community members.
12:09:33 <hagarth> I think one release in a minor train per month would be optimal.. we can always have exceptions.
12:09:59 <hagarth> we could even have something like .. 10th of each month - 3.5.x, 20th - 3.6.x, 30th - 3.7.x or something like that
12:10:03 <kkeithley> scheduled, +1 to one per month. If we have a special need we should not lock ourselves in to a schedule
12:10:15 <kshlm> I agree.
12:10:23 <hagarth> kkeithley: +1 to not lock ourselves up
12:10:54 <kkeithley> +1 to 10th, 20th, 30th as a guideline
12:10:54 <kshlm> Who would set this schedule up now?
12:11:09 <msvbhat> When there are min number of patches for a release?
12:11:17 <hagarth> maybe we should publish this schedule in gluster.org
12:11:22 <hagarth> msvbhat: at least 1 ;)
12:11:27 <ndevos> there might well be no need to do a release... so the schedule would say something like "maximum one 3.x-stable release in 4 weeks"?
12:11:32 <raghu> kshlm: I think we can target 1 month from the previous releases that have already happened
12:11:56 <kshlm> #agree Do releases periodically every month. (excluding exceptions for urgent fixes)
12:12:18 <hagarth> raghu: that would also work. I think we should just post this on gluster.org/release-schedule or something like that.
12:12:34 <kshlm> Does that url exist?
12:12:50 <kshlm> It doesn't/
12:12:55 <hagarth> kshlm: no, we would need to seed that.
12:13:07 <kshlm> hagarth, Yeah. So who's gonna be doing that?
12:13:12 <kshlm> Any volunteers?
12:13:44 <raghu> hagarth: if the minimum number of patches for minor release is 1, then I can make 3.6.5 now itself ;)
12:14:02 <kshlm> raghu, it's still not 1 month yet.
12:14:10 <kshlm> So no volunteers now?
12:14:16 <hagarth> kshlm:  me and raghu will take this up
12:14:28 <kshlm> hagarth, raghu, Thanks.
12:14:30 <kkeithley> raghu: you can, but since we just released 3.7.3 this week you need to wait a few days
12:14:38 <ndevos> hah! raghu just got volunteerd, nice :D
12:14:49 <kshlm> #action hagarth and raghu to prepare release-schedule
12:14:51 <hagarth> ndevos: ;)
12:15:06 <hagarth> if you speak about a topic, you will be volunteered ;)
12:15:08 <raghu> kkeithley: yes. I am going to wait atleast 1 more week minimum
12:15:22 * ndevos stays quiet the rest of the meeting
12:15:26 * kkeithley breathes a sigh of reliefe
12:15:30 * raghu too
12:15:40 <kshlm> Okay onto the next topic.
12:15:45 <kshlm> #topic overclk to create a feature page about lockdep in couple of week's time
12:15:56 <kshlm> overclk, do you still need time?
12:16:04 <overclk> kshlm: yep, a week.
12:16:13 <ndevos> lol
12:16:20 <kshlm> Okay. Carrying this over to the next week.
12:16:32 <kshlm> #action overclk to create a feature page about lockdep in couple of week's time
12:16:48 <kshlm> #topic Gluster 3.7
12:17:04 <overclk> kshlm: s/couple of/a/
12:18:02 <kshlm> overclk, I'll still keep it that. It'll be flatter you when you do it in a week. ;)
12:18:28 <ira> Except he slipped this week ;)
12:20:06 <ndevos> well, who knows something about the next 3.7 release?
12:20:22 * ira bets on kkeithley.
12:20:35 * ndevos thought it would be kshlm
12:21:21 <kshlm> Sorry. My internet connection got reset.
12:21:34 <hagarth> we need a release manager for 3.7.4
12:21:47 <kshlm> hagarth, I'll volunteer again.
12:21:54 <hagarth> kshlm: great, thanks!
12:22:04 <ndevos> I was going to volunteer hagarth for that :P
12:22:17 <kshlm> Did I miss anything when I was offline?
12:22:23 <ndevos> kshlm: nope
12:22:26 <kshlm> Okay.
12:22:27 <hagarth> kshlm: nothing much
12:22:30 <kshlm> So the release is done.
12:22:42 <raghu> ndevos: he he. Me too. :P
12:22:44 <kkeithley> no, but, fwiw, sometime (but not always) other packages actually land on d.g.o before the Fedora and EPEL rpms land. Whoever makes the announcement should take a quick look before announcing. It looks, IMO, a little silly to say other packages arriving later, when in fact they're already there.
12:22:50 <ndevos> raghu: :)
12:22:56 <kshlm> I need help posting the release announcements on to the blog and social media.
12:23:14 <hagarth> raghu: I thought you would be quiet for rest of the meeting ;)
12:23:17 <kshlm> And I need ndevos help to close the bugs.
12:23:24 <hagarth> kshlm: happy to help with announcements
12:23:31 <raghu> hagarth: I said same as ndevos ;)
12:23:52 <kshlm> ndevos, even sharing your scripts will help.
12:23:57 <kshlm> hagarth, thanks.
12:24:03 <ndevos> kshlm: sure, should be easy enough
12:24:15 <kshlm> #action hagarth to do 3.7.3 announcement on the gluster blog and social media.
12:24:22 <pranithk> kshlm: hagarth: I am already booking 3.7.5 release :-P
12:24:31 <hagarth> pranithk: fantastic!
12:24:38 <kshlm> #action ndevos to help kshlm close bugs
12:24:52 <kshlm> #info pranithk to be release-manager for 3.7.5
12:25:13 <kshlm> Anything else with 3.7?
12:25:30 <pranithk> kshlm: yes
12:25:47 <kshlm> Is this wrt spurious failures?
12:26:00 <pranithk> kshlm: hagarth: xavih and I feel we need to tell users that ec is ready for production. What would be a good way?
12:26:17 <kshlm> pranithk, Is it ready in 3.7.3 ?
12:26:36 <pranithk> kshlm: there are some good to have things, but we can go production IMO
12:26:42 <hagarth> pranithk: drop a note on users and also post the same on our blog.
12:26:46 <pranithk> kshlm: we can tell these are known issues and close things
12:26:46 <kshlm> Then we can add it to the release-announcements  hagarth is going to do.
12:27:03 <kkeithley> one good way would be to blog about it. Another would be in the "this week in Gluster" email
12:27:06 <pranithk> hagarth: okay. Will come up with the details then. By when do you need it?
12:27:22 <kshlm> kkeithley, that's a good idea.
12:27:33 <hagarth> pranithk: sometime in the next 2 days
12:27:38 <kshlm> pranithk, Are you willing to blog about this?
12:28:14 <pranithk> kshlm: that would be good I guess. I will come up with draft, show it to xavih and hagarth
12:29:08 <kshlm> #action pranithk to write up a post announcing EC's production readiness.
12:30:05 <kshlm> This is good news.
12:30:14 <kshlm> Is there anything else about 3.7?
12:30:39 <kshlm> Okay onto the next topic.
12:30:43 <kshlm> #topic Gluster 3.6
12:31:13 <kshlm> I don't think there's much to discuss here. Unless raghu has something to add to what we dicussed earlier.
12:31:37 <raghu> kshlm: Yeah. Not much from me.
12:31:48 <kshlm> Anyone else have anything for 3.6?
12:32:00 <raghu> kshlm: Just got some patches from Vijaykumar. Will try to include them in 3.6.5
12:32:06 * ndevos noted he should look at that FUSE groups/acl patch
12:32:23 <kshlm> ndevos, do you want to add that as an action for next week?
12:32:28 <raghu> ndevos++
12:32:28 <zodbot> raghu: Karma for devos changed to 3:  https://badges.fedoraproject.org/tags/cookie/any
12:32:43 <ndevos> kshlm: I hope to do that this week
12:33:08 <ndevos> no need to add it "_
12:33:08 <kshlm> ndevos, is this for 3.6?
12:33:19 <kshlm> ndevos, fine :)
12:33:20 <ndevos> kshlm: yeah, for 3.6, 3.7 and master
12:34:06 <ndevos> actually, 3.5 would benefit from it too, but I'm not sure if we have users hitting the issue
12:34:07 <kshlm> ndevos, okay.
12:34:21 <kshlm> Onto the next topic.
12:34:27 <kshlm> #topic Gluster 3.5
12:34:57 <ndevos> I think there was one patch or bug that I wanted to see fixed in the next 3.5 release
12:35:10 <ndevos> ... if I only could remember what it was :-/
12:35:26 <paraenggu> ndevos: maybe 1134050 ;)
12:35:37 <paraenggu> ndevos: I would really love to see that fixed
12:35:55 <ndevos> paraenggu: right, yes, that one!
12:36:22 <ndevos> poornimag: its something I could use your assistance with :)
12:36:23 <kshlm> ndevos, as you are already on top of that one, I will not make a note of it.
12:36:45 <ndevos> kshlm: no, its listed as a blocker for 3.5.6 so I'll find it again
12:37:38 <kshlm> ndevos, Is this all for 3.5?
12:37:41 <ndevos> but its a nasty bug I think, backporting probably isnt trivial - if it is completely fixed in newer releases already
12:37:47 <ndevos> kshlm: yes
12:37:52 <poornimag> ndevos, ohh the fini one, will just try backporting and see how much more changes it would require
12:38:01 <poornimag> yeah
12:38:08 <ndevos> poornimag: that is much appreciated, thanks!
12:38:10 <kshlm> Anyone has other 3.5 topics to discuss?
12:38:28 <paraenggu> poornimag: also much appreciated from my side - thank you!
12:38:29 <ndevos> hopefully 3.5.6 gets released by the end of next week or so
12:38:49 <poornimag> ndevos, pareenggu, wc:)
12:38:52 <kshlm> #info ndevos hopes to release 3.5.6 in two weeks time.
12:39:10 <kshlm> Okay. Onto the next topic.
12:39:14 <kshlm> #topic Open floor
12:39:27 <ndevos> no 4.0?
12:39:43 <kshlm> ndevos, Oops. I skipped it.
12:40:07 <kshlm> Counting down from 3.7 didn't help it.
12:40:13 <kshlm> #topic Gluster 4.0
12:40:15 <hagarth> I am working on roadmap for 4.0 that should be on gluster.org
12:40:22 <kkeithley> wrt 4.0, kp was asking about replacements for our homegrown rpc
12:40:29 <kshlm> kkeithley, yeah.
12:40:40 <hagarth> will send out a note to respective feature owners to get summary of features they plan to have
12:40:41 <kkeithley> The ntirpc folks are very interested in that
12:41:05 <kkeithley> they have rdma built in and have been doing a ton of work on performance
12:41:05 <kshlm> We wanted to find a library that can be used for Go and C.
12:41:34 <ndevos> kshlm: does it need to be the same library?
12:41:51 <kshlm> ndevos, at least the same RPC protocol.
12:41:52 <kkeithley> Can't Go link to C?
12:42:07 <ndevos> kshlm: well, RPC is the protocol :)
12:42:09 <kshlm> kkeithley, It can. But linking to C has certain drawbacks.
12:42:45 <kshlm> One of it being, goroutines cannot be used efficiently when linking to C.
12:42:58 <kkeithley> I bet that can be solved
12:43:13 <kshlm> We looked a json-rpc last week.
12:43:17 <ndevos> shouldnt there be a Go-native RPC library around?
12:43:25 <kshlm> It works well and is light weight.
12:43:45 <ndevos> ah, but we're talking about sunrpc, the current protocol that all Gluser protocols use
12:43:46 <kshlm> But has a lot of manual code writing required for C.
12:44:13 <kshlm> ndevos, Go has it's own. But we want one that we can use to talk to bricks and other daemons.
12:44:47 <ndevos> kshlm: right, so replace the whole sunrpc/xdr with something else? also for normal data access by clients?
12:45:13 <kshlm> ndevos, right now only for GlusterD to daemons and GlusterD-GlusterD communications.
12:45:29 <kshlm> We aren't looking at the IO communication.
12:45:45 <kshlm> Let's carry on this discussion later.
12:45:50 <kkeithley> oh, okay. That wasn't clear to me in the conversation last week
12:45:50 <hagarth> kshlm: how about client - glusterd?
12:45:51 <kshlm> We're running outta time.
12:45:57 <ndevos> kshlm: okay, in that case libntirpc isnt for you ;-)
12:46:18 <kshlm> #topic Open floor
12:46:52 <kkeithley> are we making any progress on cleaning up the spurious regression failures?
12:47:00 <pranithk> kkeithley: I sent a mail...
12:47:06 <pranithk> kkeithley: RaSTar and I will follow up
12:47:21 <kshlm> Weekly announcement. Please add yourself to https://public.pad.fsfe.org/p/gluster-events if you are attending any conferences and representing Gluster.
12:47:34 <rtalur> proposal: run the tests x times once every night without any new patch.
12:47:49 <kshlm> I know a few folks who got their proposals accepted to LinuxCon Eu 2015.
12:47:54 <pranithk> rtalur: it will anyway show up :-)
12:48:03 <kshlm> #topic regression test failures
12:48:11 <hagarth> I added this topic
12:48:22 <hagarth> I sent a mail on -devel earlier today
12:48:32 <kshlm> hagarth, I thought pranithk did.
12:48:46 <hagarth> I feel that we should block patch acceptance for components that have pending regression failures
12:48:56 <hagarth> so that the tests get highest priority
12:48:58 <pranithk> kshlm: hagarth sent a reply :-)
12:49:07 <pranithk> hagarth: +1 agree
12:49:29 <rafi> hagarth: +1
12:49:55 <hagarth> please chime in with your responses on that thread
12:49:57 <rtalur> hagarth: +1
12:49:58 <ndevos> +! we need to get rid of those failures asap
12:49:58 <kshlm> hagarth, but just submitting a new patchset triggers a test run. How would we focus on test-fixes in that case.
12:50:38 <pranithk> kshlm: sorry, didn't understand your statement
12:50:42 <hagarth> kshlm: that is fine, but we don't accept any new patches till the backlog is cleared for that component.
12:51:38 <hagarth> kshlm: new patches can be submitted but won't get merged
12:51:57 <hagarth> kshlm: is your internet connection acting up again? :)
12:52:20 <kshlm> hagarth, It's laggy.
12:52:32 <hagarth> kshlm: ah ok
12:53:17 <kshlm> hagarth, I'm okay with the plan.
12:53:23 <ndevos> https://public.pad.fsfe.org/p/gluster-spurious-failures is the pad with the failures
12:53:23 <hagarth> ok cool
12:53:40 <kshlm> Let's continue this discussion on the mailing lists.
12:54:04 <kshlm> #info regression failure tracker https://public.pad.fsfe.org/p/gluster-spurious-failures
12:54:11 <rtalur> yes, I have update on DiSTAF
12:54:27 <kshlm> rtalur, please go ahead
12:54:33 <kshlm> #topic DiSTAF
12:54:56 <rtalur> Will send first mail outlining how to port existing .t files and explaining basic architecture to get proposals for any missing features
12:55:13 <rtalur> shyam had some ideas around what could be improved
12:55:24 <kshlm> rtalur, Cool.
12:56:15 <kshlm> #action rtalur to send update mailing list with a DiSTAF how-to and start discussion on enhancements to DiSTAF.
12:56:28 <kshlm> rtalur, anything more to add?
12:56:40 <rtalur> kshlm: no
12:57:19 <kshlm> rtalur, thanks.
12:57:25 <kshlm> I want to note that misc bought online a slave-vm in the RH DC. We need someone to test it out.
12:57:30 <kshlm> Any volunteers?
12:57:53 <kshlm> If there is no one I'll take it up.
12:58:31 <kshlm> No one?
12:58:39 <kshlm> Okay. I'll take it up.
12:58:46 <ndevos> kshlm: thanks for picking that up!
12:58:55 <ndevos> #info REMINDER to put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
12:58:57 <kshlm> #action kshlm to test the new jenkins slave in ci.gluster.org
12:59:21 <kshlm> ndevos, We should add this reminder to the agenda.
12:59:26 <ndevos> and, I would like a volunteer to do the blog post on sunday or monday too :
12:59:30 <ndevos> )
13:00:14 <ndevos> kshlm: its there now
13:00:22 <kshlm> ndevos, Thanks :)
13:00:35 <kshlm> We are out of topics and time.
13:00:47 <kshlm> Thanks for attending this weeks meeting everyone.
13:00:51 <obnox> very punctual
13:00:58 <kshlm> #endmeeting