12:00:04 <hgowtham> #startmeeting Gluster Bug Triage
12:00:04 <zodbot> Meeting started Tue Jan 10 12:00:04 2017 UTC.  The chair is hgowtham. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:04 <zodbot> The meeting name has been set to 'gluster_bug_triage'
12:00:08 <hgowtham> #topic Roll call
12:00:15 <hgowtham> #info agenda: https://public.pad.fsfe.org/p/gluster-bug-triage
12:00:34 * Saravanakmr is here
12:00:41 * ankitraj here
12:00:58 * ndevos _o/
12:01:50 <hgowtham> Hi everyone.
12:01:52 <ndevos> hgowtham: just a reminder, but when you send out the meeting minutes, please include the full text of the generated minutes too, not only the links
12:02:09 <hgowtham> yes sure ndevos . im aware of it :)
12:02:32 <ndevos> ankitraj: I noticed you sent the links only, but I do not expect anyone to open the URLs, if the text is included more people will read it :)
12:02:38 <hgowtham> we shall start with the Action Items. so that other can join when they are here
12:02:51 <ankitraj> ndevos, ok i got it.
12:03:00 <hgowtham> i have talked with ankitraj regarding sending the whole thing from next time
12:03:11 <hgowtham> #topic Action items
12:03:31 <hgowtham> #topic ndevos need to decide on how to provide/use debug builds
12:03:45 <ndevos> thats still todo
12:03:55 <hgowtham> #action ndevos need to decide on how to provide/use debug builds
12:04:07 <ndevos> if anyone has ideas or suggestions about it, tell me! (by email)
12:04:14 <hgowtham> #topic jiffin will try to add an error for bug ownership to check-bugs.py
12:04:26 <jiffin> hgowtham: its done
12:04:42 <hgowtham> jiffin, the link to thread would be good
12:04:43 <jiffin> i have given pr link in previous meeting
12:04:50 <jiffin> wait give a sec
12:04:55 <ndevos> jiffin: oh, wow, I did not know!
12:04:56 <hgowtham> jiffin++
12:05:00 <hgowtham> jiffin, sure
12:05:22 <jiffin> https://github.com/thotz/glusterfs-patch-acceptance-tests/commit/9759f7848ef10be5cd847294b05f305fac1a0b55
12:06:36 <ndevos> jiffin: wait, that is not for check-bugs.py from the release-tools repo?
12:07:46 <ndevos> jiffin: https://github.com/gluster/release-tools/blob/master/check-bugs.py
12:08:25 <ndevos> #link https://github.com/gluster/glusterfs-patch-acceptance-tests/pull/74
12:08:46 <Saravanakmr> #link https://github.com/thotz/glusterfs-patch-acceptance-tests/commit/9759f7848ef10be5cd847294b05f305fac1a0b55
12:09:07 <jiffin> ndevos: it not merged
12:09:07 <jiffin> hgowtham: link ^^
12:09:07 <jiffin> ndevos: no I guess
12:09:07 <jiffin> it is part of smoke test
12:09:27 <hgowtham> #info Jiffin done with the changes on check-bugs.py
12:09:27 <hgowtham> jiffin, thanks
12:09:27 <hgowtham> #topic Group Triage
12:09:28 <hgowtham> #info you can find the bugs to triage here in https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:09:29 <hgowtham> #info http://www.gluster.org/community/documentation/index.php/Bug_triage
12:09:34 <hgowtham> jiffin i made a note of the link
12:10:10 <hgowtham> #link https://github.com/thotz/glusterfs-patch-acceptance-tests/commit/9759f7848ef10be5cd847294b05f305fac1a0b55 from jiffin for the check-bug.py
12:11:25 <jiffin> ndevos: do I need to revert above change and make a similar change in check-bugs.py
12:11:54 <ndevos> jiffin: I think the change is a good addition, but we also need it in check-bugs.py
12:11:54 * jiffin will logging from meeting in 5mins
12:12:02 <jiffin> ndevos: okay
12:12:14 <jiffin> ndevos: will do that
12:13:34 <hgowtham> #action jiffin needs to send the changes to check-bugs.py also
12:16:36 <ndevos> done!
12:17:00 <hgowtham> yes moving on to the next topic
12:17:11 <hgowtham> #topic Next week’s meeting host
12:17:23 <Saravanakmr> I will do
12:17:33 <hgowtham> Saravanakmr, thanks :)
12:18:06 <hgowtham> #info Saravanakmr  to host the bug triage on 17th Jan
12:18:21 <hgowtham> moving to next topic
12:18:23 <hgowtham> #topic  Open Floor
12:18:45 <Saravanakmr> we need to start using other etherpads for bug triage too
12:19:01 <ndevos> ah, yes
12:19:09 <hgowtham> so how do we transfer stuff from this one to other?
12:19:10 <Saravanakmr> final date 1 february
12:19:27 <Saravanakmr> I already did - moved to gluster github wiki
12:19:27 <ndevos> maybe also use hackmd.io like we do for the community meeting?
12:20:07 <ankitraj> hackmd looks good
12:20:08 <Saravanakmr> yup - I think from next week we can try hackmod.io
12:20:27 <hgowtham> can you provide the link?
12:20:33 <Saravanakmr> #link https://github.com/gluster/glusterfs/wiki
12:20:43 <hgowtham> thanks
12:20:58 <Saravanakmr> is it ok for everybody to host in hackmod.io ?
12:21:05 <Saravanakmr> from next week
12:21:09 <hgowtham> #info Triage meetings to use https://github.com/gluster/glusterfs/wiki instead of etherpad
12:21:19 <hgowtham> sorry decided in a hurry
12:21:31 <hgowtham> is everyone fine with it from next week?
12:22:39 * Saravanakmr why so silent? :)
12:22:49 <hgowtham> okie then ill confirm it
12:22:57 <hgowtham> anything else to discuss?
12:23:12 <Saravanakmr> nothing more
12:23:13 <ankitraj> hgowtham, send it on mailing list..
12:23:16 <ndevos> uh, the wiki is bad for online editing
12:23:19 <hgowtham> ankitraj, sure
12:23:33 <hgowtham> um okie. which one shall we opt?
12:23:41 <ndevos> we mark the bugs we triage immediately, and the wiki needs a [commit] click
12:24:07 <ndevos> the hackmd.io site allows etherpad like editing
12:24:07 <hgowtham> yes. thats going to be a bit annoying
12:24:32 <ndevos> annoying because we will most likely have conflicting edits all the time :)
12:24:43 <Saravanakmr> For Triaging we use hackmod.io - then the contents are moved to wiki for every week
12:24:53 <hgowtham> if everyone is fine with hackmd.io. we will use it
12:25:32 <ndevos> Saravanakmr: I do not think we need the agenda/logs in the wiki, having it in the email archives is probably sufficient?
12:26:23 <ndevos> but, I do not care *that* much, if there is value in having it in the wiki, then we'll just copy it there too
12:26:37 <hgowtham> So what are the final thought?
12:26:42 <Saravanakmr> ndevos,  make sense - why to have two different copy
12:26:54 <Saravanakmr> ndevos, but for community meeting it is maintained.
12:27:09 <hgowtham> okie then we will use hackmd.io instead of etherpad and continue the same mechanism there
12:27:18 <Saravanakmr> ndevos, what you say make sense - why to pollute wiki with these contents.
12:27:43 <Saravanakmr> ndevos, maybe we can discuss it tomorrow community meeting too.
12:27:53 * ankitraj thinks let's see how hackmd works for community meeting. If it works for them then we will switch.
12:28:09 <ndevos> I'm also not sure why we need the community meeting results in the wiki... I would just link to the archived email if we need that
12:28:22 <Saravanakmr> ndevos, agree :)
12:29:02 <hgowtham> #info use hackmd.io instead of etherpad
12:29:17 <Saravanakmr> ankitraj, hackmd used in community meeting already
12:29:51 <ankitraj> oh.. I wasn't aware of that. I haven't attended last few meetings
12:30:34 <Saravanakmr> hgowtham, you can end the meeting :)
12:30:45 <hgowtham> Saravanakmr, sure
12:30:54 <hgowtham> endmeeting
12:30:57 <hgowtham> #endmeeting