18:00:17 <alexsaezm> #startmeeting Go SIG meeting
18:00:17 <zodbot> Meeting started Mon Jun 19 18:00:17 2023 UTC.
18:00:17 <zodbot> This meeting is logged and archived in a public location.
18:00:17 <zodbot> The chair is alexsaezm. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:17 <zodbot> The meeting name has been set to 'go_sig_meeting'
18:00:53 <alexsaezm> #topic Roll Call
18:01:05 <alexsaezm> Hi everyone!
18:02:13 <alexsaezm> I'll give 5 minutes :)
18:02:41 <copperi[m]> .hello copperi
18:02:42 <zodbot> copperi[m]: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
18:07:13 <alexsaezm> Looks like we are going to have a short meeting today :)
18:07:38 <alexsaezm> I guess we can jump to open floor, what do you think copperi ? :)
18:08:12 <copperi[m]> sure
18:08:24 <alexsaezm> #topic Open floor
18:08:44 <mikelo> .hello mikelo2
18:08:45 <zodbot> mikelo: mikelo2 'Mikel Olasagasti Uranga' <mikel@olasagasti.info>
18:09:30 <mikelo_m[m]> hi team
18:09:37 <mikelo_m[m]> just for the record, I adopted ~100 packages already
18:09:45 <mikelo_m[m]> I'm pushing updates to rawhide for multiple packages
18:09:53 <mikelo_m[m]> trying to solve FTBFS issues and also chain dependency issues
18:10:42 <mikelo_m[m]> modernizing some of the packages I found I need more packages, so I'll be posting review requests here, if anyone can help I'll appreciate it, as otherwise progress is going to be slow
18:11:08 <mikelo_m[m]> we may need someone to adopt docker-* stuff and cointainerd
18:11:22 <mikelo_m[m]> too many things depend on them
18:12:02 <mikelo_m[m]> and I sent a mail to golang list as I'm running out of ideas on how to package azure's new go sdk
18:12:55 <mikelo_m[m]> and of course, if anyone is requiring reviews send them here also
18:14:19 <mikelo_m[m]> nothing else from my side i guess
18:17:15 <alexsaezm> thanks for taking that amount of packages
18:18:25 <mikelo_m[m]> still 1656 packages affected by orphans
18:18:56 <mikelo_m[m]> some of those are leaves that we can recheck to kill them and others, hopefully will become leaves also
18:22:41 <alexsaezm> on my side, I took ~30 packages more or less, and I guess I'll take also stuff in containerd :P
18:23:19 <alexsaezm> oh that reminds me, FYI: 1.21rc1 is out
18:24:49 <mikelo_m[m]> that will land in F39?
18:25:43 <alexsaezm> yep
18:25:49 <alexsaezm> I'm writing the proposal now
18:28:06 <mikelo_m[m]> you'll be on time this release ;)
18:28:57 <alexsaezm> don't remember me that
18:29:01 <alexsaezm> :D
18:29:08 <mikelo_m[m]> 🤐
18:32:20 <alexsaezm> on another topic, go sig seems to be maintained by eclipseo
18:32:23 <alexsaezm> the group
18:32:26 <alexsaezm> I guess we should fix that
18:32:43 <alexsaezm> I'm not sure how is managed, I saw it today in koshei's web page
18:33:29 <mikelo_m[m]> also the go-sig bi-weekly calendar event
18:33:38 <mikelo_m[m]> is sent by someone that I'm not sure if he is active
18:33:58 <alexsaezm> jcajka: is not very much active but I know him :)
18:34:32 <mikelo_m[m]> ok, so that one is somehow undercontrol
18:36:04 <alexsaezm> yes, I'm not worried about him :) but I wonder how we can manage the change of that and how to vote for the next owner
18:36:11 <alexsaezm> or owners
18:36:13 <alexsaezm> not sure how it works
18:36:30 <alexsaezm> #action alexsaezm will look into changing the group ownership of the Go SIG
18:36:37 * mikelo_m[m] votes for alex
18:37:19 <alexsaezm> will see that when we know how it is managed :P
18:37:26 <alexsaezm> I won't vote for myself
18:38:00 <alexsaezm> I don't have anything else to add btw
18:38:05 <alexsaezm> just in case you want to call it
18:38:22 <alexsaezm> now we only need to solve the issues with the packages, that's the most critical thing in general :')
18:39:59 <mikelo_m[m]> mmm, I just remembered that I may ping some maintainers about some binary packages that have not been updated in a while if they plan so, as some of the orphans are just depended by those packages (elvish, clash)
18:40:18 <mikelo_m[m]> nothing else from my side
18:40:22 <copperi[m]> I think  infra-team handles changes on ownerships
18:40:49 <copperi[m]> 1 vote for alex
18:40:50 <alexsaezm> copperi[m]: good, I'll bother them then
18:42:24 <copperi[m]> Hopefully with some co-owners as well
18:42:35 <alexsaezm> I hope so
18:42:41 <alexsaezm> I was surprised to see only a name
18:42:46 <alexsaezm> sounds like a dangerous thing
18:43:07 <alexsaezm> I might be wrong because as I said, I saw it on koshei's web page so it might only show the main one
18:43:55 <alexsaezm> anything else? :)
18:44:37 <copperi[m]> nope
18:45:19 <alexsaezm> in that case, we can call it :)
18:45:24 <alexsaezm> thanks a lot for attending :)
18:45:36 <alexsaezm> #endmeeting