19:00:12 <alexsaezm> #startmeeting Go SIG meeting
19:00:13 <zodbot> Meeting started Mon Nov 20 19:00:12 2023 UTC.
19:00:13 <zodbot> This meeting is logged and archived in a public location.
19:00:13 <zodbot> The chair is alexsaezm. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:13 <zodbot> The meeting name has been set to 'go_sig_meeting'
19:00:19 <alexsaezm> #topic Roll Call
19:00:21 <alexsaezm> Hi everyone!
19:00:23 <mikelo> .hello mikelo2
19:00:24 <zodbot> mikelo: mikelo2 'Mikel Olasagasti Uranga' <mikel@olasagasti.info>
19:00:34 <mikelo> Hi alexsaezm!
19:00:53 <alexsaezm> Hi mikelo
19:01:31 <alexsaezm> Let's wait until 05 more or less
19:06:02 <alexsaezm> We have 3 issues tagged as meeting, but non of the reports seem to be here today. Do you want to discuss some of them (https://pagure.io/GoSIG/go-sig/issues?status=Open&tags=meeting&close_status=) or jump into Open floor?
19:07:21 <mikelo> https://pagure.io/GoSIG/go-sig/issue/53 has all the bits merged, I'm not sure what's missing
19:07:55 <alexsaezm> Maybe nothing and it was left open for discussing in a meeting?
19:08:41 <mikelo> dunno
19:10:17 <alexsaezm> I'll leave a comment then, and we can move to the open floor I guess
19:11:04 <alexsaezm> #topic Open floor
19:11:19 <alexsaezm> Anyone has something to share today?
19:11:38 <mikelo> about that issue, I opened a PR to cleanup go2rpm tepmlate https://pagure.io/GoSIG/go2rpm/pull-request/33
19:11:44 <mikelo> and I guess we should document why -L flag is there
19:11:53 <mikelo> maybe I should add both things to the issue
19:12:30 <alexsaezm> that makes sense
19:13:37 <mikelo> as reported in matrix, I pushed all the changes for golang-cloud-google-* https://bodhi.fedoraproject.org/updates/FEDORA-2023-f23d9c5057
19:13:47 <alexsaezm> thanks a lot for that
19:14:01 <mikelo> everything is in bootstrap mode still, will start unbootstraping the packages now
19:14:17 <mikelo> and I guess I need to investigate genproto stuff to fix confirmed issues
19:14:27 <mikelo> I don't plan to push these changes to F39
19:14:37 <mikelo> not with the current status at least
19:14:52 <alexsaezm> why?
19:15:53 <mikelo> 2 modules of golang-cloud-google require updated genproto and so does a couple of depending packages, so pushing this to F39 will cause breaks in current release
19:16:19 <mikelo> if we manage to get all sorted in rawhide then it can make sense to push things to f39
19:16:41 <alexsaezm> that makes sense, thanks for the clarification
19:17:02 <mikelo> but even if everything is fixed, all the golang-cloud-google-* modules need to be built first in bootstrap mode, so it's not a simple rebase and requires extra effort
19:18:10 <alexsaezm> but it works on f39?
19:18:24 <alexsaezm> I mean, is it broken? :D
19:18:45 <mikelo> well.. it's complicated
19:18:48 <alexsaezm> ha
19:19:05 <mikelo> https://koschei.fedoraproject.org/package/golang-cloud-google?collection=f39
19:19:13 <mikelo> golang-cloud-google package has been broken for a while
19:19:50 <mikelo> not 100% sure if packages are building against the f38 package, but it's working, as no dependant package is known to be broken (afaik)
19:20:43 <alexsaezm> got it, thanks for the summary
19:21:12 <mikelo> overall I would say there is a huge maintenance gap between 2022 and 2023 in several stacks
19:21:20 <mikelo> like the moby/containerd/... stuff
19:21:25 <mikelo> or prometheus
19:21:49 <mikelo> or OTEL
19:21:57 <mikelo> I'm doing my best to fix some of those
19:22:26 <alexsaezm> thank you very much for the efforts
19:22:28 <alexsaezm> mikelo++
19:22:28 <zodbot> alexsaezm: Karma for mikelo2 changed to 1 (for the release cycle f39):  https://badges.fedoraproject.org/tags/cookie/any
19:23:27 <mikelo> I need https://bugzilla.redhat.com/show_bug.cgi?id=2248961 and https://bugzilla.redhat.com/show_bug.cgi?id=2248955 to be reviewed to update 5 prometheus packages that are in ftbfs
19:24:01 <mikelo> it would fix golang-github-prometheus-node-exporter... and then I opened https://bugzilla.redhat.com/show_bug.cgi?id=2250145 to rename it to sipmle node-exporter
19:24:20 <alexsaezm> I'll take those reviews
19:24:31 <alexsaezm> #action alexsaezm will review mikelo's package
19:24:42 <mikelo> for golang-github-prometheus, the server, there are some missing deps and I was not able to test
19:25:45 <mikelo> if you want to add https://bugzilla.redhat.com/show_bug.cgi?id=2250449 as another simple go2rpm review so I can update gitleaks also
19:25:57 <mikelo> but the prometheus ones are more important
19:27:22 <alexsaezm> added
19:27:32 <mikelo> there are some packages like the prometheus stack or restic & rclone that are built as bundled for EPEL and I need to learn how to update them as there are many user requests to update them
19:29:34 <alexsaezm> thanks for the updates and for the work :)
19:30:09 <alexsaezm> from my side very little to say: F39, F38, and F37 should have the latest Go versions.
19:30:32 <mikelo> it's nice when we can push things that work, what it's frustrating is how long it takes some times
19:31:29 <alexsaezm> ha :')
19:32:32 <alexsaezm> Well, as we are the only ones apparently in today's meeting... wanna call it?
19:32:45 <mikelo> sure
19:32:56 <alexsaezm> thank you very much!
19:33:07 <alexsaezm> #endmeeting