15:04:48 <sayan> #startmeeting hubs-devel
15:04:49 <zodbot> Meeting started Mon Jan 23 15:04:48 2017 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:49 <zodbot> The meeting name has been set to 'hubs-devel'
15:04:58 <sayan> ^^ there it goes
15:05:06 <shillman> Thanks, I couldn't remember the # command. :)
15:05:11 <shillman> chair?
15:05:19 <sayan> #chair shillman
15:05:19 <zodbot> Current chairs: sayan shillman
15:05:21 <shillman> Yay!
15:05:31 <shillman> #topic Feasibility of mockups for regional hubs
15:05:49 <shillman> Do you care which issue to start with?
15:06:17 <sayan> let's go with the priority you sent me
15:06:31 <shillman> #link https://pagure.io/fedora-hubs/issue/281
15:06:34 <shillman> OK!
15:07:03 <shillman> Have you had a chance to take a look, or will we be looking at them fresh now?
15:07:27 <sayan> shillman: yes, I browsed through the tickets
15:07:40 <sayan> hey pingou: are you around?
15:07:44 <shillman> #info The first one is on the master list of events.
15:09:27 <sayan> So did you decide from where are you planning to get the data for the events?
15:10:57 <sayan> The only place other that the wiki I know where we maintain the list of Fedora events is Fedocal
15:11:05 <shillman> mizmo and I were thinking that it's really hard to pull event info from other places, so it would need to be something very easy to do within hubs.
15:11:37 <shillman> We discussed the possibility of pulling it in from the wiki and various blog posts and mailing lists...
15:12:15 <shillman> And part of the problem we are trying to solve is that of lack of consistency where one can look to find events.
15:12:47 <sayan> shillman: Yes, it's a tough job given the complexity of parsing the name of the place and the mapping it
15:13:10 <shillman> I'm guessing that's true even if an event is created within hubs?
15:13:22 <shillman> I've not yet done anything on the event creation interface side of things.
15:13:34 <sayan> shillman: it would be easier than pulling data
15:13:38 <shillman> OK, good.
15:14:27 <sayan> In that case we need to make sure that it should be a protocol to create an event in hubs
15:14:50 <shillman> As in, one needs to be created?
15:14:59 <shillman> A protocol, I mean? I'm not sure what you are saying.
15:15:27 <sayan> I mean that whenever an event is announced it should be made sure that a Fedora Hubs event is created for it
15:16:30 <shillman> Ah! Yes. One of our goals is that people have reason to be working on and creating events in hubs, but how we get people who aren't (yet?) using it to create things there is an interesting problem.
15:17:22 <shillman> And not one I really have a good idea how to solve. I don't think we want to be adding to people's task list for creating events: it's already a pain to do.
15:17:50 <sayan> Making people use hubs and making the activity a part of the standard protocol
15:18:15 <sayan> Nope, the creation form should be simple so as to have minimum drop off
15:18:29 <sayan> Just need name of event, date, and place
15:18:39 <shillman> Well, if they are using hubs, then our plan is to make it really obvious that you create it in hubs.
15:18:42 <shillman> Right.
15:18:45 <shillman> Agreed.
15:18:56 <sayan> shillman: have you seen this https://reps.mozilla.org/events/ ?
15:19:05 <shillman> And allow more options if wanted, but only those are minimally needed.
15:19:32 <shillman> sayan: nope! I'm not completely sure what I'm seeing?
15:19:59 <shillman> I'm guessing a list of Mozilla events?
15:20:05 <sayan> yes, they can edit the event later to add stuffs needed but even if it's not there it's okay
15:20:17 <sayan> shillman: yes, list of events happening around the world
15:20:23 <shillman> Nice, thanks. :)
15:20:54 <fm-hubs> pagure.issue.comment.added -- wispfox commented on ticket fedora-hubs#281: "Master list of Events" https://pagure.io/fedora-hubs/issue/281#comment-71059
15:21:00 <sayan> so, whenever there is an event within mozilla this is the url shared as the event url
15:21:29 <shillman> #agreed that event creation should be really simple, only requiring event, date, and location. Anything else is optional, and can be added after the fact.
15:22:06 <shillman> sayan: One interesting point is that we want to let larger events like FLOCK and such be added to the events list as soon as the bids are accepted. Those may not yet have precise details available
15:23:06 <sayan> isn't date and the location finalized?
15:23:43 <shillman> I _think_ all three are finalized, but I'm a little fuzzy on that point.
15:24:05 <shillman> (three: name, date, place)
15:24:18 <shillman> I suppose it'd have to be in order to submit a bid?
15:24:22 <shillman> So nevermind. :)
15:24:39 <sayan> as per my experience with conferences, before the call for proposals these three are finalized so that people can submit their talk accordingly
15:25:57 <shillman> I would imagine that talk proposals come after the location bid has been accepted? Regardless, I think it is true that those are largely finalized by bid acceptance time. And if not, the changes will be minimal.
15:26:16 <sayan> Yes
15:29:34 <shillman> Any other thoughts on events lsit mockups?
15:29:36 <shillman> list
15:29:38 <sayan> shillman: if we have these details we are pretty much sorted to show couple of things within calendar
15:30:09 <sayan> shillman: there would be a seperate event page?
15:30:22 <shillman> Yes, each event will ahve their own page. I haven't yet mocked one up.
15:32:15 <sayan> cool
15:33:22 <shillman> There will be different mockups for one that hasn't existed and one that has passed, as we were thinking it'd be nice to have a place for photos, meeting minutes, videos, etc for an event that has happened.
15:34:05 <sayan> One thing I need to figure out is finding "event in x miles"
15:35:06 <sayan> there should be settings to change from miles to kilometers too :)
15:35:10 <shillman> Mmm... not necessarily an easy thing to do?
15:35:34 <shillman> Yes, absolutely. Mo was suggesting that it default to the appropriate measurement for one's locale, and have an option to change it in settings.
15:35:59 <sayan> I need to do a research on it. It's possible but I need to look into it
15:36:14 <shillman> Ok.
15:36:42 <sayan> it should be mostly to look with latitude and longitude of the place
15:36:48 <shillman> #action Sayan to look into making "event in x miles" work.
15:37:07 <shillman> sayan: we were thining that people's location info will include city/country/lat/long.
15:37:07 <sayan> let's move to the next ticket
15:37:18 <shillman> THe latter two being figured out from the info the person gives us.
15:37:21 <shillman> ok!
15:37:47 <shillman> #link https://pagure.io/fedora-hubs/issue/280 master list of people
15:39:36 <sayan> there would be option right not to show name publicaly
15:40:00 <sayan> if someone does one want's his/her data to be public
15:40:43 <shillman> We weren't planning to let peopel who weren't logged into Hubs  to use that interface. But beyond that, we could certainly adjust things.
15:40:56 <shillman> I was also thinking that we needed to include the nicknames, not just given names.
15:41:21 <sayan> yeah, that's possible
15:42:03 <sayan> What do you mean by
15:42:08 <shillman> Do you think we need to allow people to hide their names in that list from fellow Hubs members?
15:42:11 <sayan> "Friends with XYZ"
15:42:47 <sayan> Maybe name we can keep, but I am not sure about location
15:43:13 <shillman> Currently, we are thinking that means 'someone that one is mutually following'. And the goal there is to show overlap between the searcher and the person they are looking at.
15:43:42 <shillman> Yeah, Mo already pointed out removing location. It's currently just showing distance (see the last two mockups on the page).
15:44:15 <sayan> but the last mockup has the address above the map?
15:44:34 <shillman> Ah! That's one's own location.
15:44:42 <shillman> But good point, that's confusing.
15:45:05 <sayan> Oh! okay
15:45:41 <fm-hubs> pagure.issue.comment.added -- wispfox commented on ticket fedora-hubs#280: "Master list of Fedora People" https://pagure.io/fedora-hubs/issue/280#comment-71063
15:48:09 <sayan> The trick here is to get the people who are online
15:48:18 <sayan> that would be a trick problem to solve
15:48:26 <shillman> Oh! Huh.
15:48:52 <sayan> The map is movable, right? and the list gets updated?
15:49:03 <shillman> True. Yes.
15:49:21 <shillman> And the location one is searching for is also adjustable in the filter area.
15:49:54 <sayan> yes, so when the map moves we need to get the people in that region and how many of then are online and then render the list
15:50:10 <sayan> so need to make sure that this operation should not turn into a heavy one
15:50:15 <shillman> Yessss.
15:50:21 <shillman> Otherwise it'd be really slow.
15:52:02 <sayan> again posting a link from Mozilla https://reps.mozilla.org/people
15:52:26 <shillman> #info figuring out who is online with the ability to change where one is looking may be complicated. It need to not become heavy and slow.
15:52:51 <fm-hubs> pagure.issue.comment.added -- wispfox commented on ticket fedora-hubs#280: "Master list of Fedora People" https://pagure.io/fedora-hubs/issue/280#comment-71064
15:53:34 <shillman> sayan: that link doesn't appear to update when the map is moved...
15:53:44 <sayan> yes
15:53:52 <sayan> I just posted for reference
15:53:59 <shillman> *nod*
15:54:05 <shillman> Appreciated!
15:54:26 <sayan> rest looks good to me
15:54:35 <shillman> k, cool.
15:54:48 <shillman> Do you think the online thing is solvable?
15:55:58 <sayan> Yep solvable
15:56:01 <shillman> OK, cool.
15:56:47 <shillman> #action sayan to look into keeping figuring out who is online when search/filter/map changes lightweight.
15:57:27 <shillman> #link https://pagure.io/fedora-hubs/issue/286 Getting location information for people
15:57:50 <shillman> sayan: let me know if you need to head out. I don't know how long you were thinking of offering to this discussion.
15:58:23 <sayan> are you free to complete all the tickets?
15:58:30 <shillman> Yup!
15:58:59 <sayan> Rest of the tickets should be fast I guess
15:59:20 <shillman> Ok, cool.
16:00:32 <sayan> What are Regions?
16:00:58 <shillman> Right.
16:01:16 <shillman> So, we're moving away from regions. Instead, we are thinking of just talking about specific regional hubs.
16:01:44 <shillman> Originally, they were meant to describe local concepts of places that aren't really city/state/province lines.
16:02:14 <shillman> We expect that some regional hubs will be along those lines, especially if there aren't enough people in a city to have a hub.
16:02:55 <shillman> For example, some states think of themselves as part of a group of them: there are multiple states which think of themselves as a 'tri-state region' and thus part of a larger community.
16:03:20 <shillman> And in the Boston area, there's Boston proper (the city of Boston) and Greater Boston (Boston and a bunch of nearby cities).
16:03:24 <shillman> Does this makes sense?
16:04:12 <sayan> so rather than cities, we are moving to a bigger group to have more people in a hub = region?
16:04:20 <shillman> If needed, yes.
16:04:35 <sayan> but how are we planning to get those regions?
16:05:03 <sayan> I guess in the mockup the filled regions is based on the location
16:06:15 <shillman> The current thought is that Hubs can notice that a certain people are near each other, and suggest that they create a hub. If they are all in the same city, we'd suggest the city as the name. I'm not sure what we'd suggest as the name in the area bigger than a city case, as I'm not sure that there's any way to know what regions people have names for. Maybe we make a generic name and people
16:06:15 <shillman> can change it to what makes sense to them?
16:07:29 <sayan> hmm, that's a tough problem
16:07:56 <shillman> We're no longer planning to have people select regions during their location description. We were instead thinking that people have regional hubs suggested to them.
16:07:58 <sayan> let's keep it, Can you add a note about regions in the ticket?
16:08:14 <shillman> Sure!
16:08:22 <sayan> so the regional hubs would be automatically created?
16:09:09 <shillman> That is what mizmo and I were thinking, but it's not yet well specified.
16:09:17 <shillman> Well, no.
16:09:38 <shillman> Possible regional hubs would be automatically suggested to the people in them.
16:09:55 <shillman> Someone in that list would need to take on the task of creating that hub and being the admin for it.,
16:09:59 <shillman> Someone or someones.
16:10:06 <sayan> well then the issue is who would be the admin
16:10:40 <sayan> this will need a more detailed discussion, let's skip this for now
16:10:45 <shillman> ok.
16:12:01 <shillman> I'm adding this conversation to the issue to flag that it needs more conversation.
16:12:32 <shillman> #action: More discussion needed on how regional hubs are suggested, created, and named.
16:12:40 <sayan> Sure
16:12:41 <fm-hubs> pagure.issue.comment.added -- wispfox commented on ticket fedora-hubs#286: "We need to be able to get, and update, location information from hubs users" https://pagure.io/fedora-hubs/issue/286#comment-71065
16:12:46 <sayan> Rest looks good to me
16:12:55 <shillman> ok
16:13:17 <shillman> #link https://pagure.io/fedora-hubs/issue/282 Event notifications
16:15:24 <sayan> This is pretty straight forward
16:15:30 <shillman> Yeah.
16:16:41 <shillman> Moving on?
16:17:11 <sayan> Yep
16:17:24 <sayan> I was looking into the next ticket :)
16:17:27 <shillman> #link https://pagure.io/fedora-hubs/issue/287 Joining a regional hub
16:17:29 <shillman> :)
16:17:31 <shillman> ok
16:18:02 <sayan> This is also pretty straight forward
16:18:10 <sayan> Should we club multiple notifications?
16:18:19 <shillman> 'club'?
16:18:46 <sayan> combine
16:19:16 <shillman> Ah! Yeah. As per: https://pagure.io/fedora-hubs/issue/288
16:19:31 <sayan> Right
16:19:43 <shillman> Yeah, that was my thought. I was worried about too many messages. :)
16:20:16 <shillman> No mockup for that yet, though!
16:21:19 <sayan> There was one thing I needed to ask but could not find it in the mockup. I will dig into it later
16:21:36 <shillman> Mmm?
16:22:15 <shillman> If you figure it out, let me know. :)
16:22:31 <sayan> sure
16:22:47 <shillman> Thanks for your time and expertice!
16:22:47 <sayan> last 3 were quick
16:22:51 <shillman> Yeah. :)
16:23:03 <sayan> Anything you want to ask?
16:23:06 <shillman> I'm going to make a new issue for the 'suggesting regional hubs' thing.
16:23:14 <sayan> Sure
16:23:29 <shillman> Nothing is coming to mind to ask?
16:23:37 <shillman> If I think of anything, I'll ping you. :)
16:23:50 <sayan> Cool, ending the meeting then
16:23:53 <shillman> Cool!
16:23:56 <sayan> #endmeeting