15:01:23 <sayan> #startmeeting hubs-devel
15:01:23 <zodbot> Meeting started Tue Mar  7 15:01:23 2017 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:23 <zodbot> The meeting name has been set to 'hubs-devel'
15:01:36 <sayan> #topic Roll Call
15:01:43 <sayan> .hello sayanchowdhury
15:01:44 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
15:01:53 <mizmo> .hello duffy
15:01:54 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
15:01:59 <shillman> .hello wispfox
15:02:00 <zodbot> shillman: wispfox 'Suzanne Hillman' <wispfox@gmail.com>
15:02:35 <sayan> jcline: abompard: meeting time
15:03:29 <jcline> .hello jcline
15:03:30 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
15:03:50 <x3mboy> .hello x3mboy
15:03:53 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
15:04:51 <sayan> #chair mizmo shillman jcline x3mboy
15:04:51 <zodbot> Current chairs: jcline mizmo sayan shillman x3mboy
15:05:33 <sayan> #topic Action Items from last meeting
15:06:14 <sayan> * mizmo to finish irc channel for hub config mockup
15:06:16 <sayan> * mizmo to iterate IRC user list / chat mockups
15:06:18 <sayan> * shillman to finish transcripts today
15:06:20 <sayan> * shillman and mizmo to analyze info from usability sessions on Thursday
15:06:22 <sayan> * sayan to work on the migration for hubs and start hubs-devel.fic
15:07:25 <x3mboy> !
15:07:47 <sayan> mizmo: shillman: can you give an update on the action items?
15:07:57 <x3mboy> fic = Fedora Infrastructure Cloud?
15:08:01 <fm-hubs> pagure.pull-request.comment.added -- bowlofeggs commented on pull-request#332 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/332#comment-20772
15:08:07 <sayan> x3mboy: yes :)
15:08:10 <shillman> Transcription done, summary done, and I met with Mo last week.
15:09:04 <shillman> We did not complete the analysis, but there was a lot to go through. Today is my last day, so I'm working on getting loose ends tied up so that others can more easily take over my work. I'll try to keep coming to these meetings, at least until I find a full-time job (and we'll see past there).
15:09:28 <shillman> I'm going to summarize the usability testing stuff in my blog post, as well as summarize the internship.
15:09:41 <shillman> (two different posts. :)
15:09:54 <mizmo> i want to thank shillman too for doing such an awesome job for us.
15:10:06 <x3mboy> shillman++
15:10:06 <zodbot> x3mboy: Karma for wispfox changed to 3 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:10:25 <shillman> :)
15:10:41 <mizmo> sayan: i did finish the ticket on configuring chat channel => hub https://pagure.io/fedora-hubs/issue/331
15:10:54 <sayan> shillman: thanks for all the work over the last few months
15:11:12 <jcline> Yeah, shillman++
15:11:12 <zodbot> jcline: Karma for wispfox changed to 4 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:11:14 <shillman> sayan: you are welcome! It was fun and interesting and I'm so glad Mo mentioned that it existed.
15:11:21 <sayan> shillman++
15:11:21 <zodbot> sayan: Karma for wispfox changed to 5 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:11:28 <shillman> (and was willing to be my mentor)
15:12:07 <sayan> I worked on the migrations and will be migrating after merging abompard PR https://pagure.io/fedora-hubs/pull-request/334
15:12:41 <sayan> abompard: jcline: I don't think there is issue with this PR ^^. can we go ahead and merge this PR?
15:13:29 <jcline> I didn't have an issue, who wants to click the merge button?
15:14:13 * sayan goes ahead :)
15:14:31 <fm-hubs> pagure.pull-request.comment.added -- sayanchowdhury commented on pull-request#334 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/334#comment-20774
15:14:32 <fm-hubs> pagure.pull-request.closed -- sayanchowdhury merged pull-request#334 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/334
15:14:36 <sayan> #topic IRC Widget
15:16:01 <sayan> jcline: mizmo: I did not file a issue with the fedora-infrastructure for the resources. But I fired up an AWS instance to see if synapse server and irc bride works
15:16:20 <sayan> but I failed. I haven't been able to setup the connection :(
15:16:44 <sayan> jcline: have you been using the matrix?
15:16:44 <mizmo> irc bride hehe (just realized it was a typo)
15:16:51 <mizmo> thats a bummer, what kind of issues did you have
15:16:52 <sayan> haha :)
15:16:58 <jcline> So I was going to start packaging the matrix reference server for Fedora, but in the mean time we could use our personal accounts on matrix.org (or self-hosted) to test
15:17:01 <sayan> s/bride/bridge
15:17:28 <jcline> sayan, I set it up last week and other than an initial lag to get things going, it worked smoothly
15:18:11 <sayan> jcline: so you followed this for the setup? https://github.com/matrix-org/matrix-appservice-irc#setup
15:18:25 <jcline> Yeah
15:18:49 <jcline> IIRC I had to poke at the config a bit, but I can send you what's currently on my server if you want to compare
15:19:12 <sayan> jcline: I was going to say the same
15:19:25 <sayan> I would be interested in homeserver.yaml
15:20:29 <jcline> Okay, I'll send that your way
15:21:08 <x3mboy> I think, just for usability, that channels should be a dropdown menu with the Fedora owned IRC channels, and not a textbox
15:21:13 <x3mboy> But it's just me
15:23:03 <sayan> x3mboy: A lot of Fedora IRC channels come and go, so I think it's better to have a text box
15:23:39 <x3mboy> Fair point
15:24:42 <mizmo> x3mboy: if it's a new hub they might want to create a new channel for it too
15:25:10 <sayan> jcline: can you point me from where I can log into your matrix instance?
15:26:34 <jcline> sayan, I can make you an account if you want, but I had turned the instance off since I didn't spend any time making it "production" quality
15:26:43 <jcline> I wanted to package it before I deployed it for myself
15:27:28 <sayan> jcline: okay, and that's true for the fic instance too.
15:27:31 <jcline> You can also make an account on matrix.org at https://riot.im/app/#/ if you wanted to play
15:28:33 <sayan> There is terrible lag with it.
15:29:18 <jcline> Okay, well how about I package it this week and we can set up our own instance to work with?
15:29:32 <sayan> sure
15:30:07 <jcline> I think we also need to talk with the Freenode folks to make sure they're okay with us bridging to our channels
15:31:29 <sayan> #action jcline to start packaging the matrix packages
15:31:35 <jcline> sayan, https://paste.fedoraproject.org/paste/GzkQIBpePHbuAWao502H0F5M1UNdIGYhyRLivL9gydE= is my homeserver.yaml with keys redacted
15:32:29 <sayan> jcline: thanks
15:32:30 <jcline> https://paste.fedoraproject.org/paste/yW0K5Xe2bCgfbzou-ishMl5M1UNdIGYhyRLivL9gydE=/ is my irc bridge config - note that you'll need to change the channel mapping id, I think
15:32:42 <sayan> jcline: yes
15:34:10 <sayan> jcline: anyways, would you be starting with packaging synapse and related packages?
15:34:20 <jcline> sayan, yup
15:34:21 <sayan> and I can start with the irc-bridge?
15:34:35 <jcline> Sounds good
15:37:18 <sayan> I am moving over to open floor now
15:37:36 <sayan> #topic Open Floor
15:39:12 <sayan> mizmo: jcline: since IRC widget will be taking some more time, (hopefully, after the matrix setup we can iterate quickly)
15:39:27 <sayan> can we complete off the other tasks we had left?
15:40:06 <mizmo> which ones?
15:40:24 * abompard must really fix his IRC desktop notifications issue
15:40:25 <sayan> mizmo: like the release widget and the badges widget
15:40:45 <sayan> #chair abompard
15:40:45 <zodbot> Current chairs: abompard jcline mizmo sayan shillman x3mboy
15:40:46 <mizmo> where are we on those?
15:41:04 <mizmo> shillman: you had made some progress on the user's badges widget html/css right? can you make sure to email me what you have today?
15:41:30 <sayan> mizmo: for badges: I filed an issue which I am hitting on badges staging https://pagure.io/fedora-infrastructure/issue/5877
15:41:57 <sayan> Another one that got fixed last week: https://pagure.io/fedora-infrastructure/issue/5868
15:42:13 <shillman> mizmo: yeah, I'll send you that. I _think_ the latest in the etherpad is the most recent functional code, but I have to check.
15:42:17 <shillman> mizmo: http://etherpad.osuosl.org/badges_path_template
15:42:28 <sayan> and on the release widget we are left with the backend code
15:42:39 <sayan> vivek_ was supposed to work on it
15:43:41 <abompard> sayan: I'd like to discuss your PR 335 with you after the meeting if you don't mind
15:44:32 <sayan> abompard: sure, anyways, I rebased it on top of your branch and generated the migrations again
15:45:03 <fm-hubs> pagure.pull-request.comment.added -- sayanchowdhury commented on pull-request#335 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/335#comment-20782
15:45:20 <sayan> abompard: pushed again ^^
15:45:42 <abompard> sayan: it looks like this is a migration with the whole database, every column of every table
15:46:23 <sayan> abompard: yes
15:46:52 <abompard> So, in my understanding, there are two options to manage a database with Alembic
15:47:27 <abompard> Option 1: start from an empty DB, run evey migration in order to arrive at the model's current schema
15:48:20 <abompard> Option 2: start with a current DB as created by SQLAlchemy, "stamp" is as "HEAD" with Alembic, and keep older migration for those who have an older schema installed
15:48:34 <abompard> This is decribed here: http://alembic.zzzcomputing.com/en/latest/cookbook.html#building-an-up-to-date-database-from-scratch
15:49:05 <abompard> if i understand correctly, your migration is needed to implement option 1
15:49:46 <sayan> abompard: yes, but how do you generate new migrations?
15:49:49 <abompard> I'm more used to option 2, it feels cleaner to me, since a new database creation does not have to go through every migration of all times in a row
15:50:20 <abompard> sayan: oh that's simple, you keep your old DB around, change the models, and run alembic with --autogenerate
15:50:26 <abompard> it will compare the current DB to the models
15:50:31 <abompard> and generate the proper migration
15:50:46 <sayan> abompard: yes, my latest commit is built using that
15:50:52 <abompard> the good thing is that you can remove old migrations when you're sure no one has them live
15:50:59 <sayan> alembic -c hubs/alembic.ini revision --autogenerate -m "Add the intial models"
15:51:03 <abompard> so you started from an empty DB ?
15:51:18 <sayan> abompard: yes
15:51:36 <abompard> OK, well if you use option 2, you don't even need that.
15:51:49 <abompard> I'm not sure I'm clean
15:51:54 <abompard> let me try again
15:52:37 <abompard> when you want to create a new database from scratch, option 2 lets you create it from the models and just mark ("stamp") it as current in alembic
15:52:47 <abompard> you don't need a migration with all the tables
15:52:55 <abompard> you just need the models
15:53:34 <abompard> when you want to upgrade an old database, alembic will look at the schema version in the DB itself, and apply necessary migrations
15:54:21 <abompard> I guess the link to the alembic website explains it in a clearer way that I can ever do :)
15:54:25 <abompard> http://alembic.zzzcomputing.com/en/latest/cookbook.html#building-an-up-to-date-database-from-scratch
15:54:54 * sayan reads the link
15:55:03 <sayan> abompard: let's end the meeting and continue the discussion
15:55:17 <abompard> sure
15:55:32 <sayan> anything else to share in the open floor?
15:56:12 <sayan> Ending the meeting in
15:56:14 <sayan> 3.
15:56:16 <sayan> 2.
15:56:18 <sayan> 1.
15:56:20 <sayan> #endmeeting