14:02:43 <mizmo> #startmeeting hubs-devel
14:02:43 <zodbot> Meeting started Tue Jun 13 14:02:43 2017 UTC.  The chair is mizmo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:43 <zodbot> The meeting name has been set to 'hubs-devel'
14:02:46 <sayan> no issues :)
14:02:47 <mizmo> (sorry for all the spam)
14:02:52 <mizmo> okay! so how are things going?
14:03:06 <sayan> https://etherpad.gnome.org/p/hubs-flock-workshop
14:03:19 <sayan> I have drafted a talk and a hackfest proposal
14:03:38 <mizmo> awesome! two separate proposals?
14:03:46 <sayan> mizmo: yes
14:04:01 <sayan> those would be in two seperate time right?
14:04:13 <mizmo> yep! talks are going to be the first day and hackfests / workshops the other 3 days
14:04:30 <sayan> yes, so I wrote both the proposals
14:04:36 <sayan> we can add a lot to that
14:05:09 <mizmo> ok cool
14:05:21 <mizmo> do we want a third session, a working session about future hubs direction, kind of a brainstormy thing?
14:05:23 <abompard> would it make sense to have a workshop? I'm looking for a clear definition of the difference betweek workshops and hackfests, but can't find one
14:05:37 <mizmo> yeh so i can tell you, i should have documented this better
14:05:52 <mizmo> so a workshop is where you're teaching and doing. so showing ppl how to write widgets + then having them do it is a workshop
14:06:05 <mizmo> where a hackfest is more, you already work together and know what you're doing, so you're planning, coordinating, and doing, not so much teaching
14:06:09 <mizmo> does that make sense?
14:06:15 <abompard> yeah, that's what I supposed
14:06:19 <abompard> but wasn't sure
14:06:40 <abompard> do you guys think it would be useful to have a workshop too?
14:06:58 <abompard> it's more work upfront than a hackfest I think
14:07:11 <mizmo> yeh i think we were talking about doing a workshop for widget building right?
14:07:17 <abompard> since you have to design the exercices
14:07:45 <abompard> Yeah. I could work on that but maybe our workforce would best be put elsewhere
14:07:56 <sayan> abompard: mizmo: then let's move the talk to workshop
14:08:06 <abompard> Okay!
14:08:12 <sayan> how does that sound?
14:08:21 <mizmo> i think we still need a talk to give a status report on hubs
14:08:27 <mizmo> if you want i can propose that though
14:08:33 <mizmo> so not everything is on you sayan
14:08:40 <abompard> If you think it's useful, I can work on the exercises to have people write an example widget.
14:08:45 <mizmo> also, suzanne is going to propose a talk on the regional hubs idea
14:08:49 <abompard> yeah a talk seems useful
14:08:51 <sayan> mizmo: okay
14:08:54 <mizmo> abompard: that would be awesome!
14:08:57 <sayan> mizmo: yeah! that would be great
14:09:03 <mizmo> the talk ill propose will be sort of a status of where we are + a roadmap
14:09:11 <mizmo> suzanne is going to talk about the process + design of regional hubs
14:09:49 <sayan> mizmo: anyways, we need to submits the proposal of the talks?
14:10:12 <sayan> s/need to/need to decide/
14:10:35 <mizmo> sayan: wait so im a little confused, did you already propose + submit a hackfest and talk in the system? or did you just draft them?
14:11:31 <mizmo> oh i see i dont see them in system
14:11:35 <mizmo> are they in etherpad?
14:11:45 <sayan> mizmo: draft them. sorry for the confusion
14:11:53 <mizmo> it's all good :)
14:12:13 <mizmo> https://etherpad.gnome.org/p/hubs-flock-workshop
14:12:33 <mizmo> oh these writeups look great sayan!
14:12:38 <abompard> yes!
14:13:14 <mizmo> so here's my thought
14:13:26 <mizmo> we take the hackfest proposal and make it the workshop proposal
14:13:33 <mizmo> how long do you think the workshop should be?
14:14:06 <mizmo> it can be 2 or 3 hours
14:14:14 <sayan> yes
14:14:46 <mizmo> my gut is thinking 2 hrs for workshop, 3 hours for hackfest
14:15:00 <mizmo> and have them on different days so we're not hubs-ed-out all in one day lol
14:15:19 <abompard> yeah :)
14:15:22 <sayan> yeah, two days
14:16:14 <mizmo> okay so how about we do this -
14:16:17 <mizmo> we have 2 days till the deadline
14:16:29 <mizmo> sayan - can you propose the workshop?
14:16:35 <sayan> mizmo: I can
14:16:46 <mizmo> abompard: you'll  work on the exercises for the workshop -
14:16:54 <sayan> mizmo: or abompard do you want to propose the workshop?
14:16:58 <sayan> as you are working on the examples
14:17:02 <mizmo> oh that might make more sense
14:17:14 <abompard> yeah the description may be quite different from Sayan's
14:17:26 <sayan> abompard: right!
14:17:29 <abompard> since it's more about exercices than improving existing content
14:17:38 <mizmo> workshop should be 2 hours, should talk about how it's for new contributors and learning how to build hubs widgets
14:17:39 <mizmo> yeh
14:17:41 <sayan> the abstract would change a lot
14:17:48 <abompard> yeah
14:17:53 <mizmo> sayan: can you rejigger the existing hackfest writeup and propose for 3 hours?
14:18:16 <sayan> mizmo: ok
14:18:25 <mizmo> sayan: i think what needs to change in the existing hackfest is the fact we're having the workshop, so i think the proposal should mention that hackfest should occur *after* workshop, and mention the workshop for people who want to learn before attending
14:18:36 <abompard> indeed
14:18:41 <mizmo> other than that, it can be used as is
14:18:41 <sayan> yes
14:19:13 <mizmo> then i'll propose the talk, im going to tweak it a little bit to focus it on roadmap but mostly use what sayan wrote
14:19:14 <mizmo> ok
14:19:25 <mizmo> #action sayan proposing hackfest for 3 hours
14:19:31 <mizmo> #action abompard proposing workshop for 2 hours
14:19:38 <mizmo> #action abompard writing exercises for workshop
14:19:42 <mizmo> #action mizmo proposing hubs talk
14:19:51 <sayan> mizmo: yes, also add few things on building mockup to the talk proposal
14:20:16 <mizmo> sayan: actually suzanne's talk is probably going to cover the mockup process, so i could refer to hers
14:20:30 <sayan> Yeah!
14:20:33 <mizmo> kind of give a high level and if people want details look at suzanne's for specifics
14:21:00 <mizmo> i think once we get talk acceptances i want to put together a big blog post running down all of our talks to try to get people excited to come to all of them :)
14:21:16 <mizmo> okay cool i think we are in great shape for flock
14:21:17 <abompard> :+1:
14:21:20 <mizmo> in terms of proposals
14:21:27 <mizmo> anything else to discuss? how is the development coming?
14:21:34 <abompard> Yes, I have two topics
14:21:59 <mizmo> go ahead :)
14:22:21 <abompard> First, the hubs-devel machine. After I4ve submitted the workshop proposal, I can work on bringing it up-to-speed with dev
14:22:42 <abompard> making sure it's usable and all
14:22:48 <sayan> hubs-devel machine as in the vagrant box?
14:22:50 <abompard> so people can look at it before hubs
14:22:59 <abompard> nope, the one in fedorainfracloud
14:23:04 <abompard> sayan: ^
14:23:37 <sayan> abompard: yes, that something I was planning last week, but did not get much time because of fedimg
14:23:44 <abompard> My thinking is that before deciding to get involved with hubs and go to a session at flock, people will probably want to checkout what it's like
14:23:44 <mizmo> oh thats a great idea abompard
14:24:09 <sayan> abompard: I just now pinged Patrick before the meeting, seems like we are send a wrong callback url
14:24:11 <mizmo> #action abompard to update hubs-devel box @ fedorainfracloud so workshop attendees could check out how it works
14:24:19 <sayan> should be https instead of http
14:24:25 <abompard> sayan: yeah
14:24:46 <abompard> Second point, kinda related to the first
14:25:09 <abompard> I have this "feed rework" branch in review at the moment, I can't wait to show it off to you :-)
14:25:20 <abompard> so maybe I'll setup that branch on the hubs-devel host, who knows ;-)
14:25:26 <mizmo> \o/ that would be awesome!
14:25:34 <sayan> abompard++
14:25:54 <abompard> but if *someone* reviews it in the meantime, well
14:25:58 <sayan> abompard: btw, are you free after this meeting so that we can fix the hubs-dev instance
14:26:03 <abompard> I would just have to ckeckout master :-)
14:26:07 <abompard> sayan: yep!
14:26:39 <sayan> abompard: cool, let's collab after the meeting
14:26:48 <sayan> abompard: also another thing I wanted to talk on
14:27:26 <sayan> abompard: I did not use the vagrant box much, but I tried last weekend and the CSS seems to be broken for me (after I did a fresh install)
14:27:51 <abompard> sayan: I never used Vagrant, but I guess it's the perfect opportunity to learn
14:28:11 <abompard> I'll have a look
14:28:18 <abompard> but the workshop proposal comes first :-)
14:28:27 <sayan> abompard: yeah, so free sometime later this week so that we can fix the vagrant box
14:28:29 <sayan> yeah
14:28:35 <abompard> :+1:
14:28:37 <sayan> deadline approaching
14:29:16 <sayan> abompard: let's then work on Friday to fix the vagrant box
14:29:24 <abompard> okay
14:29:36 <sayan> I am slowly moving all my development to vagrant box
14:29:42 <abompard> interesting
14:30:05 <abompard> it'll be faster for me if you're there to show me, so I'm all for it :)
14:30:19 <sayan> mizmo: and I have been working on the IRC frontend, did not get much work done last week though
14:30:35 <mizmo> ok cool
14:30:41 <mizmo> hopefully more time this week?
14:30:51 <sayan> due to a high priority fedimg issue, but things are coming up weel
14:30:54 <sayan> well
14:30:56 <sayan> yeah
14:32:09 <sayan> next thing is once we are done with the proposal submission, we can start off creating slides
14:32:24 <sayan> (in July)
14:32:40 <sayan> and mock presentations over video call (in August)
14:32:51 <sayan> does that sound good?
14:33:12 <abompard> :+1:
14:33:13 <mizmo> yep that sounds like a good idea
14:33:42 <mizmo> #action sayan to work more on irc widget this week as time permits
14:33:52 <mizmo> #action [all] once proposal submissions in, we should create slides in july
14:34:07 <mizmo> #action [all] we should plan to have mock presentations over video call in august before flock
14:35:17 <sayan> that's all from my side
14:35:27 <mizmo> anything else to talk about?
14:35:37 <abompard> nope
14:35:54 <mizmo> cool let's end it there then :)
14:35:59 <mizmo> #endmeeting