13:59:59 <mizmo> #startmeeting hubs-devel
13:59:59 <zodbot> Meeting started Tue Sep 12 13:59:59 2017 UTC.  The chair is mizmo. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:59:59 <zodbot> The meeting name has been set to 'hubs-devel'
14:01:51 * sayan is back, but is also having food
14:02:09 <sayan> mizmo: I added a few points to run the meeting: https://pagure.io/fedora-hubs/pull-request/384#_1,33
14:02:19 <sayan> though not merged into README
14:03:01 <shillman> .hello wispfox
14:03:02 <zodbot> shillman: wispfox 'Suzanne Hillman' <wispfox@gmail.com>
14:03:18 <sayan> .hello sayanchowdhury
14:03:19 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:03:27 <mizmo> .hello duffy
14:03:28 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
14:04:12 <sayan> mizmo: can you chair us?
14:04:42 <mizmo> i would rather not sayan, im just not feeling well
14:05:17 <sayan> mizmo: I mean chair us, shillman or me?
14:05:23 <sayan> shillman and me
14:05:24 <mizmo> oh haha
14:05:30 <mizmo> #chair sayan shillman
14:05:30 <zodbot> Current chairs: mizmo sayan shillman
14:05:44 * mizmo sorry, operating on 4 hrs sleep :(
14:05:58 <shillman> Ugh.
14:06:07 <sayan> mizmo: sad :(
14:06:30 <sayan> I was down last week because of jet lag, feeling well since Sunday
14:07:00 <sayan> #topic Status Updates
14:07:02 <mizmo> i know the feeling, with kids instead of planes lol
14:07:16 <sayan> haha yeah
14:07:38 <sayan> mizmo: shillman: any thing to update from last week?
14:08:11 <shillman> Nope! Still continuing my job hunt, and doing other design projects, and moving my website to wix.
14:08:14 <mizmo> sayan: we've both been talking with abompard about a possible outreachy internship for helping develop hubs widgets now that he put together a great workshop for flock that could be used to onboard new devs
14:08:22 <shillman> Oh, right. Heh!
14:08:24 <mizmo> sayan: i think abompard is still working on the proposal for it
14:09:32 <sayan> #info abompard is working on the proposal for outreachy on developing hubs widgets
14:10:00 <mizmo> ive seen a lot of positive feedback on the hubs flock sessions too
14:10:00 <sayan> I was mostly down the last week so I did not much much, was most completing task which were left
14:10:06 <mizmo> we should probably do some kind of blog summary about all of it
14:10:14 <sayan> mizmo: yeah
14:10:25 <sayan> mizmo: I thought of dropping a mail last week, but I could not
14:10:26 <mizmo> sayan: do you have a link to the slides handy?
14:10:53 <mizmo> sayan: totally understand :)
14:11:00 <sayan> mizmo: the slides are hosted here: https://sayanchowdhury.fedorapeople.org/_slides/flock2017/hubs/
14:11:10 <sayan> I can create a pdf version of it I guess
14:11:11 <mizmo> awesome thanks
14:12:04 <sayan> So, the opentack folks have office hours, when they sit for 2-3 hours and work collaboratively
14:12:04 <mizmo> nah i think thats ok
14:12:41 <sayan> we can start one, once a month
14:13:05 <sayan> and a bi-weekly hubs updates blog we need to start
14:13:09 <mizmo> sayan: do you think thats a model we should follow?
14:13:18 <mizmo> that would be awesome
14:13:29 <mizmo> #idea monthly 2-3 office hours / hack session (like open stack)
14:13:35 <mizmo> #idea bi-weekly hubs update blog
14:13:41 <mizmo> i think to get new contribs we should do bounties
14:13:59 <mizmo> are we in a position to take on new contribs right now tho
14:14:11 <sayan> yes, we are in a position
14:14:40 <sayan> mizmo: we have bunch of easyfix issue https://pagure.io/fedora-hubs/issues?status=Open&tags=easyfix
14:14:57 <mizmo> awesome, so what i can do is write up some of the easy fix issues as bounties
14:15:02 <sayan> Except for a easyfix issue, there should be a format: who to contact and where in code the bug should be solved
14:15:09 <mizmo> maybe i can put togehter a 'prize pack' for whoever takes each bounty
14:15:48 <sayan> mizmo: +1
14:15:55 <mizmo> sayan: this is the template we used for design bounties: https://mairin.wordpress.com/2010/07/09/fedora-design-bounty-fedora-slide-deck-template/
14:16:27 <mizmo> ill do something up like this :)
14:16:47 <sayan> on other hand I will create a PR with whatever IRC work I did
14:17:03 <sayan> The plan is have quick PRs rather than a big work
14:17:12 <mizmo> yeh
14:17:14 <sayan> we can deploy it to the hubs-dev and see how things work
14:17:16 <mizmo> #idea bounties for easyfix in hubs issues
14:17:26 <mizmo> #idea quick PRs rather than large PRs
14:17:34 <sayan> #action sayan to create the PR for the IRC work
14:17:35 <mizmo> this all sounds great :)
14:17:56 <abompard> sorry I'm late!
14:18:06 <mizmo> its ok abompard
14:18:16 <mizmo> im here with only half a brain :)
14:18:17 * sayan waves to abompard
14:18:21 <sayan> #chair abompard
14:18:21 <zodbot> Current chairs: abompard mizmo sayan shillman
14:19:00 <sayan> abompard: so, I was discussing that we should focus on small PRs, and merge them
14:19:08 <sayan> and probaly push to hubs-devel
14:19:14 <abompard> sayan: yeah
14:19:20 <sayan> and when things work we can do push to prod
14:19:36 <sayan> abompard: also we need to start working on pushing hubs to production
14:19:42 <abompard> I'm cooking a pretty big PR for you guys, but I think it can wait after prod
14:19:50 <abompard> yeah
14:20:18 <abompard> do you guys think it's in a state where it can be useful to people?
14:20:27 <sayan> abompard: we don't know
14:20:46 <sayan> abompard: the thing is until and unless people don't use, we don't know how people are going to react
14:21:15 <abompard> sayan: yeah, maybe push to prod and advertise to small groups only first, like commops?
14:21:19 <mizmo> i think if we push something into prod at this point it relaly needs to be marked as experimental / playground -
14:21:27 <abompard> mizmo: agreed
14:21:32 <mizmo> i dont know that we have enough for any one team to get the full experience without irc
14:21:54 <mizmo> what i would rather do - is maybe use say the design team as alpha testers
14:22:02 <mizmo> so we have a user population to get feedback from without doing a real launch
14:22:13 <mizmo> with IRC i think we could do design team pretty well
14:22:15 <abompard> I'm just careful about not pushing to prod too soon, have people think "nah, useless to me" and not go back to it when we do improvements
14:22:23 <mizmo> abompard: ^^^ this, 100%
14:22:51 <shillman> Agreed.
14:23:12 <sayan> for me, it's we should have the basic features in and let people start using
14:23:20 <mizmo> sayan: i agree but not all users
14:23:30 <sayan> mizmo: yes, probably a team
14:23:31 <mizmo> i think we should pick a small community
14:23:34 <abompard> I think people got used to beta software having 99% features, like gmail when it came out
14:23:54 <mizmo> thanks google :( lol
14:24:47 <sayan> one thing that came out from the commops discussion was that if people contribute
14:24:55 <sayan> they would like there feature online
14:25:06 <sayan> that would give them the enthusiam to continue working
14:25:24 <mizmo> that makes sense, so we could allow for the alpha testing team + any devel / contribs to have access,
14:25:35 <sayan> yes
14:25:37 <sayan> we can do that
14:25:45 <mizmo> a notification maybe for others that its coming soon
14:26:01 <sayan> atleast we should start planning for production, becuase we need to start packaging things
14:26:20 <mizmo> +1
14:26:26 <mizmo> what is needed at this point for prod?
14:26:41 <sayan> abompard: wrote the ansible scripts for the deployment
14:27:15 <sayan> but we still install via pip, so we need to create rpm packages
14:27:20 <abompard> sayan: but it's still downloading a huge amount of NPM libs from the internet. Not sure they'll like that in prod
14:27:27 <sayan> for the ones which are not available
14:27:50 <abompard> Not sure we have a lot of Python deps, but we do have a lot of JS deps
14:27:57 <sayan> abompard: yeah
14:28:05 <sayan> anyways, we need to remove those deps
14:28:10 <sayan> and move to RPM
14:28:41 <sayan> we can create an issue, to track the issues to be packaged
14:28:51 <sayan> abompard: ^^
14:29:04 <sayan> s/issues/npm libraries/
14:30:17 <abompard> sayan: good idea
14:30:44 <sayan> #action sayan to create a issue to track all the libraries (Python + JS) to be packaged
14:31:37 <sayan> we can keep editing the issue, when we see new packages to be packaged
14:32:06 <sayan> mizmo: abompard: shillman: next thing I wanted to discuss was how to get more code contributors?
14:33:37 <mizmo> #action mizmo to create easyfix bounties for hubs
14:33:42 <mizmo> ^^ thats my idea :)
14:33:59 <mizmo> the main challenges:
14:34:11 <mizmo> 1) identifying things newbies can work on
14:34:25 <mizmo> 2) getting newbies bootstrapped (flock workshop will be a huge help here)
14:34:40 <mizmo> 3) getting newbies integrated into the team and keeping them
14:35:41 <sayan> we also need to identify the source to find the newbies
14:36:21 <sayan> like we can align with fedora-classroom effort to get more contributors
14:37:21 <mizmo> also GSoC and outreachy
14:37:26 * mizmo points to shillman :)
14:37:29 <sayan> Yeah!
14:37:35 <sayan> +1
14:38:21 <sayan> when is the last date for project proposal in Outreachy?
14:38:34 <shillman> :)
14:39:12 <mizmo> sayan: applications opened up on sept 7,
14:39:35 <mizmo> sayan: labbott would know when fedora is aiming to have all the proposals in by, i know we are still taking proposals but i dont know the cut off
14:39:47 <mizmo> i would guess at least by the end of sept so applicants have some time
14:39:55 <sayan> Okay
14:40:20 <sayan> In that case abompard and me can work on widget and have a detail plan ready
14:40:39 <sayan> so that we have a good experience for the applicants
14:40:56 <mizmo> sounds good :)
14:41:09 <mizmo> oh!
14:41:11 <abompard> yeah, I don't know how write this kind of plan, I'll be happy if we can do it together
14:41:21 <sayan> abompard: what are you preparing for proposal?
14:41:23 <sayan> Oh
14:41:31 <mizmo> i talked to the cornell student group working on a UX project for the semester for hubs, i gave them a list of commops folks to interview for their hub, so they're getting started on that i think
14:42:01 <sayan> abompard: should we create a timeline for the student or let the student do it?
14:42:06 <sayan> s/student/applicant
14:42:22 <shillman> work together with them?
14:42:24 <abompard> I dont know
14:42:34 <sayan> shillman: that sounds good
14:42:59 <sayan> we can create a list of task to work on, (every small task) and let applicant add the timeline to it
14:43:13 <sayan> (list of task to complete a widget)
14:43:45 <shillman> Your applicants may not be sure how long things will take. I recommend having a discussion with them and figuring out the timeline together.
14:43:52 <shillman> That's what mizmo and I did.
14:44:04 <mizmo> +1
14:44:12 <sayan> shillman: yes, we will be there for everything, but they need to put in some research
14:44:24 <mizmo> based on individual applicants interests / skillsets you can have a rough outline for the internship but fill in the week-by-week tasks based on individuals
14:44:31 <sayan> and time would be bit dependent on the potential of the students
14:45:01 <mizmo> +1
14:45:28 <shillman> *nod*
14:46:06 <sayan> so first lets discuss the widgets that we should focus on, and then we start on things we need
14:46:21 <sayan> and then when the applicants turn up we help them build there proposal
14:47:15 <mizmo> i think it might then make senes to wait until after outreachy application period to do bounties so the bounty doesn't compete with an intern's project
14:47:39 <sayan> mizmo: yes
14:47:45 <abompard> +1
14:48:12 <mizmo> #info  wait until after outreachy application period to do bounties so the bounty doesn't compete with an intern's project
14:48:33 <sayan> #action abompard and sayan to discuss the widgets for the outreachy proposal, and draft the outline of the proposal
14:49:18 <sayan> next thing is should we pushing the PRs, issue updates to the mailing list?
14:49:29 <sayan> mizmo: abompard: shillman ^
14:50:21 <mizmo> yes definitely
14:50:35 <abompard> sayan: the ML is kinda dormant at the moment, but if we push every PR update to it the signal-to-noise ratio may go way down. Maybe only the PRs?
14:50:55 <abompard> s/the PRs/the new PRs/
14:51:05 <sayan> abompard: I don't know if we can do that
14:51:12 <abompard> OK
14:51:39 <sayan> abompard: for atomic-wg we get all the activity, so I don't need to seperately watch the projects
14:51:46 <sayan> I just watch the emails in the list
14:52:04 <mizmo> ohh i was thinking we'd write summaries (human-made) not auto, i dont like hitting MLs with auto generated commits
14:52:53 <sayan> okay, in that case a summary of the weekly issue, triaged?
14:53:39 <sayan> weekly issues triaged, PRs etc
14:53:56 <abompard> that'd be great
14:54:24 <sayan> and there can be list of dates of who want to write (maintain in etherpad)
14:54:35 <sayan> check the bottom of the page here: https://fedoraproject.org/wiki/Cloud#Meetings
14:56:43 <sayan> abompard: mizmo shillman ^^
14:57:05 <abompard> sayan: it's very interesting
14:57:13 <mizmo> ah thats a good idea
14:58:07 <abompard> they do a ticket for each actions?
14:58:35 <sayan> that list is unmaintained now, as cloud moved to atomic, but we generally picked up the week we wanted to maintain
14:58:59 <sayan> abompard: nope, it just that next week we will reiterate through the action items
14:59:09 <sayan> to see what is done and what is not
15:00:13 <sayan> #action sayan to create a etherpad page with the list of dates, and add it to the readme
15:00:32 <sayan> we are at time. I am moving to open floor
15:00:37 <sayan> #topic Open Floor
15:00:55 <sayan> abompard: mizmo: shillman: anything you want to share in open floor?
15:01:12 <shillman> Not really?
15:01:18 * mizmo noppers
15:01:42 <abompard> nope
15:02:08 <sayan> cool, I am then ending the meeting
15:02:11 <sayan> #endmeeting