13:01:55 <sayan> #startmeeting hubs-devel
13:01:55 <zodbot> Meeting started Tue Jan  9 13:01:55 2018 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:55 <zodbot> The meeting name has been set to 'hubs-devel'
13:02:24 <ryanlerch> .hello ryanlerch
13:02:25 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
13:02:29 <sayan> #topic Roll Call
13:02:33 <ryanlerch> .hello ryanlerch
13:02:34 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
13:02:35 <sayan> .hello sayanchowdhury
13:02:37 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
13:02:38 <shaily> .hello2
13:02:40 <zodbot> shaily: shaily 'None' <shaily15297@yahoo.com>
13:02:42 <mizmo> .hello duffy
13:02:43 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
13:03:14 <sayan> abompard: meeting time!
13:03:31 <sayan> let's wait for a few minutes
13:03:51 <abompard> .hello2
13:03:52 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
13:04:45 <sayan> #chair ryanlerch shaily mizmo abompard
13:04:45 <zodbot> Current chairs: abompard mizmo ryanlerch sayan shaily
13:05:04 <sayan> happy new year, everyone :-)
13:05:18 <abompard> same!
13:05:21 <shaily> happy new year!
13:06:03 <mizmo> ~~~~*** \o/ ****~~~
13:06:08 <sayan> is pagure.io down?
13:06:30 <abompard> sayan: it's working for me here
13:06:32 <ryanlerch> sayan: its working for me
13:06:39 <sayan> abompard: ryanlerch: okay
13:07:02 <shaily> really slow for me here, but it does load
13:07:24 <sayan> slow, pagure.io isn't loading for me
13:07:27 <sayan> the issue page is stuck
13:07:39 <sayan> abompard: can you go with the issues?
13:08:23 <sayan> ryanlerch: ^^
13:09:09 <abompard> yeah
13:09:20 <abompard> there were no actions from last meeting
13:09:50 <abompard> wanna go ahead with the tickets or start with the status updates?
13:09:56 <ryanlerch> still aiming for 1.0 in Feb! woo!
13:10:01 <sayan> abompard: yes
13:10:15 <sayan> start with the tickets!
13:10:22 <abompard> OK
13:10:41 <abompard> #topic Ticket #489 Meetings widget on User hubs
13:11:00 <abompard> reported by ryanlerch
13:11:32 <abompard> https://pagure.io/fedora-hubs/issue/489
13:12:07 <sayan> internet is unusable for me
13:12:18 <ryanlerch> so this one needs to be restricted to stream and team
13:12:24 <abompard> I think this should be renamed to "adapt the meetings widget to work on stream and team hubs"
13:12:27 <abompard> ryanlerch: yeah
13:12:47 <ryanlerch> and then adapted on the stream to show upcoming meetings specific to that user
13:13:09 <abompard> the ticket is not assigned yet, has anyone started on that?
13:13:36 <sayan> seems like no one has
13:13:43 <ryanlerch> note to that #432 is related to this
13:13:48 <abompard> ok
13:13:53 <ryanlerch> https://pagure.io/fedora-hubs/issue/432
13:14:19 <abompard> can you update the ticket ryanlerch?
13:14:28 <ryanlerch> #432 is a bigger fix though
13:14:41 <mizmo> i can update
13:14:49 <abompard> thanks
13:14:52 <ryanlerch> the mockups depict a whenisgood kind of functionality
13:15:06 <ryanlerch> which i am not sure we can get done for MVP
13:15:10 <abompard> #action mizmo to update ticket 489
13:15:16 <mizmo> ryanlerch: its linking out to a whenisgood though, not actually reimplementing it if that makes sense
13:15:22 <mizmo> you copy/paste the whenisgood link
13:15:25 <mizmo> and we let whenisgood handle it
13:15:34 <ryanlerch> mizmo: ohhh, ok
13:15:40 <fm-hubs> pagure.issue.edit -- duffy edited the title fields of ticket fedora-hubs#489 https://pagure.io/fedora-hubs/issue/489
13:15:54 <abompard> oh yeah let's let other people deal with the timezones mess :-)
13:16:02 <mizmo> (or any meeting sync up link the person chooses)
13:16:27 <ryanlerch> ah ok -- so all it really is is a link to whenisgood/whatever
13:16:58 <mizmo> it's pretty detailed here - https://pagure.io/fedora-hubs/issue/33
13:17:05 <ryanlerch> abompard: i can have a go at these two
13:17:20 <abompard> alright ryanlerch, feel free to take them :)
13:17:26 <ryanlerch> i'm poking around in the widgets at the moment
13:17:42 <abompard> OK, next ticket?
13:17:48 <fm-hubs> pagure.issue.assigned.added -- ryanlerch assigned ticket fedora-hubs#489 to ryanlerch https://pagure.io/fedora-hubs/issue/489
13:17:51 <fm-hubs> pagure.issue.assigned.added -- ryanlerch assigned ticket fedora-hubs#432 to ryanlerch https://pagure.io/fedora-hubs/issue/432
13:17:53 <abompard> #topic Ticket #478 disable "preview" status for hubs for MVP  -- https://pagure.io/fedora-hubs/issue/478
13:17:56 <mizmo> should we close 489 and use 33 instead?
13:18:00 <mizmo> since 33 has the actual spec?
13:18:06 <abompard> mizmo: yeah makes sense
13:18:18 <ryanlerch> mizmo: +1
13:18:26 <abompard> or link them in the "depends" field if they have valuable info. But closing is good :)
13:18:35 <fm-hubs> pagure.issue.edit -- duffy edited the close_status and status fields of ticket fedora-hubs#432 https://pagure.io/fedora-hubs/issue/432
13:18:38 <fm-hubs> pagure.issue.comment.added -- duffy commented on ticket fedora-hubs#432: "Meetings widget: "Request a new meeting" button doesn't work" https://pagure.io/fedora-hubs/issue/432#comment-487402
13:19:09 <fm-hubs> pagure.issue.assigned.added -- duffy assigned ticket fedora-hubs#33 to ryanlerch https://pagure.io/fedora-hubs/issue/33
13:19:10 <fm-hubs> pagure.issue.dependency.added -- duffy added ticket fedora-hubs#33 as a dependency of ticket fedora-hubs#390 https://pagure.io/fedora-hubs/issue/33
13:19:21 <fm-hubs> pagure.issue.edit -- duffy edited the milestone and priority fields of ticket fedora-hubs#33 https://pagure.io/fedora-hubs/issue/33
13:19:41 <abompard> so, ticket 478 is assigned to ryanlerch
13:20:26 <mizmo> where a 'preview' makes sense is if you're viewing the profile hub of someone youre not friends with
13:20:39 <mizmo> but i dont know that we'll have that friendship kind of functionality for mvp
13:20:50 <mizmo> but its another reason why a preview would happen in a widget (particularly feed widget)
13:21:05 <abompard> I think we can't have much more than we curently have for MVP if we want to get it out by Feb
13:21:17 <golu> hi, sorry to interrupt the meeting. i had one quick question!
13:21:24 <mizmo> id say drop the ticket then
13:22:12 <abompard> golu: can you wait a couple minutes until we deal with this ticket?
13:22:19 <golu> sure
13:22:39 <ryanlerch> basically, "preview" is still there on group hubs
13:22:54 <ryanlerch> it was for when you could view hubs not logged in
13:23:27 <ryanlerch> so you could make group hubs widgets specifically show or not show depending on if a user was logged in
13:23:46 <mizmo> oh
13:23:47 <mizmo> just a thought
13:23:52 <mizmo> even though it wasn't the original intention
13:23:56 <ryanlerch> easy fix is just to remove that from the config UI
13:24:16 <mizmo> the big concern we've had about launching is that certain teams might not have the widgets / data to make hubs useful and they'd abandon it / get a bad impression and not come back
13:24:23 <mizmo> so there was an idea of with the launch, only having a selection of vetted group hubs available
13:24:39 <mizmo> i wonder if leaving in the prveiew functionality, and setting any non-vetted hubs to 'preview' would be useful
13:25:27 <mizmo> we'd talked about having design, comm ops, and marketing as pilot groups for an initial deployment
13:25:46 <abompard> mizmo: so we would create hubs for all groups, but in "preview" mode? Still, that mode woudn't do anything since everybody would be logged in anyway
13:26:10 <abompard> unless we make it do something else
13:26:36 <mizmo> ohhhh nevermind then
13:26:41 <mizmo> well, if we could have it apply whether or not you were logged in
13:26:41 <mizmo> i dont know
13:26:52 <mizmo> i guess the other solution is to only create hubs for the vetted set of groups
13:27:15 <ryanlerch> mizmo: i *think* that is what we will probably end up doing i think
13:27:18 <abompard> I think that was the plan
13:27:24 <mizmo> the latter is probably cleaner, but i dont know if thats possible either
13:27:59 <mizmo> oh ok awesome :)
13:28:06 <mizmo> kill preview mode then :)
13:28:06 <abompard> cool :)
13:28:07 <ryanlerch> because there are hundreds of FAS groups, so it would be super messy to just make team hubs for all of them i thought
13:28:11 <mizmo> sorry for the distraction
13:28:31 <abompard> OK, so this ticket is about removing it from the UI
13:28:35 * ryanlerch will just remove that option form the UI
13:28:42 <mizmo> yeh like fedora-gitspins
13:28:53 <ryanlerch> i think we should leave the logic in there from the time being
13:29:08 <abompard> ryanlerch: agreed
13:29:29 <ryanlerch> abompard: i can remove it from the UI
13:29:50 <abompard> ryanlerch: cool, then you're still assigned to the ticket ;-)
13:29:57 <ryanlerch> haha awesome :)
13:30:29 <abompard> #topic Ticket #474 When joining a hub, automatically subscribe the user to the hub -- https://pagure.io/fedora-hubs/issue/474
13:30:47 <abompard> I think I'm currently doing that on my work to integrate FAS
13:30:52 <abompard> so I'll just take the ticket
13:31:11 <ryanlerch> yeah, we covered this in a previous meeting too
13:31:25 <abompard> except the unsubscribe-on-leave thing, I need to add that
13:31:29 <fm-hubs> pagure.issue.assigned.added -- abompard assigned ticket fedora-hubs#474 to abompard https://pagure.io/fedora-hubs/issue/474
13:32:17 <abompard> #topic Ticket #472 Contact widget: check that the location isn't displayed if it is set to private in FAS -- https://pagure.io/fedora-hubs/issue/472
13:33:17 <abompard> hmm, I didn't know you could set your location private in FAS
13:34:22 <mizmo> yeh thats been there from day 1
13:34:41 <abompard> okay. well, that should be an easy ticket then :)
13:34:50 <mizmo> i think we have to know because of different laws about sanctions
13:35:08 <mizmo> so its a requirement to give your location but to allow fo privacy you can opt out of it being public
13:35:10 * ryanlerch wonders if the FAS api gives us that info if it is private
13:36:22 <abompard> ryanlerch: I don't see it in someone else's API entry
13:36:41 <abompard> so if it's required, they must have set it, and the API doesn't give it back. I guess we're good
13:36:57 <abompard> maybe just make sure the UI doesn't crash if the info isn't present
13:37:15 <sayan> but then there are few location based widgets
13:37:42 <ryanlerch> sayan: which ones are location based?
13:37:53 <sayan> we need to have to keep in mind if the location is not available then handle the widget accordingly
13:37:54 * ryanlerch can't remember seeing any
13:38:10 <mizmo> sayan: there's TZ based ones but TZ is a diff field
13:38:28 <mizmo> (eg meeting widget)
13:39:03 <sayan> mizmo: regional hubs?
13:39:35 <ryanlerch> regional hubs arent on the MVP roadmap at the moment i thought
13:39:38 <abompard> sayan: we don't have that yet
13:39:42 <abompard> yeah
13:39:44 <sayan> yeah
13:40:02 <sayan> I just made that point, if we are making a widget in future then that needs to be handled
13:41:22 <mizmo> +1
13:42:04 <fm-hubs> pagure.issue.comment.added -- abompard commented on ticket fedora-hubs#472: "Contact widget: check that the location isn't displayed if it is set to private in FAS" https://pagure.io/fedora-hubs/issue/472#comment-487421
13:42:20 <abompard> OK, so ticket 472 should be simple :)
13:42:28 <abompard> for MVP at least
13:42:45 <abompard> #topic Ticket #462 Hub Bio & Rules / Contact always at top of the page -- https://pagure.io/fedora-hubs/issue/462
13:43:03 <abompard> I'm assigned to that, I'll do it after FAS integration
13:43:10 <abompard> hopefully.
13:43:28 <ryanlerch> abompard: if i get a chance, i might have a look at it
13:43:42 <ryanlerch> i'll open up a WIP PR if i do
13:43:47 <mizmo> ryanlerch you tagged tha tneeds discussion, but im unclear what is needed there
13:43:49 <abompard> ryanlerch: perfect
13:44:14 <ryanlerch> mizmo: i tagged that originally IIRC, i'll remove the tag
13:44:23 <ryanlerch> we discussed it a while back :)
13:44:26 <mizmo> kk
13:44:45 <fm-hubs> pagure.issue.tag.removed -- ryanlerch removed the needsdiscussion tags from ticket fedora-hubs#462 https://pagure.io/fedora-hubs/issue/462
13:44:59 * abompard is rushing through tickets a bit, sorry
13:45:01 <abompard> #topic Ticket #459 Team Hubs -- promoted and hub of the month -- https://pagure.io/fedora-hubs/issue/459
13:45:47 <mizmo> if we're only going to have so many vetted hubs for MVP id say this isn't necessary. A flat list of the available hubs should be fairly short
13:45:54 <abompard> agreed
13:46:03 <sayan> Yes
13:46:08 <ryanlerch> when i implemented /groups/ that is excatly what i did :)
13:46:15 <abompard> :+1:
13:46:31 <fm-hubs> pagure.issue.edit -- duffy edited the milestone and priority fields of ticket fedora-hubs#459 https://pagure.io/fedora-hubs/issue/459
13:46:44 <fm-hubs> pagure.issue.edit -- abompard edited the milestone and priority fields of ticket fedora-hubs#459 https://pagure.io/fedora-hubs/issue/459
13:46:45 <fm-hubs> pagure.issue.comment.added -- abompard commented on ticket fedora-hubs#459: "Team Hubs -- promoted and hub of the month" https://pagure.io/fedora-hubs/issue/459#comment-487425
13:46:52 <ryanlerch> so this one done :)
13:47:06 <fm-hubs> pagure.issue.edit -- abompard edited the milestone fields of ticket fedora-hubs#459 https://pagure.io/fedora-hubs/issue/459
13:47:13 <fm-hubs> pagure.issue.edit -- abompard edited the priority fields of ticket fedora-hubs#459 https://pagure.io/fedora-hubs/issue/459
13:47:17 <abompard> mid-air collision! :-)
13:47:37 <ryanlerch> pew pew pew
13:47:44 <ryanlerch> updates flying everywhere
13:47:48 <abompard> #topic Ticket #437 Halp widget: do some testing -- https://pagure.io/fedora-hubs/issue/437
13:48:01 <abompard> It's actually about setting some CSS styles IIRC
13:48:35 <ryanlerch> halp may also need a little bit of explaining / user docs somewhere too
13:48:42 <fm-hubs> pagure.issue.edit -- abompard edited the title fields of ticket fedora-hubs#437 https://pagure.io/fedora-hubs/issue/437
13:48:49 <ryanlerch> it confused me so much when i first looked at it
13:49:29 <abompard> ryanlerch: ok, should we open a new ticket for that or use that one?
13:50:01 <abompard> probably a new one, right? this one already changed subject once
13:50:13 <ryanlerch> abompard: for sure new one!
13:50:48 <ryanlerch> TBH, i still am a bit fuzzy on it -- so some extra info in a new ticket would be awesome
13:51:11 <abompard> OK, there are too many open tickets to do them all in the time we have, and I'd like to have a more general discussion
13:51:29 <abompard> but first, does everybody have "enough" on their plate for Hubs?
13:52:08 <abompard> the thing is, I'm a bit worried about the Feb deadline. It's in 3 weeks and one of them will be devconf
13:52:09 <shaily> yes, search PR should be in by the end of the day
13:52:15 <shaily> i made a PR for the issues widget, #501
13:52:23 <shaily> it would be great if someone could review it
13:52:49 <abompard> I saw it shaily, thanks. I plan on reviewing it when I'm done with my first shot at FAS
13:53:01 <abompard> which would be in a couple days max
13:53:10 <shaily> okay cool
13:53:25 <ryanlerch> abompard: i am also currently going through the widgets too, and cleaning up etc
13:53:28 <abompard> if you need an earlier review, I can re-prioritize it
13:53:33 <mizmo> do you want to push back date abompard? feb 15?
13:53:48 <ryanlerch> making them show on hubs that we expect them to
13:54:02 <abompard> about 1.0, we haven't started to think of deployment
13:54:11 <abompard> and it may be more hairy than usual
13:54:14 <abompard> because of NodeJS
13:54:28 <ryanlerch> pingou ^
13:54:49 <golu> abompard: is now a good time
13:55:01 <ryanlerch> sayan: are you up for reviewing some PRs too?
13:55:03 <abompard> yeah golu, sorry I forgot about you
13:55:12 <golu> so i found out about hubs from the flock 17 archives, and i've been browsing through the codebase for the past week
13:55:12 <golu> i was wondering if you're applying for the upcoming gsoc round?
13:55:16 <golu> i went through the meeting logs, and it seems like there was a plan for using a matrix room for the IRC widget instead of embedding kiwi-irc
13:55:54 <golu> i've been looking at how riot.im is built using the matrix react sdk, so i think it can be done here too
13:56:00 <golu> if there are any plans, that is
13:56:25 <abompard> golu: we havent decided about gsoc but we may very well consider it, thanks for reaching out to us
13:56:26 <sayan> ryanlerch: yeah, i'll start up with the reviews
13:57:20 <golu> abompard: okay, org application deadline's on the 23rd so i was just checking out the project ideas of different orgs. i'll keep an eye out for this one!
13:57:22 <golu> thanks
13:57:41 <abompard> thanks!
13:57:50 <abompard> I didn't realize it was so soon
13:58:12 <golu> haha, apparently it started on thursday
13:58:43 <abompard> thanks for the heads-up goly
13:58:45 <abompard> golu
13:58:49 <golu> :)
13:59:27 <abompard> So, guys, how do you feel about deploying 1.0 on Feb ?
13:59:36 <sayan> +1
14:00:25 <sayan> Update: I will send badges PR end of this week. I've stuck with a packaging issue with the python2-tahrir pacakge
14:00:27 <abompard> sayan: do you have an idea on how we could deploy hubs in our infra ? Maybe using containers ?
14:01:00 <sayan> abompard: I was reading the email to the list, I think about containers too
14:01:11 <ryanlerch> #info there is a thread about deploying hubs recently on the fedora infra mailing list
14:01:22 <abompard> yeah
14:01:45 <sayan> as the rate of which the JS packages changes, a lot of thought needs to be gone
14:02:13 <sayan> mostly on how to handle hotfixing the security issues in the JS packages
14:03:19 <abompard> sayan: right, rebuilding the container with an updated JS package should be easy, and doable by anybody in the team or outside as long as they have the permission
14:03:54 <abompard> and it should not update other packages besides the security fix to avoid a situation where we're either down or insecure
14:03:59 <sayan> I was talking to a person at RH Bangalore office today, he pointed me to look into s2i
14:04:12 <sayan> https://github.com/openshift/source-to-image
14:04:34 <abompard> yeah, openshift would be nice, if we can connect to fedmsg there
14:05:20 <abompard> anyway, meeting is past 5 minutes, anything else to add?
14:05:30 <sayan> Nope
14:05:35 <abompard> OK !
14:05:39 <abompard> #endmeeting