05:00:47 <tagoh> #startmeeting i18n
05:00:47 <zodbot> Meeting started Thu Apr  7 05:00:47 2011 UTC.  The chair is tagoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:00:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:00:51 <tagoh> #meetingname i18n
05:00:51 <zodbot> The meeting name has been set to 'i18n'
05:01:00 <juhp> hi
05:01:02 <tagoh> #topic agenda and roll call
05:01:11 <tagoh> https://fedoraproject.org/wiki/I18N/Meetings/2011-04-07
05:01:22 <tagoh> hi
05:01:24 <dueno> hi
05:01:26 <epico_laptop> hi
05:01:53 <paragan> hi
05:02:08 <pravins> hi
05:03:26 <tagoh> if you have any topics to discuss in this meeting, please add it to wiki :)
05:03:33 <tagoh> anyway, let's get started
05:03:40 <tagoh> #topic F15
05:04:16 <dingyichen> hi
05:04:43 <tagoh> it passed away for beta changes deadline and feature complete. upcoming milestone in current schedule is beta release at 19th of April.
05:05:09 <tagoh> we don't have any beta blockers nor beta nth bugs so far.
05:06:13 * juhp is testing the tty locale bug
05:06:35 <tagoh> suppose there isn't too much things we can do at this point though, good to focus into 0-day updates if any.
05:07:00 <tagoh> of course good to propose a blocker or nth if you find out any critical issues.
05:07:34 <juhp> tagoh: btw did you have a chance to try uim with gnome3?
05:07:47 <tagoh> added a pointer for the blocker bug process and the nth bug process in the dashboard.
05:07:49 <juhp> dunno if anyone has tried scim?
05:07:58 <juhp> thanks
05:08:20 <tagoh> juhp: waiting for upstream now. they are working but some tasks aren't yet finished
05:08:37 <juhp> I see
05:08:43 <juhp> cool
05:09:09 <tagoh> we could simply drop a feature preventing to build so far perhaps
05:10:53 <juhp> btw what is the correct bug state for bugs closed for f15 - NextRelease?
05:11:16 <tagoh> maybe
05:11:21 <juhp> ok
05:13:07 <tagoh> ok, any concerns on f15 so far?
05:14:29 * juhp is currently suffering from no X pointer but otherwise looks good...
05:14:55 <juhp> haven't tested gnome-shell for a while - need to do that for beta certainly
05:15:21 <tagoh> yeah, trying to download beta tc1 for testing now
05:16:02 <paragan> mclasen just respun the F15 desktop spin to resolve missing icon issue
05:16:32 <juhp> aha
05:16:44 <tagoh> paragan: after tc1?
05:17:12 <paragan> not sure. Just got to see this bug https://bugzilla.redhat.com/show_bug.cgi?id=693060
05:17:58 <tagoh> aha
05:19:06 <juhp> without a mouse it seems hard to get out of the desktop menu...
05:19:29 <tagoh> on kvm?
05:19:32 <juhp> anyway guess there will be more bugs to iron out from the beta release
05:19:36 <juhp> tagoh: yes
05:19:52 <tagoh> juhp: aha. let me try later
05:21:02 <juhp> my workaround is Ctrl-Atl-Backspace ;) :)
05:21:20 <tagoh> pravins: any thought on disabling hinting for lohit?
05:21:29 <pravins> tagoh: yeah
05:21:42 <pravins> i have removed hinting of gujarati and devanagari fonts
05:21:57 <tagoh> in new release right?
05:22:07 <pravins> yeah
05:22:19 <pravins> after reading the thread on font list i think there is possibility of options
05:22:59 <pravins> tagoh: do you think we should remove hinting of other fonts as well?
05:23:15 <pravins> or wait for some other options i.e. disabling/enabling autohinter
05:24:00 <tagoh> how about impact on this?
05:24:13 <pravins> impact is major, rendering is not good
05:24:25 <pravins> i think for now i will apply patch and build for fedora
05:24:32 <juhp> pravins: can it be disabled in fontconfig?
05:24:32 <tagoh> if it badly affects to Indic, we should take a workaround for f15 anyway
05:25:27 <pravins> juhp: i think not
05:25:31 <tagoh> otherwise we could wait for fontconfig when they support a feature
05:25:53 <pravins> juhp: there is option of enabling/disabling autohinter in fontconfig
05:26:07 <juhp> doesn't work?
05:26:09 <pravins> tagoh: yeah, that is best options for now i am thinking to patch fedora fonts
05:26:41 <pravins> juhp: we have to disable BCI of freetype
05:27:45 <juhp> pravins: ok - your previous two comments to me seem to contradict?
05:28:02 <pravins> ohh
05:28:11 <juhp> but I haven't followed the discussion...
05:28:18 <pravins> 1) i am thinking to remove hinting instruction from fonts for now
05:28:38 <pravins> 2) i think there is presently no options for disabling freetype BCI hinter
05:28:45 <juhp> pravins: any implications for other distros for (1)?
05:28:53 <juhp> ah
05:29:04 <tagoh> juhp: thought enabling BCI enforces autohinter so far from the discussion on the list
05:29:06 <juhp> got you
05:29:17 <juhp> tagoh: I see
05:29:21 <juhp> hmm
05:29:41 <pravins> juhp: i think if other distros following upstream, then it will also affect
05:29:53 <juhp> guess I was naive to assume that fontconfig would allow disabling hinting per font
05:30:34 <paragan> https://bugzilla.redhat.com/show_bug.cgi?id=547532
05:31:46 <paragan> https://bugzilla.redhat.com/show_bug.cgi?id=679030
05:31:58 <juhp> seems to be a big change anyway
05:32:55 <juhp> pravins: putting my question another way would the new version of the fonts affect older Fedora releases?
05:33:13 <pravins> juhp: no
05:33:17 <juhp> ok good
05:33:42 <tagoh> maybe good to check other langs with BCI
05:33:49 <juhp> yes
05:33:59 <pravins> juhp: but still removing instruction from upstream looks little bit risky for now
05:34:05 <juhp> pravins: nod
05:34:55 <tagoh> pravins: it may takes a cost but would be good to work on branch with/without hinting perhaps?
05:35:07 <pravins> tagoh: hmm, nice option
05:35:18 <tagoh> and apply fixes to both branches
05:35:46 <tagoh> or if there are any easy way to drop hinting at the build time, that would be nicer than maintaining both branches though
05:36:15 <juhp> pravins: hm https://bugzilla.redhat.com/show_bug.cgi?id=679030#c5 suggests it is possible to control BCI per font
05:37:29 <tagoh> #action all to check rendering with enabling BCI on their languages
05:37:53 <paragan> ok
05:37:59 <pravins> juhp: need to try that once
05:38:11 <juhp> ok please
05:38:56 <pravins> kevin says "It can be worked around with a per-font policy using a
05:38:56 <pravins> config file similar to the above, but really, we want the BCI fixed instead."
05:39:20 <tagoh> pravins: please review the blocker/nth process if it's worth proposing for f15. otherwise good to push 0-day updates
05:39:45 <pravins> tagoh: yeah, sure
05:39:59 <tagoh> ok, anything else?
05:40:44 <juhp> pravins: yep just suggesting it is a better workaround than ripping out all the hinting instructions from fonts :)
05:41:25 <tagoh> juhp: yep. if autohinter works fine.
05:41:31 <pravins> juhp: yeah agree :), me too thinking same (just was thinking will apply patch for removing hinting instruction)
05:42:08 <tagoh> shall we move on then?
05:42:16 <juhp> sure :)
05:42:21 <tagoh> #topic Package Updates
05:42:27 <pravins> juhp: tagoh  thanks, will try that today :)
05:42:43 <tagoh> pravins: cool
05:42:53 <tagoh> anything on updates?
05:44:52 <tagoh> if not, let's move on
05:45:07 <tagoh> #topic Input Methods
05:46:14 <tagoh> any news or updates on IM?
05:46:50 <tagoh> 31 bugs are open btw
05:47:21 <dingyichen> I reproduced the one that ktakemur san found, working on it, now.
05:47:49 <tagoh> dingyichen: bug#?
05:49:07 <dingyichen> tagoh: [Bug 682650] ibus(-chewing) gets broken after hitting space key multiple times.
05:49:07 <tagoh> fujiwarat: do you have any on ibus?
05:49:38 <tagoh> dingyichen: aha
05:49:49 <fujiwarat> ah, ibus and gnome-shell are integrated into f15 for the panel icon. I think it's ok.
05:50:38 <tagoh> fujiwarat: cool
05:50:50 <fujiwarat> However today I noticed preedit string might be strange in the latest f15. will double check it later.
05:51:19 <tagoh> aha
05:53:31 <tagoh> epico_laptop: how about ibus-pinyin?
05:54:02 <epico_laptop> tagoh: pardon?
05:54:43 <tagoh> any progress on reproducing abrt bugs say?
05:54:55 <epico_laptop> I will try it later today.
05:55:03 <tagoh> ok
05:55:13 <juhp> hmm about half the im bugs seem to be from abrt
05:55:30 <juhp> at least gucharmap seems to have stopped crashing in f15 :)
05:55:30 <tagoh> right
05:55:57 <juhp> before I had a chance to file an abrt bug ;)
05:57:29 <tagoh> maybe need to catch up nkumar later for ibus-indic-table
05:57:39 <tagoh> anyway, better move on
05:57:48 <tagoh> #topic Fonts and Rendering
05:58:00 <juhp> pravins: are you looking at any of the ibus-indic-table bugs?
05:58:23 <pravins> juhp: i was thinking but looks will not get time for same :(
05:58:34 <juhp> okay
05:58:58 <tagoh> 43 fonts bugs and 27 rendering bugs are open now
06:03:00 <tagoh> trying to update motoya-l{maru,cedar}-fonts for new release, also asking upstream for messing up latin-1 supplement on them
06:04:57 <juhp> .bug 677865
06:04:58 <zodbot> juhp: Bug 677865 Menu Fonts Look Poor - https://bugzilla.redhat.com/show_bug.cgi?id=677865
06:05:10 <juhp> looks like another complaint about the hinting
06:06:02 <tagoh> thought it's irrelevant. it's the order issue on conf files?
06:08:58 <tagoh> .bug 676253
06:09:01 <zodbot> tagoh: Bug 676253 [abattis-cantarell-fonts] causes tiny characters of desktop fonts - https://bugzilla.redhat.com/show_bug.cgi?id=676253
06:09:04 <tagoh> should be dup of that
06:09:15 <juhp> aha
06:11:05 <tagoh> will check later if it happens on beta.tc1
06:11:27 <tagoh> ok, anything else on fonts/rendering?
06:11:52 <juhp> cool
06:14:07 <tagoh> ok, let's stop the meeting here then.
06:14:15 <tagoh> thanks everyone for the meeting!
06:14:22 <tagoh> #endmeeting