16:10:04 <x3mboy> #startmeeting Fedora i3 SIG
16:10:04 <zodbot> Meeting started Tue Jun  9 16:10:04 2020 UTC.
16:10:04 <zodbot> This meeting is logged and archived in a public location.
16:10:04 <zodbot> The chair is x3mboy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:10:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:10:04 <zodbot> The meeting name has been set to 'fedora_i3_sig'
16:10:08 <x3mboy> Oh cool
16:10:15 <nasirhm> .fasinfo nasirhm
16:10:16 <zodbot> nasirhm: User: nasirhm, Name: Nasir Hussain, email: nasirhussainm14@gmail.com, Creation: 2019-11-25, IRC Nick: nasirhm, Timezone: Asia/Karachi, Locale: en, GPG key ID: D8126E559CE7C35D, Status: active
16:10:19 <zodbot> nasirhm: Approved Groups: fedora-join cla_fpca cla_done advocates google-codein qa fedorabugs i3-sig
16:10:32 <x3mboy> #meetingname i3-sig
16:10:32 <zodbot> The meeting name has been set to 'i3-sig'
16:10:37 <nasirhm> I see alot of ideas being brainstormed here: https://fedoraproject.org/wiki/SIGs/i3/Brainstorm
16:10:37 <x3mboy> #topic Agenda
16:10:42 <x3mboy> #info (1) Roll call
16:10:54 <x3mboy> #info (2) Follow Ideas
16:11:02 <x3mboy> #info (4) Open Floor
16:11:12 <x3mboy> #undo
16:11:12 <zodbot> Removing item from minutes: INFO by x3mboy at 16:11:02 : (4) Open Floor
16:11:21 <x3mboy> #info (3) Open Floor
16:11:27 <x3mboy> #topic Roll call
16:11:30 <x3mboy> .hello2
16:11:31 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
16:11:40 <x3mboy> #chair nasirhm
16:11:40 <zodbot> Current chairs: nasirhm x3mboy
16:11:42 <x3mboy> #chair siddharthvipul
16:11:42 <zodbot> Current chairs: nasirhm siddharthvipul x3mboy
16:11:45 <x3mboy> #chair Defolos_
16:11:46 <zodbot> Current chairs: Defolos_ nasirhm siddharthvipul x3mboy
16:12:04 <x3mboy> Well, I think we continue with the package selection
16:12:17 <x3mboy> #topic Follow Ideas
16:12:57 <nasirhm> https://fedoraproject.org/wiki/SIGs/i3/Brainstorm
16:12:57 <nasirhm> on nm-applet, i think it deserves a place in the i3-extended group
16:13:00 * jwf is half here
16:13:18 <nasirhm> #chair jwf
16:13:18 <zodbot> Current chairs: Defolos_ jwf nasirhm siddharthvipul x3mboy
16:13:23 <x3mboy> #chair jwf
16:13:23 <zodbot> Current chairs: Defolos_ jwf nasirhm siddharthvipul x3mboy
16:13:24 <Defolos_> I agree with that
16:13:40 * aegorenk is here
16:13:47 <x3mboy> #chair aegorenk
16:13:47 <zodbot> Current chairs: Defolos_ aegorenk jwf nasirhm siddharthvipul x3mboy
16:13:56 <nasirhm> he aegorenk
16:14:11 <x3mboy> I put some menu suggestion
16:14:13 <nasirhm> hey*
16:14:50 <siddharthvipul> dmenu by default?
16:15:32 <siddharthvipul> rofi is nice, and I am sure you call do all the scripts and stuff with rofi as well, but dmenu is damn cool after a bit of playing
16:16:37 <Defolos_> dmenu is afaik recommended by i3 itself anyway
16:16:51 <Defolos_> so it should be there by default in the base group
16:17:01 <Defolos_> the extended group can use rofi
16:17:21 * nasirhm likes tools by suckless
16:18:13 <tjzabel> I prefer rofi, but yes dmenu is recommended by i3, and is generally bundled with i3
16:18:15 <jwf> I can't imagine i3 without dmenu
16:18:47 <nasirhm> dmenu++
16:19:05 <siddharthvipul> as already mentioned, dmenu by default (my vote)
16:19:19 <tjzabel> yep, that sounds good
16:19:31 <siddharthvipul> tjzabel: hey \o
16:19:37 <x3mboy> Well, I have dmenu and dmenu-desktop
16:19:46 <x3mboy> #chair tjzabel
16:19:46 <zodbot> Current chairs: Defolos_ aegorenk jwf nasirhm siddharthvipul tjzabel x3mboy
16:19:47 <tjzabel> hiya
16:20:15 <nasirhm> On Virtual Terminal, How about adding `st` ?
16:20:37 <tjzabel> another suckless tool ;)
16:20:42 <siddharthvipul> ummmm, as much as I appreciated it.. mmmm
16:20:58 <aegorenk> hey nasirhm
16:21:03 <siddharthvipul> well, sure! I don't have any problem.. :(
16:21:38 <nasirhm> hehehe, i just switched to some suckless tools now, i prefer them now over some fancy ones.
16:21:46 <Defolos_> nasirhm: it's already there
16:21:48 <x3mboy> What about alacritty?
16:21:50 <tjzabel> rxvt terminal is I think the default for many
16:21:57 <siddharthvipul> I like alacritty, a bit heacy
16:21:59 <siddharthvipul> heavy*
16:22:13 <Defolos_> alacritty is nice but would have to be packaged first
16:22:19 <nasirhm> tjzabel: `rxvt` is the default i think, that came with i3.
16:22:25 <siddharthvipul> yes, rxvt is what they share in default, we can go with that
16:23:15 <nasirhm> on `alacritty`, It's already packaged on COPR
16:23:45 <Defolos_> alacritty has one big disadvantage though: I get terrible screen tearing with it on Xorg (although that is on openSUSE)
16:23:52 <nasirhm> here it is: https://copr.fedorainfracloud.org/coprs/pschyska/alacritty/
16:23:56 <Defolos_> nasirhm: copr is a nogo for a spin
16:24:39 <siddharthvipul> I would actually prefer rxvt, light and by default, not a lot of work
16:25:00 <siddharthvipul> and if interested, people can always download others.. I think only necessary things should be shipped by default
16:25:12 <nasirhm> Defolos_: Makes sense.
16:25:50 <Defolos_> I'd say rxvt-unicode or rxvt for the base (st has the disadvantage of no scrollback) and maybe put st and alacritty into extended?
16:26:44 <jwf> $ rpm -qf /usr/bin/i3-sensible-terminal
16:26:45 <jwf> i3-4.18.1-1.fc32.x86_64
16:26:52 <tjzabel> rxvt-unicode i am in favor of
16:27:02 <jwf> I think we should stick with i3-sensible-terminal as a default terminal since it is already bundled with i3
16:27:02 <nasirhm> Defolos_: I agree with rxvt-unicode.
16:27:12 <jwf> Advanced users will have infinite opinions on terminals
16:27:27 <nasirhm> jwf: It's urxvt
16:27:29 <jwf> So, might as well ship less by using the default that we already have in the i3 package
16:27:31 <jwf> D'oh
16:27:40 <jwf> I just knew the path :-)
16:27:54 <siddharthvipul> default ++ :)
16:27:59 <tjzabel> yeah i believe it's the same thing
16:28:03 <Defolos_> jwf: i3-sensible-terminal is a script that calls the first terminal it finds
16:28:08 <Defolos_> it's not actually a terminal
16:28:16 <siddharthvipul> yeah, defined in config
16:28:20 <Defolos_> cat $(which i3-sensible-terminal)
16:29:01 <nasirhm> Defolos_: Yeah, it fetches that from the config.
16:29:21 <jwf> Today I learned
16:29:24 <jwf> Defolos++
16:29:24 <zodbot> jwf: Karma for defolos changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:30:19 <nasirhm> This is the list from which it gets: `x-terminal-emulator urxvt rxvt termit terminator Eterm aterm uxterm xterm gnome-terminal roxterm xfce4-terminal termite lxterminal mate-terminal terminology st qterminal lilyterm tilix terminix konsole kitty guake tilda alacritty hyper`
16:30:38 <siddharthvipul> nasirhm: lol, that doesn't matter :P
16:31:16 <jwf> I second siddharthvipul's earlier proposal
16:31:29 <nasirhm> default++ everyone?
16:31:29 <jwf> We could put it to a +1/0/-1 vote if we are ready?
16:31:39 <jwf> Maybe we can mark some of these with #agreed
16:31:56 <aegorenk> +1
16:32:08 <nasirhm> +1 for urxvt
16:32:13 <siddharthvipul> +1 to justin's agreement to me agreeing to tjzabel and Defolos_ haha
16:32:14 <tjzabel> +1 to rxvt-unicode
16:32:24 <tjzabel> (aka urxvt)
16:33:07 <Defolos_> +1 to urxvt in base
16:33:10 <nasirhm> `uxrvt` it is.
16:33:38 <nasirhm> i guess one vote left x3mboy , your thoughts?
16:33:42 <siddharthvipul> urxvt then, x3mboy, ship it?
16:34:07 <jwf> +1 urxvt
16:34:31 <jwf> siddharthvipul: Hahah I had to re-read scrollback to realize I repeated basically the same thing you said
16:34:44 * jwf is still sleepy…
16:34:49 <x3mboy> -1 urxvt
16:34:51 <siddharthvipul> oh not at all, I didn't mean to say it in a bad way
16:34:59 <x3mboy> Is awful
16:35:06 <x3mboy> I will prefer xterm
16:37:03 * jwf hasn't tried xterm but also acknowledges that I find urxvt not beautiful :P
16:37:18 <nasirhm> I would suggest sticking with defaults for the minimal one and with the extended we can include x-term and others
16:37:30 <tjzabel> like other things, urxvt can be customized to look very nice. But as far as defaults, I think it is the best option
16:37:30 <jwf> You know... I guess the terminal is the first impression we will make to any i3 user though...
16:37:31 <x3mboy> I suggest testing with emoji-test
16:37:36 <x3mboy> #link https://unicode.org/Public/emoji/11.0/emoji-test.txt
16:37:39 <tjzabel> Because naturally, you can easily change your default terminal once installed
16:37:48 <nasirhm> jwf: try it with `urxvt -fg white -bg black` ans it's beautiful :P
16:37:48 <siddharthvipul> I don't/won't use urxvt, but I am in favor because default.. shipping other also means we expect others to think to use that.. and there are so many options
16:38:17 <jwf> nasirhm: It doesn't work with my Powerline prompt :( https://github.com/justjanne/powerline-go
16:38:22 <nasirhm> <tjzabel "Because naturally, you can easil"> I agree here,.
16:38:43 <Defolos_> the minimal config is intended to be more for the power user that just wants everything essential
16:38:55 <tjzabel> jwf: IIRC powerline works a little differently for some reason, but I forget what the fix was/is for that
16:39:01 <Defolos_> we can ship something fancy in extended, which is for the beginner that wants cool looks ;-)
16:39:02 <tjzabel> Defolos_: agreed
16:39:16 <jwf> $ dnf info xterm
16:39:17 <jwf> Name         : xterm
16:39:17 <jwf> Size         : 596 k
16:39:18 * nasirhm > <@freenode_jwf:matrix.org> nasirhm: It doesn't work with my Powerline prompt :( https://github.com/justjanne/powerline-go
16:39:18 * nasirhm finds it interesting and thinking to play with it with fish
16:39:51 <aegorenk> urxvt is customizable. we can include nice fonts, hide borders and it'll look good
16:40:12 <nasirhm> aegorenk: Agreed.
16:40:23 <aegorenk> and ofcourse black bg and white fg
16:41:11 <nasirhm> aegorenk: hehehe, the white background sucks, just discovered how customizable urxvt is.
16:41:39 <x3mboy> But still no good unicode support without plugins
16:42:12 <tjzabel> the default configurations of urxvt are meant to be tweaked
16:42:19 <nasirhm> on xterm, it's 619 KBs, it depends on `xterm-resize`
16:42:20 <aegorenk> nasirhm: my is a little bit transparent, I like it :)
16:43:30 <tjzabel> However, we've all voted, so are we in agreement on urxvt with majority vote?
16:43:30 <nasirhm> tjzabel: yep, most of tools like `urxvt` are meant to be tweaked by powerusers.
16:43:48 <nasirhm> aegorenk: you use `rxvt`?
16:44:07 <x3mboy> I think so
16:44:13 <aegorenk> nasirhm: Urxvt
16:44:27 * nasirhm updated the wiki page from `st` to `urxvt`
16:44:58 <nasirhm> aegorenk: Ah, unicode support is a must in today's time.
16:45:01 <x3mboy> #agreed terminal emulator by default `urxvt` +1: 6, -1: 1
16:45:29 <aegorenk> nasirhm: actually I don't know if there is big difference other than unicode
16:45:46 <nasirhm> On Display manager, what do you guys think, which one we should use ?
16:46:06 <x3mboy> aegorenk, I think the plugin support
16:46:33 <aegorenk> I use "startx" :)
16:46:45 <Defolos_> aegorenk: upstream says you should no longer do that
16:47:02 <Defolos_> lightdm into extended, none into base as it still works with startx
16:47:11 <Defolos_> (my opinion on that)
16:47:33 <x3mboy> sddm
16:47:35 <x3mboy> ?
16:47:53 <nasirhm> i suggested `lightdm-gtk` on Brainstorm page, i wasn't able to find a lightweight one than it
16:47:54 <x3mboy> Probably too many qt dependencies
16:49:26 <x3mboy> nasirhm: tdm, cdm, ly
16:49:28 <nasirhm> x3mboy: which one, `lightdm` or `sddm` ?
16:49:48 <x3mboy> Also, I really like tbsm
16:50:16 <x3mboy> #link https://loh-tar.github.io/tbsm/
16:50:43 <tjzabel> I think we should use widely-used and known options for the display manager
16:50:56 <nasirhm> x3mboy: Does it initiate the X Session too?
16:51:07 <x3mboy> AFAIK yes
16:51:16 <x3mboy> I haven't try it in decades
16:51:22 <aegorenk> tjzabel: Agreed
16:51:23 <x3mboy> tjzabel, me too
16:51:40 <x3mboy> I prefer lightdm, but sddm was worth trying
16:52:10 <tjzabel> lightdm I generally see
16:52:11 <nasirhm> x3mboy: I think it's more of a Terminal Based Session Manager than Display Manager ?
16:52:42 <nasirhm> I used sddm sometime ago but now back to lightdm.
16:55:02 <nasirhm> Guys, i think let's take votes on `lightdm` now?
16:55:03 <nasirhm> I'm +1 to it.
16:56:00 <aegorenk> 0 since I don't have an expertise
16:56:18 <Defolos_> +1 on ligthdm, I'm actually using it
16:56:55 <tjzabel> +1 to lightdm
16:56:56 <tjzabel> am also using it
16:57:44 <Defolos_> jfyi: https://github.com/i3/i3/issues/3863#issuecomment-552820516
17:00:25 <nasirhm> Defolos_: It takes 2 tries with startx :P
17:00:56 <x3mboy> +1 on lightdm
17:02:18 <Defolos_> nasirhm: don't ask, I switched to lightdm and shut my mouth because I have zero patience for debugging driver related stuff…
17:02:19 <x3mboy> sddm is 3.2 MB???
17:02:21 <x3mboy> Why???
17:03:22 <nasirhm> <Defolos_ "nasirhm: don't ask, I switched t"> hehehe, I somewhere like working on it but only on weekends :D
17:03:53 <nasirhm> I am wondering what's the display manager `KDE` uses?
17:04:11 <Defolos_> kwin
17:04:38 <x3mboy> nasirhm, sddm
17:04:55 <x3mboy> Also it was discussed a few days ago in the telegram group
17:05:11 <x3mboy> They move from kdm to sddm because of Fedora
17:05:15 <x3mboy> :D
17:05:19 <nasirhm> x3mboy: which one ?
17:05:42 <x3mboy> I voted to lightdm
17:05:43 <nasirhm> * x3mboy: which telegram group ?
17:05:53 <x3mboy> Oh, @fedora
17:06:00 <x3mboy> The international group
17:06:09 <aegorenk> most votes was for lightdm, so let's stick with it
17:06:15 <x3mboy> Also, KDE recommends sddm
17:06:33 <nasirhm> lightdm is on the wiki page.
17:06:39 * nasirhm is going off to eat
17:06:59 <nasirhm> Have a good day/night folks :D
17:07:00 <aegorenk> nasirhm: bon appetit
17:07:12 <x3mboy> #agreed Display Manager by default `lightdm` +1: 4, -1: 0
17:07:26 <Defolos_> nasirhm: enjoy!
17:07:26 <x3mboy> I will close, we passed the timeline
17:07:33 <aegorenk> One question, I think related to the package choice
17:07:37 <x3mboy> Thanks everyone for coming
17:07:40 <x3mboy> aegorenk, ask it
17:07:50 <x3mboy> #topic Open Floor
17:08:06 <aegorenk> When I installed regular Fedora KDE spin my WiFi was warking out of the box . When I installed minimal server and i3 on top of that, I had to install some HW specific packages to make it work. So question is will we face the same problem? How it's handled in KDE spin for example?
17:08:38 <x3mboy> Well, minimal server is intended for servers
17:08:55 <x3mboy> So, it probably doesn't include wifi drivers
17:09:45 <x3mboy> Because we are doing a Spin, intended for desktop, power user desktops, the default driver packages that comes with any fedora (Workstation or spin) should be in
17:10:26 <aegorenk> x3mboy: yes, but how kickstart/anaconda (not sure when it happens) determine that I have a particular HW, so I need this particular HW related packages and installs exactly them, not something else.
17:11:05 <x3mboy> aegorenk, oh, that's out of my knowledge
17:11:20 <x3mboy> Defolos_, any idea?
17:11:39 <x3mboy> I know lupinix can answer or give us clue, but is not here today
17:12:55 <Defolos_> x3mboy: unfortunately none at all, I re-install my machines very rarely ;-)
17:13:18 <Defolos_> I'd guess we have to ask someone from the Workstation SIG or maybe QA
17:13:52 <x3mboy> aegorenk, open an issue in our tracker to ask, please
17:13:54 <x3mboy> Can you?
17:14:11 <aegorenk> x3mboy: sure, I'll do
17:14:23 <x3mboy> #action aegorenk will open a ticket to know how and where the HW selection happens to install drivers
17:14:32 <x3mboy> Ok, we are ready to close then
17:14:37 <x3mboy> #endmeeting