16:06:31 <nasirhm> #startmeeting Fedora i3 (2020-08-18)
16:06:31 <zodbot> Meeting started Tue Aug 18 16:06:31 2020 UTC.
16:06:31 <zodbot> This meeting is logged and archived in a public location.
16:06:31 <zodbot> The chair is nasirhm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:06:31 <zodbot> The meeting name has been set to 'fedora_i3_(2020-08-18)'
16:06:46 <nasirhm> #meetingname i3
16:06:46 <zodbot> The meeting name has been set to 'i3'
16:06:58 <nasirhm> #topic roll call
16:07:03 <nasirhm> .hello2
16:07:03 <zodbot> nasirhm: nasirhm 'Nasir Hussain' <nasirhussainm14@gmail.com>
16:07:25 <defolos> .hello2
16:07:26 <zodbot> defolos: defolos 'Dan Čermák' <dan.cermak@cgc-instruments.com>
16:08:25 <x3mboy[m]> .hello2
16:08:26 <zodbot> x3mboy[m]: Sorry, but you don't exist
16:08:32 <x3mboy> .hello2
16:08:33 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
16:08:46 <x3mboy> nasirhm, yes, I'm in a videocall
16:08:56 <x3mboy> It was last minute call, sorry
16:09:48 <nasirhm> x3mboy: No worries, It's good to have you here. You can chair once you're free from the call.
16:10:03 <nasirhm> #chair jwf defolos x3mboy
16:10:03 <zodbot> Current chairs: defolos jwf nasirhm x3mboy
16:10:13 * jwf waves
16:10:42 <nasirhm> #topic Action items from last meeting
16:11:58 <nasirhm> defolos: defolos will be working with QA to initialize OpenQA tests for the i3 spin.
16:12:46 <defolos> unfortunately no real progress on that part, as I've been under the weather for most of last week
16:13:01 <defolos> and when I wasn't, I was working on opam2rpm
16:14:17 <nasirhm> defolos: Get well soon, opan2rpm sounds interesting. I love the 2rpm tools (Makes the packaging experience whole lot easier)
16:14:33 <nasirhm> nasirhm to go through the workstation ks file to find changes and discuss them in next week's meeting.
16:15:08 <nasirhm> Unfortunately I wasn't able to go through the Workstation ks to find the chages due to some workload.
16:15:15 <nasirhm> nasirhm to add to the meeting template to the i3wm docs.
16:15:30 <nasirhm> PR up for review: https://pagure.io/i3-sig/docs/pull-request/2
16:15:33 <nasirhm> #link https://pagure.io/i3-sig/docs/pull-request/2
16:15:55 <nasirhm> #topic Follow up on bcotton's response for the Spin proposal
16:16:09 <nasirhm> #link https://pagure.io/i3-sig/Fedora-i3-Spin/issue/11
16:17:09 <nasirhm> x3mboy: Your feedback and suggestions
16:17:50 <x3mboy> I think the last feedback was mine
16:18:10 <x3mboy> That can be closed, but we need to check both links there
16:18:20 <x3mboy> #link https://fedoraproject.org/wiki/Spins_Process
16:18:38 <x3mboy> #link https://fedoraproject.org/wiki/Spins_Guidelines
16:19:29 <nasirhm> x3mboy++ Thank you for working on it
16:19:34 <nasirhm> Good to close ?
16:20:05 <x3mboy> Sure
16:20:28 <nasirhm> Done
16:20:46 <nasirhm> #topic Breaking the Kickstart file into different parts to include fedora-base.ks
16:22:24 <nasirhm> As defined in the Guidelines, we have to include fedora-live-*.ks in our Kickstart file and hence requires us to finalize the Flattened ks and then break it into different files similar to other spins.
16:24:59 <nasirhm> We need to finalize the Flattened Kickstart to break it in different files and initiate the work on the Proposal
16:25:22 <nasirhm> #topic Goals for the next respin to move forward with the proposal
16:25:33 <nasirhm> #link https://fedoraproject.org/wiki/SIGs/i3/SpinChangeProposal_Draft
16:26:25 <nasirhm> The next respin will be in 2 weeks, do we need anything that needs to be fixed/added/removed in the ks for the next respin ?
16:27:15 <defolos> where's ben when you need him?
16:27:39 <nasirhm> defolos: In the -respins SIG channel  :)
16:27:47 <x3mboy> I would like to test mousepad
16:27:54 <x3mboy> To try it against gedit
16:28:01 <nasirhm> x3mboy: Touchpad ?
16:28:08 <x3mboy> It looks like a popular choice among i3 users
16:28:21 <x3mboy> nasirhm, no, mousepad it's a text editor
16:28:38 <nasirhm> x3mboy: Oops, my bad
16:28:58 <nasirhm> is it packaged for Fedora ?
16:29:50 <defolos> that's literally the worst name for a text editor that you can choose…
16:30:13 <x3mboy> Yes, it is packaged, and yes, the name is aweful
16:30:35 <nasirhm> #info Assessment of Mousepad on i3 and discuss in the next meeting to use it in place of gedit
16:30:36 <x3mboy> But it's super minimal, and I was gathering feedback and so much users prefer it over gedit
16:30:40 <nasirhm> #link https://src.fedoraproject.org/rpms/mousepad
16:31:27 <x3mboy> TBH I don't care, I still use vim, but it's in the recommended packages I got from RH, and tons of i3 users like it
16:31:46 <defolos> the i3 author still codes in emacs 😛
16:31:55 <x3mboy> Including Manjaro i3 community edition and regolith
16:32:07 <x3mboy> defolos, in the emacs OS???
16:32:09 <x3mboy> :-P
16:32:20 <defolos> well, maybe we should go with the flow then?
16:32:46 <x3mboy> If it's gtk, it's ok with me
16:32:47 <x3mboy> :D
16:33:10 <jwf> x3mboy: I think feedback from users is a helpful indicator
16:33:14 <nasirhm> #action x3mboy to assess mousepad and discuss about it in the next meeting to add it in place of gedit
16:33:26 <x3mboy> Cool
16:33:43 <x3mboy> jwf, agreed, that's why I'm bringing this up
16:33:45 <x3mboy> :D
16:34:11 <nasirhm> Hmm, I think we can learn alot of different distros who're doing something similar.
16:34:46 <x3mboy> nasirhm, yes, that's why I'm testing both Manjaro and regolith
16:35:04 <defolos> x3mboy: great idea 👍️
16:35:17 <nasirhm> x3mboy+++++++
16:35:27 <jwf> Sounds good to me :)
16:36:03 <nasirhm> Anything else anyone would like to add ?
16:36:40 <x3mboy> Remember always to look at the following link
16:36:42 <x3mboy> #link https://pagure.io/i3-sig/Fedora-i3-Spin/blob/master/f/Ideas.md
16:36:52 <x3mboy> Yes, I have another topic
16:37:01 <x3mboy> About the email mattdm sent to all spins
16:38:17 <jwf> x3mboy: Oh we should get that in the docs site
16:38:27 <jwf> If someone can open a ticket for me, I could do that...
16:38:44 <x3mboy> #link https://lists.fedoraproject.org/archives/list/spins@lists.fedoraproject.org/thread/FGGSHMI2BWQUD627Y64OIYEVE3DGARNF/
16:39:01 <x3mboy> jwf, a ticket in docs or in our tracker
16:39:03 <x3mboy> ?
16:39:12 <jwf> Issue tracker since that is where we look most often
16:39:20 <jwf> Not docs repo
16:40:08 <defolos> anyone has a tl;dr;?
16:40:30 <nasirhm> I have the same question as defolos
16:42:15 <x3mboy> Ok, cool!
16:42:59 <x3mboy> defolos, nasirhm, we need to set "VARIANT and VARIANT_ID in /etc/os-release"
16:43:10 <nasirhm> Ah, Got it.
16:43:19 <defolos> sounds easy enough?
16:43:28 <nasirhm> defolos: It is
16:43:33 <nasirhm> I will take care of it. :)
16:43:38 <x3mboy> #link https://src.fedoraproject.org/rpms/fedora-release/blob/master/f/fedora-release.spec
16:43:42 <defolos> nasirhm: ++
16:43:49 <x3mboy> We need to ask releng
16:43:54 <nasirhm> #action nasirhm to set VARIANT and VARIANT_ID in /etc/os-release
16:44:49 <x3mboy> Remember the spec I share
16:44:53 <x3mboy> And I need to run again
16:45:09 <x3mboy> Bye guys, sorry but I'm having a hard work day
16:45:13 <nasirhm> Thank You x3mboy
16:45:43 <nasirhm> Good to open floor ?
16:45:55 * defolos nods
16:46:06 <nasirhm> #topic Open Floor
16:46:12 <nasirhm> Nothing from my side
16:46:44 <defolos> nothing from me as well
16:46:56 <defolos> I'll try to takle openQA soon-ish
16:47:23 <nasirhm> <defolos "I'll try to takle openQA soon-is"> Once the Ks is finalized, I will try my best to provide you a hand with OpenQA :)
16:47:39 <nasirhm> jwf anything you would like to add ?
16:47:58 <defolos> <nasirhm "Once the Ks is finalized, I will"> you're gonna love perl 😛
16:48:29 <jwf> Nothing from me right now. I am mostly dormant outside of the docs and once we are ready to draft the Change proposal
16:48:47 <jwf> I will be more hands-on again for the Change proposal, when we are ready :)
16:49:16 <nasirhm> defolos: I bet :D
16:49:20 <jwf> I also need to split. Have another work meeting block of meetings for 3 hours, gonna get a quick bite to eat before I am stuck in Zoom :D
16:49:26 <jwf> nasirhm: Thanks for chairing and driving today!
16:49:42 <nasirhm> Thank You everyone for joining today.
16:49:44 <nasirhm> #endmeeting