20:59:53 <smooge> #startmeeting infrastructure2
20:59:53 <zodbot> Meeting started Thu Feb 17 20:59:53 2011 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:23 <zodbot> CodeBlock: Error: Can't start another meeting, one is in progress.
21:00:25 <CodeBlock> meh
21:00:26 <CodeBlock> ok
21:00:31 <CodeBlock> well then
21:00:32 <smooge> #meetingname infrastructure
21:00:32 <zodbot> The meeting name has been set to 'infrastructure'
21:01:10 <abadger1999> Probably better to either use #fedora-admin or #fedora-meeting-X for future meetings, though.
21:01:12 <CodeBlock> ok so
21:01:21 * skvidal doesn't care
21:01:23 <ricky> anyway, what did averi want to discuss - wordpress?
21:01:30 <ricky> And killing it?  :-)
21:01:32 <skvidal> ricky: mailing lists, I think
21:01:35 <ricky> Ah, that too.
21:01:41 <smooge> #chair skvidal jds2001
21:01:41 <zodbot> Current chairs: jds2001 skvidal smooge
21:01:41 <averi> both blog's future and mailing lists
21:01:52 <smooge> #topic Blogs
21:02:14 <averi> I think we have two possibilities at the moment for blogs:
21:02:45 <averi> 1. update them to something newer avoiding security issues with wordpress-mu being so old
21:02:55 <averi> 2. remove everything and say goodbye to blogs.fp.o
21:03:03 <ricky> I thought we already all agreed on 2 :-/
21:03:21 <smooge> 3. get blogs on wordpress and have blogs.fp.o redirect to those
21:03:22 <sijis> i thought so too
21:03:33 <ricky> Or more specifically, 3
21:03:44 <averi> smooge, exactly, forgot that point
21:04:00 <smooge> I believe we agreed to pursue 3.
21:04:01 <smooge> however
21:04:13 <smooge> as I have learned this week, communication is important
21:04:22 <smooge> so until it is communicated, it isn't happening
21:04:53 * ricky has been busy last week or two, but will have time to start that end of this week, hopefully.
21:04:53 <CodeBlock> What needs to take place to communicate it?
21:04:54 <smooge> we are in the research phase of it.. so what is the research point for costs and such
21:05:12 <ricky> One thing.
21:05:14 <smooge> We need to let the people on blogs know, we need to let the marketing and other groups using it know
21:05:21 <ricky> Do we think we're at the point where it's reasonable to disable new signups?
21:05:32 <smooge> we need to let the board know.
21:05:37 <ricky> I don't want to have to deal with another 20 blogs just because we tok a long time to get this done
21:05:41 <ricky> *sigh*
21:05:41 <skvidal> ricky: yes
21:05:45 <jds2001> why does the board need to know?
21:05:46 <ricky> Why must everything be a "ask the board" nowadays?
21:05:47 <ricky> Seriously.
21:05:56 <ricky> We run this, and we don't have the resources to run this.
21:06:02 <smooge> because the board has a blog on it
21:06:05 <jds2001> ricky: +1
21:06:13 <ricky> OK, then replcae "the board" with "all users" please
21:06:16 <jds2001> oh, well, they're just another user :)
21:06:16 <sijis> based on the numbers i saw a copule of weeks ago.. a couple more signups won't matter much
21:06:26 <smooge> and I am not going to have a shitfest again with the tx transition
21:06:40 <ricky> sijis: Yeah, I just don't want somebody to start relying on the service and then we kind of screw them over a week later
21:06:46 <CodeBlock> We already agreed on it happening. I say kill signups.
21:07:02 <CodeBlock> s/it happening/the move to wp.c/
21:07:20 <sijis> i actually think we shouldn't redirect from blogs.fp.o -> wp.com. not sure what that will do
21:07:36 <sijis> so you kill signups and existing folks have time to migrate (or we do it) over
21:07:36 <ricky> I still wouldn't call that a shitfest (although the timeframe we have for transifex was particularly tight, which means stuff got rushed, yes)
21:07:36 <skvidal> huh?
21:08:39 <ricky> I think it'd be reasonable to put in blog-specific redirects for some period of time for people who request them.
21:08:40 <abadger1999> +1 to kill signups.
21:08:49 <skvidal> +1 to kill signups
21:09:01 <smooge> +1 to kill signups.
21:09:25 <jds2001> +1 to kill signups
21:09:30 <sijis> if we do redirect from blogs.fp.o.. for how long then?
21:09:32 <CodeBlock> +1 to kill signups.
21:09:51 <jds2001> sijis: thats a very low maintainence thing
21:09:52 <smooge> sijis, redirection will be dependent on how it is done
21:10:36 <jds2001> if we just do it with rewriterules (not sure that's feasible or not), then it can just stay there....
21:10:58 <sijis> my only thing with redirects is that it doesn't force folks to change things. we have redirects here that are years old and its only a temp thing but folks are things pointing to old location
21:11:11 <skvidal> sijis: yes, and?
21:11:13 <sijis> (just ranting a bit.. sorry)
21:11:35 <ricky> That's a good reason to set a time limit
21:11:58 <smooge> sijis, websites are like linux api's
21:12:40 <smooge> I feel your pain.. I had to redirect for 4 different RH websites at one point
21:12:51 <CodeBlock> hmm
21:12:52 <smooge> I think the config file was mostly redirects
21:12:55 <smooge> anyway.
21:13:29 * sijis can disable the blogs registration right now
21:13:33 <smooge> we have moved that we will kill signups to the blog.
21:13:45 <ricky> sijis: Great, thanks1
21:13:48 <smooge> so go ahead. if I get blowback I will let you know
21:13:49 <CodeBlock> #agreed willing blog signups in preparation for move to wp.c
21:13:55 * CodeBlock wonders if he needs to be a chair to do #agreed
21:14:07 <CodeBlock> and killing* not willing
21:14:08 * CodeBlock failed that up
21:14:13 <CodeBlock> *anyway*
21:14:20 * sijis registrations disabled
21:14:46 <sijis> i'm not sure if we #startedmeeting
21:14:50 <CodeBlock> in that case
21:15:04 <CodeBlock> #action sijis killed blog registration in preparation for move to wp.c
21:15:08 <CodeBlock> ;D
21:15:19 <CodeBlock> sijis: yeah, I think smooge did
21:15:33 <CodeBlock> because he added a few chairs above
21:15:34 <averi> we can't start another meeting, one is running already
21:15:47 <CodeBlock> ok so what else
21:15:54 <CodeBlock> #topic hosted mailing list pruning
21:16:11 <averi> I gave a look at the hosted mailing list and http://averi.fedorapeople.org/inactive_lists.hosted.txt
21:16:11 * CodeBlock isn't a chair, and zodbot isn't op'd and the channel is +t so that is completely pointless. BUT ANYWAY.
21:16:38 <smooge> #action sijis killed blog registration in preparation for move to wp.c
21:16:41 <averi> I've found out dozens of lists are unused and inactive since some time now
21:16:44 <smooge> it will be in the logs
21:17:10 <averi> point is what should we do with them? and what's the current policy for new lists there to avoid people making new lists with no point?
21:17:26 <ricky> We can ping list owners and ask them if they're still needed.
21:17:50 <skvidal> to put some context on this
21:17:50 <ricky> We could also ping with an "if you don't respond in X, we'll delete the lists (but not the archives)"
21:17:52 <skvidal> 196 total lists
21:18:06 <skvidal> 76 of them have no messages
21:18:10 <skvidal> 56 more no messages in 2011
21:18:26 <ricky> Before doing something like that, I think it'd be good to investigate how easy it is to restart a deleted list
21:18:28 <CodeBlock> averi: I'd be fine with a "If your list goes inactive for 60 days or more, it will be considered for deletion" policy, personally.
21:18:29 <smooge> The main reason I would want to clean up lists: we are making "free spam" websites for people finding unused lists, signing up, and filling up stuff and then sending bit.ly urls out the woods
21:18:42 <skvidal> ricky: maybe in lieu of deleting them
21:18:48 <skvidal> ricky: we could consider closing them
21:18:53 <skvidal> ricky: which means no new posts
21:18:53 <averi> CodeBlock, yup
21:18:55 <phuzion> skvidal: what about lists with no messages since 6 months ago, August 17, 2010?
21:18:55 <ricky> Perhaps hosted lists have turned into something people just request automatically when making a project.
21:18:56 <skvidal> but the archives persist
21:19:12 <ricky> skvidal: Ah, and it's easy to go from closed -> active if we somehow need to do so?
21:19:20 <skvidal> ricky: you can just reopen the list
21:19:31 <skvidal> ricky: in the mailman config
21:19:39 <ricky> So maybe we can make it clearer on the hosted pages "please only request a list if you'll actually use it"
21:19:42 <ricky> Cool.
21:19:53 <ricky> Or "if you have <3 developers and 0 users, you probably don't need a list yet"
21:20:08 <smooge> +1 contact list owners with no traffic in 3+ months. Close off lists versus delete
21:20:23 <CodeBlock> worksforme.
21:20:43 <smooge> if no answer from owner in 14 days list is closed
21:20:46 * ricky signs at the amount of time we need to spend cleaning up crap.  Not much else to do though I guess.
21:20:58 <ricky> Er, sorry, I misphrased that second sentence
21:20:58 <skvidal> ricky: there are other projects
21:21:01 <ricky> "Not much choice though"
21:21:02 <smooge> correct. it is why we get paid the big bucks
21:21:07 <skvidal> and averi lemme  ask you a question
21:21:12 <skvidal> averi: is this something you would like to work on?
21:21:17 <skvidal> averi: helping us clean up the lists?
21:21:26 <skvidal> averi: b/c if you would I'd +1 to giving you list admin access right now
21:21:29 <ricky> There are definitely other projects - didn't mean to say that :-)
21:21:31 <CodeBlock> smooge: See you can say that being an RH employee. Some of us can't.
21:21:32 <CodeBlock> :P
21:21:43 <skvidal> CodeBlock: trust me - he can't :)
21:21:47 <smooge> I got paid the big bucks to do this when I was a volunteer
21:21:49 <averi> skvidal, sure, it was part of my cleanup duty started yesterday :)
21:22:02 <skvidal> anyone else object to averi working on the above project?
21:22:06 <smooge> its all confederate money
21:22:17 <ricky> OK, so the group would be sysadmin-tools - I'd b ehappy to sponsor
21:22:26 <smooge> skvidal, averi is there a ticket number for this?
21:22:34 <CodeBlock> ricky: tools?
21:22:48 <averi> smooge, not yet, I started this off yesterday after a chat with skvidal
21:22:51 <CodeBlock> -hosted, no?
21:22:58 <ricky> Oh, never mind, I was thinking lists.fp.o, sorry.
21:23:03 <skvidal> averi: can you make a ticket and we'll get it underway
21:23:11 <averi> skvidal, sure
21:23:20 <ricky> And he's already in -hosted, great.
21:23:24 <CodeBlock> ricky: yep :)
21:23:41 * CodeBlock sponsored him yesterday. He's my first sponsoree. I think.
21:23:45 * nirik thinks a 'inactive list sop' might be good too. ;) Just sayin...
21:24:14 <CodeBlock> nirik: I can draw that up today
21:24:28 <skvidal> averi: so since you're in -hosted
21:24:33 <CodeBlock> well at least with the rules. I'm not sure how to actually close lists yet
21:24:54 <smooge> averi, put in a ticket to cover this please.. just list what you are doing, what you found and track progress in it.
21:25:10 <averi> smooge, ok, will do after meeting
21:25:17 <smooge> thanks
21:25:40 <smooge> and an SOP will definately be needed.
21:25:45 <smooge> ok anything else?
21:25:56 <skvidal> one thing
21:26:01 <smooge> #topic one thing
21:26:14 <skvidal> ricky: are you looking for another project to help with cleanup that's not just browsing and deleting?
21:26:30 <averi> smooge, sure, I am full of stuff for uni, so please remember it will take a bit for me to complete the SOP and the whole work
21:26:39 <ricky> Sure, why not :-)
21:27:12 <averi> smooge, guess we don't need to rush on this anyway :)
21:27:12 <skvidal> averi: of course
21:27:15 * CodeBlock accidentally laughs out loud in the completely quiet building he is in ($dayjob) at smooge's #topic
21:27:33 <skvidal> ricky: how about working on the db/script for tracking publictest instances/shutdowns
21:27:52 <skvidal> right now if it were just a cron job which sent out 'shut it down' notices
21:27:53 <skvidal> it would be fine
21:27:58 <skvidal> just need the data
21:28:29 <skvidal> I haven't had a chance to get to this
21:28:38 <ricky> Sure thing, I'll take a look
21:28:42 <skvidal> and it seems like something which could benefit us for nuking the publictest boxes
21:29:07 * ricky is thinking a simple sqlite database that lives on puppet01 somewhere.
21:29:15 <ricky> With a spam cronjob
21:29:29 <skvidal> +1
21:30:22 <skvidal> okay
21:30:27 <skvidal> another task for someone
21:30:34 <skvidal> does someone want to change the sudoers for publictest*
21:30:40 <skvidal> so sysadmin-main is password-less?
21:30:50 <CodeBlock> sure
21:31:01 <CodeBlock> I'd be happy to make my first private repo commit :)
21:31:31 <ricky> Woo, glad to finally have that
21:31:56 <skvidal> CodeBlock: make it so
21:31:57 <CodeBlock> skvidal: Will do that tonight/next time I get on my laptop..which is now the only place that my ssh key resides.
21:32:03 <skvidal> pretty much
21:32:10 <skvidal> I'm looking at this list
21:32:10 <skvidal> https://fedoraproject.org/wiki/Infrastructure_Cleanup_Tasks_2011
21:33:02 <smooge> ok
21:33:22 <skvidal> that's all I had
21:33:26 <skvidal> thanks
21:33:30 <CodeBlock> Ok .. so things I have to do tonight - aside from precalc homework: Start on a SOP for FH list removal, make -main have passwordless sudo on ptXX
21:33:45 <CodeBlock> got it. :)
21:33:56 <skvidal> :)
21:34:15 * CodeBlock really needs to find that cli todo program he used to have.. it was really good. :(
21:34:36 * ricky uses vim-outliner - I think abadger1999 and lmacken use it as well.
21:34:47 <ricky> Er, I mean vim-vimoutliner
21:34:55 <ricky> smooge: Want to #endmeeting?
21:35:22 <smooge> #endmeeting