19:00:00 <nirik> #startmeeting Infrastructure (2012-03-15)
19:00:00 <zodbot> Meeting started Thu Mar 15 19:00:00 2012 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:01 <nirik> #meetingname infrastructure
19:00:01 <nirik> #topic Robot Roll Call
19:00:01 <nirik> #chair smooge skvidal Codeblock ricky nirik abadger1999 lmacken dgilmore mdomsch
19:00:01 <zodbot> The meeting name has been set to 'infrastructure'
19:00:01 <zodbot> Current chairs: Codeblock abadger1999 dgilmore lmacken mdomsch nirik ricky skvidal smooge
19:00:09 <nirik> who all is around for infra meeting?
19:00:25 * skvidal is here
19:00:33 * skvidal is also on the phone so I may be a bit slow in replying
19:00:38 <marcelk1985> hi! i am here
19:00:49 <marcelk1985> Very excited
19:01:04 * kwame in da room
19:01:14 <smooge> here
19:01:51 * pingou 
19:02:09 <CodeBlock> here
19:02:24 * dgilmore waves
19:02:38 <nirik> welcome everyone.
19:03:00 <wolfkit> here :)
19:03:13 <nirik> lets go ahead and dive in...
19:03:27 <nirik> #topic New folks introductions and Apprentice tasks
19:03:29 <nirik> If any new folks want to give a quick one line bio or any apprentices
19:03:29 <nirik> would like to ask general questions, they can do so here.
19:04:16 <nirik> anyone new want to give a quick bio/intro? any apprentice questions?
19:04:18 <marcelk1985> I am definitely new here. Abbreviated I do a lot of networking/network security and linux. Hoping to be useful for the Fedora Project
19:04:26 <nirik> welcome marcelk1985
19:04:49 <wolfkit> I'm new here too.  I've been poking around different parts of Fedora, am interested in docs and infra
19:05:06 <marcelk1985> oh and I do a lot of Nagios :-)
19:05:25 <nirik> marcelk1985: you might be able to look at ticket 3191 and give some input... mangas and ctria were working on it too, and I think we have a plan, but if you know nagios well you might have a better suggestion.
19:05:37 <wolfkit> been using Fedora since fc3, so have lots of admin experience with it, hoping maybe I can contribute back to it :D
19:05:38 <nirik> wolfkit: welcome.
19:05:57 <nirik> wolfkit: are you more interested in sysadmin stuff? or application development?
19:06:08 <skvidal> nirik: he's offered to help me with pam_url
19:06:09 <skvidal> :)
19:06:19 <nirik> oh, nice. :)
19:06:25 <nirik> we def want to clean that up...
19:06:26 <wolfkit> well I'm a developer by trade, so app dev stuff that relates to sysadmin is probably my area
19:06:34 <CodeBlock> And I know him outside of Fedora, happy to sponsor him into apprentice
19:06:47 <nirik> great.
19:07:06 <nirik> welcome again, and do chime in on #fedora-admin/#fedora-noc/#fedora-apps with any questions or ideas...
19:07:07 <dgilmore> wolfkit: i have a new webapp i want to get developed for release engineering tasks
19:07:15 <davevz> I introduced myself briefly last week in #fedora-admin. I've done quite a bit of general admin / puppet stuff. Particularly interested in security work but anything will do
19:07:29 <wolfkit> dgilmore: cool!  perhaps we can chat about it after the meeting
19:07:42 <kwame> Hi, my name is Dan Bahena (aka Kwame), just joined to give back to the community from which I've received so much, I'm currently working as a L3 Linux Engineer, I'm from México http://kwame.informatux.net my blog :-) I've been a linux user since ... I guess mid 90's :-)
19:07:45 <dgilmore> wolfkit: sure drop into #fedora-releng and we can talk
19:08:09 <nirik> excellent. Lots of folks. ;)
19:08:18 <marcelk1985> hi kwame
19:08:23 <kwame> marcelk1985: hey
19:08:42 <nirik> As a side note for existing sysadmin folks: if you can think of small tasks for apprentices/easyfix tasks, please do file them and mark them... we need more to choose from I think...
19:08:57 <marcelk1985> i think so too ;)
19:09:00 <nirik> updating docs, checking scripts, doing things we just never get around to that are easy are all good to mark for that.
19:09:42 <nirik> #info sysadmin folks should file any easyfix tickets they can think of we need fixed
19:09:52 <marcelk1985> please do!
19:10:11 <pingou> dgilmore: #fedora-apps ?
19:10:23 <nirik> new folks do see me after the meeting in #fedora-admin and we can get you setup in the fi-apprentice group or point you to application easyfix stuff to work on.
19:10:42 * ianweller here
19:10:45 <kwame> nirik: cool
19:10:48 <dgilmore> pingou: not heard of that one
19:10:56 <marcelk1985> nirik: sure thing
19:10:57 <nirik> dgilmore: it's new.
19:11:02 <pingou> dgilmore: ah, few weeks old but already worth it ;)
19:11:02 <nirik> for infra applications.
19:11:26 <nirik> ok, moving along then unless anything else on this.
19:11:45 <nirik> #topic two factor auth status
19:12:02 <nirik> I guess wolfkit is going to help us clean up pam_url?
19:12:07 <nirik> and then we can move forward?
19:12:22 <wolfkit> I would like to help clean up pam_url, yes
19:12:32 <skvidal> wolfkit: I'll send you a link to the last tarball I had
19:12:42 <nirik> great. Please do.
19:12:56 <nirik> #action wolfkit is going to work on cleaning up pam_url for us.
19:13:03 <nirik> #info then we can move to testing deployment.
19:13:10 <nirik> anything else on 2 factor?
19:13:36 <skvidal> not at the moment
19:13:36 <nirik> moving on then...
19:13:50 <nirik> #topic Staging re-work status
19:13:57 <nirik> so, I worked on this this week
19:14:06 <nirik> I sent out a proposal to the list...
19:14:23 <nirik> I'd like to wait to hear from some of our developers that are our at pycon this week before we implement
19:14:44 <nirik> Hopefully they will be ok with my plan and we can quash our staging branch soon.
19:14:56 <pingou> the current situation still makes use of the stagging branch, right ?
19:14:58 <nirik> #info proposal for workflow in post staging branch life on list. Please comment.
19:15:07 <nirik> pingou: yeah, currently it does.
19:15:11 <pingou> tx
19:15:28 <nirik> In the new setup, it will all be in master... and you can make a modules-staging/ copy of your module to test with on staging machines.
19:16:05 <nirik> and default there will not be a staging module (ie, master and stg are the same except for some small differences inside if $staging)
19:16:23 <nirik> ok, anything else on this?
19:16:48 <nirik> #topic Applications status / discussion
19:16:59 <nirik> any news on our applications this week?
19:17:09 <nirik> note that most of our application folks are at pycon. ;)
19:17:11 <skvidal> :)
19:17:39 <pingou> some bug/rfe fixing in fas
19:17:52 <nirik> I managed to fix some rhel6 issues with some apps in the last few weeks.
19:17:53 * CodeBlock doesn't have much of an update on search... search-dev.fp.o is still up, people are free to comment on it... need to get back to working on that though.
19:17:58 <pingou> I'm working on the module for gather-easyfix
19:18:01 <nirik> I hope we are all ok now running on rhel6.
19:18:13 <nirik> CodeBlock: how's the crawler?
19:18:35 <CodeBlock> nirik: I think it is mostly done with docs/wiki, will add in some other sites soon
19:18:41 <nirik> ok.
19:19:00 <nirik> ok, moving along then...
19:19:14 <nirik> #topic Upcoming Tasks/Items
19:19:14 <nirik> #info 2012-03-20 to 2012-04-03 - F17 Beta Freeze
19:19:14 <nirik> #info 2012-03-27 - drop inactive maintainers from packages.
19:19:14 <nirik> #info 2012-04-01 - nag fi-apprentices.
19:19:14 <nirik> #info 2012-04-03 - F17Beta release day
19:19:14 <nirik> #info 2011-04-03 - gitweb-cache removal day.
19:19:16 <nirik> #info 2012-04-10 - drop inactive fi-apprentices
19:19:18 <nirik> #info 2012-04-24 to 2012-05-08 - F17 Final Freeze.
19:19:20 <nirik> #info 2012-05-01 - nag fi-apprentices.
19:19:22 <nirik> #info 2012-05-08 - F17 release
19:19:28 <nirik> any upcoming tasks people would like to schedule / note?
19:19:41 <nirik> I'll point out we are going into Beta freeze next week.
19:19:49 <pingou> - drop inactive maintainers from packages.    -> if there gonna be a last email regarding the packages ?
19:19:54 <pingou> s/if/is/
19:20:03 <nirik> so, if there are things you want to do before tuesday, please consider doing them.
19:20:28 <nirik> pingou: there would be... these are people that we nagged and nagged and don't change their ssh key... I'm not even sure how many are packagers.
19:20:46 <nirik> skvidal was going to nag some more via phone I think?
19:20:50 <pingou> good :)
19:21:30 <skvidal> nirik: I pingedat people I could find on irc
19:21:38 <skvidal> nirik: I haven't gotten anyone on the phone :)
19:21:48 <smooge> yeah beta freeze
19:21:52 <nirik> ok. Did it do any good?
19:22:04 <skvidal> nirik:not that Ican tell :)
19:22:19 <skvidal> nirik: lemme have one more week
19:22:33 <nirik> sure.
19:22:57 <nirik> ok, any other items to schedule/note?
19:23:23 <nirik> #topic Tickets from Ages past
19:23:39 <nirik> so, anyone like to note and discuss an old ticket?
19:23:44 * nirik has one...
19:23:56 <nirik> .ticket 1882
19:23:58 <zodbot> nirik: #1882 (FreeNode node) – Fedora Infrastructure - https://fedorahosted.org/fedora-infrastructure/ticket/1882
19:24:09 <nirik> we aren't planning on ever doing this are we? so, close?
19:24:49 <marcelk1985> well
19:25:11 <marcelk1985> are you asking if someone would/cozld host an ircd?
19:25:25 <marcelk1985> *could
19:25:29 <smooge> I don't think we could offer it with fedora resources
19:25:31 <skvidal> nirik: no, we aren't
19:25:46 <nirik> marcelk1985: the ticket is asking US to host a freenode node. Could we do it? sure. Do we want to? I don't think so. Does freenode need us to? I doubt it.
19:26:05 <CodeBlock> it'd be cool...probably not practical though.
19:26:24 <nirik> It kinda makes you a target too... for DOS, etc... which I don't think we want really.
19:26:27 * CodeBlock is fine with closing it
19:26:30 <wolfkit> freenode has been adding nodes like crazy lately, two a week, I don't think they really "need" it.  it'd be great to get Fedora out there, but probably unnecessary
19:26:35 <nirik> also, it means you give root access to an external entity. ;)
19:26:50 <skvidal> nirik: I'm for closing it
19:27:04 * nirik would be happy to revisit if it turns out to be needed or desired. ;)
19:27:21 <nirik> wolfkit: yeah, seems much better than it was back when this ticket was made.
19:27:38 <marcelk1985> I suggest closing it. the security implications are too large if not done right, and the time need in order to do it right is considerable
19:27:51 <nirik> #agreed will close ticket 1882.
19:27:55 * pingou patched #605
19:28:00 <nirik> any other tickets from the past people want to bring up?
19:28:03 <wolfkit> plus, the ircd they use doesn't exactly play nice on cent/rhel (I know from experience chary isn't "happy" on it)
19:28:04 <nirik> .ticket 605
19:28:05 <zodbot> nirik: #605 (FAS2 entry for blog feed) – Fedora Infrastructure - https://fedorahosted.org/fedora-infrastructure/ticket/605
19:28:07 <LinuxCode> wolfkit, they are adding nodes to combat a DDoS
19:28:54 <nirik> pingou: on that, I think we also would need to change planet scripts to pull from that right? unless it's just informational?
19:29:00 <nirik> and we would need to fix docs.
19:29:03 <pingou> although I allowed only 1 blog/user
19:29:17 <nirik> and populate it from existing .planet files and remove them/note they aren't used.
19:29:40 <pingou> nirik: my thoughts as well, I would add a get_planet_config or something which would return the ini file desired
19:29:52 <nirik> or perhaps look at both?
19:30:43 <nirik> yeah, so needs more working...
19:30:49 <pingou> yup
19:31:37 <pingou> we could do something like: check FAS first, override by .planet
19:31:40 <nirik> any other old tickets to kill off?
19:31:50 <pingou> allow .planet to add one more blog or so
19:31:52 <nirik> pingou: yep. or vice versa
19:32:31 <pingou> so that'll be another ticket :)
19:32:38 <pingou> fix the planet script
19:33:23 <nirik> pingou: sure, blocking that one?
19:33:27 <nirik> how about: https://fedorahosted.org/fedora-infrastructure/ticket/1162
19:33:45 <nirik> patchwork sounds interesting, but perhaps it could be merged into the mailing list rework work stuff. ;)
19:35:10 <pingou> that's an idea
19:36:24 <nirik> ok, if no other dusty tickets...
19:36:28 <nirik> #topic Open Floor
19:36:34 <nirik> Anyone have anything for open floor?
19:37:13 <marcelk1985> what happens during open floor?
19:37:30 <smooge> if you have an issue you would like to bring up. this is the time to do s
19:37:33 <wolfkit> open floor is for general discussion, if you have anything to bring up that wasn't mentioned in the topics
19:37:37 <nirik> marcelk1985: anyone can bring up topics that were not convered before. ;)
19:37:48 <nirik> covered even. Like my poor speeling.
19:37:49 <marcelk1985> oh
19:38:08 <LinuxCode> nirik, ok, your poor spelling is ..appalling!
19:38:11 <LinuxCode> lol
19:38:13 <LinuxCode> jk
19:38:13 <CodeBlock> :)
19:38:18 <nirik> :)
19:38:20 <marcelk1985> very poor speeling ;-)
19:38:26 <wolfkit> action nirik needs to install a spellcheck plugin to his IRC client
19:38:34 <nirik> ha. ;)
19:38:56 <LinuxCode> wolfkit, I have one running and it does not help
19:39:19 <nirik> anyhow, if nothing else, will close out in a minute.
19:39:29 * CodeBlock would imagine it would false trigger a lot on linuxey stuff that isn't necessarily a real word.
19:39:54 <LinuxCode> CodeBlock, no, you just do not look all the time, before you hit the enter key
19:39:57 <LinuxCode> ;-p
19:41:05 <nirik> ok, thanks for coming everyone. :) Do continue in #fedora-admin, #fedora-noc and #fedora-apps
19:41:07 <nirik> #endmeeting